Subject: Re: Dealing with INTERNAL_ADDRESS_FAILURE (was Re: [Mip6] Re: Gen-ARTreview of draft-ietf-mip6-ikev2-ipsec-07.txt)

From: Vijay Devarapalli <[email-masked]>
Date: Sat, 02 Dec 2006 10:01:03 -0800

Kilian Weniger wrote:
> Hi Vijay,
> 
> what are reasons for the INTERNAL_ADDRESS_FAILURE? Two reasons that come
> to my mind are that the home agent consults a DHCP server on the home
> link but the DHCP server is down or that the address pool of the DHCP
> server (or a pool internal in the home agent) is empty, i.e., all
> addresses are allocated. Any other reasons?
> 
> If the new home agent uses the same DHCP server/address pool, option 2
> wouldn't help, since the allocation would fail again. In contrast,
> option 1 should always work (unless the auto-configured address is
> duplicate). So depending on the deployment scenario, option 1 may have
> higher chances to succeed, in which case it would be better to go for
> option 1.

how about the following text?

    In case the home agent is unable to allocate a home address for the
    mobile node during the IKE_AUTH exchange, it MUST send a Notify
    Payload with an INTERNAL_ADDRESS_FAILURE message.  When the mobile
    node receives a Notify Payload with an INTERNAL_ADDRESS_FAILURE
    message, it SHOULD terminate the IKE_AUTH exchange.  The mobile node
    then should initiate a new IKE_SA_INIT and IKE_AUTH exchange and try
    to auto-configure a home address as described in [13].  The mobile
    node MAY also switch to another home agent from the list of home
    agents it received during the home agent discovery phase.

Vijay

> 
> Option 3 should be done if the allocation fails after multiple retries
> IMHO.
> 
> My two cents.
> 
> -Kilian
> 
>> -----Original Message-----
>> From: Vijay Devarapalli [mailto:[email-masked]] 
>> Sent: Montag, 27. November 2006 17:05
>> To: [email-masked]
>> Subject: Dealing with INTERNAL_ADDRESS_FAILURE (was Re: 
>> [Mip6] Re: Gen-ARTreview of draft-ietf-mip6-ikev2-ipsec-07.txt)
>>
>> folks,
>>
>> any comments on the options below?
>>
>> Vijay Devarapalli wrote:
>>
>>>> 3) In S9, first full paragraph of Page 22: "In case the 
>> home agent ...
>>>>  an INTERNAL_ADDRESS_FAILURE message."  If a mobile node gets an
>>>>  INTERNAL_ADDRESS_FAILURE message, does it make sense to specify
>>>>  what should it do, if anything?
>>> good catch. the mobile node has the following
>>> options.
>>>
>>> 1. it can attempt to auto-configure a home address
>>> as described in section 5.3.2 of
>>> draft-ietf-mip6-bootstrapping-split-03.txt. the
>>> sequence is a bit complicated though. it has to
>>> terminate the current IKE exchange and initiate a
>>> new one. in the new IKE_AUTH exchange, the MN
>>> should try to auto-configure a home address.
>>> 2. switch to another home agent (most home agent
>>> discovery mechanisms return more than one home
>>> agent).
>>> 3. throw an exception and report and error to the
>>> user.
>>>
>>> 2) seems to be simplest option.
>> Vijay
>>
>>
>> _______________________________________________
>> Mip6 mailing list
>> [email-masked]
>> https://www1.ietf.org/mailman/listinfo/mip6
>>
>>
> 

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: "Kilian Weniger" <[email-masked]>
Date: Tue, 5 Dec 2006 03:07:26 +0100

the proposed text looks good to me. One comment: I would omit the "from the list of home agents it received during the home agent discovery phase." in the last sentence, since some HA address discovery mechanisms don't return a list of home agents. (E.g., the anycast IKE_SA_Init mechanism).
 
Kilian

________________________________

Von: Vijay Devarapalli [mailto:[email-masked]]
Gesendet: Sa 02.12.2006 19:01
An: Kilian Weniger
Cc: [email-masked]
Betreff: Re: Dealing with INTERNAL_ADDRESS_FAILURE (was Re: [Mip6] Re: Gen-ARTreview of draft-ietf-mip6-ikev2-ipsec-07.txt)

Vijay

---

From: Vijay Devarapalli <[email-masked]>
Date: Mon, 04 Dec 2006 18:29:00 -0800

> the proposed text looks good to me. One comment: I would omit the "from the list of home agents it received during the home agent discovery phase." in the last sentence, since some HA address disco…

ok. how about the following.

    In case the home agent is unable to allocate a home address for the
    mobile node during the IKE_AUTH exchange, it MUST send a Notify
    Payload with an INTERNAL_ADDRESS_FAILURE message.  When the mobile
    node receives a Notify Payload with an INTERNAL_ADDRESS_FAILURE
    message, it SHOULD terminate the IKE_AUTH exchange.  The mobile node
    then should initiate a new IKE_SA_INIT and IKE_AUTH exchange and try
    to auto-configure a home address as described in [13].  The mobile
    node MAY also switch to another home agent from the list of home
    agents it received during the home agent discovery phase.  If the
    mobile node has only one home agent address configured, it should
    attempt to discover another home agent.

Vijay

---

From: "Kilian Weniger" <[email-masked]>
Date: Tue, 5 Dec 2006 03:57:04 +0100

The last sentence is a bit ambiguous IMHO, since it could be read as if the mobile node should always discover a new HA if it has only one HA address configured. How about:
 
...The mobile node MAY also switch to another home agent. The new home agent address can be obtained by consulting a home agent list received during a previous home agent discovery phase or, if such list is empty or not available, by attempting a new home agent discovery.

-Kilian

Von: Vijay Devarapalli [mailto:[email-masked]]
Gesendet: Di 05.12.2006 03:29
An: Kilian Weniger
Cc: [email-masked]
Betreff: Re: AW: Dealing with INTERNAL_ADDRESS_FAILURE (was Re: [Mip6] Re: Gen-ARTreview of draft-ietf-mip6-ikev2-ipsec-07.txt)

Vijay

---

From: Vijay Devarapalli <[email-masked]>
Date: Mon, 04 Dec 2006 22:05:45 -0800

> ...The mobile node MAY also switch to another home agent. The new home agent address can be obtained by consulting a home agent list received during a previous home agent discovery phase or, if suc…

yes, this is fine.

Vijay