Subject: RE: [Mip6] DSMIP6 solution and integrated bootstrap scenario

From: <[email-masked]>
Date: Wed, 28 Feb 2007 13:27:54 -0600

Okay.. I see your point now.
I agree that the DS-MIP6 I-D could either refer or mention the methods
by which the MN can discover the HA.

-Raj

>-----Original Message-----
>From: ext Chowdhury, Kuntal [mailto:[email-masked]] 
>Sent: Wednesday, February 28, 2007 1:17 PM
>To: Patil Basavaraj (Nokia-NET/Dallas); [email-masked]
>Subject: RE: [Mip6] DSMIP6 solution and integrated bootstrap scenario
>
>Hi Raj,
>
>Please see inline...
>
>> -----Original Message-----
>> From: Basavaraj Patil [mailto:[email-masked]]
>> Sent: Wednesday, February 28, 2007 12:17 PM
>> To: Chowdhury, Kuntal; [email-masked]
>> Subject: Re: [Mip6] DSMIP6 solution and integrated bootstrap scenario
>> 
>> 
>> So are you saying that the DNS approach is invalid?
>[KC>] No. The point is why DSMIP6 should say DNS is preferred way to do
>HA bootstrapping? There are two distinct scenarios for mip6
>bootstrapping as per RFC 4640. DNS is preferred way for HA 
>bootstrapping
>for only one of them i.e. split scenario. DHCP is preferred for the
>integrated scenario. The DSMIP6 I-D should just point to the mip6
>bootstrapping solutions for split and integrated scenarios. At 
>this time
>it only refers to the split I-D. That's the issue.
>
>> Or the fact that we have two different mechanisms for HA discovery?
>> 
>[KC>] To be precise there are three ways... DHCP, Anycast, DNS.
>
>> We need to converge on a single approach.
>> 
>[KC>] based on what? The DSMIP6 I-D clearly tries to ignore the
>integrated bootstrapping solution.
>
>> -Raj
>> 
>> 
>> On 2/28/07 10:35 AM, "ext Chowdhury, Kuntal"
>> <[email-masked]> wrote:
>> 
>> > Hi all,
>> >
>> > I see that in the DSMIP6 I-D
>(draft-ietf-mip6-nemo-v4traversal-03.txt)
>> > we have the following sentence in section 2.1 Home Agent Address
>> > Discover
>> >
>> > "
>> > The preferred solution for discovering the home agent's 
>IPv4 address
>is
>> > through the Domain Name System (DNS).
>> > "
>> >
>> > The preferred solution for discovering Home Agent Address in the
>> > integrated bootstrap scenario is DHCP not DNS. We need to address
>this
>> > issue.
>> >
>> > -Kuntal
>> >
>> > _______________________________________________
>> > Mip6 mailing list
>> > [email-masked]
>> > https://www1.ietf.org/mailman/listinfo/mip6
>
>
>"This email message and any attachments are confidential 
>information of Starent Networks, Corp. The information 
>transmitted may not be used to create or change any 
>contractual obligations of Starent Networks, Corp.  Any 
>review, retransmission, dissemination or other use of, or 
>taking of any action in reliance upon this e-mail and its 
>attachments by persons or entities other than the intended 
>recipient is prohibited. If you are not the intended 
>recipient, please notify the sender immediately -- by replying 
>to this message or by sending an email to 
>[email-masked] -- and destroy all copies of 
>this message and any attachments without reading or disclosing 
>their contents. Thank you."
>

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: Vijay Devarapalli <[email-masked]>
Date: Wed, 28 Feb 2007 11:45:05 -0800

> by which the MN can discover the HA.

We can mention in the DS-MIPv6 spec, that if DS-MIPv6
is being used in the integrated scenario, DHCPv6 may
also be used for HA bootstrapping. Thats not a big
deal.

But there is an issue. IPv4-access networks will not
have DHCPv6 running on them. So the solution described
in draft-ietf-mip6-bootstrapping-integrated-02.txt may
not apply, since the draft assumes DCHPv6.

Vijay