Subject: [MEXT] Binding Revocation Support Error handling

From: "Ahmad Muhanna" <[email-masked]>
Date: Mon, 21 Jul 2008 16:54:31 -0500

Hello All,
 
In preparation to Binding Revocation presentation, I came a cross the
issue of error handling in the case when the receiving node does not
support Binding Revocation. I am planning to touch on this during the
Binding Revocation presentation. However, probably we can start
discussion in preparation:) 
 
Currently, Binding Error is used to report that a specific MH type is
not supported. However, with the introduction of MGSM with different
signaling defined as subtypes, I feel that we probably need to define
something more generic but specific to MGSM.
 
 Thoughts Please?

Regards, 
Ahmad 

_______________________________________________
MEXT mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mext

---

From: "Vijay Devarapalli" <[email-masked]>
Date: Mon, 21 Jul 2008 18:02:28 -0400

My preference would be to add a new status code in section 4.3 of
draft-haley-mext-generic-notification-message-00.txt to indicate an
unknown sub-type. We can use 133 to indicate "Notification Sub-type not
recognized".

Vijay

> -----Original Message-----
> From: Ahmad Muhanna [mailto:[email-masked]] 
> Sent: Monday, July 21, 2008 2:55 PM
> To: [email-masked]
> Cc: Brian Haley; Sri Gundavelli; Vijay Devarapalli
> Subject: Binding Revocation Support Error handling 
> 
>  
> Hello All,
>  
> In preparation to Binding Revocation presentation, I came a 
> cross the issue of error handling in the case when the 
> receiving node does not support Binding Revocation. I am 
> planning to touch on this during the Binding Revocation 
> presentation. However, probably we can start discussion in 
> preparation:) 
>  
> Currently, Binding Error is used to report that a specific MH 
> type is not supported. However, with the introduction of MGSM 
> with different signaling defined as subtypes, I feel that we 
> probably need to define something more generic but specific to MGSM.
>  
>  Thoughts Please?
> 
> Regards, 
> Ahmad 
> 
>

---

From: Sri Gundavelli <[email-masked]>
Date: Mon, 21 Jul 2008 16:07:52 -0700 (PDT)

Makes sense.

Sri

---

From: "Ahmad Muhanna" <[email-masked]>
Date: Tue, 22 Jul 2008 08:19:32 -0500

Vijay,

That could work.

I also was thinking that probably an approach similar to Binding Err
would be more elegant:)
What I mean, it would be nice if the MGSM framework define a separate
subtype for reporting errors related to the MGSM signaling. Just an idea
to consider.

Regards,
Ahmad

> From: Vijay Devarapalli [mailto:[email-masked]] 
> Sent: Monday, July 21, 2008 5:02 PM
> To: Muhanna, Ahmad (RICH1:2H10); [email-masked]
> Cc: Brian Haley; Sri Gundavelli
> Subject: RE: Binding Revocation Support Error handling
> 
> My preference would be to add a new status code in section 
> 4.3 of draft-haley-mext-generic-notification-message-00.txt 
> to indicate an unknown sub-type. We can use 133 to indicate 
> "Notification Sub-type not recognized".
> 
> Vijay
> 
> cross the