Subject: [MEXT] Mandated behaviors, "whenever possible"

From: "Charles E. Perkins" <[email-masked]>
Date: Tue, 08 Jul 2008 15:39:19 -0700

Hello Ahmad,

In one email adding to the discussion about Issue #11 you wrote:

>           One final note: Any where we mandate that the MN "MUST" send
>           de-registration, we probably need to have a clause that 
> "whenever it is
>           possible for the MN to do so" i.e. if the MN moves to an 
> area without
>           coverage, then the MN wont comply anyway.

Generally, any physical network medium can lose packets
under various circumstances.  It would be wrong, I'm sure,
to append the "whenever" clause as you suggested to all
protocol mandates for all protocols that need to be obeyed
by wireless devices.  So I'd rather not have to append that
clause anywhere, since it is really already implicit.  Just to be
silly, we could rephrase it as "whenever the laws of physics
permit", or "whenever the cost is not prohibitive", or "whenever
there is no resulting danger of atomic warfare", or <insert
special circumstance here>, ...

Regards,
Charlie P.

_______________________________________________
MEXT mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mext

---

From: "Ahmad Muhanna" <[email-masked]>
Date: Wed, 9 Jul 2008 08:05:37 -0500

Hello Charlie,

Yep! I actually missed [:)] at the end of the sentence. 
But you explained exactly what I was trying to convey in details!

Best Regards,
Ahmad

> -----Original Message-----
> From: Charles E. Perkins [mailto:[email-masked]] 
> Sent: Tuesday, July 08, 2008 5:39 PM
> To: Muhanna, Ahmad (RICH1:2H10)
> Cc: [email-masked]
> Subject: Mandated behaviors, "whenever possible"
> 
> 
> Hello Ahmad,
> 
> Generally, any physical network medium can lose packets under 
> various circumstances.  It would be wrong, I'm sure, to 
> append the "whenever" clause as you suggested to all protocol 
> mandates for all protocols that need to be obeyed by wireless 
> devices.  So I'd rather not have to append that clause 
> anywhere, since it is really already implicit.  Just to be 
> permit", or "whenever the cost is not prohibitive", or 
> "whenever there is no resulting danger of atomic warfare", or 
> <insert special circumstance here>, ...
> 
> Regards,
> Charlie P.
> 
> 
>