Subject: Re: [MEXT] [mext] #11: De-registration when returning home [VijayDevarapalli <[email-masked]>]

From: "Koodli, Rajeev" <[email-masked]>
Date: Thu, 10 Jul 2008 18:04:52 -0400

Hi Charlie, Vijay,

The text is mostly fine with me. Please see below:

> >    A mobile node detects that it has returned to its home link
through
> >    the movement detection algorithm in use (Section 11.5.1), when
the
> >    mobile node detects that its home subnet prefix is again on-link.
> >    To be able to send and receive packets using its home address
from
> >    the home link, the mobile node MUST send a Binding Update to its
> >    home agent to instruct its home agent to no longer intercept or
> >    tunnel packets for it. Until the mobile node sends a
de-registration
> >    Binding Update, it will not be able to send and receive packets
                               ^^^^^^^^^^^^^^^^^^^^            

[RKo:>] I am not sure why the MN will not be able send packets until
de-registration completes. If there is no reason, we should re-word it
".. will not be able to receive packets.."

-Rajeev

_______________________________________________
MEXT mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mext

---

From: "Benjamin Lim" <[email-masked]>
Date: Fri, 11 Jul 2008 09:51:54 +0800

Hi Rajeev,

I not so sure about MN sending packet before de-reg completes.  I understand
MN should be able to forward the packet out via HA to its destination
(assuming HA is the deafut gateway), but I am unlcear on how the HA would
handle this packet.  I.e Soruce address of the packet would be HoA.  So HA
recevies this packet, checks ingress filtering (assuming) and pass it.  

Now this is the part it gets fuzzy.  In the BCE, HA would have an entry for
HoA.  This lets HA know to defend HoA.  Yet, HA see a packet coming from
home link with source address as HoA.  Since HA did not send such a packet
and HA should only be the one defending this address (other than MN), I am
not sure if this would confuse the hell out of HA.  What would HA do with
this packet? Forward? Drop?

Regards,
Benjamin Lim

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Koodli, Rajeev
> Sent: Friday, July 11, 2008 6:05 AM
> To: [email-masked]; Vijay Devarapalli
> Cc: [email-masked]
> Subject: Re: [MEXT] [mext] #11: De-registration when 
> returning home[VijayDevarapalli <[email-masked]>]
> 
> 
> Hi Charlie, Vijay,
> 
> [RKo:>] I am not sure why the MN will not be able send 
> packets until de-registration completes. If there is no 
> reason, we should re-word it ".. will not be able to receive 
> packets.."
> 
> -Rajeev
>  
> 
> 
>