Subject: [MEXT] A comment on draft-ietf-mext-binding-revocation-00

From: Sandesh <[email-masked]>
Date: Mon, 4 Aug 2008 13:31:17 +0530

Hi All,

IMO following case is possible with PMIPv6 protocol
defined in http://tools.ietf.org/html/draft-ietf-mext-binding-revocation-00
and http://tools.ietf.org/html/draft-ietf-netlmm-proxymip6-18

lt = lifetime
eth0 is the interface og MAG to the LAN in
which MN1 is present. MAG has another
interface eth1 through which it is connected to LMA.

MN1 ---- eth0 MAG eth1 -------LMA

            MAG                LMA
             |                  |
             |                  |
             |                  |
 eth0 down   |                  |
             |\ BRI(G)          |
 eth0 up     | \                |
(MN1 attaches)|  \     PBU(lt!=0)|
             |----------------->|
             |   \      +-------|
             |    \    /        |
             |     +----------->|
             |       /  +-------|
             | BRA  /  /        |
             |<----/--+         |
             |    /             |
             |   /              |
             |<-+               |
             | PBA              |
(BUL entry for MN1)           (no BCE MN1)

Reason -
1. As per these drafts BRI and PBU has their own
  (independent) sequence numbers.
2. BRI/BRA does not have timestamp option.
3. These drafts do not say that PBU cannot be sent
  if MAG has already sent BRI(G) to LMA.
4. In IP network missequencing of packets is possible.

Thanks and Regards,
Sandesh
_______________________________________________
MEXT mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mext

---

From: "Ahmad Muhanna" <[email-masked]>
Date: Mon, 4 Aug 2008 12:15:49 -0500

Hi Sandesh,
 
Thanks for reviewing the draft. Let me try to address your concern.
 
It seems to me that sending a BRI with (G) bit when the eth0 goes down,
is a MAG local policy and we can not specify that kind of behavior in
the draft. I personally believe that the use of the (G) bit should be
taken more carefully. In reality, the MAG implementation should use the
(G) bit more responsibly or let me say with a clear understanding of its
consequences. The intent was to allow the MAG to delete all sessions
with a specific LMA for a scheduled maintenance which may take sometime.
In your case, the use of the (G) bit may cause the network a problem by
introducing an unnecessary signaling traffics. 
 
If an implementation would like to use the (G) bit in a less restrictive
manner, then I believe that implementation should make sure that its use
does not create new complexity or a corner case race condition as you
mentioned. In other words, since there is a possibility for eth0 to go
up and down relatively quickly, then an implementation should take that
in consideration if it decides to send a BRI with the (G) bit for such a
case. IMO, that is an implementation decision.
 
Finally, what we could clarify in the draft is to say something like:
When the (G) bit is set, the revoking node SHOULD wait for the BRA or
exhaust all retransmits before deleting the associated mobile nodes
bindings. Will think of some cautious text to add to the LMA behavior in
the case when the Revocation Trigger is "Per-Local Policy".

Regards, 
Ahmad 

________________________________

	From: [email-masked] [mailto:[email-masked]] On
Behalf Of Sandesh
	Sent: Monday, August 04, 2008 3:01 AM
	To: [email-masked]
	Subject: [MEXT] A comment on
draft-ietf-mext-binding-revocation-00

	Hi All,
	
	IMO following case is possible with PMIPv6 protocol
	defined in
http://tools.ietf.org/html/draft-ietf-mext-binding-revocation-00
	and http://tools.ietf.org/html/draft-ietf-netlmm-proxymip6-18
	
	lt = lifetime

	            MAG                LMA
	             |                  |
	             |                  |
	             |                  |
	 eth0 down   |                  |
	             |\ BRI(G)          |
	 eth0 up     | \                |
	
	Reason - 
	
	Thanks and Regards,
	Sandesh