Subject: [Mipshop] Issue: LL Address Uniqueness in FMIP?

From: "James Kempf" <[email-masked]>
Date: Tue, 9 Sep 2003 09:33:36 -0700

The latest FMIP draft guarantees CoA uniquess for both predictive and
reactive handover, but what about the Link Local address? If the mobile node
must do DAD for the Link Local address, some of the benefits of fast
handover are lost.

            jak

_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop

---

From: Jari Arkko <[email-masked]>
Date: Tue, 09 Sep 2003 20:15:41 +0300

> must do DAD for the Link Local address, some of the benefits of fast

I'm not familiar with the details of FMIP, but is there a reason
why FMIP needs to worry about this? Wouldn't independent improvements
in DNA WG on optimistic DAD help this problem?

--Jari

---

From: "James Kempf" <[email-masked]>
Date: Tue, 9 Sep 2003 10:33:45 -0700

> in DNA WG on optimistic DAD help this problem?

Possibly. FMIP does include something (FNA) for assuring uniquness of the
CoA. Arguably, this is more important because the CoA is more likely to be
used in on-going traffic that would benefit from fast handover, but it does
seem peculiar to support one and not the other.

            jak

---

From: Rajeev Koodli <[email-masked]>
Date: Tue, 09 Sep 2003 11:05:47 -0700

Hi,

> seem peculiar to support one and not the other.

FMIP _could_ state that when NAR verifies NCoA, it MAY also
verify if LL address is also unique using the IID in NCoA.

-Rajeev

---

From: "James Kempf" <[email-masked]>
Date: Tue, 9 Sep 2003 11:32:02 -0700

Yes, it could infer the LL address from the interface id. Having that as an
option might be useful.

            jak

----- Original Message ----- 
From: "Rajeev Koodli" <[email-masked]>
To: "James Kempf" <[email-masked]>
Cc: "Jari Arkko" <[email-masked]>; <[email-masked]>
Sent: Tuesday, September 09, 2003 11:05 AM
Subject: Re: [Mipshop] Issue: LL Address Uniqueness in FMIP?

> > > > reactive handover, but what about the Link Local address? If the
mobile
> > node