Subject: [Mipshop] the global address of PAR

From: Koshiro MITSUYA <[email-masked]>
Date: Fri, 3 Dec 2004 23:47:34 +0900

Hi,
Let me ask a stupid question.

How do we know the global address of PAR?
We use it as destination address of FBU and the tunneling between NCoA.

The source address of PrRtAdv must be the link-local of PAR,
it's not the global address.

thanks,
Koshiro

_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop

---

From: "James Kempf" <[email-masked]>
Date: Fri, 3 Dec 2004 10:45:13 -0800

MIPv6 spec allows the RA to have the global address rather than link local.

        jak

---

From: Koshiro MITSUYA <[email-masked]>
Date: Sat, 4 Dec 2004 03:56:37 +0900

Hi,
Thank you for you quick response.

Do you mean the source address of PrRtAdv must be a global IP address 
of PAR? or just we should use RA to know the global address?

I prefer to change the FMIPv6 specification,
from:
    Source Address
                   MUST be the link-local address assigned to the
                   interface from which this message is sent.
to:
    Source Address
                   MUST be the global address assigned to the
                   interface from which this message is sent.

regards,
Koshiro

---

From: Vijay Devarapalli <[email-masked]>
Date: Fri, 03 Dec 2004 11:09:17 -0800

the access router that supports fast handoffs needs to
include its global address in the prefix field of the
router advertisement. similar to the Home Agent including
its address in the router advertisement instead of the
home prefix.

Vijay

---

From: "James Kempf" <[email-masked]>
Date: Fri, 3 Dec 2004 11:21:30 -0800

Any and all of the below. The router replies to RS w. RA/multicasts RA w.
global address, uses global address for Prxxx messages.

        jak

---

From: Vijay Devarapalli <[email-masked]>
Date: Fri, 03 Dec 2004 12:06:00 -0800

Jim,

I dont think MIPv6 says that. MIPv6 says

7.2.  Modified Prefix Information Option Format

    Mobile IPv6 requires knowledge of a router's global address in
    building a Home Agents List as part of the dynamic home agent address
    discovery mechanism.

    However, Neighbor Discovery [12] only advertises a router's link-
    local address, by requiring this address to be used as the IP Source
    Address of each Router Advertisement.

    Mobile IPv6 extends Neighbor Discovery to allow a router to advertise
    its global address, by the addition of a single flag bit in the
    format of a Prefix Information option for use in Router Advertisement
    messages.

    Router Address (R)

       1-bit router address flag.  When set, indicates that the Prefix
       field contains a complete IP address assigned to the sending
       router. .....

the access routers that support fast handoffs need to do the same.
they need to include the router global address instead of the
prefix.

Vijay

---

From: "James Kempf" <[email-masked]>
Date: Fri, 3 Dec 2004 12:10:32 -0800

OK, thx.

            jak

---

From: Koshiro MITSUYA <[email-masked]>
Date: Wed, 8 Dec 2004 19:41:09 +0900

Hi,

I understand. Thank you, Vijay.

Is is possible to have some sentence to mention this in the draft?

regards,
Koshiro

On 2004/12/04, at 5:06, Vijay Devarapalli wrote:

>> ----- Original Message ----- From: "Koshiro MITSUYA" 
>> <[email-masked]>
>> To: <[email-masked]>

---

From: gabriel montenegro <[email-masked]>
Date: Wed, 08 Dec 2004 07:46:25 -0800

Hmmm... As can be seen from the mipshop state in IDtracker:

https://datatracker.ietf.org/

FMIPv6 is already in the RFC's editor queue. So in principle we're
too late to make anything but corrections of an editorial nature.

However, Rajeev, could you suggest the minimum change to make this clarification?
If it's minor, we could add it during AUTH48.

-gabriel

-- 
Gabriel Montenegro (Sun Microsystems Laboratories)
16 Network Circle, UMPK16-157       Email: [email-masked]
Willow Road at Bayfront Expressway  Office: +1 650 786 6270  (sun internal: x86270)
Menlo Park, CA 94025, USA           Fax:    +1 650 786 7671

---

From: Rajeev Koodli <[email-masked]>
Date: Wed, 08 Dec 2004 17:53:25 -0800

How about this?

"Just as in Mobile IPv6, the PAR sets the 'R' bit
in the Prefix Information option, and includes
its 128 bit global address in the router advertisements.
This allows the mobile nodes to learn PAR's global
IPv6 address".

-Rajeev

---

From: "James Kempf" <[email-masked]>
Date: Thu, 9 Dec 2004 07:15:09 -0800

Sounds fine to me.

            jak

----- Original Message ----- 
From: "Rajeev Koodli" <[email-masked]>
To: "gabriel montenegro" <[email-masked]>
Cc: "Koshiro MITSUYA" <[email-masked]>; "Vijay Devarapalli"
<[email-masked]>; <[email-masked]>; "James Kempf"
<[email-masked]>
Sent: Wednesday, December 08, 2004 5:53 PM
Subject: Re: [Mipshop] the global address of PAR

---

From: Koshiro MITSUYA <[email-masked]>
Date: Fri, 10 Dec 2004 00:12:48 +0900

Hi Rajeev,

It's fine for me.
Thank you.

Koshiro

On 2004/12/09, at 10:53, Rajeev Koodli wrote:

>>>>> MIPv6 spec allows the RA to have the global address rather than 
>>>>> link
>>>>> local.
>>>>>         jak

---

From: gabriel montenegro <[email-masked]>
Date: Thu, 09 Dec 2004 08:49:15 -0800

Fine by me as well. Just missing one 'the':

> This allows the mobile nodes to learn PAR's global

s/PAR/the PAR/

-gabriel