Subject: Re: [Mipshop] [New Draft] Link Characteristic Information for MobileIP

From: gabriel montenegro <[email-masked]>
Date: Mon, 25 Apr 2005 16:14:37 -0700 (PDT)

Personal opinion:

This reminds me of some discussion in PILC (now dead) within the Transport
Area. This topic is probably much better hosted within Transport, perhaps in
tsvwg, than in MIPSHOP. After all, it is more about optimizing *data* transfer
than it is about optimizing the signaling. Or at least that is where the justification
seems to be.

Some considerations from the past are that the wireless medium being as fickle
as it is, static BW considerations may not be nearly as relevant as more dynamic
updates related to the state of the network. How to evaluate these dynamic values
of BW such that the info is actualy meaningful in practice, is a hard problem,
and one I don't quite see fitting easily within MIPSHOP at this moment.

I believe there are some 802.11 efforts on providing better measurements of 
the wireless state. Are you in touch with those folks?

-gabriel
--- James Kempf <[email-masked]> wrote:
> CARD has recently been published as an Experimental RFC, RFC 4066.
> 
>             jak
> 
> ----- Original Message ----- 
> From: "Ji Zhang" <[email-masked]>
> To: "Soohong Daniel Park" <[email-masked]>; "Gregory Daley"
> <[email-masked]>
> Cc: <[email-masked]>; <[email-masked]>
> Sent: Monday, April 25, 2005 4:41 AM
> Subject: Re: [Mipshop] [New Draft] Link Characteristic Information for
> MobileIP
> 
> 
> > Hi all,
> >
> >
> > > > > I agree and I support the draft, but I am just arguing two points:
> > > > > 1. Working in a predictive mode may bring better
> > > > performance on handovers.
> > > >
> > > > Except you've never been on the new link, so you may not be aware of
> > > > local performance constraints... (worth investigating if this is
> > > > useful).
> > >
> > > Agreed, the predictive mode would be a good alternative with this
> > > draft, but I am still not convincing how MN can recognize its
> > > predictive link information...So it still remains out of scope
> > > in my understanding.
> >
> > Maybe the Candidate Access Router Discovery (CARD) protocol can help.
> Access
> > router capabilities exchange from nAR to MN is supported there.
> >
> > Ji
> >
> > >
> > > ---------------------------------------------
> > > Daniel (Soohong Daniel Park)
> > > Mobile Platform Laboratory, SAMSUNG Electronics.
> > >
> > >
> > >
> > >
> > >
> >
> >
> > _______________________________________________
> > Mipshop mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/mipshop
> >
> 
> 
> 
> _______________________________________________
> Mipshop mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/mipshop
> 

_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop

---

From: Soohong Daniel Park <[email-masked]>
Date: Tue, 26 Apr 2005 10:48:31 +0900

> is where the justification

I guess you are thinking of this topic does not fit with Mipshop.
As I indicated, I don't know of which group is more fit for this
issue, so I did cross-posting. Basically, I thought this issue
is so related with mobility, so I personally perfer mipshop 
(or mip4/6 and even mobopts) to tsvwg. Just my opinion.

> Some considerations from the past are that the wireless 
> medium being as fickle as it is, static BW considerations 
> may not be nearly as relevant as more dynamic
> updates related to the state of the network. How to evaluate 
> these dynamic values of BW such that the info is actualy 
> meaningful in practice, is a hard problem,

Basically, I thought MN just send its attaching link
information to CN (HA) not dynamic BW when sending BU.
(I.e., 802.11a, 11b, 11n, 802.16 and etc...).
Dynamic measurement seems not useful to me.

> I believe there are some 802.11 efforts on providing better 
> measurements of the wireless state. 
> Are you in touch with those folks?

Are you saying 802.11n (or a/g) ? 

I.e, Changing MN's link into 802.11a from 802.11b will
be sent to CN along with this option described in
this draft. Any other considerations ? 

Thanks.

---

From: Greg Daley <[email-masked]>
Date: Tue, 26 Apr 2005 13:13:10 +1000

Hi Daniel,

>>Personal opinion:
[chop]
> (or mip4/6 and even mobopts) to tsvwg. Just my opinion.

If there's a perception that some aspects of this issue are
mobility related, then MOBOPTS is a good base to start with.
Further discussion on tsvwg would help determine what the
transport people think the existing problems are, and
whether mobility signaling transport is the correct medium
for conveying useful information.

[chop]
> Dynamic measurement seems not useful to me.

I guess this needs to be discussed though.

> this draft. Any other considerations ? 

I'm not looking at this in IEEE, but I guess that there
will be strong impacts from the downlink transmission
queue depth on the 802.11 AP, as well as the slot fill
(and collision) rates (which is somewhat related to the
number of users on an AP).

As described in many papers, the delays in wireless LANs
vary wildly with the up-link and downlink traffic.
So indicating an estimated packet loss and delay may be
more useful than indicating the technology in use.

Just an idea,

Greg

---

From: Soohong Daniel Park <[email-masked]>
Date: Tue, 26 Apr 2005 13:38:11 +0900

> for conveying useful information.

Greg, I don't have any hard stance on this discussion.

Thanks your efforts on this work.