Subject: RE: [Mipshop] FNA in the current spec

From: "Soliman, Hesham" <[email-masked]>
Date: Fri, 19 Aug 2005 15:15:00 -0400

It won't overwrite it if the O flag is cleared. That's 
what oDAD does anyway.

Hesham

 > -----Original Message-----
 > From: James Kempf [mailto:[email-masked]]
 > Sent: Friday, August 19, 2005 2:38 PM
 > To: Rajeev Koodli; Brett Pentland
 > Cc: Soliman, Hesham; [email-masked]
 > Subject: Re: [Mipshop] FNA in the current spec
 > 
 > 
 > I don't think it can send an unsolicited NA while the address is in
 > OPTIMISTIC state on the MN. Otherwise, it might overwrite a 
 > duplicate NC
 > entry on the router.
 > 
 >         jak
 > 
 > ----- Original Message -----
 > From: "Rajeev Koodli" <[email-masked]>
 > To: "Brett Pentland" <[email-masked]>
 > Cc: "Soliman, Hesham" <[email-masked]>; <[email-masked]>
 > Sent: Friday, August 19, 2005 11:33 AM
 > Subject: Re: [Mipshop] FNA in the current spec
 > 
 > 
 > >
 > >
 > > Brett Pentland wrote:
 > >
 > > > If the NCE goes into the STALE state (and there's no upper layer
 > > > indications to push in into REACHABLE), then there will 
 > be an NS/NA
 > > > exchange, but that will take place off the critical 
 > path, so I don't
 > >
 > > for predictive may be. (We have got some useful input from
 > > an implementation. I am hoping to get some more). For reactive,
 > > it is on critical path.
 > >
 > > Anyway, the spec needs to say that a MN has to send an 
 > unsolicited NA.
 > > What we call this and the associated semantics should take 
 > into account
 > > the implementation experience as we move towards PS.
 > >
 > > Thanks,
 > >
 > > -Rajeev
 > >
 > >
 > > > think it's worthwhile to change the meaning of 
 > STALE/REACHABLE just to
 > > > save this exchange.
 > > >
 > >
 > > > Brett.
 > >
 > >
 > > _______________________________________________
 > > Mipshop mailing list
 > > [email-masked]
 > > https://www1.ietf.org/mailman/listinfo/mipshop
 > >
 > 
 > 
 > 

===========================================================
This email may contain confidential and privileged material for the sole use
 of the intended recipient.  Any review or distribution by others is strictly
 prohibited.  If you are not the intended recipient please contact the sender
 and delete all copies.
===========================================================

_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop

---

From: "James Kempf" <[email-masked]>
Date: Fri, 19 Aug 2005 12:28:47 -0700

Ok. So if there's no duplicate, an NC entry is made (in what state?). If
there's a duplicate, no entry, but what happens then to the packets? Do they
go to the existing owner of the address? A duplicate is very low probability
(hence oDAD) but still...

            jak

----- Original Message -----
From: "Soliman, Hesham" <[email-masked]>
To: "James Kempf" <[email-masked]>; "Rajeev Koodli"
<[email-masked]>; "Brett Pentland" <[email-masked]>
Cc: <[email-masked]>
Sent: Friday, August 19, 2005 12:15 PM
Subject: RE: [Mipshop] FNA in the current spec

Hesham

===========================================================
This email may contain confidential and privileged material for the sole use
 of the intended recipient.  Any review or distribution by others is
strictly
 prohibited.  If you are not the intended recipient please contact the
sender
 and delete all copies.
===========================================================