Subject: RE: [Mipshop] FMIPv6 - Encapsulating FBU into Mobility Header (FNA)

From: "Soliman, Hesham" <[email-masked]>
Date: Thu, 11 Aug 2005 12:55:42 -0400

> => The MN doesn't need to expect anything. It just moves and 
 > announces
 > its presence.
 > --->
 > Phrasing of the sentence may no be correct but I will try to put what
 > I mean out of it.
 > 
 > This is the case I talked when the MN is send the BU and did 
 > not recieved
 > BAack. MN is still in the old link. He has not yet done the 
 > L2 handoff.
 > As BU is successful the PAR will send the packets to the 
 > NCoA. MN will
 > strat loosing packets. 

=> Right, which is why bicasting is useful and both Karim
and myself have tried to keep it in the spec with no luck. 
Please see:
http://www.ietf.org/internet-drafts/draft-elmalki-mobileip-bicasting-v6-06.txt

for a discussion of this problem. You can ignore the bicasting from
the CN case. 

   MN may do the BU retransmission in this case.
 > But packets which are send to the new link will be lost. 
 > Again I got your
 > point that buffering done by ND will be useful here.

=> Agreed. In fact, the MN may not move at all and the handover
fails. Again, this is a case for bicasting.

Hesham

===========================================================
This email may contain confidential and privileged material for the sole use
 of the intended recipient.  Any review or distribution by others is strictly
 prohibited.  If you are not the intended recipient please contact the sender
 and delete all copies.
===========================================================

_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop

---

From: Syam Madanapalli <[email-masked]>
Date: Thu, 11 Aug 2005 22:38:00 +0530

> fails. Again, this is a case for bicasting.

When MN sends FBU, then it will disassociate withe current AP/Base Station
and join the new AP/Base Station. So even if the PAR is bicasting, it
is unlikely
that the MN would receive any packets. Probably the bicasting may work
if the L2 and L3 handoffs work independently. I think in case of FMIPv6, one
need to control the L2 handover from L3.

-Syam