Subject: RE: [Mipshop] Possible Solution to Duplicate Problem?

From: "Soliman, Hesham" <[email-masked]>
Date: Wed, 24 Aug 2005 20:48:26 -0400

I feel like my comments are being ignored, so I'll
ask two questions that I think should be addressed before
we do anything on this subject:

- What is the problem? That includes the significance of such problem
- Why doesn't oDAD solve this problem?

Thx,
Hesham

 > -----Original Message-----
 > From: [email-masked] [mailto:[email-masked]]On
 > Behalf Of James Kempf
 > Sent: Wednesday, August 24, 2005 6:36 PM
 > To: [email-masked]
 > Subject: [Mipshop] Possible Solution to Duplicate Problem?
 > 
 > 
 > MIP4 requires the FA to maintain an ARP cache entry until a 
 > MN leaves the 
 > vistor list. One possible solution to the duplicate problem 
 > for FMIP might 
 > be to require a FMIPv6 router to maintain a NCE until the MN 
 > signals FBU. 
 > This would allow the NAR to provide the PAR with a 
 > definitive indication 
 > whether the address is duplicate, so the PAR could avoid 
 > sending packets if 
 > so. Downside is, what if the MN crashes? A possible 
 > compromise is to set the 
 > NCE timeout to the expected time between handovers plus 
 > perhaps a standard 
 > deviation or so (for cases where somebody comes home and 
 > their cell phone 
 > goes into dormant mode overnight, this might be a long time).
 > 
 > Comments?
 > 
 >             jak 
 > 
 > 
 > 
 > _______________________________________________
 > Mipshop mailing list
 > [email-masked]
 > https://www1.ietf.org/mailman/listinfo/mipshop
 > 

===========================================================
This email may contain confidential and privileged material for the sole use
 of the intended recipient.  Any review or distribution by others is strictly
 prohibited.  If you are not the intended recipient please contact the sender
 and delete all copies.
===========================================================

_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop

---

From: "James Kempf" <[email-masked]>
Date: Thu, 25 Aug 2005 11:20:36 -0700

>- What is the problem? That includes the significance of such problem

The problem: The probability of duplicate addresses, while very small, is 
not zero.
Its significance: Mindful of this fact, the IESG is likely to require some 
means of precluding packet delivery to the wrong host in the case that the 
odds just happen to cut the wrong way.

>- Why doesn't oDAD solve this problem?

It does solve it for reactive handover, since the NAR can drop the tunneled 
packets if there's an NCE for another host and it gets a unsolicited NA. The 
unsolicited NA alerts the NAR to the fact that the new MN is trying to claim 
somebody else's address. The unsolicited NA will probably show up prior to 
the FBU getting to the PAR and triggering tunneling, since the FBU must 
additionally traverse the NAR/PAR link. The MN gets its own notification 
when the real owner of the address replies to the oDAD NS with an NA, at 
which time it can fix the problem.

But it doesn't solve it for predictive handover, because the PAR might start 
tunneling packets prior to the MN even arriving on the link. If there's 
another MN on the link with the same address, the NAR will send the tunneled 
packets to it.

            jak