Subject: RE: [Mipshop] FNA in the current spec

From: "Soliman, Hesham" <[email-masked]>
Date: Wed, 17 Aug 2005 18:52:03 -0400

Also see this:

7.3.3.  Node Behavior

   Neighbor Unreachability Detection operates in parallel with the
   sending of packets to a neighbor.  While reasserting a neighbor's
   reachability, a node continues sending packets to that neighbor using
   the cached link-layer address.  If no traffic is sent to a neighbor,
   no probes are sent.

Hesham

 > -----Original Message-----
 > From: Rajeev Koodli [mailto:[email-masked]]
 > Sent: Wednesday, August 17, 2005 6:25 PM
 > To: Soliman, Hesham
 > Cc: [email-masked]
 > Subject: Re: [Mipshop] FNA in the current spec
 > 
 > 
 > 
 > Hi Hesham,
 > 
 > Soliman, Hesham wrote:
 > 
 > > => That's true but irrelevant at the same time :). It is true, but
 > > it has no consequence on packet delivery. In STALE, the AR can send
 > > packets to the MN while confirming reachability.
 > 
 > Could you point out the relevant text in 2461? This is implementation
 > dependent?
 > 
 > > 
 > > 
 > >       (NOTE: it is not clear to me whether an
 > >  >     unsolicited NA immediately prompts a new NS or the 
 > state machine
 > >  >     waits until the next NS is triggered since address 
 > resolution is
 > >  >     in progress). This means either active probing (sending
 > >  >     NS, expecting solicited NA) or "forward progress" 
 > determination.
 > > 
 > > => It doesn't matter, there is no disruption of service. 
 > 
 > What does happen? I am curious.
 > 
 > 
 > > => There are several unstated assumptions here:
 > >   a. You're assuming that either the BU is lost or that
 > >      the transition to the new link was quicker than the 1/2 RTT
 > >      between the MN and the PAR plus 1/2 RTT between the 
 > PAR and NAR.
 > >      The second case is extremely unlikely. But even if it happens
 > >      this would be a normal ND transaction. Note that it 
 > is very unlikely
 > >      that this happens. 
 > >   b. If the BU is lost, you're assuming that the MN would 
 > resend the
 > >      BU to the PAR. Even if this is the MN's fallback, by 
 > that time, 
 > >      the NS/NA is not a big issue because FMIP has 
 > basically failed. 
 > 
 > The assumption is that this is the FMIP reactive handover :-)
 > I don't see why FMIP has failed. It's just that FBU is sent 
 > from the new
 > link.
 > 
 > > => You MUST NOT set the state to REACHABLE until you know that 
 > > bidirectional reachbility is available. The FNA does not do that. 
 > > It seems like an ill-defined shortcut to me.
 > 
 > If you could forward packets "optimistically" when in STALE 
 > state, why 
 > not make it "official" for FMIP purposes? Note that this is an FMIP 
 > optimization, and not baseline ND operation.
 > 
 > -Rajeev
 > 
 > 
 > 
 > > 
 > > Hesham
 > > 
 > >  > 
 > >  > -Rajeev
 > >  > 
 > >  > 
 > >  > 
 > >  > 
 > >  > _______________________________________________
 > >  > Mipshop mailing list
 > >  > [email-masked]
 > >  > https://www1.ietf.org/mailman/listinfo/mipshop
 > >  > 
 > > 
 > > ===========================================================
 > > This email may contain confidential and privileged 
 > material for the sole use
 > >  of the intended recipient.  Any review or distribution by 
 > others is strictly
 > >  prohibited.  If you are not the intended recipient please 
 > contact the sender
 > >  and delete all copies.
 > > ===========================================================
 > > 
 > 
 > 
 > 
 > 

_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop

---

From: Rajeev Koodli <[email-masked]>
Date: Wed, 17 Aug 2005 19:09:36 -0700

So, what this means is that packet forwarding happens in STALE state but 
also address resolution (NS - NA exchange) signaling takes place. Right?
Could others confirm this forwarding behavior in implementations?
It would still be nice to eliminate the extra signaling. Again, others?

Thanks,

-Rajeev