Subject: RE: [Mipshop] FMIPv6 - Encapsulating FBU into Mobility Header (FNA)

From: "Soliman, Hesham" <[email-masked]>
Date: Wed, 10 Aug 2005 00:10:42 -0400

> ----> NAR needs to do some extra processing than normal NA.
 > If NAR is proxying for the MN's NCoA (so that during the handoff ,
 > other nodes will not configure NCoA), NAR needs to stop proxying.

=> I guess this discussion started with the question of whether
FNA is needed when the MN uses oDAD. If you use oDAD then there
is no need for the whole proxying of NCoA part, which is 
unnecessarily complex anyway. So we go back to clean plain
ND + oDAD. 

Hesham

 > 
 > Regarding forwarding the buffered packets, I think it is 
 > more implementation
 > dependent. Generally, whenever an upper layer packet comes, 
 > if NC entry
 > is not present, then the node will start address resolution. 
 > After finding
 > MAC address, node will send the packets.
 > In FMIPv6 case, it is bit different. NAR will not start 
 > address resolution.
 > Whenever MN sends FNA, NAR will forward the buffered packets.
 > So, some implementations may prefer to store the FMIPv6 
 > packets separately
 > (may be as part of FMIPv6 module), then usual upper layer 
 > packets (may be in
 > IPv6 module).
 > 
 > Thanks & Regards,
 > Subba Reddy
 > 
 > 

===========================================================
This email may contain confidential and privileged material for the sole use
 of the intended recipient.  Any review or distribution by others is strictly
 prohibited.  If you are not the intended recipient please contact the sender
 and delete all copies.
===========================================================

_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop

---

From: Subba Reddy <[email-masked]>
Date: Wed, 10 Aug 2005 09:44:18 +0530

Hi Hesham,

---->I think, this case will cover only reactive handoffs. 
If we want predictive handoffs also, proxying may still be required.

Thanks & Regards,
Subba Reddy