Subject: RE: [Mipshop] Warning: Bicasting and FMIPv6

From: "Soliman, Hesham" <[email-masked]>
Date: Thu, 11 Aug 2005 20:49:46 -0400

Greg, 

I think to be fair to the people that developed
Eifel or sent the charges for the IPR (I'm sure none
of them is on this list to defend themselves) we would
need to know a lot more detail than that to dismiss
Eifel. Like, who is this implementer?? was it a commercial
implementation? 
Of course an IPR holder has every right to demand payment
for a commercial implementation. My understanding is 
that the IPR statement for EIfel is RAND, which is 
widely accepted in IETF. 

Hesham

 > -----Original Message-----
 > From: [email-masked] [mailto:[email-masked]]On
 > Behalf Of Greg Daley
 > Sent: Thursday, August 11, 2005 8:40 PM
 > To: [email-masked]
 > Subject: [Mipshop] Warning: Bicasting and FMIPv6
 > 
 > 
 > Dear Mipshop,
 > 
 > I posted about this recently, but it was lost in the noise.
 > 
 > I was at the TCPM WG session where they were discussing
 > a draft recommending TCP implementation practices.
 > 
 > During the session, there was consensus to move the Eifel
 > algorithm, to an experimental section of the document
 > _because_ it has not been widely deployed and because
 > of existing uncertainties regarding IPR.
 > 
 > What was discussed in the session was the occurrance of
 > an implementor being presented with a schedule of
 > charges for licenses by an IPR holder.
 > 
 > Eifel has been described as a way to handle
 > packet duplication events experienced due to bicasting
 > in the draft (section 10):
 > 
 > http://www.ietf.org/internet-drafts/draft-elmalki-mobileip-bi
casting-v6-06.txt

While the IETF (in compliance with its policy: BCP 79)
will not take a position on the validity of the IPR claims,
please be aware that Eifel is not widely implemented,
and isn't likely to be implemented by default in TCP
stacks, due to its experimental nature.

If bicasting is important, it may be worth investigating if
another mechanism is available for reducing the effect of
duplicated packets on upper layer protocol stacks.

Greg

_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop

===========================================================
This email may contain confidential and privileged material for the sole use
 of the intended recipient.  Any review or distribution by others is strictly
 prohibited.  If you are not the intended recipient please contact the sender
 and delete all copies.
===========================================================

_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop

---

From: Greg Daley <[email-masked]>
Date: Fri, 12 Aug 2005 13:01:08 +1000

Hi Hesham,

I'm not indicating whether the IPR is justified or wrong,
just that Eifel isn't being recommended for implementation
by the group who is in charge of TCP maintenance.

I'm sure the TCPM WG chairs would have the details.

Greg