Subject: RE: [Mipshop] FMIPv6 Reactive Handover - HI/HAck

From: Narayanan Vidya-CVN065 <[email-masked]>
Date: Tue, 23 Aug 2005 00:04:14 -0500

------> It does seem that the FBAck is sent to the NCoA (as per the IP destination value in 6.3.2, although this doesn't make much sense if it is sent on the old link itself, as in the predictive handoff case). 

--> In the predictive case, I feel sending FBack to old link may be better. 
 
As per the spec sending FBack to old link is optional. 
But, if MN does not receive FBack after retries, it must assume that fast handover is not available.
I think, this is bit ambiguous.
Sec 4 (page 13, last but one para) 
 
------> I agree. The spec isn't very clear on this. Sending the FBAck on the old link would make sense when possible. 

"...
The PAR MAY send the
   FBack to the previous link to facilitate faster reception in the
   event that the MN is still present.  The result of the FBU and FBack
   processing is that PAR begins tunneling the MN's packets to NCoA.  If
   the MN does not receive an FBack message even after retransmitting
   the FBU for FBU_RETRIES, it must assume that fast handover support is
   not available and stop the protocol operation."

Nevertheless, we could take advantage of the fact that it is going through the NAR for sure in the case of reactive handovers. 
 
--> I think, if FBack is secured, NAR may not be able to process FBack.
 
------> Not sure if this is necessarily true. The FBAck will not be encrypted, only authenticated. It should be possible to construct the message such that it contains a MAC for the MN to verify and the AH that the NAR can verify. The NAR should be able to process the relevant fields of the FBAck. 
 
Does this make sense? 

 Thanks, 
Vidya

_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop

---

From: Subba Reddy <[email-masked]>
Date: Tue, 23 Aug 2005 10:45:23 +0530

MessageHi Vidya,

        Does this make sense? 

        --> I think, it makes sense. 

        Thanks & Regards,
        Subba Reddy