Subject: RE: [Mipshop] FNA in the current spec

From: "Soliman, Hesham" <[email-masked]>
Date: Thu, 18 Aug 2005 13:17:48 -0400

> >  > The assumption is that this is the FMIP reactive handover :-)
 > >  > I don't see why FMIP has failed. It's just that FBU is sent 
 > >  > from the new
 > >  > link.
 > > 
 > > => But in this case there is nothing to worry about, the MN
 > > will send the BU while doing DAD (e.g. oDAD) and when
 > > packets are received normal ND will take place. a normal
 > 
 > Actually in the reactive mode, you don't do DAD. It is just 
 > that FBU is 
 > sent from the NAR's link, as soon as the attachment occurs.

=> You still have to do DAD though, you need to verify the 
new CoA. 

 > There is L2 switching delay and then the RTT over the air itself. In 
 > addition, there is processing delay at the nodes. I would 
 > still like to 
 > minimize any signaling independent of particular L2 
 > switching and RTT 
 > values. That way, the protocol will be independent of them.

=> Ok, but at the same time you can't ignore the applicability
of the solution. Otherwise it becomes overly complex for no 
practical benefit, which is what I think we have today: A solution
optimised for the very rare exceptions. 

 > > => REACHABLE is not an "official" statement for the existence of 
 > > a node. It means that bidirectional reachability was confirmed. 
 > 
 > I meant if the state is REACHABLE, then you know you can 
 > deliver packets 

=> You *know* you can do that in STALE as well.  

 > without requiring reachability confirmation (which 

=> Reachability confirmation is not required to send packets. 

 > eliminates the need 
 > for any signaling even if it happens in parallel in an 
 > implementation).

=> But you can't set something to REACHABLE without confirming
that it is in fact reachable. The FNA doesn't give you
that confirmation, so it's actually wrong to set the state
to REACHABLE based on the reception of the FNA. It's a bug
in the spec...
You seem to be defending this as an advantage, it's not, it's 
a bug. You could just as well say that the NAR sets the state to 
REACHABLE if it receives HI :) This would save sending the FNA, but it's 
still wrong...

Hesham

===========================================================
This email may contain confidential and privileged material for the sole use
 of the intended recipient.  Any review or distribution by others is strictly
 prohibited.  If you are not the intended recipient please contact the sender
 and delete all copies.
===========================================================

_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop

---

From: Rajeev Koodli <[email-masked]>
Date: Thu, 18 Aug 2005 10:38:13 -0700

> REACHABLE if it receives HI :) This would save sending the FNA, but it's 

I don't see it as a bug, but an extension :-) And, it works, correctly!
Setting it to REACHABLE is not according to standard ND behavior. But 
doing so allows us to avoid additional signaling. And, I am also asking 
folks to provide some input on what their experience has been on 
forwarding packets when in STALE state.

So, let's wait for some additional input.

Thanks,

-Rajeev