Subject: RE: [Mipshop] FMIPv6 - Encapsulating FBU into Mobility Header (FNA)

From: "Soliman, Hesham" <[email-masked]>
Date: Tue, 9 Aug 2005 23:43:58 -0400

>  > I think, atleast to notify NAR about MN arrival, so that
 >  > NAR can forward the buffered packets, we need
 >  > some message(FNA). This may be done by some
 >  > other means like L2 trigger at NAR, if available.
 > 
 > => This was discussed for a very long time late 2003. 
 > You can do that by sending a standard NA. It works fine 
 > according to 2461 and 2461bis.
 > 
 > ---->True. As I mentioned in the reply to Jak's mail, NAR 
 > may need to 
 > verify buffering database (buffered packets list) for each NA. NAR
 > needs to stop proxying for NCoA.

=> I'm not sure I understand your comment. Typical ND processing
will require the AR to add a NCE if it had packets waiting, 
if not, it will ignore the NA. Nothing new to add here and no 
checking of buffered data required, it's a check of the NC state. 

Hesham

 > Thanks & Regards,
 > Subba Reddy

===========================================================
This email may contain confidential and privileged material for the sole use
 of the intended recipient.  Any review or distribution by others is strictly
 prohibited.  If you are not the intended recipient please contact the sender
 and delete all copies.
===========================================================

_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop

---

From: Subba Reddy <[email-masked]>
Date: Wed, 10 Aug 2005 09:29:28 +0530

Hi Hesham,

----> NAR needs to do some extra processing than normal NA.
If NAR is proxying for the MN's NCoA (so that during the handoff ,
other nodes will not configure NCoA), NAR needs to stop proxying.

Regarding forwarding the buffered packets, I think it is more implementation
dependent. Generally, whenever an upper layer packet comes, if NC entry
is not present, then the node will start address resolution. After finding
MAC address, node will send the packets.
In FMIPv6 case, it is bit different. NAR will not start address resolution.
Whenever MN sends FNA, NAR will forward the buffered packets.
So, some implementations may prefer to store the FMIPv6 packets separately
(may be as part of FMIPv6 module), then usual upper layer packets (may be in
IPv6 module).

Thanks & Regards,
Subba Reddy