Subject: RE: [Mipshop] FMIPv6 - Encapsulating FBU into Mobility Header (FNA)

From: "Soliman, Hesham" <[email-masked]>
Date: Wed, 10 Aug 2005 11:21:56 -0400

Exactly.

Hesham

 > -----Original Message-----
 > From: James Kempf [mailto:[email-masked]]
 > Sent: Wednesday, August 10, 2005 11:18 AM
 > To: Subba Reddy; Soliman, Hesham; Junghoon Jee; Koshiro MITSUYA;
 > Alexandru Petrescu
 > Cc: [email-masked]
 > Subject: Re: [Mipshop] FMIPv6 - Encapsulating FBU into 
 > Mobility Header
 > (FNA)
 > 
 > 
 > Most implementations of IPv6 routers have a buffer of a few 
 > packets to allow
 > a node to finish address configuration. I think what Hesham 
 > is proposing is
 > to drop HI/HAck and use an extension of that buffer. The 
 > length might be
 > made configurable so that the network operator could allow 
 > slightly more
 > packets to be buffered depending on deployment circumstance.
 > 
 >             jak
 > 
 > ----- Original Message -----
 > From: "Subba Reddy" <[email-masked]>
 > To: "Soliman, Hesham" <[email-masked]>; "James Kempf"
 > <[email-masked]>; "Junghoon Jee" 
 > <[email-masked]>; "Koshiro
 > MITSUYA" <[email-masked]>; "Alexandru Petrescu"
 > <[email-masked]>
 > Cc: <[email-masked]>
 > Sent: Tuesday, August 09, 2005 11:01 PM
 > Subject: Re: [Mipshop] FMIPv6 - Encapsulating FBU into 
 > Mobility Header (FNA)
 > 
 > 
 > > Hi Hesham,
 > >
 > >
 > > You're still assuming collisions for NCoA...The whole
 > > premise of oDAD is that with a decent RNG, there are no
 > > collisions for any practical deployment. It was already
 > > proven in draft-soto that it is more likely that the MN will
 > > be hit by lightning before a collision takes place.
 > >
 > > ---> Ok. If we don't assume collisions, proxying is not required.
 > >
 > > In this case there is no need for HI/Hack.
 > >
 > > ---> If HI/HAck exchange is not there, then it may be 
 > difficult for NAR
 > > to decide which packets to buffer. If HI/HAck exchange is 
 > present, then
 > > NAR can know NCoA's for which it needs to buffer.
 > > Am I missing something?
 > >
 > >
 > >  In fact, the current spec does not mandate HI/Hack.
 > >
 > > ---> True. For confirming the address, spec is not mandating.
 > > But it mandates the implementation of HI, HAck.
 > >
 > > Section 3.1, last paragraph,
 > > "
 > > ...
 > >    Finally, the access routers
 > >    could transfer network-resident contexts, such as 
 > access control,
 > >    QoS, and header compression, in conjunction with 
 > handover.  For these
 > >    operations, the protocol provides "Handover Initiate (HI)" and
 > >    "Handover Acknowledge (HAck)" messages.  Both of these 
 > messages MUST
 > >    be supported and SHOULD be used.
 > > ..."
 > >
 > > Thanks & Regards,
 > > Subba Reddy
 > >
 > >
 > 
 > 
 > 

===========================================================
This email may contain confidential and privileged material for the sole use
 of the intended recipient.  Any review or distribution by others is strictly
 prohibited.  If you are not the intended recipient please contact the sender
 and delete all copies.
===========================================================

_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop

---

From: Subba Reddy <[email-masked]>
Date: Wed, 10 Aug 2005 20:55:23 +0530

Hi Hesham & Jak,

I have a small question.
Do you want to use buffering or bicasting or both?

Thanks & Regards,
Subba Reddy