Subject: RE: [Mipshop] FMIPv6 - Encapsulating FBU into Mobility Header (FNA)

From: "Soliman, Hesham" <[email-masked]>
Date: Wed, 10 Aug 2005 00:58:46 -0400

> => I don't think so. The MN can form its CoA before it move
 > (predictive) or after (reactive). In either case the CoA
 > would be defended with oDAD. I don't see where the difference
 > is.
 > 
 > ----> I am mentioning about the predictive case as specified 
 > in FMIPv6 RFC.
 > If we want to send FBU in PAR's link, then proxying may be 
 > still required.
 > I think, oDAD is more useful in reactive handoffs.

=> It might be better if you explain why you think oDAD
will not work in this case. It's not clear how you came 
to that conclusion.

Hesham

 > Thanks & Regards,
 > Subba Reddy

===========================================================
This email may contain confidential and privileged material for the sole use
 of the intended recipient.  Any review or distribution by others is strictly
 prohibited.  If you are not the intended recipient please contact the sender
 and delete all copies.
===========================================================

_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop

---

From: Subba Reddy <[email-masked]>
Date: Wed, 10 Aug 2005 10:45:04 +0530

Hi Hesham,

---->Sorry for not being clear. 
In predictive case,
If MN anticipates handoff, MN will send FBU to PAR with 
prospective NCoA when MN is still connected to PAR's link.
PAR will send HI with NCoA. NAR will verify NCoA.
If NCoA is already in use, NAR may assign new CoA.
NAR will send HAck to PAR. 

If NAR specifies address in HAck,
(i.e, either accepted the NCoA in HI or proposed new CoA), NAR
needs to do proxy for NCoA, till MN comes to NAR's link (so that
nodes in the NAR link will not configure during handoff of MN).
PAR will send FBack.

So, I think,  oDAD may not come into picture in predictive case.

Thanks & Regards,
Subba Reddy