Subject: RE: [Mipshop] FMIPv6 - Encapsulating FBU into Mobility Header (FNA)

From: "Soliman, Hesham" <[email-masked]>
Date: Wed, 10 Aug 2005 00:20:20 -0400

> => I guess this discussion started with the question of whether
 > FNA is needed when the MN uses oDAD. If you use oDAD then there
 > is no need for the whole proxying of NCoA part, which is 
 > unnecessarily complex anyway. So we go back to clean plain
 > ND + oDAD. 
 > 
 > ---->I think, this case will cover only reactive handoffs. 
 > If we want predictive handoffs also, proxying may still be required.

=> I don't think so. The MN can form its CoA before it move
(predictive) or after (reactive). In either case the CoA
would be defended with oDAD. I don't see where the difference
is.

Hesham

 > Thanks & Regards,
 > Subba Reddy

===========================================================
This email may contain confidential and privileged material for the sole use
 of the intended recipient.  Any review or distribution by others is strictly
 prohibited.  If you are not the intended recipient please contact the sender
 and delete all copies.
===========================================================

_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop

---

From: Subba Reddy <[email-masked]>
Date: Wed, 10 Aug 2005 09:52:04 +0530

Hi Hesham,

----> I am mentioning about the predictive case as specified in FMIPv6 RFC.
If we want to send FBU in PAR's link, then proxying may be still required.
I think, oDAD is more useful in reactive handoffs.

Thanks & Regards,
Subba Reddy

---

From: "James Kempf" <[email-masked]>
Date: Wed, 10 Aug 2005 08:09:47 -0700

Hesham,

jak>> Yes, I think you are right. The PAR starts forwarding to the nCoA via
the NAR when it gets the FBU while the MN is on the previous router, the NAR
buffers until the MN arrives. If the MN uses oDAD, there's no delay in
confirming the nCoA when the MN moves to the NAR, as we discussed for
reactive.

jak>> The only issue is if someone arrives on the NAR prior to the MN and
tries to claim the nCoA. Unless the NAR Proxy ND's it, anybody could take
it. The same statistics that make oDAD favorable make a legitimate
counterclaim unlikely, but there is a risk of attack. I guess CGAs could be
used with SEND, but the proxying wouldn't be secure, if that's a concern.

jak>> Have I missed anything?

            jak

---

From: "James Kempf" <[email-masked]>
Date: Wed, 10 Aug 2005 08:10:11 -0700

No, it works fine for both.

            jak

----- Original Message -----
From: "Subba Reddy" <[email-masked]>
To: "Soliman, Hesham" <[email-masked]>; "James Kempf"
<[email-masked]>; "Junghoon Jee" <[email-masked]>; "Koshiro
MITSUYA" <[email-masked]>; "Alexandru Petrescu"
<[email-masked]>
Cc: <[email-masked]>
Sent: Tuesday, August 09, 2005 9:22 PM
Subject: Re: [Mipshop] FMIPv6 - Encapsulating FBU into Mobility Header (FNA)

---

From: Subba Reddy <[email-masked]>
Date: Wed, 10 Aug 2005 21:00:39 +0530

Hi Jak,

> buffers until the MN arrives.

If NAR needs to do buffering, then HI, HAck exchange may be required.
As Hesham mentioned, if bicasting is used, then message exchange may not be
requied.

Thanks & Regards,
Subba Reddy