Subject: RE: [Mipshop] FMIPv6 - Encapsulating FBU into Mobility Header (FNA)

From: "Soliman, Hesham" <[email-masked]>
Date: Wed, 10 Aug 2005 09:34:12 -0400

> ---> If HI/HAck exchange is not there, then it may be 
 > difficult for NAR
 > to decide which packets to buffer. If HI/HAck exchange is 
 > present, then
 > NAR can know NCoA's for which it needs to buffer.
 > Am I missing something?

=> Sure but two things to consider:
- You can buffer/bicast in the old AR.
- It would be interesting to see if you need any buffering
   more than the standard ND delay for address resolution.

 > ---> True. For confirming the address, spec is not mandating.
 > But it mandates the implementation of HI, HAck.

=> It mandates the implementation but not the *use*.

 > 
 > Section 3.1, last paragraph,
 > "
 > ...
 >    Finally, the access routers
 >    could transfer network-resident contexts, such as access control,
 >    QoS, and header compression, in conjunction with 
 > handover.  For these
 >    operations, the protocol provides "Handover Initiate (HI)" and
 >    "Handover Acknowledge (HAck)" messages.  Both of these 
 > messages MUST
 >    be supported and SHOULD be used.
 > ..."

=> Unfortunately this is the kind of handwaving that should not be in
the spec. CT is a separate protocol.

Hesham

 > Thanks & Regards,
 > Subba Reddy

===========================================================
This email may contain confidential and privileged material for the sole use
 of the intended recipient.  Any review or distribution by others is strictly
 prohibited.  If you are not the intended recipient please contact the sender
 and delete all copies.
===========================================================

_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop

---

From: Subba Reddy <[email-masked]>
Date: Wed, 10 Aug 2005 19:30:50 +0530

Hi Hesham,

---> True. In the case of bicasting we don't require HI, HAck.

---> Yes. If this can be done, implementation also becomes easy.

Thanks & Regards,
Subba Reddy