Subject: RE: [Mipshop] FMIPv6 - Encapsulating FBU into Mobility Header (FN A)

From: Narayanan Vidya-CVN065 <[email-masked]>
Date: Fri, 12 Aug 2005 09:57:14 -0500

> >  
> > Why can't the FBU still be sent from the old link? What 
> does assigned  
> > addressing have to do with it? Once the MN autoconfigures an IP 
> > address based on the info from PrRtAdv, can it not send an 
> FBU to the 
> > PAR on the old link?
> 
> The FBU _can_ be sent from the PAR link, to PAR.  But.
> 
> When PAR receives FBU, it sends HI, receives HAck and only 
> then sends back FBAck.  Assigned addressing is used in 
> HAck/FBAck.  If "assigned addressing" is removed from 
> HAck/FBAck, then the entire semantics change, namely there is 
> no provision for replying back to MN that NAR can't use that 
> NCoA, so no reason to have a FBAck.  So there's no FBAck.  So 
> no reason to have FBU sent from MN on the old link.  There is 
> no reason why an FBU to be sent if there's no FBAck.
> 

I must be missing something here. I thought that the HAck/FBAck allowed for assigned addressing - didn't require it. If the MN already auto-configured an address, it can send it in the FBU - the PAR includes it in the HI for the NAR to verify it. The NAR then sends a HAck to indicate that the address was acceptable and the PAR sends an FBAck to the MN. Optionally, I thought that the HI may not include an IP address for the MN, in which case, assigned addressing is expected. Is this not true? 

> Second, as in previous post, not much is gained with sending 
> FBU from the previous link, as opposed to RS/RA/FBU on the new link.
> 
> Third, sending FBU prior a successful link-layer attachment 
> is wishful thinking.  The document acknowledges this in 
> "Erroneous Movement" section.
> 
> So let me return the question: why would MN send FBU prior to 
> attachment to a new link?  What would it gain?  Is 
> RtSolPr/PrRtAdv/FBU/HI/HAck/FBAck any faster than RS/RA/FBU/FBAck?
> 
> Alex
> 

_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 12 Aug 2005 17:14:40 +0200

Narayanan Vidya-CVN065 wrote:

> I must be missing something here. I thought that the HAck/FBAck allowed
> for assigned addressing - didn't require it. If the MN already
> auto-configured an address, it can send it in the FBU - the PAR includes
> it in the HI for the NAR to verify it. The NAR then sends a HAck to
> indicate that the address was acceptable and the PAR sends an FBAck to
> the MN. Optionally, I thought that the HI may not include an IP address
> for the MN, in which case, assigned addressing is expected. Is this not
> true?

Ok... the whole reason of PAR going HI/HAck before FBAck to MN is to
confirm, or infirm, something to the MN.  The way of infirming the
requested NCoA is to provide another NCoA (via "assigned autoconf").

The only one other way for NAR to infirm the NCoA back to PAR is via
Alternate CoA in BAck.  But "Alternate CoA" as Mobile IPv6 3775 says is
only present in BU, not in BAck (as FMIPv6 says).  If FBAck contains an
address to be used by MN then FBAck suddenly becomes another address
assignment configuration method.

Alex