Subject: [Mipshop] RE: WG Consensus call on AAA based handover keys for FMIPv6

From: "John.zhao" <[email-masked]>
Date: Fri, 27 Apr 2007 16:26:19 +0800

Hi,vijay

         Just as you have mentioned.

> ..

> So we would like to check if the WG still wants to develop a AAA based 

> handover keying mechanism for FMIPv6. So please reply to this email on 

> whether you think such a mechanism needs to be developed by the 

> MIPSHOP WG. Please respond by April 30. This is a short one-week 

> consensus call since we need to re-charter pretty soon.

         I suggest that I think it is right at least. But I want to know, if
we go ahead that means we will develop a new protocol to do the AAA based
handover keying mechanism? IMHO, because the hokey seems just do this work ,
although it didn't aim only to FMIPv6. But it can be use here later. So what
is you mean?

         In another side, if only two method are chosen? One is based on
SeND, and the other is based on AAA. If still can be developed to base
anything others if applicable?

         To the statement, you in another thread just like the following, If
that means the consensus call work has been done and a document is needed at
now?

> Thank you. :)

> But seriously I would rather see a document gathering WG support rather
than saying it should go ahead because there is no one objecting.

> Vijay

         So what do you mean about the document?

         My two cents.

         Best Rgds,

Thanks,

John.zhao

_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop

---

From: "James Kempf" <[email-masked]>
Date: Fri, 27 Apr 2007 11:48:20 -0700

Actually, this issue came up recently in a conversation I had with someone.

I wonder if Vidya or someone who has been active in organizing the HOKEY BOF 
can explain what the difference is between what HOKEY is proposing as work 
items for a WG and draft-vidya for FMIP AAA based keying which we've been 
working on in MIPSHOP? I understand that HOKEY is looking at other, more 
controversial issues, such as IPSEC gateway state transfer, but I'm 
interested specifically at the issue of access router handover keys, which, 
if I recall correctly, was part of what HOKEY was originally going to do. Is 
draft-vidya part of some larger system enhancement that people in HOKEY are 
discussing? Or has HOKEY dropped access router handover keys entirely? I'm a 
little confused.

            jak

----- Original Message ----- 
From: "John.zhao" <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>
Sent: Friday, April 27, 2007 1:26 AM
Subject: [Mipshop] RE: WG Consensus call on AAA based handover keys 
forFMIPv6

>         So what do you mean about the document?

--------------------------------------------------------------------------------

---

From: "Alper Yegin" <[email-masked]>
Date: Mon, 30 Apr 2007 10:36:42 +0300

James,

I'd like to take your and WG's attention to this work:

http://ietf.org/internet-drafts/draft-yegin-fmip-sa-00.txt

I think this would classify as a "AAA-based" solution.
It is not in the scope of HOKEY WG, as far as I can understand the scope of
that WG.

I'd like to hear some feedback on this I-D. 

Alper

> -----Original Message-----
> From: James Kempf [mailto:[email-masked]]
> Sent: Friday, April 27, 2007 9:48 PM
> To: [email-masked]; [email-masked]
> Cc: [email-masked]
> Subject: HOKEY and the AAA FMIP Handover Keys Draft? (was: Re: [Mipshop]
> RE:WG Consensus call on AAA based handover keys forFMIPv6)
> 
> > handover keying mechanism? IMHO, because the hokey seems just do this
> work
> > ,
> > that means the consensus call work has been done and a document is
> needed
> > at
> > now?
> >
> >> Thank you. :)
> >
> >>
> >

---

From: "James Kempf" <[email-masked]>
Date: Mon, 30 Apr 2007 11:15:12 -0700

Thanx, I'll check it out.

            jak

----- Original Message ----- 
From: "Alper Yegin" <[email-masked]>
To: "'James Kempf'" <[email-masked]>; <[email-masked]>; 
<[email-masked]>
Cc: <[email-masked]>
Sent: Monday, April 30, 2007 12:36 AM
Subject: RE: HOKEY and the AAA FMIP Handover Keys Draft? (was: Re: [Mipshop] 
RE:WG Consensus call on AAA based handover keys forFMIPv6)

>> discussing? Or has HOKEY dropped access router handover keys entirely? 
>> I'm
>> a
>> little confused.
>>
>>             jak
>>
>> >         I suggest that I think it is right at least. But I want to 
>> > know,
>> > if
>> >         To the statement, you in another thread just like the 
>> > following,
>> > If

---

From: "Vijay Devarapalli" <[email-masked]>
Date: Mon, 30 Apr 2007 18:16:07 -0700

Hello Jim,

Good question.

The way I understand it, draft-ietf-hokey-emsk-hierarchy-00 
generates USRK (Usage Specific Root Key) as part of access 
authentication. These USRKs can be used by "other" 
applications. I don't think the USRKs can be used directly 
(somebody correct me if I am wrong). So you still need a 
mechanism to generate FMIPv6 specific keys from the USRKs 
generated by the HOKEY protocols.

Now coming to draft-vidya-mipshop-handover-keys-aaa, one 
could equate an USRK with the Handover Master Key (HMK).

Vijay

> Sent: Friday, April 27, 2007 11:48 AM
> To: [email-masked]; Vijay Devarapalli
> Cc: [email-masked]
> Subject: HOKEY and the AAA FMIP Handover Keys Draft? (was: 
> Re: [Mipshop] RE: WG Consensus call on AAA based handover 
> keys forFMIPv6)
> 
> >         I suggest that I think it is right at least. But I 
> want to know, 
> > if
> > handover keying mechanism? IMHO, because the hokey seems 
> just do this work 
> > ,
> > although it didn't aim only to FMIPv6. But it can be use 
> here later. So 
> > what
> > is you mean?
> >
> >         To the statement, you in another thread just like 
> the following, 
> > If
> > that means the consensus call work has been done and a 
> document is needed 
> > at
> > now?
> >
> >> Thank you. :)
> >
> >>
> >