Subject: [Mipshop] HMIPv6 AAA

From: "hao chen" <[email-masked]>
Date: Mon, 14 May 2007 00:14:53 +0800

Hi all,
I am working on HMIPv6 AAA,and my network topology is  below

           +-----+               +-----+
           |AAAL |-------------|AAAH |
           +-----+               +-----+
              |                       |
     ------------------          +-----+
     |                |           | HA  |
   +-----+         +-----+   +-----+
   |MAP1 |     | MAP2|
   +-----+        +-----+

      +-----+
      | MN  |
      +-----+

 I want to use the mechanism discribed in
 draft-vidya-mipshop-handover-keys-aaa-04 to
 deal with handover keys management.First of all,
 my handover key hierarchy,in my opinion,
 should be like this,

                   HMK(HKS/AAAH)
                    |
 ----------------------------------------------------------------------------------------------
 |                 |
|                                          |
 |                 |
|                                          |
 |                 |
|                                         |
 HIK    MAP_HK1(MAP1)   MAP_HK2(MAP2)               HA_HK(HA)
(MN-HKS)

 so the SA between MN and MAP is separate from
  the SA between MN and HA.
 They are estabished in the similar way.

 Anything wrong?

 Thank you very much.
--chen
_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop

---

From: Michael Ye <[email-masked]>
Date: Mon, 14 May 2007 10:30:22 +0800

Hi chen,

see below,

BR,
Michael

________________________________

	From: hao chen [mailto:[email-masked]] 
	Sent: Monday, May 14, 2007 12:15 AM
	To: [email-masked]
	Subject: [Mipshop] HMIPv6 AAA

	Hi all,

	           +-----+               +-----+ 

	      +-----+
	      | MN  |
	      +-----+

	                   HMK(HKS/AAAH)
	                    |
	
----------------------------------------------------------------------------
------------------
	 |                 |                                |
| 
	 |                 |                                |
|
	 |                 |                                |
| 
	 HIK    MAP_HK1(MAP1)   MAP_HK2(MAP2)               HA_HK(HA) 
	(MN-HKS)            

Michael==>I am confused a little here.  you think the SA's establishment
between MN and MAP  is based on draft-vidya-mipshop-handover-keys-aaa-04? 

Michael==>what is the method which you will use for establishing them here?

	 Anything wrong?

	 Thank you very much. 

	--chen

---

From: "hao chen" <[email-masked]>
Date: Mon, 14 May 2007 16:43:35 +0800

Hi , Michael

Here is my answers:

> 1 you think the SA's establishment

   Yes.In the draft , I found these lines:Additionally, keys between an MN
and a MAP can be derived using this protocol for Hiearchical Mobile IPv6
(HMIPv6) [10] operation.

2 They are estabished in the similar way.

   I mean in the handover key management of HMIPv6, MAPs an HAs should be
treated equally? In other words ,should  MAP_HKs and HA_HKs be in the same
level of the  key hierarchy?
Thank you.

--chen

---

From: "Narayanan, Vidya" <[email-masked]>
Date: Tue, 15 May 2007 14:45:48 -0700

Hi Chen,
If you are using the AAAH as the HKS for both HMIP and MIP purposes,
what you have shown below would work just fine.  As you correctly note,
the mechanism described in draft-vidya-mipshop-handover-keys-aaa-04 will
work for key establishment between the MN and any other entity, as long
as that entity can talk to the HKS.  

Regards,
Vidya 

> -----Original Message-----
> Sent: Sunday, May 13, 2007 9:15 AM
> To: [email-masked]
>  draft-vidya-mipshop-handover-keys-aaa-04 to  deal with 
> handover keys management.First of all,  my handover key 
> hierarchy,in my opinion,  should be like this, 
> 
>  
> 
>                    HMK(HKS/AAAH)
>                     |
>