Subject: [Mipshop] Review on FMIP6 over IEEE 802.16e Networks

From: "Daniel Park" <[email-masked]>
Date: Wed, 9 May 2007 19:37:45 +0900

To MIPSHOP WG,

Here is an official review by 16NG expert as Jinhyeock Choi. Also, two
more experts are in the progress of reviewing this document. They will
get back to MIPSHOP soon.

=================

I went over the draft and overall it looks fine. It presents an useful
information to efficiently run FMIPv6 over 802.16e with primitives.

I found no technical issue except one.

There are incorrect statements in Sec 3 Deployment Architecture. For
example, there can be more than 2 subnets in figure 1, whereas it's
written that 'Figure 1 shows the deployment with two IP subnets'. In
fact there can be as many subnets as the # of MNs according to
per-MN-prefix link/subnet model. I recommend to re-write the section
or remove it altogether. IMO, the draft will do fine without the
section.

I have a few more comments but they are all editorial. I'll send them
to the authors in a separate mail.

Thanks in advance for your kind consideration.

Best Regards

JinHyeock

=================

Hope this helps...

-- Daniel Park

_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop

---

From: Behcet Sarikaya <[email-masked]>
Date: Wed, 16 May 2007 16:20:28 -0700 (PDT)

I think that subnet concept is important for handover because subnet change is the reason for Layer 3 handover.
Besides, draft-ietf-16ng-ipv6-over-ipv6cs-09 would be better reference for FMIPv6 over IEEE 802.16e document.

My 2 cents.

Behcet
----- Original Message ----
From: Daniel Park <[email-masked]>
To: Behcet Sarikaya <[email-masked]>
Cc: [email-masked]; "[email-masked]" <[email-masked]>
Sent: Wednesday, May 16, 2007 4:38:21 PM
Subject: Re: [16NG] Review on FMIP6 over IEEE 802.16e Networks

[16ng chair hat off, just individual comments on this thread]

My resolution is:

Leave Section 3 out, and just refer to 16ng IPv6 subnet model document
<draft-ietf-16ng-ipv6-link-model-analysis-03, its status is RFC Queue>
for further applicable cases in conjunction with this document. If we
are supposed to take care of these concerns in this document, it would
be really complex. It seems beyond scope of this document in my
understanding...

-- Daniel Park

On 5/17/07, Behcet Sarikaya <[email-masked]> wrote:
>
> Hi Daniel,
>   I agree with Jin-Hyeock's comment, I think that Sec 3 should probably not
> be removed but instead a clarification to the base FMIPv6 can be made.
>   On 802.16e links, the AR-Info triplet:
>  [Router's L2 address, Router's IP address and Prefix]
> the prefix in the triplet is valid on the interface to which the Access
> Point (identified by AP-ID) and is different for each MN that is attached
> due to p2p link model.
>
> Based on this, the second paragraph can be slightly modified as follows:
> Figure 1 shows the deployment with two ARs (ASN-GWs).
> Each MN under an access router
>  (AR) and several base stations (BSs) forms a single subnet. In this
>  case, the movement between BSs does not always require IP mobility.
>  The handover from BS1 to BS2, can be carried
>  out using link layer mobility without IP mobility. However, the
>  handover from BS5 to BS6 may require IP mobility since they belong to
>  the different subnets respectively.
> We are checking if Sec. 6 requires any changes because of p2p link model and
> let you know soon.
>
> Regards,
>
> Behcet
> ----- Original Message ----
> From: Daniel Park <[email-masked]>
> To: [email-masked]
> Cc: "[email-masked]" <[email-masked]>
> Sent: Wednesday, May 9, 2007 5:37:45 AM
> Subject: [16NG] Review on FMIP6 over IEEE 802.16e Networks
>
> To MIPSHOP WG,
>
> 16NG mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/16ng
>
>

---

From: Heejin Jang <[email-masked]>
Date: Fri, 18 May 2007 07:09:37 +0000 (GMT)

Dear Daniel & Behcet.

Thanks for your comment.

Based on the feedbacks from Jinhyeock and you,
Section 3 will be removed to avoid the ambiguity in the next revision .

Thanks for your comment.

- Regards, 
Heejin. 

------- Original Message -------
Sender : Daniel Park<[email-masked]>
Date   : 2007-05-17 06:38
Title  : Re: [16NG] Review on FMIP6 over IEEE 802.16e Networks

My resolution is:

-- Daniel Park

On 5/17/07, Behcet Sarikaya <[email-masked]> wrote:
>
> Hi Daniel,
>   I agree with Jin-Hyeock&#39;s comment, I think that Sec 3 should probably not
>  [Router&#39;s L2 address, Router&#39;s IP address and Prefix]
> example, there can be more than 2 subnets in figure 1, whereas it&#39;s
> written that &#39;Figure 1 shows the deployment with two IP subnets&#39;. In
> fact there can be as many subnets as the &#35; of MNs according to
> I have a few more comments but they are all editorial. I&#39;ll send them