Subject: [MLS] 20200908 MLS WG Virtual Interim

From: Sean Turner <[email-masked]>
Date: Tue, 8 Sep 2020 09:36:05 -0400

Hi! We are having a virtual interim Tuesday 9 September 2020 at 1600 UTC. Webex details can be found here:
https://datatracker.ietf.org/meeting/interim-2020-mls-20/session/mls
Our agenda is to address protocol related issues and PRs. Outstanding Issues and PRs can be found here:
https://github.com/mlswg/mls-protocol

Nick and Sean

---

From: Richard Barnes <[email-masked]>
Date: Tue, 8 Sep 2020 13:56:40 -0400

Here are my notes:

2020-09-08
* #336
    * ReInit as Proposal makes sense, just require that it be the last
proposal in the Commit
    * Also have Replace with Welcome / H(Welcome)?
* #337 - Hold pending #336
* #360 - RLB and Brendan working out details, will merge when ready
* #349
    * Anonymous version could make ordering requirements difficult for
server / require more state
    * Anonymous version could complicate fork detection; since messages in
the two forks will have different epochIDs, they won’t be obviously
colliding
    * Whichever we do (current or anonymous), the other one can be built
over the top:
        * Anonymous->not: Leak extra information, e.g., in AAD
        * Not->Anonymous: Strip/replace groupID+epoch in MLSCiphertext on
send, reconstitute on receive
    * For now: Keep anonymous thing, make bigger, add operational
considerations (server vis, fork detection => leak in AAD)

On Tue, Sep 8, 2020 at 9:36 AM Sean Turner <[email-masked]> wrote:

> _______________________________________________
> MLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mls
>