Subject: RE: [MMUSIC] Prelim copy of comedia-02 available

From: "David Yon" <[email-masked]>
Date: Fri, 12 Apr 2002 16:34:09 -0400

> >
> >Ok, unless there are objections, I'm changing the sentence to read:
> >
> >	Endpoints that specify direction:passive MUST NOT
> >	send any media, including control packets such as 
> >	RTCP, from their passive ports until they receive 
> >	a packet on these ports and record the source address
> >	and port of the sender.  
> 
> I think it needs to say "MUST NOT send RTP until it has 
> received an RTP
> packet on the passive port; MUST NOT send RTCP until it has 
> received an
> RTCP packet on the passive port". Be explicit about it.
> 
> Colin
> 

Except that there are other protocols in the world besides those based
on RTP/RTCP.  Rohan's language specifically includes other protocols
(hence the UDP reference).  T.38 over UDP, for example, would not be
addressed by your proposed language.

Given the need to include the entire set of media types in Rohan's
language, I'm still of the opinion that my proposed language above is
unambigious to the alert reader, even if they have RTP/RTCP in mind.

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Colin Perkins <[email-masked]>
Date: Fri, 12 Apr 2002 17:07:58 -0400

>addressed by your proposed language.

True.

>unambigious to the alert reader, even if they have RTP/RTCP in mind.

I'm not too worried about it. You could add a "For example, if using RTP,
..." maybe?

Colin