Subject: RE: [MMUSIC] Prelim copy of comedia-02 available

From: "David Yon" <[email-masked]>
Date: Thu, 11 Apr 2002 11:52:21 -0400

> Short answer is: the passive peer can't send RTP until it has 
> recieved a
> packet of RTP on the RTP port, and can't send RTCP until it 
> has received a
> packet of RTCP on the RTCP port.
> 
> You can't (and MUST NOT) send RTP, RTCP, UDP, TCP, etc... 
> media  from a
> passive port until a packet has arrived to that port from 
> (presumably) the
> active peer.  The reason is simple--you don't know the address/port of
> your peer until your recieve that first packet.
> 

Ok, unless there are objections, I'm changing the sentence to read:

	Endpoints that specify direction:passive MUST NOT
	send any media, including control packets such as 
	RTCP, from their passive ports until they receive 
	a packet on these ports and record the source address
	and port of the sender.  

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Colin Perkins <[email-masked]>
Date: Thu, 11 Apr 2002 20:46:40 -0400

>	a packet on these ports and record the source address

I think it needs to say "MUST NOT send RTP until it has received an RTP
packet on the passive port; MUST NOT send RTCP until it has received an
RTCP packet on the passive port". Be explicit about it.

Colin