Subject: [MMUSIC] whitespace after 's=' in SDP

From: [email-masked]
Date: Fri, 14 Jun 2002 09:46:36 +0300

Is a whitespace allowed in the s= line of an SDP message?

from ABNF grammar:

session-name-field =  "s=" text CRLF

; generic sub-rules: datatypes
text =                byte-string

byte-string =         1*(%x01-09/%x0B-0C/%x0E-FF)
                      ;any byte except NUL, CR or LF

The space is %x20 so it can be included in any byte-string.
Byte-sting 's= Some Text" should be valid.

But the draft also mentions that "Whitespace MUST NOT be used either side of the `='
sign"

So, is the grammar wrong? or is s= an exception? Are there any other exceptions?

Regards,
Hisham

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Colin Perkins <[email-masked]>
Date: Fri, 14 Jun 2002 18:36:36 -0400

>Is a whitespace allowed in the s= line of an SDP message?

Yes.

>But the draft also mentions that "Whitespace MUST NOT be used either side of the `='

Correct.

>So, is the grammar wrong? or is s= an exception? Are there any other exceptions?

I'd claim that the grammar is correct, in that you still have "<type>=<value>",
without spaces, but that in this case the <value> can include whitespace. Just
another wart, that can't be fixed without breaking compatibility.

Colin