Subject: RE: [MMUSIC] Comments on draft-ietf-mmusic-kmgmt-ext-07.txt

From: "Peterson, Jon" <[email-masked]>
Date: Tue, 15 Apr 2003 04:45:59 -0400

A few notes below.

Jon Peterson
NeuStar, Inc.

> -----Original Message-----
> From: Fredrik Lindholm (EAB) [mailto:[email-masked]]
> Sent: Sunday, April 13, 2003 11:37 PM
> To: 'Colin Perkins'
> Cc: [email-masked]
> Subject: RE: [MMUSIC] Comments on draft-ietf-mmusic-kmgmt-ext-07.txt 
> 
[snip]
> 
> The SIP/SDP may only be protected hop-by-hop (i.e. between the 
> SIP proxies and SIP proxy - terminal). MIKEY is then needed to provide 
> end-to-end security for the media streams. More or less, you only 
> need to trust the proxies to provide a reliable transport, but 
> you do not need to trust the proxies for your media.
> 
> An almost analogous example would be email. You may use SSL to your 
> mail server (to secure your session and account), but if you like 
> end-to-end protection, you do not rely on this but apply something 
> like S/MIME... 
> 

It is worth pointing out that SIP encourages support of S/MIME for just this
reason.

> > 
> > >>    Are attacks possible by manipulating the non-authenticated parts
of the
> > >>    SDP?
> > >
> > >If you, by attacks, are referring to attacks towards the key
management 
> > >and the secured media, I would say no.
> > 
> > But is may be possible to redirect a media stream, for example?
> 
> Of course (note though that there are plenty of other methods to 
> do re-direction attacks of streams if you happen to be 
> "on-the-path"...).  
> 

Again, it is worth noting that wrapping SDP in S/MIME prevents this sort of
attack (at least redirection at the layer of SDP - SIP, for example, has
some other safeguards to prevent malicious redirection at the SIP layer). 

This of course speaks only to carrying SDP in SIP. But is it true that all
of the protocols that currently use SDP (RTSP, SAP, SIP...) carry MIME
types, and consequently could use S/MIME if needed?

> Fredrik
> 
> > Colin
> > 
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/mmusic
> 
_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Colin Perkins <[email-masked]>
Date: Tue, 15 Apr 2003 07:45:57 -0500

>It is worth pointing out that SIP encourages support of S/MIME for just this

Although this requires you to trust any intermediate proxies. This need
could perhaps be avoided if MIKEY authenticated the entire SDP end2end?

>types, and consequently could use S/MIME if needed?

RTSP certainly could use S/MIME; SAP probably can't as it's unidirectional
and one-to-many.

Colin

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 15 Apr 2003 11:02:11 -0400

> could perhaps be avoided if MIKEY authenticated the entire SDP end2end?

I'm confused.

S/MIME does not require you to trust intermediate proxies, thats the 
whole point.

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
Chief Scientist                             Parsippany, NJ 07054-2711
dynamicsoft
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

---

From: Colin Perkins <[email-masked]>
Date: Tue, 15 Apr 2003 10:49:05 -0500

>S/MIME does not require you to trust intermediate proxies, thats the 

Duh, my bad. Confusing S/MIME and SSL. Ignore that message, not enough
coffee this morning :)

Colin

---

From: Flemming Andreasen <[email-masked]>
Date: Tue, 15 Apr 2003 16:52:23 -0400

"Peterson, Jon" wrote:

<snip>

> types, and consequently could use S/MIME if needed?

Megaco (and MGCP) don't

-- Flemming

---

From: Tom Taylor <[email-masked]>
Date: Wed, 16 Apr 2003 10:27:34 -0400

The other point about these protocols is that they are not intended to be handled by 
intermediate proxies.

---

From: Flemming Andreasen <[email-masked]>
Date: Wed, 16 Apr 2003 10:43:06 -0400

> The other point about these protocols is that they are not intended to be handled by

This is true, an although I agree than an MG needs to place some amount of trust in its
MGC, not everybody want to place 100% trust in their MGC. For example, some MGs may want
to negotiate media stream ciphers (or at least keys) in such a way that their MGC will
not be able to decipher the media stream.

-- Flemming