Subject: Re: [MMUSIC] draft-ietf-mmusic-rtsp-nat-00.txt questions

From: [email-masked]
Date: Wed, 30 Apr 2003 19:20:04 +0200

TLS ?

but there is no TLS involved in the type of STUN usage we want
right ? it is just sending a few UDP packets with the right (STUN) syntax,
nothing more

Philippe Gentric
Software Architect
Philips MP4Net
[email-masked]
http://www.platform4.philips.com

                                                                                                                                       
                                                   To:   Jonathan Rosenberg <[email-masked]>                                  
                                                   cc:   Tom Marshall <[email-masked]>                                             
                                                    Philippe Gentric/MP4-SUR/CE/PHILIPS@EMEA1                                          
                                                    Thomas Zeng <[email-masked]>                                                 
               Aaron Colwell                        "'Magnus Westerlund'" <[email-masked]>                          
               <[email-masked]>                  IETF MMUSIC WG <[email-masked]>                                                   
                                                    [email-masked]                                                              
               30/04/2003 18:00                    Subject:    Re: [MMUSIC] draft-ietf-mmusic-rtsp-nat-00.txt questions                
                                                                                                                                       
                                                   Classification:                                                                     

In my opinion requiring an implementation to use STUN to do this is a
pretty large requirement. It means the client will have to have a TLS
implementation right? The cost in code space or CPU usage of the TLS
implementation may be too high for some embedded applications like 3GPP
devices. I think demultiplexing the STUN and RTP/RTCP messages could get
tricky. The STUN solution also won't work behind a Symmetric NAT unless
the server implements STUN as well. I just feel that the use of STUN puts
too many requirements on the client and server.

I agree with Thomas though that by making these binding packets RTP data
packets, the client and server end up having to do much more RTCP protocol
then we really need. We really just need a packet that looks like an RTP
packet like Tom Marshall said. We could just get one of the reserved
payload types assigned for binding packets and specify that these packets
do not require the normal RTCP chat associated with a data stream. Old
implementations will keep state for these packets and send RTCP chat for
the data, but newer impelementations will know that they don't have to
care about these packets.

What do people think?

Aaron

On Wed, 30 Apr 2003, Jonathan Rosenberg wrote:

>
>
> Tom Marshall wrote:
>
> >
> >> Actually in the ligth of this discussion the usage of STUN looks so
> >> much more straigthforward no ?
>
> I was thinking the same thing.
>
> >
> >
> > Well, the case of a STUN server that is a third party to the client
> > and server is quite straightforward.  But that doesn't work with
> > 5-tuple NAT setups, so we have the RTP/STUN multiplexing case.  And
> > that, really, is no more or less complicated than "symmetric rtp".
> > They are mostly equivalent solutions.  It only looks less complicated
> > at this point in time because the format for STUN packets has already
> > been agreed upon, and we are still looking at the format for the
> > "symmetric rtp" packets.
>
> Its an issue of - why are you inventing yet another thing when we
> already have something on the table?
>
> -Jonathan R.
>
>
> --
> Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
> Chief Scientist                             Parsippany, NJ 07054-2711
> dynamicsoft
> [email-masked]                     FAX:   (973) 952-5050
> http://www.jdrosen.net                      PHONE: (973) 952-5000
> http://www.dynamicsoft.com
>
>

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Aaron Colwell <[email-masked]>
Date: Wed, 30 Apr 2003 10:51:55 -0700 (PDT)

Are we intending to skip over the Shared Secret part of the STUN protocol?
On pages 7 and 24 of RFC 3489 it talks about RTP use scenarios
specifically and it says the first step is to send a shared secret
request. On pages 6 and 8 the RFC says that shared secret requests are
always sent over TLS.

Aaron