Subject: RE: [MMUSIC] ICE feature - TCP alternates for a UDP stream

From: "Francois Audet" <[email-masked]>
Date: Wed, 2 Feb 2005 12:41:40 -0500

OK. I guess for the latter, you are not defining procedures
for verifying connectivity (akin to the peer-to-peer STUN in
ICE), correct? It is outside the scope of what you are proposing, 
right?

I assume the RTP/TCP transport option will NOT be made mandatory in ICE?

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Jonathan Rosenberg
> Sent: Wednesday, February 02, 2005 02:16
> To: Audet, Francois [SC100:9T51:EXCH]
> Cc: 'IETF MMUSIC WG'
> Subject: Re: [MMUSIC] ICE feature - TCP alternates for a UDP stream
> 
> 
> 
> 
> Francois Audet wrote:
> 
> > So you are saying that the media would be transported over 
> RTP/TCP to 
> > the TURN relay, and then to the other endpoint using 
> another RTP/TCP 
> > session, right?
> 
> Yes.
> 
> > 
> > And not and end-to-end RTP/TCP session between the two peers, right?
> 
> One could offer that up as an additional alternate, yes. In 
> other words, 
> just like the client would offer UDP alternates learned from 
> STUN, TURN 
> and local interfaces, so too they could offer TCP alternates learned 
> from TURN and local interfaces. The latter, if it works, 
> would result in 
> a direct TCP connection from one user to the other. The 
> former would end 
> up with clients connecting through the TURN server.
> 
> -Jonathan R.
_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 02 Feb 2005 23:08:55 -0500

> ICE), correct? It is outside the scope of what you are proposing,

My first inclination was that you would still use STUN for the 
connectivity check over TCP; irregardless of whether that tcp is through 
a TURN relay or direct (indeed, the peer in the call won't normally even 
know whether the tcp connection it will make is direct or through a 
relay). Recall that stun can run over tcp.

However, it is less useful here since establishment of the connection 
itself could be considered a connectivity check. As such, I could go 
either way.

Do you have a preference here, and if so, why?

> I assume the RTP/TCP transport option will NOT be made mandatory in ICE?

No, in that we concluded that nothing in particular was mandatory, not 
even TURN/UDP. However I will add motivation text for this which 
explains why it might be a good idea.

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.                   600 Lanidex Plaza
Director, Service Provider VoIP Architecture   Parsippany, NJ 07054-2711
Cisco Systems
[email-masked]                              FAX:   (973) 952-5050
http://www.jdrosen.net                         PHONE: (973) 952-5000
http://www.cisco.com