Subject: RE: [MMUSIC] Re: [Sipping] What role (if any) for IMS/SIP in aStreaming Service: IMS/SIP - RTSP interworking

From: [email-masked]
Date: Wed, 2 Nov 2005 12:55:00 -0500

Yes. I agree. I would have liked to lead such a discussion, but alas, my
travel plans are uncertain and there's a good chance I won't make it
either. Hence, my reluctance. Nevertheless, I think such a discussion
would be useful.

-Steve

-----Original Message-----
From: Michael Hammer (mhammer) [mailto:[email-masked]] 
Sent: Wednesday, November 02, 2005 12:36 PM
To: Dean Willis; Colin Perkins
Cc: Chris Steck; Uzelac,Adam; [email-masked]; Steven D. Whitehead;
[email-masked]
Subject: RE: [MMUSIC] Re: [Sipping] What role (if any) for IMS/SIP in
aStreaming Service: IMS/SIP - RTSP interworking

Although I won't be there, one question might be whether an "RTSP-lite"
protocol could be defined that is intended to be used with SIP and
avoids the overlap on session setup.  Seems that overlap was the crux of
the issue.

Mike

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Dean Willis
> Sent: Tuesday, November 01, 2005 6:37 PM
> To: Colin Perkins
> Cc: Chris Steck; 'Uzelac,Adam'; [email-masked]; 
> [email-masked]; [email-masked]
> Subject: Re: [MMUSIC] Re: [Sipping] What role (if any) for 
> IMS/SIP in aStreaming Service: IMS/SIP - RTSP interworking
> 
> 
> On Nov 1, 2005, at 2:42 PM, Colin Perkins wrote:
> 
> > We have some time available in the MMUSIC agenda, if it would be 
> > useful to have a discussion on this subject. Contact the 
> MMUSIC chairs 
> > if you'd like to lead the discussion.
> >
> 
> Watching a "movie" is no more less interactive than is 
> leaving a recording on a voice-mail server.  So obviously one 
> could issue an INVITE with a receive-only offer to a 
> "player", that would respond with a send-only answer, and 
> voila, you're watching a movie. And clearly the 
> authentication mechanisms, resource precondition mechanisms, 
> and so one could be reused. We've been talking about this 
> sort of thing for years,
> 
> 
> There's also nothing fundamentally wrong, IMHO, with using 
> SIP to discover/establish an RTSP session to control playout 
> of a multimedia stream. There might be some tricky bits of 
> SDP needed, and MMUSIC is definitely where that expertise is.
> 
> I have no objection to discussing this idea in MMUSIC, but 
> would suggest that we phrase the discussion in the context of 
> SIP and peer protocols (RTP, RTCP, RTSP, etc.) in the 
> generally related IETF architecture, rather than in the 
> context of IMS.
> 
> --
> Dean
> 
> 
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP 
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments of core SIP
> 

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: "Chris Steck" <[email-masked]>
Date: Wed, 2 Nov 2005 10:17:34 -0800

I won't be able to attend this either unless it's very early in the week.  I
will however be in Bordeaux for the 3GPP SA-4 working group mtg the 14-18th,
and we could potentially get this on the discussion for the
Packet-Switched-Streaming sub group in the context of IMS recommendations.

If you think that's worthwhile at this point, let me know and I'll ask for a
T-doc #.

-Chris

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]

Sent: Wednesday, November 02, 2005 9:55 AM
To: [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: RE: [MMUSIC] Re: [Sipping] What role (if any) for IMS/SIP in
aStreaming Service: IMS/SIP - RTSP interworking

Yes. I agree. I would have liked to lead such a discussion, but alas, my
travel plans are uncertain and there's a good chance I won't make it either.
Hence, my reluctance. Nevertheless, I think such a discussion would be
useful.

-Steve

-----Original Message-----
From: Michael Hammer (mhammer) [mailto:[email-masked]]
Sent: Wednesday, November 02, 2005 12:36 PM
To: Dean Willis; Colin Perkins
Cc: Chris Steck; Uzelac,Adam; [email-masked]; Steven D. Whitehead;
[email-masked]

Although I won't be there, one question might be whether an "RTSP-lite"
protocol could be defined that is intended to be used with SIP and avoids
the overlap on session setup.  Seems that overlap was the crux of the issue.

Mike

> Subject: Re: [MMUSIC] Re: [Sipping] What role (if any) for IMS/SIP in 
> Watching a "movie" is no more less interactive than is leaving a 
> recording on a voice-mail server.  So obviously one could issue an 
> INVITE with a receive-only offer to a "player", that would respond 
> with a send-only answer, and voila, you're watching a movie. And 
> clearly the authentication mechanisms, resource precondition 
> mechanisms, and so one could be reused. We've been talking about this 
> sort of thing for years,
> 
>