Subject: RE: [MMUSIC] Usage of stream bandwidth attribute in SDP offer/answer

From: "Desineni, Harikishan" <[email-masked]>
Date: Tue, 6 Jun 2006 14:00:16 -0700

Is the "a=alt" attribute already defined in some draft/RFC or are you
suggesting that this attribute be newly defined to handle the particular
scenario I am trying to address?

Cheers,
Hari

> -----Original Message-----
> From: Kylin Wei [mailto:[email-masked]]
> Sent: Monday, June 05, 2006 11:10 PM
> To: Desineni, Harikishan
> Cc: [email-masked]
> Subject: RE: [MMUSIC] Usage of stream bandwidth attribute in SDP
> offer/answer
> 
> Hi Harikishan:
> Desineni, Harikishan wrote:
> > Is the "b=AS" parameter allowed to be used this way to communicate
> that
> > the offerer would like to send/receive the stream with the specified
> > bandwidth?
> 
> If Alice offers several alternative bandwidths by "a=alt" attribute,
Bob
> can
> select one of them to start with.
> I think that it may be improper to use this way to indicate directly
the
> specified
> bandwidth.
> Kylin Wei

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Magnus Westerlund <[email-masked]>
Date: Tue, 06 Jun 2006 23:35:50 +0200

Hi,

The a=alt is an attribute defined by 3GPP (TS 26.234) for use in 
streaming and have no defined behavior in an offer/answer exchange. I 
would propose staying away from doing that. It will get you into a mess.

Cheers

Magnus

-- 

Magnus Westerlund

Multimedia Technologies, Ericsson Research EAB/TVA/A
----------------------------------------------------------------------
Ericsson AB                | Phone +46 8 4048287
Torshamsgatan 23           | Fax   +46 8 7575550
S-164 80 Stockholm, Sweden | mailto: [email-masked]