Subject: RE: [MMUSIC] Usage of stream bandwidth attribute in SDP offer/answer

From: "Desineni, Harikishan" <[email-masked]>
Date: Mon, 5 Jun 2006 15:28:04 -0700

>From RFC3264, Sec 5.1, Page 6

"For sendonly RTP streams, the address and port number indirectly
indicate where the offerer wants to receive RTCP reports". 

In the example given by me, Alice can receive RTCP receiver reports on
port 51373. The same applies to the sendonly stream in the response from
Bob (Bob can receive RTCP receiver reports on port 54417.

Cheers,
Hari D

> -----Original Message-----
> From: James M. Polk [mailto:[email-masked]]
> Sent: Monday, June 05, 2006 2:33 PM
> To: Desineni, Harikishan; [email-masked]
> Subject: Re: [MMUSIC] Usage of stream bandwidth attribute in SDP
> offer/answer
> 
> Asside from your BW question, how can Alice state in SDP what Bob's
> receive
> port number is?  Isn't that against the rules?
> 
> At 02:10 PM 6/5/2006 -0700, Desineni, Harikishan wrote:
> >Hello MMUSIC folks,
> >
> >I am trying to build an SDP offer/answer for a point to point call
using
> >RFC3264 SDP offer/answer model. The offerer (alice) would like to
convey
> >that it would like to send and receive audio at 16000bps, send video
at
> >64000 bps and receive video at 128000bps. The answerer(bob) would
like
> >to receive video at 32000bps and send video at 64000bps. Below is the
> >SDP exchange between alice and bob.
> >
> >
> >[SDP offer]
> >       v=0
> >       o=alice 2890844526 2890844526 IN IP4 host.sd.example.com
> >       s=
> >       c=IN IP4 host.sd.example.com
> >       t=0 0
> >       m=audio 49170 RTP/AVP 0
> >       a=rtpmap:0 PCMU/8000
> >       b=AS:16000
> >       m=video 51372 RTP/AVP 31
> >       a=rtpmap:31 H261/90000
> >       b=AS:64000
> >       a=sendonly
> >       m=video 51374 RTP/AVP 31
> >       a=rtpmap:31 H261/90000
> >       b=AS:128000
> >       a=recvonly
> >
> >[SDP answer]
> >       v=0
> >       o= bob 2808844564 2808844564 IN IP4 host.la.example.com
> >       s=
> >       c=IN IP4 host.la.example.com
> >       t=0 0
> >       m=audio 52124 RTP/AVP 0
> >       a=rtpmap:0 PCMU/8000
> >       b=AS:16000
> >       m=video 53212 RTP/AVP 31
> >       a=rtpmap:31 H261/90000
> >       b=AS:32000
> >       a=recvonly
> >       m=video 54416 RTP/AVP 31
> >       a=rtpmap:31 H261/90000
> >       b=AS:64000
> >       a=sendonly
> >
> >
> >Is the "b=AS" parameter allowed to be used this way to communicate
that
> >the offerer would like to send/receive the stream with the specified
> >bandwidth?
> >
> >RFC3264 (Sec 5.1, Page 7) states "If the bandwidth parameter is
present
> >for a stream, it indicates the desired bandwidth that the offerer
would
> >like to receive". From the RFC text, it is not clear whether the
> >bandwidth parameter can also be used to indicate the desired
bandwidth
> >the offerer would like transmit (atleast when a=sendonly)
> >
> >Cheers,
> >Hari D
> >
> >_______________________________________________
> >mmusic mailing list
> >[email-masked]
> >https://www1.ietf.org/mailman/listinfo/mmusic

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: "Even, Roni" <[email-masked]>
Date: Tue, 6 Jun 2006 09:07:00 +0300

Hi,
My understanding is that only the receive rate is important and it is a
maximum rate. The sender may send any rate up to the maximum rate
supported by the receiver.
Video does not have a fixed "frame" size. The size of the frame may
change based on the information.  

Roni Even

> From: Desineni, Harikishan [mailto:[email-masked]]
> Sent: Tuesday, June 06, 2006 12:10 AM
> To: [email-masked]
> Subject: [MMUSIC] Usage of stream bandwidth attribute in SDP
offer/answer
using
convey
at
> 64000 bps and receive video at 128000bps. The answerer(bob) would like
that
present
would
> bandwidth parameter can also be used to indicate the desired bandwidth