Subject: RE: [MMUSIC] Protocol Action: 'SDP: Session Description Protocol'-resolution declaration for video stream

From: "Even, Roni" <[email-masked]>
Date: Fri, 23 Jun 2006 19:02:34 +0300

Hi,

Those parameters are defined are defined in the codec parameters. It is in H.261 and H.263; note that for H.261 it is only QCIF and CIF while H.263 has more defined resolutions as well as custom resolutions. 

H.264 is slice based codec and not based on a specific resolution, this enables the creation of different geometries. The decoder must be able to scale the received picture to display.

Note that the resolution parameters in SDP are more for the receive capability and are not applicable to RTSP. 

Roni Even

________________________________

From: Alan Bergmin [mailto:[email-masked]] 
Sent: Thursday, June 22, 2006 11:24 PM
To: [email-masked]
Subject: RE: [MMUSIC] Protocol Action: 'SDP: Session Description Protocol'-resolution declaration for video stream

I have a similar remark: when I read the draft draft-shacham-sipping-session-mobility-02 (section 6.2), I think it would be nice for some applications to be able to advertize in the SDP the display size available (in pixels) on the terminal, not only for H.263 (as in draft-ietf-avt-rfc2429-bis-08.txt), but for every format. I understand that it would not always be possible to fully use the display capabilities of the terminal according to the different codecs but it can help in some cases of session mobility.

> Hi, I'm looking for the resolution declaration for video

> stream in SDP. I didn't find anything standard for

> declaration of video resolution - like "CIF", "QCIF",...
> SHALL be it a part of the "a=fmtp" line of SDP? 

> Is it any other standard option exists?
> Best regards
>
> Osher

  

________________________________

Yahoo! Messenger with Voice. <http://us.rd.yahoo.com/mail_us/taglines/postman3/*http:/us.rd.yahoo.com/evt=39666/*http:/messenger.yahoo.com>  PC-to-Phone calls for ridiculously low rates.

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: "Even, Roni" <[email-masked]>
Date: Fri, 23 Jun 2006 19:05:45 +0300

Alan,

If you are talking about the physical display resolution (different from the stream resolution) in order to show advertise if it is an HD display to the encoder this is something which is relevant to H.264 and not to H.261.

Roni Even