Subject: [MMUSIC] Implementation of 301 Moved Permenantly

From: "CIHAT GOKTUG GURLER" <[email-masked]>
Date: Wed, 14 Jun 2006 20:47:10 +0300

Hi everyone,

I would like to build a dummy server that will forward the client to the optimum server for bandwidth consideration. What I do is to create a program that listens port 554. By looking at incoming ipnumber it generates a RTSP message in order to guide the client to the selected server. It is something like this.

For this example
Dummy server is at 172.18.2.64
Optimum server at 172.18.2.71

C-S>
DESCRIBE rtsp://172.18.2.64/audio.mp4 RTSP/1.0
CSeq: 1
Accept: application/sdp
Bandwidth: 384000
Accept-Language: en-US
User-Agent: xxxx/7.1

S-C>
Response: RTSP/1.0 301 Moved 
CSeq: 1
Location: rtsp://172.18.2.71/audi.mp4
Connection: Close

But the client useragent just hangs up instead of looking further in the new location.

It there a way which I can implement this differently?

Best wishes

C.Goktug Gurler
Koc University
Turkey

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Kylin Wei <[email-masked]>
Date: Thu, 15 Jun 2006 10:15:14 +0800

Hi C.Goktug Gurler:

I think that you can use the "REDIRECT" method to solve this problem.
A redirect request informs the client that it must connect to another server

location.
Example:
S->C: REDIRECT rtsp://172.18.2.64/audio.mp4 RTSP/1.0
           CSeq: 1
           Location: rtsp://172.18.2.71/audi.mp4

Kylin Wei 

> -----Original Message-----
> From: CIHAT GOKTUG GURLER [mailto:[email-masked]]
> Sent: Thursday, June 15, 2006 1:47 AM
> To: [email-masked]
> Subject: [MMUSIC] Implementation of 301 Moved Permenantly
> 
> Hi everyone,
> 
> I would like to build a dummy server that will forward the client to the
optimum
> server for bandwidth consideration. What I do is to create a program that
> listens port 554. By looking at incoming ipnumber it generates a RTSP
message
> in order to guide the client to the selected server. It is something like
this.
> But the client useragent just hangs up instead of looking further in the
new
> location.