Subject: [MMUSIC] Is RTSP a "control" media or an "application" media?

From: [email-masked]
Date: Wed, 7 Jun 2006 17:24:04 -0400

If I wanted to use SDP to create a session description that included one
or more "content" media streams that were to be managed by an "RTSP
control" media stream, what would be the best way to describe the RTSP
media stream, as a "control" or an "application".

That is, would it be something like this:
m=control <port> TCP RTSP

Or more like this:
m=application <port> TCP RTSP

Reading RFC 2327 it says in the section on Media Announcements:
	"control" is used to specify an additional 
       conference control channel for the session.

Is RTSP considered a "conference control channel"?

Thanks,

-Steve

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Kylin Wei <[email-masked]>
Date: Fri, 09 Jun 2006 11:44:15 +0800

Hi Steve:

I don't know much about your question, but I expect my reply would be
helpful for you.
Follow example is origin text of rfc2326bis.

C->M: DESCRIBE rtsp://example.com/twister.3gp RTSP/2.0
         CSeq: 1
         User-Agent: PhonyClient/1.2

   M->C: RTSP/2.0 200 OK
         CSeq: 1
         Server: PhonyServer/1.0
         Date: 23 Jan 1997 15:35:06 GMT
         Content-Type: application/sdp
         Content-Length: 257
         Content-Base: rtsp://example.com/twister.3gp/
         Expires: 24 Jan 1997 15:35:06 GMT

         v=0
         o=- 2890844256 2890842807 IN IP4 172.16.2.93
         s=RTSP Session
         i=An Example of RTSP Session Usage
         e=[email-masked]
         a=control: *
         a=range: npt=0-0:10:34.10
         t=0 0
         m=audio 0 RTP/AVP 0
         a=control: trackID=1
         m=video 0 RTP/AVP 26
         a=control: trackID=4

C->M: SETUP rtsp://example.com/twister.3gp/trackID=1 RTSP/2.0
         CSeq: 2
         User-Agent: PhonyClient/1.2
         Require: play.basic
         Transport: RTP/AVP;unicast;dest_addr=":8000"/":8001"

Please note that " a=control: trackID=1" and " a=control: trackID=4" are
two RTSP URIs.
Their full descriptions are "rtsp://example.com/twister.3gp/trackID=1"
and "rtsp://example.com/twister.3gp/trackID=4.".
In RTSP the used URIs are as general rule in fact URL's as they gives a
location for the resource.

Kylin Wei 

> -----Original Message-----
> From: [email-masked]
[mailto:[email-masked]]
> Sent: Thursday, June 08, 2006 5:24 AM
> To: [email-masked]
> Subject: [MMUSIC] Is RTSP a "control" media or an "application" media?
>

---

From: Magnus Westerlund <[email-masked]>
Date: Tue, 13 Jun 2006 17:40:03 +0200

Hi Steve,

One normally starts with an RTSP URI. Use that the go to the server with 
the content. Then request the media configuration information as an SDP 
using RTSP. As Wei pointed out that SDP will indicate the RTSP URI for 
the individual resources part of an aggregate.

Cheers

Magnus

-- 

Magnus Westerlund

Multimedia Technologies, Ericsson Research EAB/TVA/A
----------------------------------------------------------------------
Ericsson AB                | Phone +46 8 4048287
Torshamsgatan 23           | Fax   +46 8 7575550
S-164 80 Stockholm, Sweden | mailto: [email-masked]