Subject: RE: [MMUSIC] SDP Capability Negotiation: Updated solution document (-04)

From: "Dan Wing" <[email-masked]>
Date: Thu, 1 Mar 2007 17:13:04 -0800

Flemming,

> Please note that this is the second-last version before 
> Prague and our goal is to go WGLC after Prague. If you have any 
> comments or concerns with this draft, now would be a good time 
> to let us know.

Question:  I didn't see any guidance for when an offerer would put all of
its transport capabilities on one a=tcap line versus splitting them into
separate a=tcap lines.  Near as I can discern, the following:

  a=tcap:1 RTP/AVP
  a=tcap:2 RTP/AVPF

is exactly identical to:

  a=tcap:1 RTP/AVP RTP/AVPF

Nit: In section 3.3.2, the sentence in the last paragraph starting with
"This may seem redundant" is a discussion and might best to intend it a few
spaces.

-d

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Flemming Andreasen <[email-masked]>
Date: Sun, 04 Mar 2007 14:55:43 -0500

>   a=tcap:1 RTP/AVP RTP/AVPF
Yup - syntactical sugar. Is that a problem  ?

The former is more readable than the latter, but also a bit larger.

> "This may seem redundant" is a discussion and might best to intend it a few
Done.

Thanks

-- Flemming

---

From: "Dan Wing" <[email-masked]>
Date: Wed, 7 Mar 2007 11:27:12 -0800

_____  

From: Flemming Andreasen [mailto:[email-masked]] 
Sent: Sunday, March 04, 2007 11:56 AM
To: Dan Wing
Cc: 'mmusic'
Subject: Re: [MMUSIC] SDP Capability Negotiation: Updated solution document
(-04)

Dan Wing wrote: 

Flemming,

to let us know.

  a=tcap:1 RTP/AVP

  a=tcap:2 RTP/AVPF

is exactly identical to:

  

It's not a problem but I would at least like a sentence or two that explains
they're identical and there is no advantage to the longer syntax.  But why
not just remove the <trpr-cap-num> element and have only one a=tcap line,
like:
 
  a=tcap RTP/AVP RTP/AVPF
 
Or do you anticipate some need for <trpr-cap-num> later?  As it is, it feels
like a bit of leftover cruft.
 
-d

spaces.

Done. 

Thanks

-- Flemming 

-d