Subject: [MMUSIC] new figure on checks, pairs, transport addr, etc. for ICE?

From: Jonathan Rosenberg <[email-masked]>
Date: Sat, 03 Mar 2007 16:50:00 -0500

Both ekr and Jean-Francois expressed concern that it was hard to figure 
out the relationship between a bunch of different ICE concepts - 
transport addresses, checks, candidates, candidate pairs, check lists, 
valid lists, etc. We've had diagrams that did some of this in pre-ice-9 
days but it got yanked to reduce document size.

I made a stab at a new diagram:

Please view in a fixed-width font such
               as Courier.

    +------------------------------+
    |                              |
    | +-------------+  +Type       |
    | |+----+ +----+|              |
    | || IP | |Port||  +Priority   |
    | ||Addr| |    ||              |
    | |+----+ +----+|  +Foundation |
    | |  Transport  |              |
    | |    Addr     |  +Base       |
    | +-------------+              |
    |         Candidate            |
    +------------------------------+
    *                        ******
    *            ************
    *      ******
   +-----------------------------------+
  .|+------------------------+         |
   ||Local  + default? Remote|         |
   ||+----+ + valid?   +----+|         |
   |||Cand| + favored? |Cand|| +State  |
   ||+----+            +----+|         |
   ||      Candidate Pair    |         |
   |+------------------------+         |
   |             Check                 |
   +-----------------------------------+
   *                              ****
   *                      ********
   *                  ****
   +------------------+
   |      Check       |
   +------------------+
   +------------------+
   |      Check       |
   +------------------+
   +------------------+
   |      Check       |
   +------------------+

          Check
          List

Comments welcome on whether this is useful.

-Jonathan R.
-- 
Jonathan D. Rosenberg, Ph.D.                   600 Lanidex Plaza
Cisco Fellow                                   Parsippany, NJ 07054-2711
Cisco Systems
[email-masked]                              FAX:   (973) 952-5050
http://www.jdrosen.net                         PHONE: (973) 952-5000
http://www.cisco.com

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Dafydd Harries <[email-masked]>
Date: Tue, 6 Mar 2007 18:23:22 +0000

> Comments welcome on whether this is useful.

I think this makes grasping ICE much easier, and that it should be included.

-- 
Dafydd

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 06 Mar 2007 23:16:27 -0500

Yes, it was included in -14, now available.

-Jonathan R.