Subject: [MMUSIC] SDP media capabilities and nightmare SDP

From: "Ingemar Johansson S \(LU/EAB\)" <[email-masked]>
Date: Wed, 21 Mar 2007 15:14:22 +0100

Hi again
Seems like whole lotta linebreaks was lost in my last email so here we go again... 

Below is a "nightmare SDP offer" from a VoIP client that says that it can support everything that 3GPP TS 28.062 and 3GPP TS 26.103 specifies in terms of codec mode configurations for AMR and AMR-WB. Further down my effort to encode the same SDP according to draft-ietf-mmusic-spd-media-capabilities-01.txt. I hope I got everything right in the "reencoding". My humble question is whether or not it is possible to do things more smart or simply put if I have missed some crucial feature that makes it possible to compress the whole shebang a little better.

Comments welcome.

==================================
m=audio 49152 RTP/AVP xx xx ... xxx
a=rtpmap:xx AMR/8000/1
a=fmtp:xx mode-set=0; mode-change-capability=2; max-red=220
a=rtpmap:xx AMR/8000/1
a=fmtp:xx mode-set=0,2,4,7; mode-change-capability=2; max-red=220
a=rtpmap:xx AMR/8000/1
a=fmtp:xx mode-set=2; mode-change-capability=2; max-red=220
a=rtpmap:xx AMR/8000/1
a=fmtp:xx mode-set=3; mode-change-capability=2; max-red=220
a=rtpmap:xx AMR/8000/1
a=fmtp:xx mode-set=4; mode-change-capability=2; max-red=220
a=rtpmap:xx AMR/8000/1
a=fmtp:xx mode-set=5; mode-change-capability=2; max-red=220
a=rtpmap:xx AMR/8000/1
a=fmtp:xx mode-set=6; mode-change-capability=2; max-red=220
a=rtpmap:xx AMR/8000/1
a=fmtp:xx mode-set=7; mode-change-capability=2; max-red=220
a=rtpmap:xx AMR/8000/1
a=fmtp:xx mode-set=0,2; mode-change-capability=2; max-red=220
a=rtpmap:xx AMR/8000/1
a=fmtp:xx mode-set=0,2,3; mode-change-capability=2; max-red=220
a=rtpmap:xx AMR/8000/1
a=fmtp:xx mode-set=0,2,3,4; mode-change-capability=2; max-red=220
a=rtpmap:xx AMR/8000/1
a=fmtp:xx mode-set=0,2,3,6; mode-change-capability=2; max-red=220
a=rtpmap:xx AMR/8000/1
a=fmtp:xx mode-set=0,2,5,7; mode-change-capability=2; max-red=220
a=rtpmap:xx AMR/8000/1
a=fmtp:xx mode-set=0; mode-change-capability=2; max-red=220; octet-align=1
a=rtpmap:xx AMR/8000/1
a=fmtp:xx mode-set=0,2,4,7; mode-change-capability=2; max-red=220; octet-align=1
a=rtpmap:xx AMR/8000/1
a=fmtp:xx mode-set=2; mode-change-capability=2; max-red=220; octet-align=1
a=rtpmap:xx AMR/8000/1
a=fmtp:xx mode-set=3; mode-change-capability=2; max-red=220; octet-align=1
a=rtpmap:xx AMR/8000/1
a=fmtp:xx mode-set=4; mode-change-capability=2; max-red=220; octet-align=1
a=rtpmap:xx AMR/8000/1
a=fmtp:xx mode-set=5; mode-change-capability=2; max-red=220; octet-align=1
a=rtpmap:xx AMR/8000/1
a=fmtp:xx mode-set=6; mode-change-capability=2; max-red=220; octet-align=1
a=rtpmap:xx AMR/8000/1
a=fmtp:xx mode-set=7; mode-change-capability=2; max-red=220; octet-align=1
a=rtpmap:xx AMR/8000/1
a=fmtp:xx mode-set=0,2; mode-change-capability=2; max-red=220; octet-align=1
a=rtpmap:xx AMR/8000/1
a=fmtp:xx mode-set=0,2,3; mode-change-capability=2; max-red=220; octet-align=1
a=rtpmap:xx AMR/8000/1
a=fmtp:xx mode-set=0,2,3,4; mode-change-capability=2; max-red=220; octet-align=1
a=rtpmap:xx AMR/8000/1
a=fmtp:xx mode-set=0,2,3,6; mode-change-capability=2; max-red=220; octet-align=1
a=rtpmap:xx AMR/8000/1
a=fmtp:xx mode-set=0,2,5,7; mode-change-capability=2; max-red=220; octet-align=1
a=rtpmap:yy AMR-WB/16000/1
a=fmtp:yy mode-set=0,1,2; mode-change-capability=2; max-red=220
a=rtpmap:yy AMR-WB/16000/1
a=fmtp:yy mode-set=0,1,2,5; mode-change-capability=2; max-red=220
a=rtpmap:yy AMR-WB/16000/1
a=fmtp:yy mode-set=0,1,2,9; mode-change-capability=2; max-red=220
a=rtpmap:yy AMR-WB/16000/1
a=fmtp:yy mode-set=0,1,2; mode-change-capability=2; max-red=220; octet-align=1
a=rtpmap:yy AMR-WB/16000/1
a=fmtp:yy mode-set=0,1,2,5; mode-change-capability=2; max-red=220; octet-align=1
a=rtpmap:yy AMR-WB/16000/1
a=fmtp:yy mode-set=0,1,2,9; mode-change-capability=2; max-red=220; octet-align=1
a=rtpmap:yy AMR-WB/16000/1
a=maxptime:240
a=ptime:20
==================================

According to SDP media cap. Draft:

a=creq:v1

a=tcap:1 RTP/AVP
m=cmed:1 audio AMR AMR AMR AMR AMR
m=cmed:6 audio AMR AMR AMR AMR AMR
m=cmed:11 audio AMR AMR AMR AMR AMR
m=cmed:16 audio AMR AMR AMR AMR AMR	
m=cmed:21 audio AMR AMR AMR AMR AMR
m=cmed:26 audio AMR-WB AMR-WB AMR-WB AMR-WB AMR-WB AMR-WB

m=audio 49152 RTP/AVP AMR
a=rtpmap:100 AMR/8000/1 mode-set=0; mode-change-capability=2; max-red=220

a=cenc:1 8000/1 mode-set=0; mode-change-capability=2; max-red=220
a=cenc:2 8000/1 mode-set=0,2,4,7; mode-change-capability=2; max-red=220
a=cenc:3 8000/1 mode-set=2; mode-change-capability=2; max-red=220
a=cenc:4 8000/1 mode-set=3; mode-change-capability=2; max-red=220
a=cenc:5 8000/1 mode-set=4; mode-change-capability=2; max-red=220
a=cenc:6 8000/1 mode-set=5; mode-change-capability=2; max-red=220
a=cenc:7 8000/1 mode-set=6; mode-change-capability=2; max-red=220
a=cenc:8 8000/1 mode-set=7; mode-change-capability=2; max-red=220
a=cenc:9 8000/1 mode-set=0,2; mode-change-capability=2; max-red=220 a=cenc:10 8000/1 mode-set=0,2,3; mode-change-capability=2; max-red=220
a=cenc:11 8000/1 mode-set=0,2,3,4; mode-change-capability=2; max-red=220
a=cenc:12 8000/1 mode-set=0,2,3,6; mode-change-capability=2; max-red=220
a=cenc:13 8000/1 mode-set=0,2,5,7; mode-change-capability=2; max-red=220
a=cenc:14 8000/1 mode-set=0; mode-change-capability=2; max-red=220; octet-align=1
a=cenc:15 8000/1 mode-set=0,2,4,7; mode-change-capability=2; max-red=220; octet-align=1
a=cenc:16 8000/1 mode-set=2; mode-change-capability=2; max-red=220; octet-align=1
a=cenc:17 8000/1 mode-set=3; mode-change-capability=2; max-red=220; octet-align=1
a=cenc:18 8000/1 mode-set=4; mode-change-capability=2; max-red=220; octet-align=1
a=cenc:19 8000/1 mode-set=5; mode-change-capability=2; max-red=220; octet-align=1 a=cenc:20 8000/1 mode-set=6; mode-change-capability=2; max-red=220; octet-align=1
a=cenc:21 8000/1 mode-set=7; mode-change-capability=2; max-red=220; octet-align=1
a=cenc:22 8000/1 mode-set=0,2; mode-change-capability=2; max-red=220; octet-align=1
a=cenc:23 8000/1 mode-set=0,2,3; mode-change-capability=2; max-red=220; octet-align=1
a=cenc:24 8000/1 mode-set=0,2,3,4; mode-change-capability=2; max-red=220; octet-align=1
a=cenc:25 8000/1 mode-set=0,2,3,6; mode-change-capability=2; max-red=220; octet-align=1

a=cenc:26 16000/1 mode-set=0,2,5,7; mode-change-capability=2; max-red=220; octet-align=1
a=cenc:27 16000/1 mode-set=0,1,2; mode-change-capability=2; max-red=220
a=cenc:28 16000/1 mode-set=0,1,2,5; mode-change-capability=2; max-red=220
a=cenc:29 16000/1 mode-set=0,1,2,9; mode-change-capability=2; max-red=220 a=cenc:30 16000/1 mode-set=0,1,2; mode-change-capability=2; max-red=220; octet-align=1
a=cenc:31 16000/1 mode-set=0,1,2,5; mode-change-capability=2; max-red=220; octet-align=1
a=cenc:32 16000/1 mode-set=0,1,2,9; mode-change-capability=2; max-red=220; octet-align=1
a=pcfg:1 t=1 m=1|2|3|4|5|6|7|8|9|10|11|12|13|14|15|16|17|18|19|20|21|22|23|24|25|26|27|28|29|30|31|32 pt=1:100,2:100,3:100,4:100,5:100,6:100,7:100,8:100,9:100,10:100,11:100,12:100, 13:100,14:100,15:100,16:100,17:100,18:100,19:100,20:100,21:100,22:100,23:100, 24:100,25:100,26:100,27:100,28:100,29:100,30:100,31:100,32:100

a=maxptime:240
a=ptime:20
===========================

Regards
Ingemar
*******************************************
Ingemar Johansson
Senior Research Engineer
EAB/TVP - Multimedia Technologies Ericsson Research
Ericsson AB
Box 920
S-971 28 Luleå, Sweden
Tel: +46 (0)8 4043042
ECN: 850-43042
Mobile: +46 (0)730 783289
*******************************************

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: "Ingemar Johansson S \(LU/EAB\)" <[email-masked]>
Date: Wed, 21 Mar 2007 15:23:03 +0100

Hi

Please disregard my last two emails, I will make another try with the
same email once I manage to get the linebreaks to survive in cyberspace.

Sorry for making the extra noise..
Ingemar 

> -----Original Message-----
> From: Ingemar Johansson S (LU/EAB) 
> [mailto:[email-masked]] 
> Sent: den 21 mars 2007 15:14
> To: [email-masked]
> Subject: [MMUSIC] SDP media capabilities and nightmare SDP
> 
> Hi again