Subject: [MMUSIC] SDP media capabilities question regarding a=bcap

From: "Ingemar Johansson S" <[email-masked]>
Date: Thu, 6 Dec 2007 18:56:16 +0100

Hi
 
Reading 
http://tools.ietf.org/id/draft-ietf-mmusic-sdp-media-capabilities-02.txt
And trying to understand the a=bcap (like the approach though), this is maybe a question that some RTFM might answer but even though I tried I don't beleieve I get it.
 
If we have a bunch of alternatives with different RS and RR (could be result of different AVP vs. AVFP options)
     a=bcap:1 TIAS:val1
     a=bcap:2 RS:val2
     a=bcap:3 RS:val3
     a=bcap:4 RS:val4
     a=bcap:5 RR:val5
     a=bcap:6 RR:val6
     a=bcap:7 RR:val7
 
What is the syntax to combine these in the a=pcfg line(s) ?
 
Is it in the form 
     a=pcfg:1 m=1 b=1,2,5 pt:100
     a=pcfg:2 m=1 b=1,3,6 pt:100

or do we need to write a=bcap and a=pcfg lines like
     a=bcap:1 TIAS:val1 RS:val2 RR:val5
     a=bcap:2 TIAS:val1 RS:val3 RR:val6
     ...
     ...
     a=pcfg:1 m=1 b=1 pt:100
     a=pcfg:2 m=1 b=2 pt:100

Regards
Ingemar

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Flemming Andreasen <[email-masked]>
Date: Thu, 06 Dec 2007 16:45:30 -0500

You would use the first form, i.e. one bandwidth capability attribute 
per type/value pair and then reference each of them using the 
corresponding bandwidth capability number in the pcfg line.

-- Flemming