Subject: [MMUSIC] SDP Capability Negotiation: Transport negotiation and media

From: "Christer Holmberg" <[email-masked]>
Date: Fri, 7 Dec 2007 06:03:25 +0100

Hi,
 
Chapter 4.2 of the SDP cap neg draft shows an example of transport negotiation.
 
After the initial offer/answer transaction is complete, it is said that a second offer/answer transaction may be sent in order not to confuse possible intermediates that do not support the SDP cap neg mechanism.
 
But, is there any recommendation on whether the answerer should wait for the second offer for a while before start sending media, in case the media will not reach the offerer due to the "transport mismatch" that may been seen by intermediates? Or, is it assumed that the mismatch will not prevent media from reaching the offerer?
 
Regards,
 
Christer

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Flemming Andreasen <[email-masked]>
Date: Fri, 07 Dec 2007 14:32:11 -0500

Since the second offer/answer exchange is not mandatory, the answerer 
should not wait for a second offer/answer exchange. If you want to reach 
this level of "certainty", use of a precondition would be appropriate.

-- Flemming

---

From: "Christer Holmberg" <[email-masked]>
Date: Tue, 11 Dec 2007 11:53:00 +0100

Hi,

Unless it's already there (I admit I haven't read the latest versions of
the spec in detail), would it be useful to describe these kind of
potential issues with intermediates in the "main" part of the spec,
instead of only in an example?

Regards,

Christer 

> -----Original Message-----
> From: Flemming Andreasen [mailto:[email-masked]] 
> Sent: 7. joulukuuta 2007 21:32
> To: Christer Holmberg
> Cc: [email-masked]
> Subject: Re: [MMUSIC] SDP Capability Negotiation: Transport 
> negotiation and media
> 
> Since the second offer/answer exchange is not mandatory, the 
> answerer should not wait for a second offer/answer exchange. 
> If you want to reach this level of "certainty", use of a 
> precondition would be appropriate.
> 
> -- Flemming
> 
> Christer Holmberg wrote:
> > Hi,
> >  
> > After the initial offer/answer transaction is complete, it 
> is said that a second offer/answer transaction may be sent in 
> order not to confuse possible intermediates that do not 
> support the SDP cap neg mechanism.
> >  
> > But, is there any recommendation on whether the answerer 
> should wait for the second offer for a while before start 
> sending media, in case the media will not reach the offerer 
> due to the "transport mismatch" that may been seen by 
> intermediates? Or, is it assumed that the mismatch will not 
> prevent media from reaching the offerer?
> >  
> > Regards,
> >  
> > Christer
> >
> >

---

From: Flemming Andreasen <[email-masked]>
Date: Tue, 11 Dec 2007 13:09:15 -0500

> instead of only in an example?
I think that's already covered by Section 3.12 which talks about 
middlebox interactions.

Thanks

-- Flemming

>>> Chapter 4.2 of the SDP cap neg draft shows an example of 
>>>       
>> transport negotiation.
>>     
>>>