Subject: [MMUSIC] draft-ietf-sipping-sip-offeranswer-08

From: "Ingemar Johansson S" <[email-masked]>
Date: Tue, 20 May 2008 08:56:45 +0200

Hi

Reading the draft-ietf-sipping-sip-offeranswer-08 I find some info as regards to what happens if an offer is unacceptable. In light of the SDP capability negotiation framework (work in progress in MMUSIC) I have the following question. 

What happens if an SDP answer is found unacceptable ?. 
The SDPCapNeg framework specifies  that the SDP answer should be rewritten so that it matches a selected potential configuration.
For instance if the "m=" line specifies RTP/AVP in the offer. The same "m=" line may specify RTP/SAVP in the answer. A proxy in the signaling path (e.g a P-CSCF) that inspects and does some policing on the SDP accepts AVP but not SAVP.
What will happen?, a list of things that may happen that I know of

1) Session terminated. 
   Will both endpoints know that the session is terminated ?
2) Answer rejected with some 400 message
3) SDP rewritten

Comments/answers welcome

Ingemar
******************************************* 
Ingemar Johansson 
Senior Research Engineer, IETF "nethead" 
EAB/TVP - Multimedia Technologies 
Ericsson Research Ericsson AB 
Box 920 S-971 28 Luleå, Sweden 
Tel: +46 (0)8 4043042 
ECN: 850-43042 
ECC: 850-43074 
Mobile: +46 (0)730 783289 
******************************************* 
_______________________________________________
mmusic mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mmusic

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 20 May 2008 08:07:18 -0400

> Reading the draft-ietf-sipping-sip-offeranswer-08 I find some info as regards to what happens if an offer is unacceptable. In light of the SDP capability negotiation framework (work in progress in…

I will admit to not having been following the capability negotiation work.

> What happens if an SDP answer is found unacceptable ?. 

At least historically the rules for o/a negotiation have been written so 
that a validly constructed answer will always be acceptable to the offerer.

> For instance if the "m=" line specifies RTP/AVP in the offer. The same "m=" line may specify RTP/SAVP in the answer.

Since it was a potential configuration proposed by the offerer, one 
would expect that it is acceptable to the offerer.

> A proxy in the signaling path (e.g a P-CSCF) that inspects and does some policing on the SDP accepts AVP but not SAVP.

Proxies don't have any formal role in o/a.  The proxy ought to shut up 
and let the UAC deal with the answer.

In any case there is very little that a proxy *can* do when the answer 
passes by.

>    Will both endpoints know that the session is terminated ?

What would you propose that a proxy do to terminate the session?

> 2) Answer rejected with some 400 message

You can't send a response to a response.

> 3) SDP rewritten

Ignoring the legality of doing so, the proxy *can* rewrite the SDP. (If 
its not encrypted or signed.)

Once it is rewritten, the offerer and the answerer have different 
understandings of what has been negotiated. There are only certain kinds 
of rewriting that will "work".

	Paul