Subject: [MMUSIC] NICE: scope and terminology

From: Gonzalo Camarillo <[email-masked]>
Date: Thu, 15 May 2008 10:39:22 +0300

Hi,

in order to use NICE as the HIP's NAT traversal solution we need to 
agree on the scope of NICE and on the terminology to be used.

Scope: should the NICE spec define a subset of ICE or simply describe 
how non-SIP protocols can use regular ICE?

Terminology: should the NICE spec define new terminology or simply reuse 
the terminology used by the ICE spec?

Comments are welcome.

Thanks,

Gonzalo
_______________________________________________
mmusic mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mmusic

---

From: Henry Sinnreich <[email-masked]>
Date: Thu, 15 May 2008 08:54:21 -0700

> the terminology used by the ICE spec?

Unless there are valid reasons to do otherwise, why not re-use all the
terminology developed for ICE?

If there are, it would be interesting to hear them and especially to see a
memo (I-D) on NAT traversal for HIP. Otherwise, we can just keep ICE
terminology IMO.

Henry

---

From: Philip Matthews <[email-masked]>
Date: Tue, 20 May 2008 05:24:06 -0400

I agree with Henry's comments.
People are used to the ICE terminology.
For example, the HIP NAT traversal group has been using the terms "ICE  
Offer" and "ICE Answer".
- Philip

On Thu, 15-May-08, at 11:54 , Henry Sinnreich wrote:
> On 5/15/08 12:39 AM, "Gonzalo Camarillo" <[email-masked] 
> >
> wrote:
>
>> Hi,
>>

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 21 May 2008 23:49:46 -0400

Not a lot was clear from last IETF on the direction here, but one thing 
that WAS clear was that people did not want a subset or change in ICE, 
just rather something that would help us avoid the problem of each 
protocol defining their own ICE usage.

MY worry is that may happen anyway if each protocol decides that, it 
doesn't like or doesn't want parts of the spec. So I'd really like to 
turn the question around, and ask the folks working on HIP, RTSP, MIP or 
whoever else is thinking of using ICE - what would you find it useful 
for this draft to do, such that it would eliminate the need for you to 
have lots of ICE-specific text?

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.                   499 Thornall St.
Cisco Fellow                                   Edison, NJ 08837
Cisco, Voice Technology Group
[email-masked]
http://www.jdrosen.net                         PHONE: (408) 902-3084
http://www.cisco.com
_______________________________________________
mmusic mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mmusic

---

From: "Christer Holmberg" <[email-masked]>
Date: Fri, 23 May 2008 13:05:50 +0200

Hi,

Has anyone thought of how many protocols there are out there which could
apply NICE?

Of course there may also be future protocols, but there is nothing
saying that they won't have similar issues as SIP - issues which NICE
assume do not exist.

Regards,

Christer 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Jonathan Rosenberg
Sent: 22. toukokuuta 2008 6:50
To: Philip Matthews
Cc: Gonzalo Camarillo; mmusic
Subject: Re: [MMUSIC] NICE: scope and terminology

-Jonathan R.

>>> Terminology: should the NICE spec define new terminology or simply 
>>> reuse the terminology used by the ICE spec?
>> Unless there are valid reasons to do otherwise, why not re-use all 
>> the terminology developed for ICE?
>>
>> If there are, it would be interesting to hear them and especially to 
>> see a memo (I-D) on NAT traversal for HIP. Otherwise, we can just 
>> keep ICE terminology IMO.
>>
>> Henry
>>
>>
>>> Scope: should the NICE spec define a subset of ICE or simply 
>>> describe how non-SIP protocols can use regular ICE?
>>>
>>> Terminology: should the NICE spec define new terminology or simply 
>>> reuse the terminology used by the ICE spec?
>>>
>>> Comments are welcome.
>>>
>>> Thanks,
>>>
>>> Gonzalo

---

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 23 May 2008 22:42:42 -0400

There are certain things in ICE which are really specific to SIP - the 
default candidate stuff for example is to fake out intermediaries that 
assume legacy SDP interpretation. That is obviously something that 
doesn't make sense for other protocols.

-Jonathan R.

---

From: "Christer Holmberg" <[email-masked]>
Date: Sat, 24 May 2008 13:56:01 +0200

Why can't there be intermediates for other protocols than SIP?

Regards,

Christer 

-----Original Message-----
From: Jonathan Rosenberg [mailto:[email-masked]] 
Sent: 24. toukokuuta 2008 5:43
To: Christer Holmberg
Cc: Philip Matthews; Gonzalo Camarillo; mmusic
Subject: Re: [MMUSIC] NICE: scope and terminology

-Jonathan R.

Christer Holmberg wrote:
> Hi,
> 
> Has anyone thought of how many protocols there are out there which 
> could apply NICE?
> 
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Jonathan Rosenberg
> Not a lot was clear from last IETF on the direction here, but one 
> thing that WAS clear was that people did not want a subset or change 
> in ICE, just rather something that would help us avoid the problem of 
> each protocol defining their own ICE usage.
> 
> turn the question around, and ask the folks working on HIP, RTSP, MIP 
> or whoever else is thinking of using ICE - what would you find it 
> useful for this draft to do, such that it would eliminate the need for

> you to have lots of ICE-specific text?
> 
> -Jonathan R.
> 
> Philip Matthews wrote:

---

From: Rémi Denis-Courmont <[email-masked]>
Date: Sat, 24 May 2008 10:11:45 +0300

> doesn't make sense for other protocols.

And role negotiation is for 3pcc, right? If the protocol is 
naturally "asymetric", such as RTSP or Mobile IP, that's not very useful.

-- 
Rémi Denis-Courmont
http://www.remlab.net/

---

From: Miika Komu <[email-masked]>
Date: Mon, 26 May 2008 14:32:01 +0300 (EEST)

On Tue, 20 May 2008, Philip Matthews wrote:

Hi,

I am fine with ICE terminology in general. However, we have to explain in 
the HIP NAT traversal draft that "offer" and "answer" are actually I2 and 
R2 packets carrying locators. I would use another term in place of 
"rendezvous service" because it will create confusion in HIP terminology 
space. Currently the HP NAT draft just talks about "Relay Service".

>> see a

-- 
Miika Komu                                       http://www.iki.fi/miika/
_______________________________________________
mmusic mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mmusic

---

From: Miika Komu <[email-masked]>
Date: Mon, 26 May 2008 14:39:29 +0300 (EEST)

On Thu, 15 May 2008, Gonzalo Camarillo wrote:

Hi,

> how non-SIP protocols can use regular ICE?

The exchange of offer and answer should be defined in an 
protocol-independent way. The connectivity tests can be described in an 
protocol-dependent way based on the current ICE. At least, these are the 
requirements for current HIP NAT traversal.

---

From: Magnus Westerlund <[email-masked]>
Date: Fri, 30 May 2008 21:41:45 +0200

> have lots of ICE-specific text?

I think you are correct that there are variations here. That is why I 
think NICE is very difficult. Each different protocol will have to 
operate slightly different to make things work.

There is also the issue of message pacing that needs to be clarified for 
non-SIP usage. Especially the ones that doesn't have a RTP flow.

Cheers

Magnus Westerlund

IETF Transport Area Director & TSVWG Chair
----------------------------------------------------------------------
Multimedia Technologies, Ericsson Research EAB/TVM
----------------------------------------------------------------------
Ericsson AB                | Phone +46 8 4048287
Färögatan 6                | Fax   +46 8 7575550
S-164 80 Stockholm, Sweden | mailto: [email-masked]
----------------------------------------------------------------------