Subject: [MMUSIC] SDP extensions for Explicit Asymmetric RTP

From: OKUMURA Shinji <[email-masked]>
Date: Fri, 21 Aug 2009 20:41:08 +0900

Hi all,

I apologize if this has already been discussed.

I am thinking a little about "SDP extensions for Explicit Asymmetric RTP".
It is very simple extensions as below.

   m=audio 62986 RTP/AVP 0 4 18
   a=rtpmap:0 PCMU/8000
   a=rtpmap:4 G723/8000
   a=rtpmap:18 G729/8000
   a=fmtp:4 sendonly
   a=fmtp:18 recvonly
   a=fmtp:4 ptime:30
   a=fmtp:18 ptime:20

Any thoughts on this extensions?

Regards,
Shinji

---

From: "Ingemar Johansson S" <[email-masked]>
Date: Fri, 21 Aug 2009 15:04:46 +0200

Hi

While the proposal below is very tempning it is not valid according to RFC2327. The only way to solve asymmetry in a general fashion is to define several media lines.

I sketched on a general solution to asymmetry issues some time ago
http://tools.ietf.org/html/draft-johansson-mmusic-asymmetric-media-00
The whole thing was meant to be a partly backwards compatible extension to SDPCapNeg, the interest was however quite low. Still I believe that questions like these will show up more in the future and then it would be good to have a generic solution.

Regards
Ingemar

>Shinji

******************************************* 
Ingemar Johansson 
Senior Research Engineer, IETF "nethead" 
EAB/TVK - Multimedia Technologies 
Ericsson Research Ericsson AB 
Box 920 S-971 28 Luleå, Sweden 
Tel: +46 (0)10 7143042 
ECN: 852-43042 
ECC: 852-19042
Mobile: +46 (0)730 783289 
Visit http://labs.ericsson.com !
*******************************************