Subject: Re: [MMUSIC] [Sip-implementors] Example correct? (draft-schwarz-mmusic-sdp-offer-answer-examples-00.txt); RE: Revised SDPO/A; RE: codec negotiation

From: "Schwarz Albrecht" <[email-masked]>
Date: Mon, 3 Aug 2009 14:03:12 +0200

Right, the draft is very initial, the crucial part is just the SDP example only.
As soon as we got agreement that the SDP syntax is correct and inline with SDPCapNeg and SDPMediaNeg, we'll polish the text and update scope, abstract etc.

The challenge with the codec negotiation example here is the fact that we got
a) mono-media vs dual-media configurations (VoIP vs VoIP+FoIP), and
b) consecutive media-formats on a single RTP session (VoIP - VBDoIP).

That's the interesting part from offer/answer perspective, which may be solved in an elegant manner by the revised SDP O/A syntax in our understanding.

[Know-ledge about T.38 & V.152 is not required from O/A perspective. That's just the references which defining part of the SDP syntax for that media formats.]
 
Albrecht

> -----Original Message-----
> From: Dale Worley [mailto:[email-masked]] 
> Sent: Freitag, 31. Juli 2009 19:27
> To: Schwarz Albrecht
> Cc: [email-masked]; mmusic (E-mail)
> Subject: Re: [Sip-implementors] Example 
> correct?(draft-schwarz-mmusic-sdp-offer-answer-examples-00.txt
> ); RE: Revised SDPO/A; RE: codec negotiation
> 
> On Fri, 2009-07-31 at 15:23 +0200, Schwarz Albrecht wrote:
> > 
> http://www.ietf.org/internet-drafts/draft-schwarz-mmusic-sdp-offer-ans
> > wer-examples-00.txt
> > 
> > Dear SDP Offer/Answer experts!
> > 
> > Our draft provides an example in § 4.4.1.3, using the new 
> SDP syntax 
> > according revised SDP O/A:
> > "SDP Capability Negotiation",
> > draft-ietf-mmusic-sdp-capability-negotiation
> > "SDP media capabilities Negotiation",
> > draft-ietf-mmusic-sdp-media-capabilities
> > 
> > Before progressing our draft we would appreciate any feedback, 
> > comments by the SDP O/A experts.
> 
> The Abstract isn't very clear.  The Abstract just describes 
> the draft as providing offer/answer examples.  But I think 
> that the draft is trying to give examples specifically for 
> V.152 and T.38, and it seems that 
> draft-ietf-mmusic-sdp-capability-negotiation and 
> draft-ietf-mmusic-sdp-media-capabilities are essential to 
> handling those situations well.  If that is so, the Abstract 
> should make it clear.
> Otherwise, people won't realize why they want to read the I-D/RFC.
> 
> Dale
> 
> 
>

---

From: "Schwarz Albrecht" <[email-masked]>
Date: Tue, 4 Aug 2009 08:34:59 +0200

The request was addressed to MMUSIC (and for info for SIP implementors).
MMUSIC developed the revised SDP O/A protocol AFAIK:
http://tools.ietf.org/wg/mmusic/draft-ietf-mmusic-sdp-capability-negotia
tion/
http://tools.ietf.org/wg/mmusic/draft-ietf-mmusic-sdp-media-capabilities
/

Any SDP experts in MMUSIC, familiar with that SDP extensions?
If yes, please have a look at just the SDP Offer of the example.
http://www.ietf.org/internet-drafts/draft-schwarz-mmusic-sdp-offer-answe
r-examples-00.txt
You may focus on the syntax first (Table x1) ...

Albrecht

PS
If the format as a 'draft' is an issue, then we may put just the 80 SDP
lines of the SDP Offer in an email.

> Sent: Montag, 3. August 2009 18:10
> To: Schwarz Albrecht
> Cc: sip-implementors
> Subject: RE: [Sip-implementors] Example 
> ); RE: RevisedSDPO/A; RE: codec negotiation
> 
> On Mon, 2009-08-03 at 14:03 +0200, Schwarz Albrecht wrote:
> > As soon as we got agreement that the SDP syntax is correct 
> and inline 
> > with SDPCapNeg and SDPMediaNeg, we'll polish the text and update 
> > scope, abstract etc.
> 
> It is extremely hard to determine if a particular SDP example 
> is correct if one does not have a clear description of what 
> the SDP is attempting to accomplish.  That is why you want to 
> update the abstract and descriptive text before bringing the 
> question to a general mailing list like SIP-Implementors.  
> After all, most of your readers here don't know what 
> "SDPCapNeg", "SDPMediaNeg", T.38, and V.152 are, nor have 
> they thought about the usage scenarios that the SDP is 
> intended to support.
> 
> Dale
> 
> 
>