Subject: [MMUSIC] GET_PARAMETER for keep-alive in RTSP 2.0?

From: "Jose Rey" <[email-masked]>
Date: Tue, 4 Aug 2009 16:54:21 +0200

Hi all,

Is there any reason why GET_PARAMETER is not mentioned in "10.5. Showing Liveness" as mechanism for keep-alive? The description of the method itself would suggest it should go between SET_PARAMETER and OPTIONS.

Thanks,

José

Panasonic R&D Center Germany GmbH
63225 Langen, Hessen, Germany
Reg: AG Offenbach (Hessen) HRB 33974
Managing Director: Thomas Micke

---

From: "Rémi Denis-Courmont" <[email-masked]>
Date: Tue, 4 Aug 2009 18:02:10 +0300

On Tuesday 04 August 2009 17:54:21 ext Jose Rey wrote:
> Hi all,
>
> Is there any reason why GET_PARAMETER is not mentioned in "10.5. Showing
> Liveness" as mechanism for keep-alive? The description of the method itself
> would suggest it should go between SET_PARAMETER and OPTIONS.

The problem is, there are no standardized actual GET_PARAMETER request 
parameter, so the rely cannot rely on this... (I do agree that this is the 
most common method in existing RTSP/1.0 deployment)

-- 
Rémi Denis-Courmont
Nokia Devices R&D, Maemo Software, Helsinki

---

From: "Jose Rey" <[email-masked]>
Date: Tue, 4 Aug 2009 17:05:33 +0200

But I don't really need parameters for keep-alive. An empty body is good enough...so is that still a problem? 

> -----Original Message-----
> From: Rémi Denis-Courmont [mailto:[email-masked]] 
> Sent: Tuesday, August 04, 2009 5:02 PM
> To: [email-masked]
> Cc: ext Jose Rey
> Subject: Re: [MMUSIC] GET_PARAMETER for keep-alive in RTSP 2.0?
> 
> > Is there any reason why GET_PARAMETER is not mentioned in "10.5. 
> > Showing Liveness" as mechanism for keep-alive? The 
> description of the 
> > method itself would suggest it should go between 
> SET_PARAMETER and OPTIONS.
> 
> The problem is, there are no standardized actual 
> GET_PARAMETER request parameter, so the rely cannot rely on 
> this... (I do agree that this is the most common method in 
> existing RTSP/1.0 deployment)
> 
> --
> Rémi Denis-Courmont