Subject: [MMUSIC] About measurement unit for ParallaxInfo

From: Bert Greevenbosch <[email-masked]>
Date: Tue, 19 Apr 2011 07:29:25 +0000

Hi all,

During the Prague meeting, there was a question about the measurement unit of the "ParallaxInfo" attribute. Currently, this unit is pixels, but I was asked if it would make sense to use another unit, for example cm, to cater for different screen sizes and resolutions.

As many before me, I did some calculations. The results match similar calculations in MPEG-C part 3, ISO/IEC 23002-3. It turns out that the parallax P is a hyperbolic function of the depth Z (where Z=0 corresponds to the position of the screen itself). The function P(Z) has a zero at screen depth, a vertical asymptote at the viewing distance and a horizontal asymptote of the distance between the eyes.

Near to the screen, P(Z) can be approximated by a line, that goes trough (Z=0,P=0). It has the form

(1)	P(Z) ~= A*Z,

where A depends on the x- and z-positions of the left and right eyes. (In the calculations, I have neglected y, leading to a small bias.)

Since formula (1) is linear, near to the screen, multiplying the parallax by a certain factor results in increasing the depth by approximately the same factor. This is desirable, since if in one representation the horizontal and vertical distances are twice as big as in another, it is natural that the depth is twice as big as well.

If we have a fixed screen resolution in pixels, e.g. 1280x720 pixels, then the parallax in pixels will be smaller on a small screen than on a big screen. But since the rest of the video is equally smaller, through (1) the complete picture remains in sync (assuming the depth range is not too large).

So I think the unit "pixels" is appropriate for the ParallaxInfo attribute. We might want to add some text clarifying that the parallax suits the pixel width and height of the video.

Any opinions on this?

Best regards,
Bert

---

From: Stephen Botzko <[email-masked]>
Date: Tue, 19 Apr 2011 06:17:26 -0400

Thx for the formula / followup.

The screen resolution is not known though.  With H.264 all you know is the
profile/level.

Regards,
Stephen Botzko

On Tue, Apr 19, 2011 at 3:29 AM, Bert Greevenbosch <
[email-masked]> wrote:

> Hi all,
>
> During the Prague meeting, there was a question about the measurement unit
> of the "ParallaxInfo" attribute. Currently, this unit is pixels, but I was
> asked if it would make sense to use another unit, for example cm, to cater
> for different screen sizes and resolutions.
>
> As many before me, I did some calculations. The results match similar
> calculations in MPEG-C part 3, ISO/IEC 23002-3. It turns out that the
> parallax P is a hyperbolic function of the depth Z (where Z=0 corresponds to
> the position of the screen itself). The function P(Z) has a zero at screen
> depth, a vertical asymptote at the viewing distance and a horizontal
> asymptote of the distance between the eyes.
>
> where A depends on the x- and z-positions of the left and right eyes. (In
> the calculations, I have neglected y, leading to a small bias.)
>
> Since formula (1) is linear, near to the screen, multiplying the parallax
> by a certain factor results in increasing the depth by approximately the
> same factor. This is desirable, since if in one representation the
> horizontal and vertical distances are twice as big as in another, it is
> natural that the depth is twice as big as well.
>
> If we have a fixed screen resolution in pixels, e.g. 1280x720 pixels, then
> the parallax in pixels will be smaller on a small screen than on a big
> screen. But since the rest of the video is equally smaller, through (1) the
> complete picture remains in sync (assuming the depth range is not too
> large).
>
> So I think the unit "pixels" is appropriate for the ParallaxInfo attribute.
> We might want to add some text clarifying that the parallax suits the pixel
> width and height of the video.
>
> Any opinions on this?
>
> Best regards,
> Bert
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic
>

---

From: huiyu <[email-masked]>
Date: Wed, 20 Apr 2011 13:45:27 +0800

Hi,all

The SDP  "ParallaxInfo" attribute  is  actually computed relative to  a
reference screen, which has a  fixed screen resolution .

The  reference screen  has  a   screen resolution of 11520 horizontal pixels
.

The number has been standardized by the SMPTE .

The SDP  "ParallaxInfo" attribute indicates the parallax in units of pixels
related to  reference screen with 11,520 horizontal pixels.

The transformation from the reference parallax in pixels to the actual
parallax in pixels for different display sizes shall be as follows:

PARALLAX= parallax/[11520/ W_pix]

PARALLAX  means the parallax in the actual screen in units of pixels.

W_pix means  the horizontal pixels  of the actual screen solution.

parallax is  the 'parallax' value in the SDP  "ParallaxInfo" attribute line
in units of pixels.

Because there may be master spatial resolutions for which [PARALLAX ] cannot
be readily derived by dividing by an integer. so the resulting [PARALLAX ]
value shall be appropriately rounded to the nearest integer value."  Here
‘[11520/ W_pix]’ means  the resulting value  shall  be rounded to the
nearest integer.

As for 11520, SMPTE  provide the following reasoning:

The reason for this particular reference display value is that the native
parallax Value of the three most popular standards for horizontal resolution
can be readily derived from the display value by dividing by an integer, as
follows:

o       1920 horizontal pixels = 11,520 / 6

o       1440 horizontal pixels = 11,520 / 8

o       1280 horizontal pixels = 11,520 / 9

The following illustrates the processing of  deducing the transformation.

In MPEG-C part 3, ISO/IEC 23002-3，the formula P/P_ref=W/W_ref demonstrates
the transformation of parallax from  a reference screen to a actual screen,

although it is just approximate. 

 The unit of all parameters can be 'cm'. 

  'W_ref' means the horizontal screen size of the reference screen.

  'w' means the horizontal screen size of the actual screen.

  'P_ref'  means the parallax  in the reference screen.

  'P'  means the parallax  in the actual screen.

According to the physical size of each pixel  in screen, we can change the
unit of 'cm' to the unit of 'pixel' .

  the parallax of the reference screen in units of pixels can be expressed
as P_refpix,

  the horizontal screen size  of the reference screen in units of pixels can
be expressed as W_refpix,  

  the parallax in the actual screen in units of pixels can be expressed as
P_pix,

  the horizontal screen size  of the actual screen in units of pixels can be
expressed as W_pix,

  so it has :

   W_refpix/P_refpix=W_ref/P_ref;

   W_pix/P_pix=W/P;

   According to  the above formulas,  it has:   P_pix= P_refpix/( W_refpix /
W_pix) .

   Correspondingly, 

   the value of W_refpix is 11520, 

   P_refpix is  the 'parallax' value in the SDP  "ParallaxInfo" attribute
line  . 

   the value of W_pix is the horizontal  pixels of actual screen  solution.

   then  P_pix  is the actual parallax in actual screen, it can also be
transformed to cm  according to the physical size of each pixel.

So this formula P_pix= P_refpix/( W_refpix / W_pix)  corresponds to the
previous transformation formula.

   In summary, we reference the  SMPTE standard , and choose 11520  as the
horizontal pixels  of the reference screen solution ,

and define  the transformation.    we will add some text clarifying the
transformation of parallax.

Best regards,

HuiYu

发件人: [email-masked] [mailto:[email-masked]] 代表
Stephen Botzko
发送时间: 2011年4月19日 18:17
收件人: Bert Greevenbosch
抄送: [email-masked]
主题: Re: [MMUSIC] About measurement unit for ParallaxInfo

Regards,
Stephen Botzko

On Tue, Apr 19, 2011 at 3:29 AM, Bert Greevenbosch
<[email-masked]> wrote:

Hi all,

Near to the screen, P(Z) can be approximated by a line, that goes trough
(Z=0,P=0). It has the form

(1)     P(Z) ~= A*Z,

Since formula (1) is linear, near to the screen, multiplying the parallax by
a certain factor results in increasing the depth by approximately the same
factor. This is desirable, since if in one representation the horizontal and
vertical distances are twice as big as in another, it is natural that the
depth is twice as big as well.

Any opinions on this?

Best regards,
Bert

---

From: Stephen Botzko <[email-masked]>
Date: Wed, 20 Apr 2011 06:29:26 -0400

I agree that having an implicit reference screen width of 11,520 pixels
resolves the problem.  This essentially defines the signaled value as a
fraction of the screen size (using somewhat unusual but carefully chosen
units).

An alternative would be to explicitly signal the reference screen width.
The only advantage I see to the alternative approach is that it allows an
exact representation for other screen widths (such as 1024 for computer
screens or 800 for mobile devices).  Though this advantage is limited to
cases there the text is intended for a narrow range of devices.

Regards,
Stephen Botzko

2011/4/20 huiyu <[email-masked]>

> Hi,all
>
>
>
> *The SDP  "ParallaxInfo" attribute  is  actually computed relative to  a
> reference screen, which has a  fixed screen resolution .*
>
> *The  reference screen  has  a   screen resolution of 11520 horizontal
> pixels .*
>
> *The number has been standardized by the SMPTE .*
>
>
>
> *The transformation from the reference parallax in pixels to the actual
> parallax in pixels for different display sizes shall be as follows:*
>
> *PARALLAX= parallax/[11520/ W_pix]*
>
>
>
> parallax is  the 'parallax' value in the SDP  "ParallaxInfo" attribute
> line  in units of pixels.
>
>
>
> Because there may be master spatial resolutions for which [PARALLAX ]
> cannot be readily derived by dividing by an integer. so the resulting
> [PARALLAX ] value shall be appropriately rounded to the nearest integer
> value."  Here  ‘[11520/ W_pix]’ means  the resulting value  shall  be
> rounded to the nearest integer.
>
>
>
>
>
> * *
>   the horizontal screen size  of the reference screen in units of pixels
> can be expressed as W_refpix,
>
>   the horizontal screen size  of the actual screen in units of pixels can
> be expressed as W_pix,
>
>
>
>   so it has :
>
>    According to  the above formulas,  it has:   P_pix= P_refpix/( W_refpix
> / W_pix) .
>
>
>
>    Correspondingly,
>
>  *  In summary, we reference the  SMPTE standard , and choose 11520  as
> the horizontal pixels  of the reference screen solution ,*
>
> *and define  the transformation.    we will add some text clarifying the
> transformation of parallax.*
>
>
>
>
>
> Best regards,
>
> HuiYu
>
>
>
>
>
>
>
> *发件人:* [email-masked] [mailto:[email-masked]] *代表 *Stephen
> Botzko
> *发送时间:* 2011年4月19日 18:17
> *收件人:* Bert Greevenbosch
> *抄送:* [email-masked]
> *主题:* Re: [MMUSIC] About measurement unit for ParallaxInfo
>
>
>

---

From: huiyu <[email-masked]>
Date: Thu, 21 Apr 2011 10:31:30 +0800

Hi Stephen，

Thanks for your advice.

I think the two methods are all reasonable.

But in fact whether selecting 11520 pixels as the reference screen width or
signalling  the reference screen width  in SDP  "ParallaxInfo" attribute
line, 

the resulting [PARALLAX ] value  may be a fraction and need to  be
appropriately rounded to the nearest integer value in some cases.

we select  11520  pixels as the reference screen width.

Mainly Concerning that the standardized number is adopted by some  standard
such as DVB ,SMPTE.

so we think it should be consistent with  these standard ,though it leads to
a fraction of  in some cases.

Best regards，

Huiyu

发件人: Stephen Botzko [mailto:[email-masked]] 
发送时间: 2011年4月20日 18:29
收件人: huiyu
抄送: [email-masked]; Bert Greevenbosch
主题: Re: [MMUSIC] About measurement unit for ParallaxInfo

Regards,
Stephen Botzko

Hi,all

 

 

  so it has :

   W_pix/P_pix=W/P;

   Correspondingly, 

 

Best regards,

HuiYu

Regards,
Stephen Botzko

Hi all,

(1)     P(Z) ~= A*Z,

Any opinions on this?

Best regards,
Bert