Subject: [MMUSIC] Comments to draft-salgueiro-mmusic-image-iana-registration-05.txt

From: "Miguel A. Garcia" <[email-masked]>
Date: Wed, 25 May 2011 10:15:34 +0200

Some comments, as an individual, to the 'image' IANA registration draft. 
They are mostly editorial.

- The SDP example in Section 2 contains only relevant lines. I think it 
is not a big overhead to write all the SDP lines, including the v=, o=, 
s=, and t= lines. I prefer to see complete and syntactically correct SDP 
examples.

- Consider the last two paragraphs in Section 2, i.e., those starting with:

  "This document complies with ...."

  and

  "The purpose of this document is ..."

  I believe the order of these paragraphs should be interchanged, so that 
the purpose of the document is first described, and then, once we know 
what the document is about to do, we learn whether it complies with the 
requirements in RFC 4566 for that matter.

- Section 3, 5th bullet point. The text reads:

    (5)  Purpose of the registered name:

            The currently registered list of SDP media types ('audio',
            'video', 'text', 'application', and 'message') does not
            include one suitable for real-time facsimile (fax)
            applications.  The 'image' media type for the Session
            Description Protocol (SDP) is primarily intended to be
            utilized as a parameter by SDP [RFC4566] in SIP [RFC3261] to
            establish T.38 [T38] media streams.

I believe you should describe here the purpose of the "image" media type 
in SDP, not the purpose of the registration of the "image" media type, 
which is what is written. So, I would suggest a paragraph along these 
lines (feel free to amend them):

    The "image" media type describes a media stream that represents a 
still image. The submedia type further describes the format of the image.

/Miguel

-- 
Miguel A. Garcia
+34-91-339-3608
Ericsson Spain

---

From: Gonzalo Salgueiro <[email-masked]>
Date: Wed, 25 May 2011 19:50:32 -0400

Thanks for the review Miguel. The suggested edits all seemed reasonable to me. I have addressed them all in the latest version (http://tools.ietf.org/html/draft-salgueiro-mmusic-image-iana-registration).

Please let me know if there is any remaining feedback.

Regards,

Gonzalo

On May 25, 2011, at 4:15 AM, Miguel A. Garcia wrote:

> Some comments, as an individual, to the 'image' IANA registration draft. They are mostly editorial.
> 
> - The SDP example in Section 2 contains only relevant lines. I think it is not a big overhead to write all the SDP lines, including the v=, o=, s=, and t= lines. I prefer to see complete and syntactically correct SDP examples.
> 
> I believe the order of these paragraphs should be interchanged, so that the purpose of the document is first described, and then, once we know what the document is about to do, we learn whether it complies with the requirements in RFC 4566 for that matter.
> 
> I believe you should describe here the purpose of the "image" media type in SDP, not the purpose of the registration of the "image" media type, which is what is written. So, I would suggest a paragraph along these lines (feel free to amend them):
> 
>   The "image" media type describes a media stream that represents a still image. The submedia type further describes the format of the image.
> 
> 
> 
> /Miguel
> 
> 
> 
> -- 
> Miguel A. Garcia
> +34-91-339-3608
> Ericsson Spain