Subject: Re: [MMUSIC] [codec] SDP Support for Multiple Packetisation Periods

From: "Schwarz, Albrecht (Albrecht)" <[email-masked]>
Date: Fri, 29 Jul 2011 11:31:08 +0200

Paul,

1) SDP => IETF MMUSIC

2) ptime problem statement ("well known"), see

Multiple Packetization Times in the Session Description Protocol (SDP):
Problem Statement, Requirements & Solution
draft-garcia-mmusic-multiple-ptimes-problem-03.txt
http://tools.ietf.org/html/draft-garcia-mmusic-multiple-ptimes-problem-03

3) Solution:
= revised SDP Offer/Answer
see
a) SDP) Capability Negotiation RFC 5939
   http://tools.ietf.org/html/rfc5939
b) SDP Media Mapabilities Negotiation
   http://tools.ietf.org/wg/mmusic/draft-ietf-mmusic-sdp-media-capabilities/

Thus, revised SDP Offer/Answer must be used (instead of legacy SDP Offer/Answer RFC 3264).

-Albrecht

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of Paul Beaumont
> Sent: Donnerstag, 28. Juli 2011 19:31
> To: [email-masked]
> Subject: [codec] SDP Support for Multiple Packetisation Periods
> 
> All
> 
> Apologies, being first time to IETF and its mailing lists, if 
> this is not the right mailing list to post this request to.
> 
> On initial inspection it looks like it is not possible to 
> specify in SDP the specific packetisation period associated 
> with a codec that is available through negotiation. Specific 
> case I am concerned with is to support (1) G.711 @ PP=10ms 
> and (2) G.711 @ PP=20ms; prioritised in that order. The ptime 
> parameter would appear to apply to both.
> 
> Please can you advise where I should submit this question or 
> if this is the right frum then whether the above observation 
> is correct and any supplemental information/comments you may have? 
> 
> Thanks
> Paul Beaumont
> 
> 
> 
> _______________________________________________
> codec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/codec
>

---

From: "Miguel A. Garcia" <[email-masked]>
Date: Sun, 31 Jul 2011 10:33:32 +0200

Yeap, I was also going to point to the (already expired) I-D on multiple 
packetization problem draft,

http://tools.ietf.org/id/draft-garcia-mmusic-multiple-ptimes-problem-03.txt

The authors didn't see much interest in solving this problem, so the 
draft was abandoned. If the community realizes that the problem still 
persists, we can easily resurrect it.

/Miguel

On 29/07/2011 11:31, Schwarz, Albrecht (Albrecht) wrote:
> Problem Statement, Requirements&  Solution
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic
>

-- 
Miguel A. Garcia
+34-91-339-3608
Ericsson Spain