Subject: [MMUSIC] Multipath RTP (interface advertisement in SDP)

From: Varun Singh <[email-masked]>
Date: Mon, 25 Jul 2011 15:26:05 +0300

Greetings,

The draft is part of AVTCore but we have recently introduced an "interface" attribute in SDP, as an alternative to in-band interface advertisement. The draft also contains some O/A examples and these changes can be found in the SDP Considerations section. http://tools.ietf.org/rfcdiff?url2=draft-singh-avtcore-mprtp-02.txt

Comments and suggestions are welcome from MMUSIC. 

Regards,
Varun

Begin forwarded message:
> 
> A new version of I-D, draft-singh-avtcore-mprtp-02.txt has been successfully submitted by Varun Singh and posted to the IETF repository.
> 
> Filename: draft-singh-avtcore-mprtp
> Revision: 02
> Title: Multipath RTP (MPRTP)
> Creation date: 2011-07-08
> WG ID: Individual Submission
> Number of pages: 34
> 
> Abstract:
> The Real-time Transport Protocol (RTP) is used to deliver real-time
> content and, along with the RTP Control Protocol (RTCP), forms the
> control channel between the sender and receiver. However, RTP and
> RTCP assume a single delivery path between the sender and receiver
> and make decisions based on the measured characteristics of this
> single path. Increasingly, endpoints are becoming multi-homed, which
> means that they are connected via multiple Internet paths. Network
> utilization can be improved when endpoints use multiple parallel
> paths for communication. The resulting increase in reliability and
> throughput can also enhance the user experience. This document
> extends the Real-time Transport Protocol (RTP) so that a single
> session can take advantage of the availability of multiple paths
> between two endpoints.
> 
> 
> 
> 
> The IETF Secretariat
-- 

http://www.netlab.tkk.fi/~varun

---

From: "Dan Wing" <[email-masked]>
Date: Tue, 26 Jul 2011 16:20:56 -0400

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Varun Singh
> Sent: Monday, July 25, 2011 8:26 AM
> To: IETF MMUSIC WG
> Subject: [MMUSIC] Multipath RTP (interface advertisement in SDP)
> 
> Greetings,
> 
> The draft is part of AVTCore but we have recently introduced an
> "interface" attribute in SDP, as an alternative to in-band interface
> advertisement. The draft also contains some O/A examples and these
> changes can be found in the SDP Considerations section.
> http://tools.ietf.org/rfcdiff?url2=draft-singh-avtcore-mprtp-02.txt
> 

ICE's STUN connectivity checks, which use the password exchanged
in signaling as HMACs for the connectivity check, feel like a 
natural way to add new MPRTP addresses.  Have you analyzed using
such a technique and discarded the idea?

-d

> Regards,
> Varun
> 
> Begin forwarded message:
> >
> > A new version of I-D, draft-singh-avtcore-mprtp-02.txt has been
> successfully submitted by Varun Singh and posted to the IETF
> repository.
> >
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic

---

From: "Miguel A. Garcia" <[email-masked]>
Date: Wed, 27 Jul 2011 21:37:03 +0200

As a chair.

We encourage everyone to read this draft and provide comments to the 
protocols that deal with MMUSIC, namely, SDP and ICE.

Nevertheless, Christer Holmberg has volunteered to provide a review of 
the document from the point of view of MMUSIC. It should be ready within 
the next two weeks. Thank you Christer!

/Miguel

-- 
Miguel A. Garcia
+34-91-339-3608
Ericsson Spain