Subject: Re: [MMUSIC] MSID and mslabel

From: Bernard Aboba <[email-masked]>
Date: Thu, 11 Oct 2012 07:30:35 -0700

Question:  Can someone comment on the difference between msid and the
"mslabel" attribute?

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Stefan Hakansson LK
Sent: Thursday, October 11, 2012 7:13 AM
To: [email-masked]
Subject: [MMUSIC] WG poll for consensus MSID draft

I'm not a MMUSIC regular, but active in rtcweb. I would like this draft to
go forward as the info that msid provides is necessary for "gluing together"
the JS API and the actual rtp streams.

Stefan

"At the last IETF meeting we had a presentation of the following draft:

http://datatracker.ietf.org/doc/draft-alvestrand-mmusic-msid/

At that time, there was interest in solving the problem of cross session
stream identification.

We would like to poll the working group for consensus on adopting the 
above mentioned draft as a working group item, once we get an approved 
milestone.

If you support this work or have problems with the adoption of this 
document as WG item, please indicate it by replying to this e-mail 
within the next 5 days.

Flemming and Miguel (co-chairs)

--
Miguel A. Garcia
+34-91-339-3608
Ericsson Spain"
_______________________________________________
mmusic mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mmusic

---

From: Harald Alvestrand <[email-masked]>
Date: Fri, 12 Oct 2012 11:34:34 +0200

> Question:  Can someone comment on the difference between msid and the
I think "mslabel" was an early name for an attempt to do the same thing 
as msid, but never got a formal proposal attached to it.

Given that the word "label" often refers to human readable text, I 
prefer "id" for identifiers that must be unique and are not intended for 
human consumption.

(I may have missed something else called "mslabel", though).

---

From: "Miguel A. Garcia" <[email-masked]>
Date: Sat, 13 Oct 2012 09:48:44 +0200

Bernard,

I cannot identify the "mslabel" attribute. Do you know where it is specified?

Perhaps you refer to the "label" attribute (RFC 4574).

/Miguel

-- 
Miguel A. Garcia
+34-91-339-3608
Ericsson Spain

---

From: Bernard Aboba <[email-masked]>
Date: Tue, 23 Oct 2012 12:00:40 -0700

> Perhaps you refer to the "label" attribute (RFC 4574).

[BA] As Harald noted (see http://www.ietf.org/mail-archive/web/mmusic/current/msg09712.html), "mslabel" is used within a=ssrc lines, presumably for a similar purpose that "msid" is proposed for.  An example:

SDP from createOffer(), Chrome Version 24.0.1297.0 dev

v=0
o=- 1321413050 2 IN IP4 127.0.0.1
s=-
t=0 0
a=group:BUNDLE audio video
m=audio 1 RTP/SAVPF 103 104 0 8 106 105 13 126
c=IN IP4 0.0.0.0
a=rtcp:1 IN IP4 0.0.0.0
a=ice-ufrag:9wMh/Gc6fgJBzvzQ
a=ice-pwd:4I4SozPeoRtm9C58OF8M/deY
a=ice-options:google-ice
a=sendrecv
a=mid:audio
a=rtcp-mux
a=crypto:1 AES_CM_128_HMAC_SHA1_80 inline:JyWcGXs7j0U5aWAj8RlUdSwWkBRtmbvg3njMO1FB
a=rtpmap:103 ISAC/16000
a=rtpmap:104 ISAC/32000
a=rtpmap:0 PCMU/8000
a=rtpmap:8 PCMA/8000
a=rtpmap:106 CN/32000
a=rtpmap:105 CN/16000
a=rtpmap:13 CN/8000
a=rtpmap:126 telephone-event/8000
a=ssrc:1635880669 cname:ZXVf3drwG3fT+Wh5
a=ssrc:1635880669 mslabel:cLFXFpfLOP31s7D1A9on2I2rAvhTKqGSZEWr
a=ssrc:1635880669 label:cLFXFpfLOP31s7D1A9on2I2rAvhTKqGSZEWr00
m=video 1 RTP/SAVPF 100 101 102
c=IN IP4 0.0.0.0
a=rtcp:1 IN IP4 0.0.0.0
a=ice-ufrag:9wMh/Gc6fgJBzvzQ
a=ice-pwd:4I4SozPeoRtm9C58OF8M/deY
a=ice-options:google-ice
a=sendrecv
a=mid:video
a=rtcp-mux
a=crypto:1 AES_CM_128_HMAC_SHA1_80 inline:JyWcGXs7j0U5aWAj8RlUdSwWkBRtmbvg3njMO1FB
a=rtpmap:100 VP8/90000
a=rtpmap:101 red/90000
a=rtpmap:102 ulpfec/90000
a=ssrc:1563041388 cname:ZXVf3drwG3fT+Wh5
a=ssrc:1563041388 mslabel:cLFXFpfLOP31s7D1A9on2I2rAvhTKqGSZEWr
a=ssrc:1563041388 label:cLFXFpfLOP31s7D1A9on2I2rAvhTKqGSZEWr10

---

From: Harald Alvestrand <[email-masked]>
Date: Wed, 24 Oct 2012 18:40:38 +0200

On 10/23/2012 09:00 PM, Bernard Aboba wrote:
> [BA] As Harald noted (see 
> http://www.ietf.org/mail-archive/web/mmusic/current/msg09712.html),
> "mslabel" is used within a=ssrc lines, presumably for a similar 
> purpose that "msid" is proposed for.

 From a quick look at the source code, it looks like an identifier for a 
synchronization context - so it's a synonym for cname, more or less.

> An example:
> a=crypto:1 AES_CM_128_HMAC_SHA1_80 
> inline:JyWcGXs7j0U5aWAj8RlUdSwWkBRtmbvg3njMO1FB
> a=rtpmap:103 ISAC/16000
> a=rtpmap:104 ISAC/32000
> a=rtpmap:0 PCMU/8000
> a=rtpmap:8 PCMA/8000
> a=rtpmap:106 CN/32000
> a=rtpmap:105 CN/16000
> a=rtpmap:13 CN/8000
> a=crypto:1 AES_CM_128_HMAC_SHA1_80 
> inline:JyWcGXs7j0U5aWAj8RlUdSwWkBRtmbvg3njMO1FB
> a=rtpmap:100 VP8/90000
> a=rtpmap:101 red/90000

---

From: Martin Thomson <[email-masked]>
Date: Wed, 24 Oct 2012 16:58:47 -0700

> synchronization context - so it's a synonym for cname, more or less.

That's not my experience, this appears to be critical to the
functioning of the browser.  I removed the line and the corresponding
track did not get created.

Unless there is something that has changed between the code that was
used to compile my copy of Chromium and what you are seeing.

--Martin