Subject: Re: [MMUSIC] T.38 (Re: M-line philosophy (Re: Wisdom sought: Prioritization of codecs))

From: Stefan Hakansson LK <[email-masked]>
Date: Thu, 22 Nov 2012 14:39:14 +0100

On 11/20/2012 15:56, Adam Roach wrote:
>
>
>    +---------+   +------------+   +---------+
>    | Web App |---| SIP Server |---|         |
>    +---------+   +------------+   |         | +-------------+
>         |                         | PSTN GW |--| Fax Machine |
>    +---------+      media         |         | +-------------+
>    | Browser |--------------------|         |
>    +---------+                    +---------+

For cases when one client is not a proper fax machine, is not the usual 
thing that is done that the facsimile is converted to/from TIFF, JPEG, 
PDF or similar somewhere between that client and the fax machine? (And 
often sent as a mail attachment)

If so, all tools are already available (e.g. File API if you want to 
store/access on the local file system, XHR or WebSockets - or even the 
rtcweb data channel for transport) to build a client that can handle 
fax. (I am probably missing something)

Stefan

---

From: "Schwarz, Albrecht (Albrecht)" <[email-masked]>
Date: Thu, 22 Nov 2012 14:59:42 +0100

Looks like that your are describing T.37 FoIP behaviour, whereas Adam did point on T.38 FoIP.

WebRTC should firstly agree
a) whether fax is part of this conversational realtime multimedia service at all,
and if,
b) which transport mode via IP.

To a): support of F.185 (Internet fax) Yes/No
To b): 
	b.1) T.37 FoIP store-and-forward already sufficient Yes/No
	b.2) T.38 FoIP realtime required Yes/No ((perhaps T.38 over RTP/UDP or UDPTL/UDP))
	b.3) or any alternative to T.38 FoIP realtime Yes/No

NOTE: T.38 would specify the behaviour of the 
1) PSTN gateway (as "T.38 gateway", which is always a PSTN-to-IP gateway) and
2) Browser (as "T.38 IAD" (Internet aware fax device))
in below illustration.

-Albrecht

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Stefan Hakansson LK
Sent: Donnerstag, 22. November 2012 14:39
To: [email-masked]
Subject: Re: [MMUSIC] T.38 (Re: M-line philosophy (Re: Wisdom sought: Prioritization of codecs))

Stefan

_______________________________________________
mmusic mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mmusic

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 22 Nov 2012 19:59:22 +0000

Hi, 

> For cases when one client is not a proper fax machine, is not the usual thing that is done that the 
> facsimile is converted to/from TIFF, JPEG, PDF or similar somewhere between that client and the fax machine? (And often sent as a mail attachment)

I don't think you can make that assumption. Note that I am not talking specifically about browsers, but IP clients in general.

Now, there is ongoing work (draft-hanes-dispatch-fax-capability) in defining a media feature tag, which clients can use to indicate their fax capabilities. Maybe "picture" should be addded as an option...

Regards,

Christer