Subject: Re: [MMUSIC] T.38 (Re: M-line philosophy (Re: Wisdom sought: Prioritization of codecs))

From: Stefan Hakansson LK <[email-masked]>
Date: Fri, 23 Nov 2012 12:08:36 +0100

Thanks for the clarifications, and I agree to what rtcweb/webrtc should
decide.

What I was implying in my original mail is that I think T.38 support
should not be added to browsers (at least not as part of the
rtcweb/webrtc effort), and there are at least two reasons:

* It is not in any of the use-cases
* You can support store-and-forward FoIP in browsers already

But this discussion should happen in the rtcweb/webrtc space.

Stefan

On 11/22/2012 02:59 PM, Schwarz, Albrecht (Albrecht) wrote:
> Looks like that your are describing T.37 FoIP behaviour, whereas Adam
> did point on T.38 FoIP.
>
> WebRTC should firstly agree
> a) whether fax is part of this conversational realtime multimedia
> service at all,
> and if,
> b) which transport mode via IP.
>
> To a): support of F.185 (Internet fax) Yes/No
> To b):
>      b.1) T.37 FoIP store-and-forward already sufficient Yes/No
>      b.2) T.38 FoIP realtime required Yes/No ((perhaps T.38 over RTP/UDP
> or UDPTL/UDP))
>      b.3) or any alternative to T.38 FoIP realtime Yes/No
>
> NOTE: T.38 would specify the behaviour of the
> 1) PSTN gateway (as "T.38 gateway", which is always a PSTN-to-IP
> gateway) and
> 2) Browser (as "T.38 IAD" (Internet aware fax device))
> in below illustration.
>
> -Albrecht
>
> -----Original Message-----
> From: mmusic-bounces at ietf.org [mailto:mmusic-bounces at ietf.org] On
> Behalf Of Stefan Hakansson LK
> Sent: Donnerstag, 22. November 2012 14:39
> To: mmusic at ietf.org
> Subject: Re: [MMUSIC] T.38 (Re: M-line philosophy (Re: Wisdom sought:
> Prioritization of codecs))
>
> On 11/20/2012 15:56, Adam Roach wrote:
>  >
>  >
>  >    +---------+   +------------+   +---------+
>  >    | Web App |---| SIP Server |---|         |
>  >    +---------+   +------------+   |         | +-------------+
>  >         |                         | PSTN GW |--| Fax Machine |
>  >    +---------+      media         |         | +-------------+
>  >    | Browser |--------------------|         |
>  >    +---------+                    +---------+
>
> For cases when one client is not a proper fax machine, is not the usual
> thing that is done that the facsimile is converted to/from TIFF, JPEG,
> PDF or similar somewhere between that client and the fax machine? (And
> often sent as a mail attachment)
>
> If so, all tools are already available (e.g. File API if you want to
> store/access on the local file system, XHR or WebSockets - or even the
> rtcweb data channel for transport) to build a client that can handle
> fax. (I am probably missing something)
>
> Stefan
>
> _______________________________________________
> mmusic mailing list
> mmusic at ietf.org
> https://www.ietf.org/mailman/listinfo/mmusic

---

From: "Schwarz, Albrecht (Albrecht)" <[email-masked]>
Date: Fri, 23 Nov 2012 12:11:24 +0100

Fully agree!

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Stefan Hakansson LK
Sent: Freitag, 23. November 2012 12:09
To: [email-masked]
Subject: Re: [MMUSIC] T.38 (Re: M-line philosophy (Re: Wisdom sought: Prioritization of codecs))

Stefan

[email-masked]

---

From: "Parthasarathi R" <[email-masked]>
Date: Fri, 23 Nov 2012 21:53:41 +0530

Stefan,

I agree with you that usecase does not exists.

I think that T.38 shall be considered as part of PSTN interop as DTMF
usecase is already considered for PSTN interop. In fact, DTMF interop with
PSTN gateway shall be easily achieved using non-media (RTP) mechanism but it
is tough achieve real-time fax interop without media (T.38) support.

Thanks
Partha

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Stefan Hakansson LK
Sent: Friday, November 23, 2012 4:39 PM
To: [email-masked]
Subject: Re: [MMUSIC] T.38 (Re: M-line philosophy (Re: Wisdom sought:
Prioritization of codecs))

Stefan

---

From: Stefan Håkansson LK <[email-masked]>
Date: Sun, 25 Nov 2012 19:43:17 +0100

Hi Partha,
> is tough achieve real-time fax interop without media (T.38) support.

This is correct AFAIK. And personally I did not really want DTMF as part 
of rtcweb - it is just for legacy interop, and can be solved by other 
means as you point out. But the wg's view was that sending DTMF should 
be supported, and perhaps that makes sense - DTMF is quite often used, 
by a lot of people (I use it almost daily to navigate IVRs).

I don't think this goes for fax, I think fax these days is only used by 
certain (few) organizations and only for certain types of communication.

But if you think differently, please make a proposal on the rtcweb mail 
list!

Thanks,
Stefan

---

From: Bernard Aboba <[email-masked]>
Date: Sun, 25 Nov 2012 11:43:46 -0800

Stefan said:

> But if you think differently, please make a proposal on the rtcweb mail list!

[BA]  Given the steep decline in landlines, POTS is on the road to becoming economically non-viable by the end of the decade, if not sooner.   Once POTS shuts down, the legal and regulatory requirements which prop up the use of fax will need to be re-thought.  IMHO given the bleak future of fax, supporting it in WebRTC is not worth the effort. 

BTW, support for RFC 4733 (DTMF) is now required in draft-ietf-rtcweb-audio-01 instead of  RFC 4734 (Fax, Modem and Text Telephony) which was cited (mistakenly) in -00.   

Bernard "Spent several hours debugging T.38 last week" Aboba

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Mon, 26 Nov 2012 10:55:54 +0100

Be careful to address this issue from a worldwide context rather than a North America specific one.

There are still plenty of people raising fax issues from the Asian countries.

Keith

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Bernard Aboba
Sent: 25 November 2012 19:44
To: Stefan Håkansson LK
Cc: [email-masked]
Subject: Re: [MMUSIC] T.38 (Re: M-line philosophy (Re: Wisdom sought: Prioritization of codecs))