Subject: [MMUSIC] Multiple media streams in SDP

From: "Klatsky, Carl" <[email-masked]>
Date: Thu, 15 Nov 2012 17:48:27 +0000

Hi,

Question on the use of multiple media stream in SDP.  When multiple streams each of  (more than one m= line) of type RTP/AVP are offered and answered, does that imply that the RTP media packets for each stream gets their own unique synchronization source (SSRC) identifier?

Regards,

Carl Klatsky

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Thu, 15 Nov 2012 22:59:14 +0000

As currently defined (i.e. without SHIM or BUNDLE), each m-line corresponds to a separate RTP session, each with its own SSRC space. An implementation would be free to use the same or different SSRCs across RTP sessions, depending on the circumstances.

Cheers,
Charles

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Klatsky, Carl
> Sent: Thursday, November 15, 2012 9:48 AM
> To: [email-masked]'
> Subject: [MMUSIC] Multiple media streams in SDP
> 
> Hi,
> 
> 
> 
> Question on the use of multiple media stream in SDP.  When multiple
> streams each of  (more than one m= line) of type RTP/AVP are offered and
> answered, does that imply that the RTP media packets for each stream gets
> their own unique synchronization source (SSRC) identifier?
> 
> 
> 
> Regards,
> 
> 
> 
> Carl Klatsky
> 
>