Subject: [MMUSIC] NEED WG CONSENSUS: media-loopback is all-or-nothing

From: Hadriel Kaplan <[email-masked]>
Date: Tue, 20 Nov 2012 18:16:03 +0000

Howdy,
during IESG review of the media-loopback draft, a discussion arose regarding the language around indicating media-loopback support per media description (i.e., per m-line), in sections 3.1 and 3.2.

My interpretation/understanding was we were requiring ALL m-lines to indicate media-loopback; in other words it's an all-or-nothing in both the offer+answer, and either every media stream is looped back, or none are.  However the text currently doesn't make this clear, and it could be argued either way, with pro's/con's either way too; so I'd like the WG's consensus on whether it should in fact be an all-or-none approach, or not.

Please respond to this email by **Tuesday, December 4th** with a "YES" if the draft should mandate ALL media be looped-back, or "NO" if it should allow a hybrid approach of some streams being looped while others are not.

For reference, the draft is here:
http://tools.ietf.org/html/draft-ietf-mmusic-media-loopback-24

-hadriel

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 20 Nov 2012 13:42:43 -0500

NO

*Why* should the draft be limited this way if it need not be?

	Thanks,
	Paul

On 11/20/12 1:16 PM, Hadriel Kaplan wrote:
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic
>

---

From: Bernard Aboba <[email-masked]>
Date: Tue, 20 Nov 2012 10:56:41 -0800

To Paul's point, there may be a scenario in which some m lines would be looped back and others would not.  For example, what if I want to do a loopback test of audio/video but also want to be able to converse via RTT to discuss the results of the test in progress.  In that case the audio and video m lines would be looped back but the text line would not be. 

> Date: Tue, 20 Nov 2012 13:42:43 -0500
> From: [email-masked]
> To: [email-masked]
> Subject: Re: [MMUSIC] NEED WG CONSENSUS: media-loopback is all-or-nothing
> 
> NO
>

---

From: Hadriel Kaplan <[email-masked]>
Date: Tue, 20 Nov 2012 19:51:33 +0000

I take this is a "NO" vote?

-hadriel

On Nov 20, 2012, at 1:56 PM, Bernard Aboba <[email-masked]<mailto:[email-masked]>> wrote:

> From: [email-masked]<mailto:[email-masked]>
> To: [email-masked]<mailto:[email-masked]>
> > [email-masked]<mailto:[email-masked]>
> [email-masked]<mailto:[email-masked]>
_______________________________________________
mmusic mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/mmusic

---

From: Hadriel Kaplan <[email-masked]>
Date: Tue, 20 Nov 2012 19:54:14 +0000

Are you asking for someone to defend/explain the advantages are for limiting it, or just giving that as the rationale for your NO vote?
(I don't mean this in a negative way - I'm literally not sure if you're asking a question or being rhetorical)

-hadriel

---

From: Bernard Aboba <[email-masked]>
Date: Tue, 20 Nov 2012 12:02:22 -0800

"NO".

From: [email-masked]
To: [email-masked]
CC: [email-masked]; [email-masked]
Subject: Re: [MMUSIC] NEED WG CONSENSUS: media-loopback is all-or-nothing
Date: Tue, 20 Nov 2012 19:51:33 +0000

-hadriel

On Nov 20, 2012, at 1:56 PM, Bernard Aboba <[email-masked]> wrote:

To Paul's point, there may be a scenario in which some m lines would be looped back and others would not.  For example, what if I want to do a loopback test of audio/video but also want to be able to converse via RTT to discuss the results of
 the test in progress.  In that case the audio and video m lines would be looped back but the text line would not be. 

> > My interpretation/understanding was we were requiring ALL m-lines to indicate media-loopback; in other words it's an all-or-nothing in both the offer+answer, and either every media stream is looped back, or none are. However the text currently doesn't make
 this clear, and it could be argued either way, with pro's/con's either way too; so I'd like the WG's consensus on whether it should in fact be an all-or-none approach, or not.

mmusic mailing list

[email-masked]

---

From: Gunnar Hellström <[email-masked]>
Date: Tue, 20 Nov 2012 21:30:40 +0100

NO

There are unforeseeable effects of requiring all or nothing.

What if a new RTP based medium is registered, e.g. m=aroma.
Then the logic would require that the media-loopback specification would 
need to be updated before m=aroma could be used at all.

There is also an inconsistency in that 3.1 requires all m-lines in the 
sdp to include loopback payload type and the draft is valid only for RTP 
media. There are other media also declared by m-lines, e.g. m=message 
for MSRP, and many m=application are not RTP-based.
A proposal taking care of this problem, but not the one above about new 
media would be to in 3.1 in the phrase
"

each individual media description"
say
"each individual RTP-based media description"

/Gunnar

On 2012-11-20 19:42, Paul Kyzivat wrote:
>> during IESG review of the media-loopback draft, a discussion arose 
>> regarding the language around indicating media-loopback support per 
>> media description (i.e., per m-line), in sections 3.1 and 3.2.
>>
>> My interpretation/understanding was we were requiring ALL m-lines to 
>> indicate media-loopback; in other words it's an all-or-nothing in 
>> both the offer+answer, and either every media stream is looped back, 
>> or none are.  However the text currently doesn't make this clear, and 
>> it could be argued either way, with pro's/con's either way too; so 
>> I'd like the WG's consensus on whether it should in fact be an 
>> all-or-none approach, or not.
>>
>> Please respond to this email by **Tuesday, December 4th** with a 
>> "YES" if the draft should mandate ALL media be looped-back, or "NO" 
>> if it should allow a hybrid approach of some streams being looped 
>> while others are not.
>>

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 20 Nov 2012 15:50:43 -0500

> (I don't mean this in a negative way - I'm literally not sure if you're asking a question or being rhetorical)

It was primarily a justification for my NO vote.
But it is also an invitation for someone who votes yes to convince me of 
why.

	Thanks,
	Paul

---

From: Flemming Andreasen <[email-masked]>
Date: Tue, 20 Nov 2012 16:31:52 -0500

One more "NO" vote - I also don't see a reason to mandate such a 
restriction as it may limit the use cases.

-- Flemming

On 11/20/12 1:42 PM, Paul Kyzivat wrote:
> .

---

From: "Richard L. Barnes" <[email-masked]>
Date: Tue, 20 Nov 2012 17:09:38 -0500

I lean in favor of YES, because it seems to be much simpler and address the most pressing use cases.

(I haven't been involved deeply in the discussion, though; is there something I'm missing?)

On Nov 20, 2012, at 4:31 PM, Flemming Andreasen <[email-masked]> wrote:

> One more "NO" vote - I also don't see a reason to mandate such a restriction as it may limit the use cases.
> 
> -- Flemming
>

---

From: Flemming Andreasen <[email-masked]>
Date: Tue, 20 Nov 2012 18:11:32 -0500

We normally try and provide general solutions rather than focus on 
specific use cases. Looking at media streams in general, we negotiate 
and accept/reject them independently (and likewise for preconditions). 
Why should this be any different ?

Thanks

-- Flemming

---

From: "Muthu Arul Mozhi Perumal (mperumal)" <[email-masked]>
Date: Wed, 21 Nov 2012 04:30:59 +0000

|Please respond to this email by **Tuesday, December 4th** with a "YES" if the 
|draft should mandate ALL media be looped-back, or "NO" if it should allow a 
|hybrid approach of some streams being looped while others are not.

NO.

Muthu

|-----Original Message-----
|From: [email-masked] [mailto:[email-masked]] On Behalf Of Hadriel Kaplan
|Sent: Tuesday, November 20, 2012 11:46 PM
|To: [email-masked] (E-mail)
|Cc: Gonzalo Camarillo; [email-masked]
|Subject: [MMUSIC] NEED WG CONSENSUS: media-loopback is all-or-nothing
|
|Howdy,
|during IESG review of the media-loopback draft, a discussion arose regarding the language around
|indicating media-loopback support per media description (i.e., per m-line), in sections 3.1 and 3.2.
|
|My interpretation/understanding was we were requiring ALL m-lines to indicate media-loopback; in other
|words it's an all-or-nothing in both the offer+answer, and either every media stream is looped back,
|or none are.  However the text currently doesn't make this clear, and it could be argued either way,
|with pro's/con's either way too; so I'd like the WG's consensus on whether it should in fact be an
|all-or-none approach, or not.
|
|Please respond to this email by **Tuesday, December 4th** with a "YES" if the draft should mandate ALL
|media be looped-back, or "NO" if it should allow a hybrid approach of some streams being looped while
|others are not.
|
|For reference, the draft is here:
|http://tools.ietf.org/html/draft-ietf-mmusic-media-loopback-24
|
|-hadriel
|
|_______________________________________________
|mmusic mailing list
[email-masked]
|https://www.ietf.org/mailman/listinfo/mmusic

---

From: "Parthasarathi R" <[email-masked]>
Date: Wed, 21 Nov 2012 21:17:38 +0530

NO...it is possible that some of the device may prefer to loop back only one
of the stream (audio) and not the other streams (like Video).

Thanks
Partha

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Muthu Arul Mozhi Perumal (mperumal)
Sent: Wednesday, November 21, 2012 10:01 AM
To: Hadriel Kaplan; [email-masked] (E-mail)
Cc: Gonzalo Camarillo; [email-masked]
Subject: Re: [MMUSIC] NEED WG CONSENSUS: media-loopback is all-or-nothing

|Please respond to this email by **Tuesday, December 4th** with a "YES" if
the 
|draft should mandate ALL media be looped-back, or "NO" if it should allow a

NO.

Muthu

|-----Original Message-----
|From: [email-masked] [mailto:[email-masked]] On Behalf Of
Hadriel Kaplan
|Sent: Tuesday, November 20, 2012 11:46 PM
|To: [email-masked] (E-mail)
|Cc: Gonzalo Camarillo; [email-masked]
|Subject: [MMUSIC] NEED WG CONSENSUS: media-loopback is all-or-nothing
|
|Howdy,
|during IESG review of the media-loopback draft, a discussion arose
regarding the language around
|indicating media-loopback support per media description (i.e., per m-line),
in sections 3.1 and 3.2.
|
|My interpretation/understanding was we were requiring ALL m-lines to
indicate media-loopback; in other
|words it's an all-or-nothing in both the offer+answer, and either every
media stream is looped back,
|or none are.  However the text currently doesn't make this clear, and it
could be argued either way,
|with pro's/con's either way too; so I'd like the WG's consensus on whether
it should in fact be an
|all-or-none approach, or not.
|
|Please respond to this email by **Tuesday, December 4th** with a "YES" if
the draft should mandate ALL
|media be looped-back, or "NO" if it should allow a hybrid approach of some
streams being looped while
|others are not.
|
|For reference, the draft is here:
|http://tools.ietf.org/html/draft-ietf-mmusic-media-loopback-24
|
|-hadriel
|
|_______________________________________________
|mmusic mailing list
[email-masked]
|https://www.ietf.org/mailman/listinfo/mmusic
_______________________________________________
mmusic mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mmusic

---

From: "Cullen Jennings (fluffy)" <[email-masked]>
Date: Tue, 27 Nov 2012 03:43:13 +0000

no

---

From: "Hutton, Andrew" <[email-masked]>
Date: Tue, 27 Nov 2012 10:58:15 +0000

NO. 

I see no reason to mandate that all media is looped back.

Regards
Andy

> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Hadriel Kaplan
> Sent: 20 November 2012 18:16
> To: [email-masked] (E-mail)
> Subject: [MMUSIC] NEED WG CONSENSUS: media-loopback is all-or-nothing
> 
> Howdy,
> indicate media-loopback; in other words it's an all-or-nothing in both
> the offer+answer, and either every media stream is looped back, or none
> are.  However the text currently doesn't make this clear, and it could
> be argued either way, with pro's/con's either way too; so I'd like the
> WG's consensus on whether it should in fact be an all-or-none approach,
> or not.
> 
> Please respond to this email by **Tuesday, December 4th** with a "YES"
> if the draft should mandate ALL media be looped-back, or "NO" if it
> should allow a hybrid approach of some streams being looped while
> others are not.
>

---

From: Enrico Marocco <[email-masked]>
Date: Wed, 28 Nov 2012 10:00:44 +0100

No.

I see no compelling reason for introducing such a limitation, but a
bunch of cases where it breaks things badly. In interconnection
scenarios, for instance.

Enrico

---

From: Qin Wu <[email-masked]>
Date: Thu, 29 Nov 2012 08:54:22 +0800

No,
I see it will be more flexible to allow some being looped back while some not.

Regards!
-Qin

---

From: "Nikos Leontsinis" <[email-masked]>
Date: Thu, 29 Nov 2012 16:09:05 +0200

No for scalability reasons

/nikos

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Qin Wu
Sent: Thursday, November 29, 2012 2:54 AM
To: Hadriel Kaplan
Cc: [email-masked]; [email-masked];
Gonzalo Camarillo
Subject: Re: [MMUSIC] NEED WG CONSENSUS: media-loopback is all-or-nothing

No,
I see it will be more flexible to allow some being looped back while some
not.

Regards!
-Qin
----- Original Message ----- 
From: "Cullen Jennings (fluffy)" <[email-masked]>
To: "Hadriel Kaplan" <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>;
"Gonzalo Camarillo" <[email-masked]>
Sent: Tuesday, November 27, 2012 11:43 AM
Subject: Re: [MMUSIC] NEED WG CONSENSUS: media-loopback is all-or-nothing

>> during IESG review of the media-loopback draft, a discussion arose
regarding the language around indicating media-loopback support per media
description (i.e., per m-line), in sections 3.1 and 3.2.
>> My interpretation/understanding was we were requiring ALL m-lines to
indicate media-loopback; in other words it's an all-or-nothing in both the
offer+answer, and either every media stream is looped back, or none are.
However the text currently doesn't make this clear, and it could be argued
either way, with pro's/con's either way too; so I'd like the WG's consensus
on whether it should in fact be an all-or-none approach, or not.
>> 
>> Please respond to this email by **Tuesday, December 4th** with a "YES" if
the draft should mandate ALL media be looped-back, or "NO" if it should
allow a hybrid approach of some streams being looped while others are not.