Subject: [MMUSIC] Bundle and Complex ICE Scenarios

From: "Hutton, Andrew" <[email-masked]>
Date: Thu, 14 Mar 2013 21:47:07 +0000

Having reviewed the various bundle proposals I don't believe enough attention has been made to issues around using bundle with ICE and especially some of the more complex ICE scenarios to verify that they will work or are optimal in these cases.

For example there is no analysis of the following issues:

1. IPV6 / Dual Stack environments where it is necessary to generate candidates for multiple address families. 

2. Scenarios involving Server Reflexive, Relayed Candidates, and TCP Candidates are required.

Some of these scenarios relate to scenarios involving NAT's & Firewalls which we have started to analyse in http://tools.ietf.org/html/draft-hutton-rtcweb-nat-firewall-considerations-00. 

I intend to do some further analysis and look more closely at bundle in the context of these scenarios over the next couple of weeks but personally until this is done I cannot say whether the current bundle proposals meet our needs.

Regards
Andy

---

From: "Hutton, Andrew" <[email-masked]>
Date: Fri, 15 Mar 2013 12:08:22 +0000

An example of why I have a concern can be seen in the bundle slides presented in the mmusic session earlier this week http://www.ietf.org/proceedings/86/slides/slides-86-mmusic-9.pdf.

Slides 3 and 4 indicate that two offer answer cycles (Maybe 1.5) are needed to get bundled media to flow and they show how the ports on the m-lines are used.  The 2nd offer contains the same port used in the 1st m-line of the 1st offer in all the bundled m-lines of the 2nd offer.

This would appear to conflict with the 2nd offer that is required in some ICE scenarios where the port used in the 2nd offer is chosen from one of the candidates and does not match any port on the m-lines in the initial offer/answer.

I believe more analysis is needed and I will work on that.

It maybe that trying to come to a single solution covering rtcweb and all other environments would compromise the rtcweb solution which is not something we should do. Multiple solutions may be better than a single one that compromises quality.

Regards
Andy

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Hutton, Andrew
> Sent: 14 March 2013 17:47
> To: [email-masked]
> Subject: [MMUSIC] Bundle and Complex ICE Scenarios
> 
> Having reviewed the various bundle proposals I don't believe enough
> attention has been made to issues around using bundle with ICE and
> especially some of the more complex ICE scenarios to verify that they
> will work or are optimal in these cases.
> 
> 1. IPV6 / Dual Stack environments where it is necessary to generate
> candidates for multiple address families.
> 
> Some of these scenarios relate to scenarios involving NAT's & Firewalls
> which we have started to analyse in http://tools.ietf.org/html/draft-
> hutton-rtcweb-nat-firewall-considerations-00.
> 
> I intend to do some further analysis and look more closely at bundle in
> the context of these scenarios over the next couple of weeks but
> personally until this is done I cannot say whether the current bundle
> proposals meet our needs.
> 
> Regards
> Andy
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic