Subject: [MMUSIC] BUNDLE: mandate RTP/RTCP multiplexing?

From: Christer Holmberg <[email-masked]>
Date: Tue, 30 Apr 2013 13:26:35 +0000

Hi,

As currently indicated in BUNDLE, and SDP offer for RTP must contain an rtcp-mux attribute, indicating support of RTP/RTCP multiplexing.

However, it is currently optional to include it in the SDP answer.

There has been some discussions on whether we should MANDATE the usage of rtcp-mux whenever BUNDLE is enabled.

Would anyone OBJECT to that?

Regards,

Christer

---

From: Bernard Aboba <[email-masked]>
Date: Tue, 30 Apr 2013 08:21:14 -0700

No objection here to requiring rtcp-mux with BUNDLE.   Implementations not supporting rtcp-mux probably don't support BUNDLE either.  

From: [email-masked]
To: [email-masked]
Date: Tue, 30 Apr 2013 13:26:35 +0000
Subject: [MMUSIC] BUNDLE: mandate RTP/RTCP multiplexing?

Hi,

 

Regards,
 
Christer

_______________________________________________
mmusic mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mmusic

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 30 Apr 2013 13:12:30 -0400

On 4/30/13 9:26 AM, Christer Holmberg wrote:
> Hi,
>
> As currently indicated in BUNDLE, and SDP offer for RTP must contain an
> rtcp-mux attribute, indicating support of RTP/RTCP multiplexing.
>

What are the implications of *not* mandating it?

Doing so requires two ports, so in some sense you end up with two bundles.

If a=rtcp:nn is used, then presumably it will need to be the same in all 
RTP m-lines. But we have many such requirements, so this one isn't special.

I guess I won't *object*, but it does offend my notion that independent 
things should be kept independent.

	Thanks,
	Paul

---

From: Martin Thomson <[email-masked]>
Date: Tue, 30 Apr 2013 12:00:31 -0700

> What are the implications of *not* mandating it?

I'm more interesting in learning why someone might want to split it
out.  I can't see any reason for doing that...

...that is, except perhaps for some of the fictitious attacks I invent
when someone suggests that RTCP is a good place for a security
mechanism of one sort or other.

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 30 Apr 2013 15:30:05 -0400

> mechanism of one sort or other.

Well, IIUC it was separate before there was a way to combine them.
Why was that? Why hasn't separate RTCP gone away entirely?

	Thanks,
	Paul