Subject: Re: [MMUSIC] New Liaison Statement, "LS on Missing IANA Registration Information on SDP Attributes in RFC 2326"

From: Magnus Westerlund <[email-masked]>
Date: Tue, 13 Aug 2013 15:10:06 +0200

On 2013-07-29 09:53, Ari Keränen wrote:
> MMUSIC,
> 
> We have received a liaison statement from 3GPP regarding missing SDP
> attributes at the IANA registry (see the e-mail below for details).
> 
> As the statement says:
>> SA4 has identified that IANA registrations of three SDP attributes
>> defined in RFC 2326, namely ‘control’, ‘range’ and ‘etag’, are missing
> 
> As a solution, the RTSP 2.0 draft already registers 'control' and
> 'range' for RFC 2326 and RFC 2326bis
> (http://tools.ietf.org/html/draft-ietf-mmusic-rfc2326bis-34#section-22.15).
> However, in RFC2326bis 'etag' is renamed into 'mtag'.
> 
> Hence, it seems that we should also register 'etag' but for that
> reference RTSP 1.0 (RFC 2326) only.
> 
> Please review the liaison statement and our proposed solution and send
> your comments to us and to the list.

WG,

I volunteer to send an email registering these SDP attributes to IANA so
that a respond can be sent to 3GPP SA4 that they attribute has been
registered. I propose to include all attributes in that registration. I
can clarify in the RFC 2326bis draft that the SDP registrations are an
update to what we put in at this stage. I have also chosen to put "etag"
in the both category due to that is what has been done in the RFC2326bis
draft as the original text is far from clear if it is a session only or not.

Thus I propose to send the below to IANA on Monday (19th of Aug) unless
someone disagree.

> Dear IANA,
> 
> It has come to our attention that the SDP attributes defined in RFC 2326
> are not registered in the SDP attributes registry, i.e. related to RFC
> 4566 found at:
> www.iana.org/assignments/sdp-parameters/sdp-parameters.xhtml
> 
> In registry: att-field (both session and media level)
> 
> Please add the following SDP Attributes:
> 
> SDP Name: control
> Reference: RFC 2326
> 
> SDP Name: range
> Reference: RFC 2326
> 
> SDP Name: etag
> Reference: RFC 2326
> 
> Contact: Authors of RFC 2326
> 
> Thanks
> 
> Magnus Westerlund

Cheers

Magnus Westerlund

----------------------------------------------------------------------
Multimedia Technologies, Ericsson Research EAB/TVM
----------------------------------------------------------------------
Ericsson AB                | Phone  +46 10 7148287
Färögatan 6                | Mobile +46 73 0949079
SE-164 80 Stockholm, Sweden| mailto: [email-masked]
----------------------------------------------------------------------

---

From: "Cullen Jennings (fluffy)" <[email-masked]>
Date: Tue, 13 Aug 2013 23:09:56 +0000

Sounds reasonable to me.

On Aug 13, 2013, at 7:10 AM, Magnus Westerlund <[email-masked]> wrote:

> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic

---

From: Ari Keränen <[email-masked]>
Date: Thu, 15 Aug 2013 15:11:03 +0300

This looks good to me. Thanks Magnus!

Cheers,
Ari