Subject: Re: [MMUSIC] draft-ejzak-mmusic-data-channel-sdpneg and draft-ejzak-mmusic-msrp-usage-data-channel

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Sun, 2 Nov 2014 15:07:22 +0000

At the London IETF meeting, we were not quite at the point of asking for adoption of draft-ejzak-mmusic-data-channel-sdpneg. There was a request that certain revisions should be made and a couple of issues addressed.

That has now occurred.

I would like to ask if we can now moved forward to adoption of this draft as a working group item. While it is the responsibility of the chairs to make a formal call, I have asked for a small amount of time in Honolulu with this intent, and it would be useful if people could start to express their opinions one way or other on the list, i.e. whether they think the draft is generally useful, or alternatively, just a bad idea!

Regards

Keith

> -----Original Message-----
> From: DRAGE, Keith (Keith) 
> Sent: 27 October 2014 14:39
> To: [email-masked]
> Subject: draft-ejzak-mmusic-data-channel-sdpneg and 
> draft-ejzak-mmusic-msrp-usage-data-channel
> 
> Based on the discussion on list over the last few days, I 
> have submitted revised versions of the two SDP negotiation 
> over data channel drafts as follows:
> 
> A new version of I-D, draft-ejzak-mmusic-data-channel-sdpneg-02.txt
> has been successfully submitted by Keith Drage and posted to 
> the IETF repository.
> 
> Name:		draft-ejzak-mmusic-data-channel-sdpneg
> Revision:	02
> Title:		SDP-based "SCTP over DTLS" data channel 
> negotiation
> Document date:	2014-10-27
> Group:		Individual Submission
> Pages:		22
> URL:            
> http://www.ietf.org/internet-drafts/draft-ejzak-mmusic-data-ch
> annel-sdpneg-02.txt
> Status:         
> https://datatracker.ietf.org/doc/draft-ejzak-mmusic-data-chann
> el-sdpneg/
> Htmlized:       
> http://tools.ietf.org/html/draft-ejzak-mmusic-data-channel-sdpneg-02
> Diff:           
> http://www.ietf.org/rfcdiff?url2=draft-ejzak-mmusic-data-chann
> el-sdpneg-02
> 
> Abstract:
>    The Real-Time Communication in WEB-browsers (RTCWeb) 
> working group is
>    charged to provide protocols to support direct interactive rich
>    communications using audio, video, and data between two peers' web-
>    browsers.  For the support of data communication, the 
> RTCWeb working
>    group has in particular defined the concept of bi-directional data
>    channels over SCTP, where each data channel might be used to
>    transport other protocols, called sub-protocols.  Data 
> channel setup
>    can be done using either the internal in-band band (also 
> referred to
>    as 'internal' for the rest of the document) WebRTC Data Channel
>    Establishment Protocol or some external out-of-band simply referred
>    to as 'external negotiation' in the rest of the document . This
>    document specifies how the SDP offer/answer exchange can be used to
>    achieve such an external negotiation.  Even though data 
> channels are
>    designed for RTCWeb use initially they may be used by 
> other protocols
>    like, but not limited to, the CLUE protocol.  This document is
>    intended to be used wherever data channels are used.
> 
> 
> A new version of I-D, 
> draft-ejzak-mmusic-msrp-usage-data-channel-01.txt
> has been successfully submitted by Keith Drage and posted to 
> the IETF repository.
> 
> Name:		draft-ejzak-mmusic-msrp-usage-data-channel
> Revision:	01
> Title:		MSRP over SCTP/DTLS data channels
> Document date:	2014-10-27
> Group:		Individual Submission
> Pages:		11
> URL:            
> http://www.ietf.org/internet-drafts/draft-ejzak-mmusic-msrp-us
> age-data-channel-01.txt
> Status:         
> https://datatracker.ietf.org/doc/draft-ejzak-mmusic-msrp-usage
> -data-channel/
> Htmlized:       
> http://tools.ietf.org/html/draft-ejzak-mmusic-msrp-usage-data-
> channel-01
> Diff:           
> http://www.ietf.org/rfcdiff?url2=draft-ejzak-mmusic-msrp-usage
> -data-channel-01
> 
> Abstract:
>    This document specifies how the Message Session Relay 
> Protocol (MSRP)
>    can be instantiated as a data channel sub-protocol, using 
> the the SDP
>    offer/answer exchange-based external negotiation defined in
>    [I-D.ejzak-mmusic-data-channel-sdpneg].  Two network configurations
>    are documented: a WebRTC end-to-end configuration (connecting two
>    MSRP over data channel endpoints), and a gateway configuration
>    (connecting an MSRP over data channel endpoint with an 
> MSRP over TCP
>    endpoint).

---

From: Christer Holmberg <[email-masked]>
Date: Sun, 2 Nov 2014 15:50:18 +0000

Hi,

I think the draft is useful, and I support adopting it as a WG item. I also intend to be active in the work, review and provide comments, etc.

Regards,

Christer

Sent from my Windows Phone
________________________________
From: DRAGE, Keith (Keith)<mailto:[email-masked]>
Sent: ‎02/‎11/‎2014 17:07
To: [email-masked]<mailto:[email-masked]>
Subject: Re: [MMUSIC] draft-ejzak-mmusic-data-channel-sdpneg and draft-ejzak-mmusic-msrp-usage-data-channel

That has now occurred.

Regards

Keith

>    (connecting an MSRP over data channel endpoint with an
_______________________________________________
mmusic mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mmusic

---

From: Paul Kyzivat <[email-masked]>
Date: Sun, 02 Nov 2014 11:36:54 -0500

> I would like to ask if we can now moved forward to adoption of this draft as a working group item. While it is the responsibility of the chairs to make a formal call, I have asked for a small amoun…

I support adopting this draft.

	Thanks,
	Paul

---

From: "DOLLY, MARTIN C" <[email-masked]>
Date: Sun, 2 Nov 2014 16:50:23 +0000

I support this as a WG item.

From: mmusic [mailto:[email-masked]] On Behalf Of Christer Holmberg
Sent: Sunday, November 02, 2014 10:50 AM
To: DRAGE, Keith (Keith); [email-masked]
Subject: Re: [MMUSIC] draft-ejzak-mmusic-data-channel-sdpneg and draft-ejzak-mmusic-msrp-usage-data-channel

Hi,

Regards,

Christer

That has now occurred.

Regards

Keith

_______________________________________________
mmusic mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/mmusic

---

From: Christian Groves <[email-masked]>
Date: Mon, 03 Nov 2014 12:01:18 +1100

I also support this as a WG item.

Regards, Christian

On 3/11/2014 3:50 AM, DOLLY, MARTIN C wrote:
> *From:*mmusic [mailto:[email-masked]] *On Behalf Of *Christer 
> Holmberg
> *Sent:* Sunday, November 02, 2014 10:50 AM
> *To:* DRAGE, Keith (Keith); [email-masked]
> *Subject:* Re: [MMUSIC] draft-ejzak-mmusic-data-channel-sdpneg and 
> I think the draft is useful, and I support adopting it as a WG item. I 
> also intend to be active in the work, review and provide comments, etc.
>
> Regards,
>
> Christer
>
> ------------------------------------------------------------------------
>
> *From: *DRAGE, Keith (Keith) <mailto:[email-masked]>
> *Sent: *‎02/‎11/‎2014 17:07
> *To: [email-masked] <mailto:[email-masked]>
> *Subject: *Re: [MMUSIC] draft-ejzak-mmusic-data-channel-sdpneg and 
> At the London IETF meeting, we were not quite at the point of asking 
> for adoption of draft-ejzak-mmusic-data-channel-sdpneg. There was a 
> request that certain revisions should be made and a couple of issues 
> addressed.
>
> That has now occurred.
>
> I would like to ask if we can now moved forward to adoption of this 
> draft as a working group item. While it is the responsibility of the 
> chairs to make a formal call, I have asked for a small amount of time 
> in Honolulu with this intent, and it would be useful if people could 
> start to express their opinions one way or other on the list, i.e. 
> whether they think the draft is generally useful, or alternatively, 
> just a bad idea!
>
> Regards
>
> Keith
>
> > To: [email-masked] <mailto:[email-masked]>
> [email-masked] <mailto:[email-masked]>