Subject: Re: [MMUSIC] Dummy ports

From: Christer Holmberg <[email-masked]>
Date: Tue, 4 Nov 2014 18:53:31 +0000

Hi,

I went through this thread, to see whether it requires some text to BUNDLE.

Justin said earlier that this has nothing to do with BUNDLE, as one could also use port 9 in multiple non-bundled m- lines.

That is partly true, but keep in mind that with BUNDLE the answerer has to select the offerer BUNDLE address. It would have to choose port 9 - without knowing what port will eventually be used. 

Perhaps it doesn't care, but I think that would require some text in BUNDLE.

Regards,

Christer

-----Original Message-----
From: mmusic [mailto:[email-masked]] On Behalf Of Martin Thomson
Sent: 11 July 2014 21:34
To: Emil Ivov
Cc: [email-masked]; Paul Kyzivat
Subject: Re: [MMUSIC] Dummy ports

On 11 July 2014 11:17, Emil Ivov <[email-masked]> wrote:
>
>
> On 11.07.14, 19:51, Martin Thomson wrote:
>>
>> On 11 July 2014 09:33, Justin Uberti <[email-masked]> wrote:
>>>
>>> a) We require unique 'dummy' ports in the initial trickle offer.
>>> b) We allow use of the same dummy port (9) in the initial trickle offer.
>>> (This is what Chrome does, although it currently uses port 1).
>>>
>>> We had been leaning towards (a) based on the legacy equipment case 
>>> mentioned above. However, if nobody can provide details on this 
>>> case, I agree we should end up with (b).
>>
>>
>> As a general rule, if accommodating legacy equipment is particularly 
>> hard for us here, then we should leave the fixups needed for that 
>> legacy equipment to application code.  This seems like a good 
>> candidate for that.  It's not like non-9 ports will work with all 
>> legacy equipment anyway.
>
> Also note that, in the case of trickle, port 9s would only occur if 
> the offerer expects (knows) it would be supported. In other cases it 
> would just do half trickle and the problem wouldn't exist.

Yeah, that's even more reason to do the right thing (as opposed to the safe thing).

_______________________________________________
mmusic mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mmusic

---

From: Suhas Nandakumar <[email-masked]>
Date: Tue, 4 Nov 2014 13:52:19 -0800

+1 on keeping 9 in all the m= lines for full trickle and also BUNDLE must
say a note on this to clarify the usage.

Thanks
Suhas

On Tue, Nov 4, 2014 at 10:53 AM, Christer Holmberg <
[email-masked]> wrote:

> Justin said earlier that this has nothing to do with BUNDLE, as one could
> also use port 9 in multiple non-bundled m- lines.
>
> That is partly true, but keep in mind that with BUNDLE the answerer has to
> select the offerer BUNDLE address. It would have to choose port 9 - without
> knowing what port will eventually be used.
>