Subject: [MMUSIC] Continuous nomination and mapping to SIP

From: "Stach, Thomas" <[email-masked]>
Date: Wed, 12 Nov 2014 20:09:08 +0000

All,

maybe is too early  to get an answer, but how is the SIP INVITE transaction and SDP offer/answer affected by continuous nomination?

If I understand correctly, the nomination and trickling does not necessarily end when a 200OK is received for the INVITE.
In that case the SDP Answer in the 200OK would not include all candidates, but only those known at the time when the SIP 200 OK response is being sent.
Further candidates could still be trickled (and nominated) during the confirmed dialog.
Is that correct?

... and related to another discussion, wouldn't  that render the ICE updated offer procedures either useless, or alternatively, would require a new offer/answer cycle each time a new candidate is nominated?

Regards
Thomas

---

From: Justin Uberti <[email-masked]>
Date: Wed, 12 Nov 2014 12:33:39 -0800

On Wed, Nov 12, 2014 at 12:09 PM, Stach, Thomas <[email-masked]>
wrote:

>  All,
>
>
>
> maybe is too early  to get an answer, but how is the SIP INVITE
> transaction and SDP offer/answer affected by continuous nomination?
>
>
>
> If I understand correctly, the nomination and trickling does not
> necessarily end when a 200OK is received for the INVITE.
>
> In that case the SDP Answer in the 200OK would not include all candidates,
> but only those known at the time when the SIP 200 OK response is being sent.
>

Correct.

>  Further candidates could still be trickled (and nominated) during the

Correct. Since they are sent as SIP INFO (IIRC), I don't think this
presents a problem.

>
>
> … and related to another discussion, wouldn’t  that render the ICE updated
> offer procedures either useless, or alternatively, would require a new
> offer/answer cycle each time a new candidate is nominated?
>

If we were going to strictly follow the rules, then yes, one would need to
send an updated offer any time the selected pair changes. I defer any
comments on whether this is a good idea to the updated-offer discussion we
are going to have later this week.