Subject: [MMUSIC] draft-nandakumar-mmusic-proto-iana-registration-00

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Thu, 13 Nov 2014 19:36:53 +0000

So based on the discussion just taking place in MMUSIC I would make the following two comments:

1)	In section 3, every item should contain a normative reference to the RFC (or other document) that defines the framing structure that goes with that label.

2)	In section 4, I would prefer to see text that defines exactly the changes that need to be made and to exactly where.

So this is to the "proto" subregistry within "Session Description Protocol (SDP) Parameters" registry.

And essentially for every entry you need to state:
Type: protoc
SDP Name: ...
Reference: ...

Will the reference just be to this draft, or to this draft and the document that also defines the framing.

Regards

Keith

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 13 Nov 2014 14:08:26 -1000

> 1)	In section 3, every item should contain a normative reference to the RFC (or other document) that defines the framing structure that goes with that label.

We are talking about protos of the form A/B/C/D

For each boundary in there (A/B, B/C, C/D) there must exist, somewhere, 
a definition of how the upper layer is packaged within the lower layer. 
This is basic network stack stuff.

In many cases the lower layer has a well defined mechanism for this. In 
some cases (e.g. TCP) it does not. In some cases the upper layer spec 
has a specification for how it is framed over specific lower layers. In 
some cases it may need to be separate. We probably don't want to force 
people to declare the obvious. But may not be clear what is obvious and 
what is not.

	Thanks,
	Paul

> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic
>