Subject: Re: [MMUSIC] BUNDLE WGLC: Default candidate for bundle-only m- line with zero port value?

From: Justin Uberti <[email-masked]>
Date: Thu, 6 Nov 2014 11:49:20 -0800

I don't think you need an ICE candidate for a m= line with a zero port
value. We already covered something similar for trickle ICE (i.e. the dummy
ports).

On Mon, Oct 27, 2014 at 4:43 AM, Christer Holmberg <
[email-masked]> wrote:

>  Hi,
>
>
>
> One question that has been raised by Thomas Stach during the BUNDLE WGLC,
> is regarding ICE candidates and bundle-only m- lines with a zero port value.
>
>
>
> The current text says that identical ICE candidate values are assigned to
> bundle-only m- lines.
>
>
>
> Now, in the case where a zero port value is assigned to a bundle-only m-
> lines, it means that a candidate with a zero port value is also needed (in
> order to fulfil the ICE rules for default candidates).
>
>
>
> IF we want to avoid that, a couple of alternatives have been presented:
>
>
>
> 1)      Do not assign ICE candidates to bundle-only m- lines with port
> zero. The problem is that the answerer, even if it supports
> BUNDLE/bundle-only, doesn’t know whether the offerer wants to use ICE for
> those m- lines; or
>
> 2)      Relax the 5245 rules, so that there doesn’t need to be a
> candidate matching the m- line port value.
>
>
>
> Comments?
>
>
>
> Regards,
>
>
>
> Christer
>
>
>
>
>
>
>
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic
>
>

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 7 Nov 2014 02:46:46 +0000

Hi Justin,

No candidates is what I intend to suggest too.

Regards,

Christer

Sent from my Windows Phone
________________________________
From: Justin Uberti<mailto:[email-masked]>
Sent: ‎06/‎11/‎2014 21:49
To: Christer Holmberg<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [MMUSIC] BUNDLE WGLC: Default candidate for bundle-only m- line with zero port value?

I don't think you need an ICE candidate for a m= line with a zero port value. We already covered something similar for trickle ICE (i.e. the dummy ports).

On Mon, Oct 27, 2014 at 4:43 AM, Christer Holmberg <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

One question that has been raised by Thomas Stach during the BUNDLE WGLC, is regarding ICE candidates and bundle-only m- lines with a zero port value.

The current text says that identical ICE candidate values are assigned to bundle-only m- lines.

Now, in the case where a zero port value is assigned to a bundle-only m- lines, it means that a candidate with a zero port value is also needed (in order to fulfil the ICE rules for default candidates).

1)      Do not assign ICE candidates to bundle-only m- lines with port zero. The problem is that the answerer, even if it supports BUNDLE/bundle-only, doesn’t know whether the offerer wants to use ICE for those m- lines; or

2)      Relax the 5245 rules, so that there doesn’t need to be a candidate matching the m- line port value.

Comments?

Regards,

Christer

_______________________________________________
mmusic mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/mmusic

---

From: "Stach, Thomas" <[email-masked]>
Date: Fri, 7 Nov 2014 14:42:17 +0000

+1

From: mmusic [mailto:[email-masked]] On Behalf Of Christer Holmberg
Sent: Freitag, 7. November 2014 03:47
To: Justin Uberti
Cc: [email-masked]
Subject: Re: [MMUSIC] BUNDLE WGLC: Default candidate for bundle-only m- line with zero port value?

Hi Justin,

Regards,

Christer

Comments?

Regards,

Christer