Subject: [MMUSIC] draft-ejzak-mmusic-data-channel-sdpneg - "label" optional in a=dcmap?

From: Juergen Stoetzer-Bradler <[email-masked]>
Date: Tue, 25 Nov 2014 16:43:57 +0100

Hi,

The ABNF rules in draft-ejzak-mmusic-data-channel-sdpneg-02's section  5.1.1.1 allow the "label" 
parameter to _not_ being present in a=dcmap attribute lines.
However, the "label" related description in section 5.1.1.2 says: "...Label is a mandatory 
parameter. ...".

Recent CLUE related discussions indicate that there may be use cases, where applications may not 
need to convey data channel label values in draft-ejzak-mmusic-data-channel-sdpneg based SDP offers 
or answers.

Therefore we would propose to actually make the "label" parameter optional in a=dcmap attribute 
lines and to replace section 5.1.1.2's sentence "Label is a mandatory parameter" with

     "Label is an optional parameter. If the label parameter is not present, then its value defaults 
to the empty string.

Note: The empty string may also be explicitly used as "label" value, such that label="" is 
equivalent to the "label" parameter not being present at all.
[I-D.ietf-rtcweb-data-protocol] allows the DATA_CHANNEL_OPEN message's "Label" value to be an empty 
string."

Would this be agreeable?

Thanks,
Juergen
JSB_email_signature

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 25 Nov 2014 17:03:49 -0500

Sounds reasonable to me.

On 11/25/14 10:43 AM, Juergen Stoetzer-Bradler wrote:
> Hi,
>
> The ABNF rules in draft-ejzak-mmusic-data-channel-sdpneg-02's section
> 5.1.1.1 allow the "label" parameter to _not_ being present in a=dcmap
> attribute lines.
> However, the "label" related description in section 5.1.1.2 says:
> "...Label is a mandatory parameter. ...".
>
> Recent CLUE related discussions indicate that there may be use cases,
> where applications may not need to convey data channel label values in
> draft-ejzak-mmusic-data-channel-sdpneg based SDP offers or answers.
>
> Therefore we would propose to actually make the "label" parameter
> optional in a=dcmap attribute lines and to replace section 5.1.1.2's
> sentence "Label is a mandatory parameter" with
>
>      "Label is an optional parameter. If the label parameter is not
> present, then its value defaults to the empty string.
>
> Note: The empty string may also be explicitly used as "label" value,
> such that label="" is equivalent to the "label" parameter not being
> present at all.
> [I-D.ietf-rtcweb-data-protocol] allows the DATA_CHANNEL_OPEN message's
> "Label" value to be an empty string."
>
> Would this be agreeable?
>
> Thanks,
> Juergen
> JSB_email_signature
>
>
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic
>