Subject: Re: [MMUSIC] SDP work in ICE WG [was Re: Draft MMUSIC Meeting Minutes from IETF 93]

From: Flemming Andreasen <[email-masked]>
Date: Fri, 4 Sep 2015 06:59:55 -0400

Can we get some more comments from folks on this.

We are in the process of writing up proposed charter and re-charter text 
for the ICE and MMUSIC WGs and we need to agree on what work should 
reside where. Based on the discussion in Prague, most people seemed to 
favor having ICE related SDP work done in the new WG, but per the below, 
not everybody agrees with that.

Thanks

     Flemming (MMUSIC co-chair)

On 8/25/15 7:05 AM, Marc Petit-Huguenin wrote:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA256
>
> (back from extended vacations)
>
> "Marc Petit-Huguenin: Prefer to keep SDP related ICE work to MMUSIC and move ICE core work to new WG."
>
> Most people in the session did not agree with this, but as I had subsequent discussions with people that were not attending the session but agreed with me, let me try another time.
>
> My opinion is that separating SDP/SIP for ICE and the ICE mechanism itself by keeping the former in MMUSIC and moving the latter in the WG-to-be is important "to make the Internet work better".  The new WG should be focused in making ICE better for *all* the protocols that are using ICE, not just for RTCWeb.  That includes HIP and RELOAD, and as nobody has proposed to update RFC6940's AppAttachReq/AppAttachAns in the new WG, then the new WG should not work on SDP either.  Obviously RTCWeb and MMUSIC (for ICE in RSTP) should coordinate with the new WG, but on an equal manner than with the representatives from HIP and RELOAD.
>
> As an example, I would very much like to see an encoding-agnostic version of ICE-trickle developed in the new WG, so RELOAD and HIP can reuse it.
>
> Thanks.
>
>
> On 08/14/2015 08:28 AM, Ari Keränen wrote:
>> Hi all,
>>
>> The draft meeting minutes for the two MMUSIC sessions at IETF 93 are available here:
>>
>>    https://www.ietf.org/proceedings/93/minutes/minutes-93-mmusic
>>
>> Please take a look and let us know if you have any questions or comments.
>>
>>
> - -- 
> Marc Petit-Huguenin
> Email: [email-masked]
> Blog: http://blog.marc.petit-huguenin.org
> Profile: http://www.linkedin.com/in/petithug
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v2
>
> iQIcBAEBCAAGBQJV3Ev4AAoJECnERZXWan7EWVwP/1oSM3em8sFRKbhn7VFjo2Cp
> 7r7FQkceqZo/rNYK85TG8x9MyiAM3/Q9UhzT+lrnQq16sigCXHArez7kyyI4MGF8
> lOnoxprudvC1zv2lt+Mb3pr91wQQ37kHGKvBpMFG0ZsQaVhB5FCGB97VBIAh52gh
> 5GntSjsPirnZTeZU83WQTaH3CyZHsdV/4DLmonkzPrJkgUZ6y5RGnzAnovYPPBER
> jy5i4R9yUUGUxLojT3W2Qj4kw23xH/eu6sLj0kkGBan5S6Yy7jiDrCckaPg0wonI
> ReMEpoVzuQPsZQDVFjdVrvk+9eeDpcn8j28Fcz3Ix5W0SSW8Jk0c8KN2EU3H3suh
> DubSGvkKjNUCD681ReH0oU/U054V/m3YJ+O+ToZMRrUkBmpE86oT+7x28xEAcamS
> ol6lC/JSzeqPsKLP06lgItSZzy32F1Lg6cV2RN5y4SfU8Z6yiaOuQie7/fgcgDeR
> b+LaPo/milZq0DjLAwBw3jpvi5Wf7fFRPOvSAbY3sl32JQz9irj28FmCqcTYD0pu
> XD2fhQwoEcQsW8/OtZXa/6wG0WuUr0nshtlqBQ+UIS3CDSnihFv4vyRFYlE0CLoi
> KrkuCviiDXcczczyZlqWlEBZ+xuyEgthiyz4Apkod3z+N93ua/QUAgfSmP9hO4y2
> MMY52sO58eBs3rlFWoJS
> =Ta0W
> -----END PGP SIGNATURE-----
>
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic

---

From: "Pal Martinsen (palmarti)" <[email-masked]>
Date: Mon, 7 Sep 2015 07:01:24 +0000

Hi

I agree with Marc. ICE SDP related things should stay with MMUSIC. 

Since all the ICE candidates belongs to a medialine there are all kinds of “magic” happening regarding muxing, bundling and other offer/answer weirdness like hold resume and early offers. To make sure all that still works I think it is best to keep the ICE SDP discussion in MMUSIC where all the SDP knowledge is. 

.-.
Pål-Erik

> On 04 Sep 2015, at 12:59, Flemming Andreasen (fandreas) <[email-masked]> wrote:
>