Subject: Re: [MMUSIC] [Ice] SDP rtcp attribute with trickle ICE

From: Peter Saint-Andre <[email-masked]>
Date: Mon, 22 Feb 2016 21:13:06 -0700

On 1/20/16 1:12 PM, Christer Holmberg wrote:
> Another, more administrative issue, is that we also would need to get this change into JSEP and trickle ICE. Unless I remember wrong, both of those specs currently references RFC 5245.

draft-ietf-ice-trickle references icebis.

> -----Original Message-----
> From: Ice [mailto:[email-masked]] On Behalf Of Christer Holmberg
> Sent: 20 January 2016 22:10
> To: Roman Shpount <[email-masked]>
> Cc: Ari Keränen <[email-masked]>; [email-masked]; Marc Petit-Huguenin <[email-masked]>; [email-masked]; 🔓Dan Wing <[email-masked]>; [email-masked]
> Subject: Re: [Ice] [MMUSIC] SDP rtcp attribute with trickle ICE
>
> Hi Roman,
>
>>> Your suggested text looks ok, but it does not solve my issue :) I
>>> think it should be clear that, if there is no RTCP candidate, the spec does not define usage of the SDP rtcp attribute.
>>
>> Well, in my proposed text "if RTCP candidate is present and not equal
>> to the same address and the next higher port number of the RTP candidate, the agent MUST encode the RTCP candidate using the a=rtcp attribute".
>> Do you also want text saying that a=rtcp attribute MUST not be present of no RTCP candidates are present and rtcp-mux is not used?
>
> I am not sure we need to say anything about mux.
>
> When reading your text again, I now agree that it covers my case. I just hope it is clear enough :)
>
> Perhaps, in the trickle ICE document, we could have a note somewhere clarifying that the RTCP candidate is not used when the RTP port is 9.

We removed all of the SDP-related text from draft-ietf-ice-trickle 
because we were supposed to write a trickle-sdp or trickle-sip 
specification. Right now we don't have that text about the RTP port in 
draft-ietf-ice-trickle...

Peter

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 23 Feb 2016 08:21:30 +0000

Hi,

> draft-ietf-ice-trickle references icebis.

Sorry, I mean draft-ietf-mmusic-trickle-ice-sip.

....which of course references draft-ietf-ice-trickle, and therefor implicitly 5245bis :)

So, unless someone has a technical reason why JSEP, trickle-ice-sip etc should reference RFC 5245, I really think we should change and reference 5245bis.

Regards,

Christer

> Cc: Ari Keränen <[email-masked]>; [email-masked]; Marc 
> Petit-Huguenin <[email-masked]>; [email-masked]; 🔓Dan Wing 
> <[email-masked]>; [email-masked]

We removed all of the SDP-related text from draft-ietf-ice-trickle because we were supposed to write a trickle-sdp or trickle-sip specification. Right now we don't have that text about the RTP port in draft-ietf-ice-trickle...

Peter