Subject: Re: [MMUSIC] Fwd: I-D Action: draft-ietf-mmusic-dtls-sdp-05.txt

From: Roman Shpount <[email-masked]>
Date: Mon, 1 Feb 2016 16:31:10 -0500

Flemming,

We should be ready for WGLC.

Regards,

_____________
Roman Shpount

On Thu, Jan 28, 2016 at 9:29 PM, Flemming Andreasen <[email-masked]>
wrote:

> Greetings MMUSIC
>
> We would like to start moving towards WGLC on this draft - do people
> believe the draft is ready for that at this point ? If not, please let us
> know which issues you see.
>
> Thanks
>
> -- Flemming (as MMUSIC chair)
>
>
>
>
> -------- Forwarded Message --------
> Subject: [MMUSIC] I-D Action: draft-ietf-mmusic-dtls-sdp-05.txt
> Date: Mon, 18 Jan 2016 09:30:11 -0800
> From: [email-masked]
> To: [email-masked]
> CC: [email-masked]
>
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
>  This draft is a work item of the Multiparty Multimedia Session Control Working Group of the IETF.
>
>         Title           : Using the SDP Offer/Answer Mechanism for DTLS
>         Authors         : Christer Holmberg
>                           Roman Shpount
> 	Filename        : draft-ietf-mmusic-dtls-sdp-05.txt
> 	Pages           : 21
> 	Date            : 2016-01-18
>
> Abstract:
>    This draft defines the SDP offer/answer procedures for negotiating
>    and establishing a DTLS association.  The draft also defines the
>    criteria for when a new DTLS association must be established.
>
>    This draft defines a new SDP media-level attribute, 'dtls-
>    connection'.
>
>
> The IETF datatracker status page for this draft is:https://datatracker.ietf.org/doc/draft-ietf-mmusic-dtls-sdp/
>
> There's also a htmlized version available at:https://tools.ietf.org/html/draft-ietf-mmusic-dtls-sdp-05
>
> A diff from the previous version is available at:https://www.ietf.org/rfcdiff?url2=draft-ietf-mmusic-dtls-sdp-05
>
>
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
>
> Internet-Drafts are also available by anonymous FTP at:ftp://ftp.ietf.org/internet-drafts/
>
> _______________________________________________
> mmusic mailing [email-masked]://www.ietf.org/mailman/listinfo/mmusic
>
> .
>
>
>
>
>
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic
>
>

---

From: "Gonzalo Salgueiro (gsalguei)" <[email-masked]>
Date: Tue, 2 Feb 2016 07:15:43 +0000

Hi Flemming - 

I have read this draft and think it is in good shape and ready for WGLC.

-G

> On Thu, Jan 28, 2016 at 9:29 PM, Flemming Andreasen <[email-masked]> wrote:
> Greetings MMUSIC
> 
> We would like to start moving towards WGLC on this draft - do people believe the draft is ready for that at this point ? If not, please let us know which issues you see. 
> 
> Thanks 
> 
> The IETF datatracker status page for this draft is:
> 
> https://datatracker.ietf.org/doc/draft-ietf-mmusic-dtls-sdp/
> 
> 
> There's also a htmlized version available at:
> 
> https://tools.ietf.org/html/draft-ietf-mmusic-dtls-sdp-05
> 
> 
> A diff from the previous version is available at:
> 
> https://www.ietf.org/rfcdiff?url2=draft-ietf-mmusic-dtls-sdp-05
> 
> 
> 
> until the htmlized version and diff are available at 
> tools.ietf.org
> .
> 
> Internet-Drafts are also available by anonymous FTP at:
> 
> ftp://ftp.ietf.org/internet-drafts/
> 
>

---

From: Colin Perkins <[email-masked]>
Date: Thu, 4 Feb 2016 15:53:48 +0000

Hi Christer,

I’ve read the draft, and have no objection to it going to working group last call. 

The only real technical comment I had is that the draft doesn’t really describe how errors are to be handled in all cases, so there’s perhaps scope for different interpretations (e.g., what does the answering party do if the offer includes “a=dtls-connection:existing” but there is no DTLS connection?  Or what happens if an existing connection is used, but the answer contains a modified fingerprint? etc.) Much of this is likely obvious to someone more familiar with all the referenced specs, but it might not hurt to add extra references, or spell out the details.

Cheers,
Colin

> On 3 Feb 2016, at 07:50, Christer Holmberg <[email-masked]> wrote:
> 
> Hi Colin,
>  
> Could you take a look at the draft, and indicate on the list if you think that we are ready to start WGLC (or, if you don’t think we’re ready, indicate why).
>  
> Note that comments etc can still be given during WGLC, but personally I don’t see any major issues that would have to be dealt with before we begin WGLC.
>  
> Thanks!
>  
> Regards,
>  
> Christer
>  
>  
> From: mmusic [mailto:[email-masked]] On Behalf Of Flemming Andreasen
> Sent: 29. tammikuuta 2016 4:30
> To: mmusic
> Subject: [MMUSIC] Fwd: I-D Action: draft-ietf-mmusic-dtls-sdp-05.txt
>  
> Greetings MMUSIC
> 
> Subject: 
> [MMUSIC] I-D Action: draft-ietf-mmusic-dtls-sdp-05.txt
> Date: 
> From: 
> [email-masked] <mailto:[email-masked]>
> To: 
> [email-masked] <mailto:[email-masked]>
> CC: 
> [email-masked] <mailto:[email-masked]>
>  
> 
> https://datatracker.ietf.org/doc/draft-ietf-mmusic-dtls-sdp/ <https://datatracker.ietf.org/doc/draft-ietf-mmusic-dtls-sdp/>
>  
> https://tools.ietf.org/html/draft-ietf-mmusic-dtls-sdp-05 <https://tools.ietf.org/html/draft-ietf-mmusic-dtls-sdp-05>
>  
> https://www.ietf.org/rfcdiff?url2=draft-ietf-mmusic-dtls-sdp-05 <https://www.ietf.org/rfcdiff?url2=draft-ietf-mmusic-dtls-sdp-05>
>  
>  
> ftp://ftp.ietf.org/internet-drafts/ <ftp://ftp.ietf.org/internet-drafts/>
>  
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/mmusic <https://www.ietf.org/mailman/listinfo/mmusic>
> .
>  
>  
>  

-- 
Colin Perkins
https://csperkins.org/

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 4 Feb 2016 18:00:14 +0000

Hi,

Thanks!

>The only real technical comment I had is that the draft doesn’t really describe how errors are to be handled in all cases, so there’s perhaps scope for different interpretations (e.g., what does >the answering party do if the offer includes “a=dtls-connection:existing” but there is no DTLS connection?  Or what happens if an existing connection is used, but the answer contains a >modified fingerprint? etc.) Much of this is likely obvious to someone more familiar with all the referenced specs, but it might not hurt to add extra references, or spell out the details.

We normally don’t say too much about these kind of error cases. But, if there are procedures we can refer to we can for sure add references. We can also say that, if such offer/answer error occurs, the offerer must terminate the stream (including any possible DTLS connection associated with it).

Regards,

Christer

On 3 Feb 2016, at 07:50, Christer Holmberg <[email-masked]<mailto:[email-masked]>> wrote:

Hi Colin,

Thanks!

Regards,

Christer

Greetings MMUSIC

Thanks

-------- Forwarded Message --------
Subject:

Date:

Mon, 18 Jan 2016 09:30:11 -0800

From:

[email-masked]<mailto:[email-masked]>

To:

[email-masked]<mailto:[email-masked]>

CC:

[email-masked]<mailto:[email-masked]>

                          Roman Shpount

        Pages           : 21

        Date            : 2016-01-18

Abstract:

   connection'.

until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.

mmusic mailing list

[email-masked]<mailto:[email-masked]>

.

_______________________________________________
mmusic mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/mmusic

--
Colin Perkins
https://csperkins.org/

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Thu, 4 Feb 2016 22:12:59 +0000

I think its ready for WG last call well.

Cheers,
Charles

On 2/1/16, 11:15 PM, "mmusic on behalf of Gonzalo Salgueiro (gsalguei)"
<[email-masked] on behalf of [email-masked]> wrote:

>>believe the draft is ready for that at this point ? If not, please let
>>us know which issues you see.
>> 
>> Thanks 
>>