Subject: [MMUSIC] Draft new: draft-holmberg-mmusic-4572-update

From: Christer Holmberg <[email-masked]>
Date: Mon, 29 Feb 2016 09:36:54 +0000

Hi,

I submitted a new draft, draft-holmberg-mmusic-4572-update. The purpose is for making the 4572 updates we have been discussing: usage of multiple 'fingerprint' attributes, and updating the preferred cipher suite.

The cipher suite update should not be a big issue, but feel free to suggest text regarding the 'fingerprint' attribute.

Also on github: https://github.com/cdh4u/draft-4572-update

Regards,

Christer

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 29 Feb 2016 11:37:12 -0500

Christer,

On 2/29/16 4:36 AM, Christer Holmberg wrote:
> Hi,
>
> I submitted a new draft, draft-holmberg-mmusic-4572-update. The purpose
> is for making the 4572 updates we have been discussing: usage of
> multiple ‘fingerprint’ attributes, and updating the preferred cipher suite.
>
> The cipher suite update should not be a big issue, but feel free to
> suggest text regarding the ‘fingerprint’ attribute.

Section 3 starts with "This section updates section 5 of RF 4572". But 
then just before the old text is: "Update to section 8.3.2"! What is 
that about? (In the html it is linked to a non-existent section in 
*this* draft. And there is also no section 8.3.2 in 4572.)

Clearly is is really section 5 that is being changed. But showing the 
change this way with old/new versions of the entire section makes it 
very difficult to see what the actual change is. I had to use it to 
create a temporary update to 4572 text and run diff on it to find that 
the actual change was simply:

s/'SHA-1' preferred/'SHA-256' preferred/

Can you do something to make that clearer? (E.g., reduce the old and new 
parts to just the affected paragraph, and also verbally describe what 
has been changed.)

After doing the diff, I find no text discussing the semantics of 
multiple fingerprint attributes. What am I missing? Are you waiting for 
somebody else to propose the semantics? (I want to hear from somebody 
that has asked for this feature.)

     Thanks,
     Paul

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 29 Feb 2016 18:40:44 +0000

Hi Paul,

The reference to section 8.3.2 doesn't belong there. I used another XML file as template, and forgot to change it.

Regarding the fingerprint attribute - there is no new text yet. I am asking people to suggest text :)

Regards,

Christer

Sent from my Windows Phone
________________________________
From: Paul Kyzivat<mailto:[email-masked]>
Sent: ‎29/‎02/‎2016 18:37
To: [email-masked]<mailto:[email-masked]>
Subject: Re: [MMUSIC] Draft new: draft-holmberg-mmusic-4572-update

Christer,

     Thanks,
     Paul

_______________________________________________
mmusic mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mmusic

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 29 Feb 2016 19:07:36 +0000

Hi,

...

> Can you do something to make that clearer? (E.g., reduce the old and new parts to just the affected paragraph, and also verbally describe what has been changed.)

If that's the ONLY change, I agree it should be done that way.

But, I assume the fingerprint changes will be done in the same section, so let's first work on the changes and then we see how we document them.

> After doing the diff, I find no text discussing the semantics of multiple fingerprint attributes. What am I missing? Are you waiting for somebody else to propose the semantics? 

Yes.

> (I want to hear from somebody that has asked for this feature.)

Martin mentioned the draft he had been working with. I understood you had looked at it, but did not find the semantics?

Regards,

Christer