Subject: Re: [MMUSIC] Offer/Answer PT Questions - 3pcc

From: Christer Holmberg <[email-masked]>
Date: Tue, 23 Feb 2016 18:26:45 +0000

Hi,

….

> 3. PT reuse in sessions such as one triggered by 3pcc where it would be impossible to enforce PT from ever being reused.

Assuming you are talking about the 3pcc case where an empty SIP (re-)INVITE request triggers an offer in the SIP response, the (re-)INVITE could always contain information (“declarative SDP”, if you like) about what PT/codec mappings are currently available in the session.

Regards,

Christer

---

From: Roman Shpount <[email-masked]>
Date: Tue, 23 Feb 2016 13:29:45 -0500

On Tue, Feb 23, 2016 at 1:26 PM, Christer Holmberg <
[email-masked]> wrote:

> > 3. PT reuse in sessions such as one triggered by 3pcc where it would be
> impossible to enforce PT from ever being reused.
>
>
>
> Assuming you are talking about the 3pcc case where an empty SIP
> (re-)INVITE request triggers an offer in the SIP response, the (re-)INVITE
> could always contain information (“declarative SDP”, if you like) about
> what PT/codec mappings are currently available in the session.
>
>
>
3pcc can be used to connect two existing sessions. This means empty SIP
re-INVITE should carry the information about the existing PT in the
session. I am not aware of any specification that proposes a mechanism to
do this.
_____________
Roman Shpount

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 23 Feb 2016 14:02:27 -0500

On 2/23/16 1:29 PM, Roman Shpount wrote:
> On Tue, Feb 23, 2016 at 1:26 PM, Christer Holmberg
> <[email-masked] <mailto:[email-masked]>>
> wrote:
>
>      > 3. PT reuse in sessions such as one triggered by 3pcc where it
>     would be impossible to enforce PT from ever being reused.
>
>     __
>
>     __ __
>
>     (re-)INVITE request triggers an offer in the SIP response, the
>     (re-)INVITE could always contain information (“declarative SDP”, if
>     you like) about what PT/codec mappings are currently available in
>     the session. ____
>
>
>
> session. I am not aware of any specification that proposes a mechanism
> to do this.

Yes - there is no existing mechanism to deliver this "declarative SDP" 
so that it is understood to not be an offer.

	Thanks,
	Paul

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 23 Feb 2016 19:19:29 +0000

Hi,

>> 3pcc can be used to connect two existing sessions. This means empty 
>> SIP re-INVITE should carry the information about the existing PT in 
>> the session. I am not aware of any specification that proposes a 
>> mechanism to do this.
>

That is one reason we attend IETF - to define mechanisms when none exists :)

I guess it wouldn't even have to be SDP. It could e.g. be JSON, that we all love. 

Regards,

Christer