Subject: Re: [MMUSIC] Not fixing a=rtcp and rtcp-mux exclusive

From: Christer Holmberg <[email-masked]>
Date: Tue, 2 Feb 2016 09:32:15 +0000

Hi,

So, assuming we would define a new attribute to indicate/negotiate mux-exclusive, I still think we need to say something about a=rtcp, don’t we?

We could simply say that the a=rtcp attribute value must be identical to the port and address for RTP. That would work also for trickle ICE.

Regards,

Christer

From: Roman Shpount [mailto:[email-masked]]
Sent: 25. tammikuuta 2016 23:11
To: Paul Kyzivat
Cc: Christer Holmberg; Suhas Nandakumar; [email-masked]
Subject: Re: [MMUSIC] Not fixing a=rtcp and rtcp-mux exclusive

On Mon, Jan 25, 2016 at 2:55 PM, Paul Kyzivat <[email-masked]<mailto:[email-masked]>> wrote:
Do you have data supporting this assertion?

I believe a=rtcp was developed to work in conjunction with RFC 3489. In practice such deployment scenarios are recipes for disaster since end points will end up not getting connected often enough for large groups of your customers to complain. Such architecture also has serious security problems. This entire architecture was later completely redesigned (see https://tools.ietf.org/html/rfc5389#section-2 for more details).

Anything commercially viable is using either something like ICE or host based NAT traversal. I think we should strongly steer service implementers towards ICE when NAT support is required and do not extend or promote a=rtcp based solutions. ICE does mention a=rtcp but it is only used there for legacy interop with exiting end points which were designed to work with RFC 3489 derived addresses. I do not think a=rtcp has any use cases beyond such legacy interop.
_____________
Roman Shpount

---

From: Roman Shpount <[email-masked]>
Date: Tue, 2 Feb 2016 09:54:04 -0500

On Tue, Feb 2, 2016 at 4:32 AM, Christer Holmberg <
[email-masked]> wrote:

> So, assuming we would define a new attribute to indicate/negotiate
> mux-exclusive, I still think we need to say something about a=rtcp, don’t
> we?
>
>
>
> We could simply say that the a=rtcp attribute value must be identical to
> the port and address for RTP. That would work also for trickle ICE.
>
>
>
There is no harm in specifying a=rtcp but, in most practical scenarios, it
will serve no purpose. If legacy end point does not support mux-exclusive,
then media connection will be torn down even if the legacy end point does
support a=rtcp. The a=rtcp attribute should still be added for compliance
with ICE specification and for support of any forwarding or monitoring
agents.
_____________
Roman Shpount