Subject: [MMUSIC] DTLS-SDP: TLS support added

From: Christer Holmberg <[email-masked]>
Date: Sun, 9 Apr 2017 07:14:30 +0000

Hi,

Based on the decision in Chicago to allow usage of the SDP 'dtls-id' attribute also for TLS connections, I have created a pull request:

https://github.com/cdh4u/draft-dtls-sdp/pull/26

Note that the name of the attribute has now been changed to 'tls-id'.

The approach I've taken is: rather than talking about both DTLS and TLS throughout the document, I've basically added a section describing the TLS-specific considerations - mainly regarding the interaction with the SDP 'connection' attribute.

Now, I think we do need some text on WHY we also cover TLS connections since, as far as creating new connections is concerned, the 'connection' attribute can be used. We know that it would be needed for draft-thomson-avtcore-sdp-uks (https://datatracker.ietf.org/doc/draft-thomson-avtcore-sdp-uks/). But, AFAIK that work has not been adopted yet, so I don't think we can use it as justification at this point?

Note that this pull request does NOT include any of the changes to be done based on the gen-art/sec-dir reviews. I have updated the 4572-update reference, though.

Regards,

Christer

---

From: Roman Shpount <[email-masked]>
Date: Mon, 10 Apr 2017 16:01:13 -0400

On Sun, Apr 9, 2017 at 3:14 AM, Christer Holmberg <
[email-masked]> wrote:

> Now, I think we do need some text on WHY we also cover TLS connections
> since, as far as creating new connections is concerned, the ‘connection’
> attribute can be used. We know that it would be needed for
> draft-thomson-avtcore-sdp-uks (https://datatracker.ietf.org/
> doc/draft-thomson-avtcore-sdp-uks/). But, AFAIK that work has not been
> adopted yet, so I don’t think we can use it as justification at this point?
>
>
>
I was thinking that we should include something like:

The pair of newly defined SDP 'tls-id' attribute values from the offer and
the corresponding answer can be used to uniquely identify TLS or DTLS
association. This unique identifier can be used by TLS protocol extensions
to differentiate between multiple TLS and DTLS association and correlate
these associations with specific offer/answer exchanges.
_____________
Roman Shpount

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 11 Apr 2017 07:11:04 +0000

Hi,

Based on the input from Roman, I’ve updated the pull request.

I used separate commits for the ‘connection attribute clarification’ and the ‘TLS justification’.

Regards,

Christer

From: Roman Shpount [mailto:[email-masked]]
Sent: 10 April 2017 23:01
To: Christer Holmberg <[email-masked]>
Cc: mmusic (E-mail) <[email-masked]>; [email-masked]; Ben Campbell <[email-masked]>
Subject: Re: [MMUSIC] DTLS-SDP: TLS support added

On Sun, Apr 9, 2017 at 3:14 AM, Christer Holmberg <[email-masked]<mailto:[email-masked]>> wrote:
Now, I think we do need some text on WHY we also cover TLS connections since, as far as creating new connections is concerned, the ‘connection’ attribute can be used. We know that it would be needed for draft-thomson-avtcore-sdp-uks (https://datatracker.ietf.org/doc/draft-thomson-avtcore-sdp-uks/). But, AFAIK that work has not been adopted yet, so I don’t think we can use it as justification at this point?

The pair of newly defined SDP 'tls-id' attribute values from the offer and the corresponding answer can be used to uniquely identify TLS or DTLS association. This unique identifier can be used by TLS protocol extensions to differentiate between multiple TLS and DTLS association and correlate these associations with specific offer/answer exchanges.
_____________
Roman Shpount