Subject: [MMUSIC] New version of SDP UKS draft

From: Martin Thomson <[email-masked]>
Date: Thu, 20 Apr 2017 20:52:06 +1000

https://datatracker.ietf.org/doc/html/draft-thomson-mmusic-sdp-uks

Inspired by Christer updating the dtls-sdp draft, I have updated the
SDP UKS draft to match the recent changes (thanks Christer!).

I found a few minor errors while editing this.  I'd appreciate it if
people can take a look and see if it is ready.  I'm biased, but I
think that it's in reasonable shape.

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 20 Apr 2017 12:59:35 +0000

Hi,

Should the draft reference RFC 8122 instead of 4572?

Regards,

Christer

On 20/04/17 13:52, "mmusic on behalf of Martin Thomson"
<[email-masked] on behalf of [email-masked]> wrote:

>_______________________________________________
>mmusic mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/mmusic

---

From: Martin Thomson <[email-masked]>
Date: Fri, 21 Apr 2017 09:22:41 +1000

You sir, caught me out.  Yes.

---

From: Martin Thomson <[email-masked]>
Date: Fri, 21 Apr 2017 09:24:05 +1000

> Should the draft reference RFC 8122 instead of 4572?

I've updated the editor's copy.  No sense publishing an update for that though.

---

From: Iñaki Baz Castillo <[email-masked]>
Date: Fri, 21 Apr 2017 19:31:03 +0200

> think that it's in reasonable shape.

In section 2:

      By substituting the the fingerprint

(double "the").

Also in section 2:

   In usages of TLS and DTLS that use SDP for negotiation, an endpoint
   is able to acquire the certificate fingerprint another entity.

(*of* another entity).

-- 
Iñaki Baz Castillo
<[email-masked]>

---

From: Roman Shpount <[email-masked]>
Date: Fri, 21 Apr 2017 13:44:48 -0400

I have already mentioned that I prefer not to call this extension
sdp_tls_id. Since this extension applies to Jingle and ORTC, this extension
is not SDP specific. It should be called simply tls_id or tls_helo_id.

Regards,

_____________
Roman Shpount

---

From: Iñaki Baz Castillo <[email-masked]>
Date: Fri, 21 Apr 2017 19:46:07 +0200

> is not SDP specific. It should be called simply tls_id or tls_helo_id.

Agreed.

-- 
Iñaki Baz Castillo
<[email-masked]>

---

From: Martin Thomson <[email-masked]>
Date: Mon, 24 Apr 2017 09:08:58 +1000

> is not SDP specific. It should be called simply tls_id or tls_helo_id.

I apologize for missing this.  I've updated my copy of the draft.
I've named it external_session_id/ExternalSessionId so that it can be
used in some other context without issues.

Making this generic means that this document needs to either define
how the attribute is used generically, or it needs to state that
things other than SDP aren't in scope.

I've chosen to limit this to SDP.  If another protocol wants to fix
this problem, then they need to define the a=tls-id equivalent anyway;
they can define the hook into using this extension at the same time.

---

From: Roman Shpount <[email-masked]>
Date: Mon, 24 Apr 2017 18:04:10 -0400

> they can define the hook into using this extension at the same time.

I think we can say that this document is limited to SDP with other
protocols out of scope. ORT and Jingle can define how to signal tls-id in
separate documents.

Regards,
_____________
Roman Shpount

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 25 Apr 2017 06:15:40 +0000

Hi,

I agree with Roman.

I suggest splitting the draft into two main parts: one parts which describes the concept in general, and another “Usage with SDP Offer/Answer” part which describes the SDP specific parts.

It then makes it easier for others to reference the generic part, and then add their “Usage with ORTC/Jingle/H.323/whatever” part.

Regards,

Christer

From: mmusic <[email-masked]<mailto:[email-masked]>> on behalf of Roman Shpount <[email-masked]<mailto:[email-masked]>>
Date: Tuesday 25 April 2017 at 01:04
To: Martin Thomson <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [MMUSIC] New version of SDP UKS draft

On Sun, Apr 23, 2017 at 7:08 PM, Martin Thomson <[email-masked]<mailto:[email-masked]>> wrote:

I think we can say that this document is limited to SDP with other protocols out of scope. ORT and Jingle can define how to signal tls-id in separate documents.

Regards,
_____________
Roman Shpount

---

From: Martin Thomson <[email-masked]>
Date: Wed, 26 Apr 2017 16:13:08 +1000

On 25 April 2017 at 16:15, Christer Holmberg
<[email-masked]> wrote:
> I suggest splitting the draft into two main parts: one parts which describes
> the concept in general, and another “Usage with SDP Offer/Answer” part which
> describes the SDP specific parts.

I'll look at doing that in the next version.