Subject: [MMUSIC] ICE check list state

From: Christer Holmberg <[email-masked]>
Date: Fri, 3 Nov 2017 09:00:22 +0000

Hi,

Section 8.1 of draft-mmusic-trickle-ice talks about “active” and “frozen” check lists.

Note that the concept of “active" and “frozen" check lists has been removed from ICEbis. Only the check list states (Running, Completed and Failed) remain.

So, IF the concept is needed for trickle, it has to be defined in the ICE trickle spec, and then reflected in the MMUSIC trickle spec.

Commenting on the actual text in section 8.1., which says:

   "Given that with trickle ICE, other check lists may still be empty at that point, a trickle ICE
   agent SHOULD also maintain an explicit Active/Frozen state for every check list,…"

In my opinion you should not call it an Active/Frozen state. Rather call it flag, or something.

Regards,

Christer

---

From: Thomas Stach <[email-masked]>
Date: Mon, 6 Nov 2017 11:23:17 +0100

Christer,

> Section 8.1 of draft-mmusic-trickle-ice talks about “active” and 
What document are you talking about?
I'm only aware of draft-ietf-mmusic-trickle-ice-sip and this doesn't 
lose a single word about the ICE states.

>
> Note that the concept of “active" and “frozen" check lists has been 
> removed from ICEbis. Only the check list states (Running, Completed 
> and Failed) remain.
>
> So, IF the concept is needed for trickle, it has to be defined in the 
> ICE trickle spec, and then reflected in the MMUSIC trickle spec.
You may be right for draft-ietf-ice-trickle, but 
draft-ietf-mmusic-trickle-ice-sip never signalled any states of any 
check lists at the - what we call it - ICE agents.
I also can't imagine such a need now, since 
draft-ietf-mmusic-trickle-ice-sip only defines how the candidates are 
trickled,
but it is deliberately silent about ICE's connectivity checking algorithm.
  Maybe you can advise in case I'm missing something, but currently I 
don't see that changes necessary for draft-ietf-mmusic-trickle-ice-sip.

> call it flag, or something.
After quite some searching I only found this text in in section 8.1 of 
https://tools.ietf.org/html/draft-ietf-mmusic-trickle-ice-01 (!)
If this is the document you are talking about at the top, it seems to 
be  slightly out of date :)

Regards
Thomas
>
>
> Regards,
>
> Christer
>
>
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 6 Nov 2017 10:38:09 +0000

Hi Thomas,

You are right – I was looking at an old version of the document.

I double checked the latest version of draft-ietf-mmusic-trickle-ice-sip, and the issue does NOT exist there.

Sorry for the confusion.

The problem DOES seem to exist in draft-ietf-mmusic-ice-sip-sdp, however, but that’s a separate discussion :)

Regards,

Christer

From: Thomas Stach <[email-masked]<mailto:[email-masked]>>
Date: Monday 6 November 2017 at 13:23
To: Christer Holmberg <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [MMUSIC] ICE check list state

Christer,

Section 8.1 of draft-mmusic-trickle-ice talks about “active” and “frozen” check lists.
What document are you talking about?
I'm only aware of draft-ietf-mmusic-trickle-ice-sip and this  doesn't lose a single word about the ICE states.

So, IF the concept is needed for trickle, it has to be defined in the ICE trickle spec, and then reflected in the MMUSIC trickle spec.
You may be right for draft-ietf-ice-trickle, but draft-ietf-mmusic-trickle-ice-sip never signalled any states of any check lists at the - what we call it - ICE agents.
I also can't imagine such a need now, since draft-ietf-mmusic-trickle-ice-sip only defines how the candidates are trickled,
but it is deliberately silent about ICE's connectivity checking algorithm.
 Maybe you can advise in case I'm missing something, but currently I don't see that changes necessary for draft-ietf-mmusic-trickle-ice-sip.

In my opinion you should not call it an Active/Frozen state. Rather call it flag, or something.
After quite some searching I only found this text in in section 8.1 of https://tools.ietf.org/html/draft-ietf-mmusic-trickle-ice-01 (!)
If this is the document you are talking about at the top, it seems to be  slightly out of date :)

Regards
Thomas

Regards,

Christer

_______________________________________________
mmusic mailing list
[email-masked]<mailto:[email-masked]>https://www.ietf.org/mailman/listinfo/mmusic