Subject: [MMUSIC] BUNDLE: Disable individual m= section does not affect other m= sections within BUNDLE group

From: Christer Holmberg <[email-masked]>
Date: Fri, 24 Nov 2017 14:35:17 +0000

Hi,

I have lately received some questions regarding BUNDLE, indicating that the procedures are unclear.

As you know, the latest version (-40) includes a number of editorial changes and clarifications.

But, I’m afraid that’s not enough. Especially the SDP Offer/Answer procedures are unclear, and I’ve spent quite a bit of time looking into how they can be clarified.

However, based on my judgement, it would be very difficult to make them more clear.

So, I have submitted a PR, where I do some TECHNICAL changes, and introduce some restrictions, in order to make things more clear.

  *   When a BUNDLE group has been negotiated, the offerer/answerer BUNDLE address is ONLY assigned to the m- section represented by the BUNDLE-tag. Every other bundled m- section contains a zero port value and an SDP bundle-only attribute. This makes the text more clear, and removes the “shared address” concept.
  *   RESTRICTION: The suggested text says that, when an answerer receives an offer with a BUNDLE address (previously negotiated, or new suggested), the answerer cannot move the m- section including the BUNDLE address (the m- section represented by the offerer BUNDLE-tag) out of the BUNDLE group. The answerer will either have to reject the whole offer, and/or send an offer of it’s own where it removes the m- section out of the BUNDLE group.
  *   RESTRICTION: The suggested text says that, when an answerer receives an offer with a BUNDLE address (previously negotiated, or new suggested), the answerer cannot reject the m- section including the BUNDLE address (the m- section represented by the offerer BUNDLE-tag). The answerer will either have to reject the whole offer, or send an offer of it’s own where it disables the m- section.

With the changes/restrictions above, I personally think the SDP offer/answer procedures are easier to understand.

The PR can be found here:

https://github.com/cdh4u/draft-sdp-bundle/pull/45

I ask anyone that is interested in BUNDLE to take a look.

Regards,

Christer

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 24 Nov 2017 14:47:13 +0000

BTW, don’t worry about the subject. Copy/paste error.

From: mmusic <[email-masked]<mailto:[email-masked]>> on behalf of Christer Holmberg <[email-masked]<mailto:[email-masked]>>
Date: Friday 24 November 2017 at 16:35
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [MMUSIC] BUNDLE: Disable individual m= section does not affect other m= sections within BUNDLE group

Hi,

Regards,

Christer