Subject: Re: [MMUSIC] Getting draft-ietf-mmusic-sdp-uks-04 ready for PubReq

From: Bo Burman <[email-masked]>
Date: Tue, 4 Jun 2019 12:07:43 +0000

Thank you for your review Roman.

Authors, since there are no unaddressed comments beyond the editorial ones from Flemming (here <https://mailarchive.ietf.org/arch/msg/mmusic/ZewhLMuV3EJ6r6rVsCtSiF4TsaM> ), and there seems to be no objections to proceed, please submit an update addressing Flemming’s comments that I will then submit for publication.

Thanks,

/Bo

MMUSIC co-chair

From: mmusic <[email-masked]> On Behalf Of Roman Shpount
Sent: den 30 maj 2019 00:45
To: Martin Thomson <[email-masked]>
Cc: mmusic <[email-masked]>
Subject: Re: [MMUSIC] Getting draft-ietf-mmusic-sdp-uks-04 ready for PubReq

I have reviewed the document and I have confirmed that the document is clear and my understanding is correct.

Thank you, Martin.

_____________

Roman Shpount

On Mon, May 27, 2019 at 12:45 AM Martin Thomson <[email-masked] <mailto:[email-masked]> > wrote:

On Sat, May 25, 2019, at 10:03, Roman Shpount wrote:
> Sorry for the late question, but is there a scenario where party is 
> communicating with attacker but believes that it communicates with 
> patsy?

I don't think so.  I think that would require failures in parts of the system that we are assuming to be OK (the IdP in one case, the signaling system in the other).  The attacker can swap another entity into a call, but not vice versa.

> In all the described attacks, all I see is that one of the attacked 
> parties is communicating with another but thinks it is communicating 
> with the attacker. What is the risk associated with this? How this is 
> different then just setting up a communication channel with attacker 
> who is re-encoding the data?

This is different because a recipient is able to authenticate the source of the media as being the victim.  It is very much like relaying media by instantiating a new session and forwarding media, but if context (or ambient authority) is used in interpreting that data, the attacker might gain something.

Imagine the following conversation: 

victim: I will buy 10.
response: Are you quite sure?
victim: Yes. Please charge to my account.

If the attacker is selling boxes of cookies and the target is selling refrigerators, the result might be surprising.

---

From: "Martin Thomson" <[email-masked]>
Date: Wed, 05 Jun 2019 13:00:50 +1000

-05 is up.  Thanks.

On Tue, Jun 4, 2019, at 22:07, Bo Burman wrote:
> Authors, since there are no unaddressed comments beyond the editorial 
> ones from Flemming (here 
> <https://mailarchive.ietf.org/arch/msg/mmusic/ZewhLMuV3EJ6r6rVsCtSiF4TsaM>), and there seems to be no objections to proceed, please submit an update addressing Flemming’s comments that I will then submit for publication.
> 
> 
> Thanks,
> 
> /Bo
> 
> MMUSIC co-chair
> 
> 
> 
> *From:* mmusic <[email-masked]> *On Behalf Of *Roman Shpount
> *Sent:* den 30 maj 2019 00:45
> *To:* Martin Thomson <[email-masked]>
> *Cc:* mmusic <[email-masked]>
> *Subject:* Re: [MMUSIC] Getting draft-ietf-mmusic-sdp-uks-04 ready for PubReq
> 
> 
> On Mon, May 27, 2019 at 12:45 AM Martin Thomson <[email-masked]> wrote:
> 
> Attachments:
> * smime.p7s