Subject: [MOBILE-IP] Private FA address [was RE: [MOBILE-IP] Darwinian evolution of pr oxy tunnelling...]

From: "Casati, Alessio (Alessio)" <[email-masked]>
Date: Sun, 19 Sep 1999 15:16:13 +0100

> Also to require strictly correct use of leaf FA addressing makes it
> hard to do large picocellular environments with Mobile IPv4 due to the
> need for either customization of all the leaf routing engines or too
> many public addresses. I could imagine using a private/local network
> among my desktop IrDA devices (without having a customized routing
> engine on all those with FA) if I can guarantee no conflicting
> addresses exist there.
>
>
We were discussing in Poole (3GPP MIP ad hoc) a
few days ago which the most appropriate IP level
movement detection mechanism would be.
Charlie mentioned checking the IP source address
in MIP agent advertisements as a good way to support
movement detection.

In my opinion this, as much as the subnet prefix
based movement detection, which I believed to be
good until that discussion, suffers in the case of
lack of coordination between administrative
domains: in case a MN moves from a FA in domain A
to FA in domain B, both with the same private address
on the interface used to send advertisements, the
mobile would not detect movement unless
a FA NAI extension is used.

Note that in some environment such as cellular environments
it is not possible to send periodic advertisements with a
sufficiently high frequency to make Advertisement Lifetime
based movement detection feasible.

Therefore, my suggestion would be to incorporate a FA NAI
extension in any MIP advertisement, so that each FA
is uniquely identified and movement detection easy.

Is it an appropriate thing to be added when MIP will be moved
to draft std?

alessio

---

From: Tom Weckström <[email-masked]>
Date: Sun, 19 Sep 1999 21:18:38 +0300

Hello,

I agree with you Alessio. Taking into account that private address
spaces might be used for FA addresses in Foreign Networks would be very
kind. Adding the NAI could solve this problem. Including the FA NAI
extension to the agent advertisements should be made volountary, since
not all the organizations want to use private addresses and for those
the NAI extension would only be overhead.

Support for private addresses in Mobile Nodes should also be supported.
I suggest this kind of deployment scenarios be taken into account in the
RCF (draft standard) itself, too. Not just in drafts. There are
basically two alternatives for implementing such support, I think.
First, using a tuple like
{mn_home_addr, mn_coloc_add, mn_link_layer_address} and second, adding a
NAI instead of home_addr and/or link_layer_addr.

> Is it an appropriate thing to be added when MIP will be moved

Reagrds,
        Tom

--
        Tom Weckström           Dynamics group
                                Helsinki University of Technology
                                [email-masked]
                                http://www.cs.hut.fi/Research/Dynamics/