Subject: Re: [MOBILE-IP] 3g wireless HLR/VLR Issues

From: "Casati, Alessio (Alessio)" <[email-masked]>
Date: Tue, 14 Dec 1999 15:36:30 -0000

Andrew,

> Correct - we say let Mobile IP be the master of the wide area
> and the micros do the local (LAN, Campus, Met) area stuff.
>
MIP is certainly a protocol good for wide area.

> I think tunneling is a broken concept (here) promoting pseudo
> connections
> in the core and will not do in the longer term to support packet data or
> scalability. You are replacing a connection with a
> tunneled connection (in case of GPRS). Doesn't that stink?
>
No, it doesn't.

alessio

---

From: Thomas Eklund <[email-masked]>
Date: Tue, 14 Dec 1999 18:17:16 +0100

> -----Original Message-----
> From: Andrew T. Campbell [mailto:[email-masked]]
> Sent: Tuesday, December 14, 1999 7:00 PM
> To: [email-masked]
> Subject: Re: [MOBILE-IP] 3g wireless HLR/VLR Issues
>
>
> Jonne:
>
> [email-masked] wrote:
> >
> > Hi,
> >
> > >In both PN-4286 and 3G TR 23.923
> > >we continue to see the existence of the location
> registries of HLR and VLR
> > and
> > >SS7 signalling. Only the proposals like Cellular IP and
> Hawaii do not
> > contain those
> > >in their architectures.
> > >  My question no 1 is if HLR/VLR and SS7 will outlive all
> IP networks of
> > future.
> > >  My question no 2 is both PN-4286 and TR 23.923 talk
> about FA which
> > disappears in IPv6,
> > >so what is the new architecture for Mobile IPv6?
> >
> > I can only speak for the 3G TR 23.923, because that is what
> I have worked
> > with. Our design assumptions when starting that TR was to study the
> > integration of Mobile IP with the UMTS packet switched
> infrastructure
> > without affecting the functionality of the infrastructure
> itself too much.
> > This was done to achieve compatibility with networks and
> mobiles that are
> > not of the same "Step" of Mobile IP TR, e.g. a Step 3 network would
> > interwork with a pre-Step 3 network and with non-Mobile IP
> mobiles. Thus, it
> > was vital that the HLR and the MAP protocol were kept.
> >
> > In the 3GPP Release 2000 there is studied the possibility
> to have the
> > architecture to run on IP. One of the candidates is to
> replace the SS7
> > interfaces with IP based interfaces and run the MAP
> protocol over IP.
> >
> > If I have understood this correctly and I believe that
> somebody mentioned
> > this already on this mailing list, the Cellular IP and
> Hawaii proposals are
> > not meant to replace the current Wide Area Cellular
> Networks. Thus, the
> > architectural needs are a bit different as well.
> >
>
> Good news to see that SS7 is being killed off. We need
> signaling in wireless Internet but not that sort of signaling!
>
>
> > To your second question about the IPv6 with the 3G TR
> 23.923, it is true
> > that the FA plays an important role in the TR. The 3GPP TSG
> SA WG2 Mobile IP
> > Ad Hoc group, which did that document, did simply not have
> the time to look
> > into IPv6 as well. As the work of the group was finished
> last month, the
> > group listed this handicap as one of the open issues for
> further study.
> >
> > One other thing, I know this is kind of late for the
> discussion of the
> > architectural difference between the 3GPP2 defined CDMA2000
> and the 3GPP
> > define UMTS, but I'm going to contribute to that discussion
> anyway. My
> > understanding is partly based on the presentation that Tom
> Hiller did in a
> > 3GPP Mobile IP Ad Hoc meeting in Swindon, England last
> summer. Based on the
> > knowledge (or believe) it seems to me that if we try to map
> the UMTS packet
> > domain with the CDMA2000 packet domain the CDMA2000 RNN
> corresponds to the
> > 3GPP NodeB + RNC + SGSN. The CDMA2000 RP tunnelling
> corresponds to the 3GPP
> > GTP (GPRS Tunnelling Protocol), and the CDMA2000 PDSN to
> the 3GPP GGSN. My
> > opinion is based on the functionality of the nodes.
>
So how would you get security for Cellular IP if you dont use an IP tunnel
out to the mobile node?
....:-)

/Thomas Eklund,SwitchCore