Subject: Re: [MOBILE-IP] MIER V01 [actually V02]

From: Patrice Calhoun <[email-masked]>
Date: Tue, 14 Dec 1999 14:28:23 -0800

>Charlie,
>
>Leaving the reserved bits aside for the moment, am I
>right is gathering from your last posting that you
>have no problems with making MIER extension format
>binding on _all_ future extensions for Mobile IP.
>
>I hope you agree with me that not having such a
>requirement would defeat the very purpose of the
>draft.
>
>>Exactly.  It's _one_ potential use.  There might be
>>others.  And, there is no way you can anticipate all
>>of them with a single extension now.And you can't be
>>sure that all future developers could live
>comfortably >with the remaining subtype space if
>>you use some of it for flags.
>
>The fact that we cannot aniticipate all of them is
>also exactly the reason why we would like to leave it
>open for _future_ standardization.
>
>After all, if the original mobile IP extension had
>some reserved bits, then we could have easily used
>them today for subtypes today -- could we not ?
no, I would have preferred to have a larger extension address
space.

>It is
>a question of simply whether you want to design _just
>for today_ or prudently leave some room for some
>expansion.
I won't say that one should only design for today, but in
this particular instance, since no one can come up with a
fairly good use of the bits (even as examples), and the
fact that Mobile IP is a well understood protocol, I would
opt that we design for today.

PatC
>
>--Raja
>
>ps: Apologize for having to use a diff email account.
>Am having difficulty in using my work email at the
>moment.
>
>__________________________________________________
>Do You Yahoo!?
>Thousands of Stores.  Millions of Products.  All in one place.
>Yahoo! Shopping: http://shopping.yahoo.com

---

From: Neil Justusson <[email-masked]>
Date: Thu, 16 Dec 1999 10:27:45 +1100

Pat & Raja,

How about something like this: don't reserve any bits in the subtype
byte, but reserve a subtype value (255?) that if needed could be
standardized in the future to mean (for example) the next two bytes are
the actual subtype followed by a flag byte (or whatever is needed).
Would this address both your concerns?

--
Neil Justusson                          mailto:[email-masked]
Nortel Networks Technology Centre, Wollongong, Australia
Phone: +61 2 4224 2837        Fax: +61 2 4224 2801        ESN: 639 2837