Subject: Re: [MOBILE-IP] MIER V01 [actually V02]

From: Raja Narayanan <[email-masked]>
Date: Wed, 15 Dec 1999 05:29:17 -0800

Hello Charlie,

Thanks for your note.
I certainly wholeheartedly agree with you on your
comment "I do not think this has to be so hard!" :-)

I would like to understand what you mean in some of
your other comments.

Charlie's posting >> I do not think this restriction
is necessary. I am not in favor of making this
restriction.I think that future extensions may well be
defined that would not fit within the MIER framework.

It would be kind of you if you could help me out and
tell me why having the first 32 bytes defined in the
MIER format handicaps future extensions.

Charlie's posting >> You can leave it open for future
standardization by using different types better than
by leaving reserved flag bits.

Sounds like we agree that it is a good idea to leave
it open for future standardization. I always thought
that the semantics of 'reserved' was that you could
use it for anything. But I would be most happy to
consider some 'opaque' type definitions that you may
have to suggest.

Thanks for your time.

--Raja
__________________________________________________
Do You Yahoo!?
Thousands of Stores.  Millions of Products.  All in one place.
Yahoo! Shopping: http://shopping.yahoo.com

---

From: Patrice Calhoun <[email-masked]>
Date: Wed, 15 Dec 1999 15:53:08 -0800

Perhaps this is a better approach, so by the time we do need something, we
can decide exactly what it is that we need and design it at that time.

PatC
>Pat & Raja,
>
>How about something like this: don't reserve any bits in the subtype
>byte, but reserve a subtype value (255?) that if needed could be
>standardized in the future to mean (for example) the next two bytes are
>the actual subtype followed by a flag byte (or whatever is needed).
>Would this address both your concerns?
>
>
>Patrice Calhoun wrote:
>>
>> >Charlie,
>> >
>> >Leaving the reserved bits aside for the moment, am I
>> >right is gathering from your last posting that you
>> >have no problems with making MIER extension format
>> >binding on _all_ future extensions for Mobile IP.
>> >
>> >I hope you agree with me that not having such a
>> >requirement would defeat the very purpose of the
>> >draft.
>> >
>> >>Exactly.  It's _one_ potential use.  There might be
>> >>others.  And, there is no way you can anticipate all
>> >>of them with a single extension now.And you can't be
>> >>sure that all future developers could live
>> >comfortably >with the remaining subtype space if
>> >>you use some of it for flags.
>> >
>> >The fact that we cannot aniticipate all of them is
>> >also exactly the reason why we would like to leave it
>> >open for _future_ standardization.
>> >
>> >After all, if the original mobile IP extension had
>> >some reserved bits, then we could have easily used
>> >them today for subtypes today -- could we not ?
>> no, I would have preferred to have a larger extension address
>> space.
>>
>> >It is
>> >a question of simply whether you want to design _just
>> >for today_ or prudently leave some room for some
>> >expansion.
>> I won't say that one should only design for today, but in
>> this particular instance, since no one can come up with a
>> fairly good use of the bits (even as examples), and the
>> fact that Mobile IP is a well understood protocol, I would
>> opt that we design for today.
>>
>> PatC
>> >
>> >--Raja
>> >
>> >ps: Apologize for having to use a diff email account.
>> >Am having difficulty in using my work email at the
>> >moment.
>> >
>--
>Neil Justusson                          mailto:[email-masked]
>Nortel Networks Technology Centre, Wollongong, Australia
>Phone: +61 2 4224 2837        Fax: +61 2 4224 2801        ESN: 639 2837

---

From: Raja Narayanan <[email-masked]>
Date: Thu, 16 Dec 1999 09:47:57 -0600

OK, we like the approach as well. Just one subtype value will perhaps be too
little. If acceptable to all then I suggest reserving values 201 thru 255.
This gives us 200 [far more than 16] subtypes for use.

We will make the changes to the draft shortly and post it.

--Raja

-----Original Message-----
From: Patrice Calhoun [mailto:[email-masked]]
Sent: Wednesday, December 15, 1999 5:53 PM
To: [email-masked]
Subject: Re: [MOBILE-IP] MIER V01 [actually V02]

PatC