Subject: [mobile-ip] Draft 15

From: "Charles E. Perkins" <[email-masked]>
Date: Mon, 24 Sep 2001 14:07:53 -0700

Hello folks,

I have done a rough edit on revision 15 of Mobile IPv6.
It needs some proofreading.  There may still be some problems
left over because of eliminating the Mobile Router capability,
and the "Prefix Length" field of the Binding Update.  Also,
I am still puzzling over the e-mail about how a mobile node
should get the link-layer address of the home agent when it
returns home.

Here is the current draft:
	http://people.nokia.net/charlep/txt/mobilev6/mobilev6.txt

Here is a list of changes:

    -  Removed the Mobile Router Prefix Length Sub-Option
   
    -  Removed the Prefix Length field from the Binding Update.
   
    -  Reworded the specification so that the Home Agent now has to
       perform Duplicate Address Detection for the mobile node's address
       on all the prefixes for which the router is performing home agent
       service.
   
    -  Removed the section about Mobile Routers
   
    -  Added the Authentication Data Sub-option; reorganized the section
       about computing authentication data.
    
    -  Specified that the Home Agent lifetime is by default the same as
       the Router lifetime, in a Router Advertisement.
    
    -  Specified that Binding Updates with zero lifetime and the 'A' bit
       set should cause a Binding Acknowledgement to be sent back to the
       Source IP address of the Binding Update.

    -  Qualified the allowable times when a mobile node can send a
       Binding Update to a correspondent node

    -  Added text allowing the correspondent node to extend an existing
       Routing Header by also including the care-of address as the entry
       of a routing header to be visited immediately before the home
       address.  In this way, for instance, the mobile node can be an
       intermediate node of a path along the way to some other node.
   
    -  Removed the Home Address field from the Home Agent Address
       Discovery Request Message.
    
    -  Noted that ICMP Unreachable forms a potential mechanism by which
       a malicious node can cause a correspondent node to delete a valid
       entry from its Binding Cache.

    -  Specified that, when a router stops offering home agent services
       by turning off the 'H' flag, the mobile node has to delete the
       corresponding entry from its Home Agent list. 

I'll wait a bit longer before sending it, depending on current
mailing list discussion and any other comments that may be
contributed.  Surely there will be some other changes that have
to be made anyway, but it is possible to imagine that they will
be small ones.

Regards,
Charlie P.

---

From: Francis Dupont <[email-masked]>
Date: Tue, 25 Sep 2001 16:54:15 +0200

=> charlep -> charliep   

      
=> I like the Prefix-Length==0 option and I am very displeased this
is no more possible. As there are many dangling references to the
Prefix Length I suggest to give this back!

I have another concern about movement detection (10.4, 10.6) which
makes the hidden and incorrect assumption that there is only one
candidate default router. No, mobile is not wireless only and
wireless is not cellular only.

Regards

[email-masked]

---

From: "Chae-yong Chong" <[email-masked]>
Date: Wed, 26 Sep 2001 14:37:06 +0900

I am sorry, but i cannot get a revised copy of this draft.
The site is not accessible. 
Where can I get a copy?

Chae-yong

---

From: "Charles E. Perkins" <[email-masked]>
Date: Wed, 26 Sep 2001 09:07:30 -0700

Hello Francis,

>         http://people.nokia.net/charlep/txt/mobilev6/mobilev6.txt

Yes, I regret the error.  Actually, 'i' is almost bad on my keyboard :-(.

	http://people.nokia.net/charliep/txt/mobilev6/mobilev6.txt

> wireless is not cellular only.

Of course I agree with you that such an assumption would be wrong,
and that mobile != wireless.  But I didn't see where the assumption
was actually made.

Regards,
Charlie P.

---

From: Francis Dupont <[email-masked]>
Date: Wed, 26 Sep 2001 19:32:38 +0200

=> almost everywhere in 10.4 after the introduction:
For instance:
   "so that it can switch to a new default router and
    to a new primary care-of address": the "and" suggests
   that the loss of "the" default router implies a movement.
   "it is likewise important for the mobile node to detect
    when it becomes unreachable for packets sent from its
    default router": this makes the assumption that packets
   can't come from another (default) router.
   etc...
More than one half of statements in 10.4 are false for a host with
multi-path routing (i.e. which can use many default routers at the
same time) connected to a link with a large number of routers.
My concern is the default router tracking method to detect movement
switched from an example to the only method... Illustration is
*not* recommendation.

Regards