Subject: Re: [mobile-ip] Mobile IPv6 draft revision

From: Alper Yegin <[email-masked]>
Date: Fri, 21 Sep 2001 15:15:45 -0700 (PDT)

Charlie,

This looks good. One point tough:

> - The Binding Acknowledgement is to be sent to the Mobile Node
>   at the address in the Source IP address field of the Binding Update.

This packet should be sent to care-of address, right? Not necessarily the source 
address of the incoming BU. Care-of address would be different than the source 
address of BU if there's a alternate care-of address option.

>   If this is not the same as the Mobile Node's home address, then
>   the Binding Acknowledgement is to be delivered using a Routing
>   Header to the delivery address, _as if_ there were a Binding
>   Cache entry associating the mobile node's specified delivery
>   address with its home address.  This is the main point of
>   difference with previous specification, and allows the mobile
>   node to reliably turn off delivery of packets to its care-of
>   addresses without having to be on the home network.

Thanks Charlie!

alper

---

From: Charlie Perkins <[email-masked]>
Date: Fri, 21 Sep 2001 16:30:26 -0700

Hello Alper,

> address of BU if there's a alternate care-of address option.

I thought the purpose of using the alternate care-of address
was to deregister a care-of address at which the mobile node
no longer had connectivity.  If this is true, then it makes more
sense to use the source address of the packet containing the
Binding Update, I think.

> alper

Regards,
Charlie P.

---

From: Francis Dupont <[email-masked]>
Date: Mon, 24 Sep 2001 12:21:29 +0200

>    When deregistering, the HoA is the (unique) key and the only use
   >    of the CoA is to be used as destination of the BA. If an alt-CoA
   >    is in the deregistering BU, the only reason must be that the
   
   If I understand you correct, I recognize that "only reason" was not
   a good wording. You have described another good reason below.
   
=> you've understood be correctly.

   >    mobile node for some reason want the BA to be sent there.
   > 
   > => the CoA is implicitly the source address of the BU where there is
   > no alt-CoA, so if you'd like to use an alternate source address for the
   > BU the alt-CoA feature provides exactly what you need. For instance
   > if you have registered only a global HoA, the deregistration packet
   > can be: source=link-local address on the home link, destination=HA
   > own address, HA=HoA, alt-CoA=HoA. This works very well without
   > any interference with neighbor discovery.
   
   In this case, the destination of the BA could still be the alt-CoA=HoA?
   
=> yes, the destination of the BA should be the HoA.

   Interference with ND is needed at least before sending a BA on the 
   home network, I guess.
   
=> yes but this will happen *after* the deregistration so without trouble.
This works so well that I'll complain if someone suggests to remove the
alt-CoA feature.

Regards

[email-masked]

---

From: Francis Dupont <[email-masked]>
Date: Mon, 24 Sep 2001 10:34:13 +0200

Regards

---

From: "Peter Grimstrup (TED)" <[email-masked]>
Date: Mon, 24 Sep 2001 10:16:31 +0200

Comments below.

> sense to use the source address of the packet containing the

When registering, I think a number of reasons to use an alt-CoA 
could be listed. The (alt-)CoA will be put in the binding cash 
with the HoA as (unique) key.

Peter

---

From: "Peter Grimstrup (TED)" <[email-masked]>
Date: Mon, 24 Sep 2001 10:59:04 +0200

Hi Francis

Comments inline.

Regards
Peter
--

-- 
Peter Grimstrup          Systems Developer
Ericsson Telebit A/S     tel: +45 89 38 52 75
Skanderborgvej 232       fax: +45 89 38 51 01
DK 8260 Viby J, Denmark  e-mail: [email-masked]

---

From: "Charles E. Perkins" <[email-masked]>
Date: Mon, 24 Sep 2001 09:38:31 -0700

> with the HoA as (unique) key.

Right.

> mobile node for some reason want the BA to be sent there.

It seems to me that the following natural interpretation
works well:

- The Source IP address is where the packet came from --
  and thus where the Binding Acknowledgement should go.
- The Alternate care-of address is the care-of address
  that should be deregistered.  This conforms to the
  specification for that Sub-Option.

But this is different than your interpretation.

Regards,
Charlie P.

---

From: "Charles E. Perkins" <[email-masked]>
Date: Mon, 24 Sep 2001 09:55:32 -0700

Hello Francis,

Francis Dupont wrote:
> BU the alt-CoA feature provides exactly what you need.

O.K., but I like the more the explicit and natural statement that
the source of the Binding Update is in the Source IP address field
of the IPv6 header.  We've gone to a lot of trouble to make exactly
that statement true (e.g., create the Home Address destination option).

>                                                     For instance

> => yes, the destination of the BA should be the HoA.

I didn't see your reasoning here.  I gather that you would
rather the Binding Acknowledgement _not_ be sent to the
Source IP address of the Binding Update, so I am worried.

Regards,
Charlie P.