Subject: Re: [mobile-ip] Coexistence with other uses for routing header

From: "Peter Grimstrup (TED)" <[email-masked]>
Date: Fri, 07 Sep 2001 11:29:36 +0200

Charlie wrote:
>    It is possible that a correspondent node, having no knowledge of the
>    mobile node's care-of address, would still (for reasons unspecified
>    here but not necessarily related to mobility) attempt to deliver a 
>    packet, either to or by way of the mobile node's home address,
>    by using a routing header.  If the correspondent node subsequently
>    accepts a Binding Update and creates a Binding Cache entry for the
>    mobile node, then afterwards, the routing header used by the
>    corresponding node which includes the mobile node's home address
>    SHOULD also include the mobile node's care-of address.
>    The correspondent node SHOULD put the mobile node's care-of address
>    as the intermediate node address immediately preceding the
>    mobile node's home address.  When the care-of address is the
>    first intermediate node address, this implies that the care-of
>    address is to be placed in the Destination Address of the IPv6
>    headerd, and the mobile node's home address is the first entry
>    in the type 0 routing header.  Otherwise, the correspondent 
>    node MUST place the mobile node's home address immediately 
>    after the care-of address entry of the routing header, following
>    all other intermediate node addresses that would have
>    already been in the routing header before the creation
>    of the Binding Cache entry for the care-of address.

I don't understand the last part, i.e. "... following all other ..." 

Suggest replacing with
    ...
    in the type 0 routing header.  Otherwise, the correspondent 
    node MUST insert the mobile node's care-of address immediately 
    before the home address entry in the routing header.

An example:

Packets like these are sent:

IPv6 Hdr:      source
               intermediate-dest-1
RH(3 entries): intermediate-dest-2
               intermediate-dest-3
               destination

Then a BU(intermediate-dest3=HoA-3, CoA-3) is accepted and the next packets
should be:

IPv6 Hdr:      source
               intermediate-dest-1
RH(4 entries): intermediate-dest-2
               CoA-3
               intermediate-dest-3
               destination

Further I suggest changing section "8.9 Sending Packets to a Mobile Node"
in a way that the next example will be described/allowed:

IPv6 Hdr:      source
               intermediate-dest-1
RH(4 entries): intermediate-dest-2
               CoA
               MN-HoA

Peter

---

From: "Charles E. Perkins" <[email-masked]>
Date: Fri, 07 Sep 2001 08:41:32 -0700

"Peter Grimstrup (TED)" wrote:

                 ..........

>     before the home address entry in the routing header.

Yes, this is better.  I'll use your simpler formulation.

> RH(4 entries): intermediate-dest-2

No problem; can you suggest some text?

Regards,
Charlie P.