Subject: [mobile-ip] DOUBT!!

From: Amit Shakya <[email-masked]>
Date: Thu, 27 Sep 2001 12:24:10 +0530

hi
I have a doubt regarding the implementation of FA. If a Router has only one
network interface and it advertises that as a care of address via Agent
Advertisement then it will start receiving both normal packets for routing
as well as packets to be decapsulated. Now my question is how will the
Router know whether the packet it is receiving has to be decapsulated and
then forwarded or forward directly ? Is my understanding of FA correct with
regards to this question or am i missing something?
Regards
Amit

---

From: Bjorn Andersson <[email-masked]>
Date: Thu, 27 Sep 2001 17:50:13 +0300

> regards to this question or am i missing something?

If the FA sets the Code field in the advertisement to 16, then
the agent does not route common traffic. See the "Agent
Advertisement section" in the specs:

ICMP Fields

   Code     The Code field of the agent advertisement is
            interpreted as follows:

             0 The mobility agent handles common traffic -- that
               is, it acts as a router for IP datagrams not
               necessarily related to mobile nodes.
            16 The mobility agent does not route common traffic.
               However, all foreign agents MUST (minimally)
               forward to a default router any datagrams received
               from a registered mobile node (Section 4.2.2).

Hope that answers your question.

Regards,
Bjorn

-- 
Bjorn Andersson <[email-masked]>                       +358 50 341 2556
Lifix Systems Oy <http://www.lifix.fi/>                 PGP id 5AFC144B
Yliopistonkatu 5, 3rd floor; FIN-00100 Helsinki

---

From: Dionisios Gatzounas <[email-masked]>
Date: Thu, 27 Sep 2001 10:08:19 +0000

Hello Amit,

> regards to this question or am i missing something?

source ---> encapsulator --------> decapsulator ---> destination
The Router (decapsulator) will check the Protocol Type field in the IP 
header. If this is 4 (IP in IP encapsulation) then the Router will 
decapsulate the packet and forward it to the destination.
Is this the problem or you meant something else?

Regards,
Dionisios.
-- 
------------------------------------------
Dionisios D. Gatzounas           	          
Development Programmes Department 	     
INTRACOM S.A.                       	          
254 Panepistimiou Str., Patras 26443, GREECE              	          
tel: +30 61 465168
fax: +30 61 465070
e-mail: [email-masked]
------------------------------------------