Subject: RE: [mobile-ip] comments on HMIPv6 draft

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Mon, 17 Sep 2001 16:53:11 +0200

> I just wonder some bits in HMIPv6 draft (04):
> 
>   - Why needs two bits ("R" and "M") instead of one to classify 
>     Basic Mode and Extended Mode?
> 
	=> No good answer really ! It seemed safer at the time to explicitly
	leave on flag per mode. 

>  (Consequently the "P" and "T")
>     Is there any other mode beyond Basic Mode and Extended Mode?
> 
	=> You need 2 here because one says that the network is mandatnig 
	that the user uses RCoA as a source address. So if another 
	one is used the routers ingress filtering will drop the packets. 
	Anothe flag is needed to allow the user to use RCoA if they wish (MAY).

> Also I would favor if a section on possible "conceptual data 
> structures" added/updated over MIPv6 could be provided.
> 
	=> OK, will add that to the TODO list. 

	Thanks, 
	Hesham

---

From: Behcet Sarikaya <[email-masked]>
Date: Thu, 20 Sep 2001 11:41:01 -0400

Hi Hesham,
  In
draft-mobileip-hmipv6-04.txt in Fig. A.2 MAP sends HI to nAR. This interaction is
marked 1a which seems to suggest that MAP knows that HO got initiated before
anybody else. How could this be possible considering the fact that MAP is probably
the farthest away node in the configuration?

>         => OK, will add that to the TODO list.

Regards,

--
Behcet