Subject: [mobile-ip] comments on HMIPv6 draft

From: Xiaoming Fu <[email-masked]>
Date: Mon, 17 Sep 2001 14:46:29 +0200

Hi,

I just wonder some bits in HMIPv6 draft (04):

  - Why needs two bits ("R" and "M") instead of one to classify 
    Basic Mode and Extended Mode? (Consequently the "P" and "T")
    Is there any other mode beyond Basic Mode and Extended Mode?
  - "I" bit still depends on some other configuration, right? 
    If so is it necessary to keep this bit?

Also I would favor if a section on possible "conceptual data 
structures" added/updated over MIPv6 could be provided.

Thanks in advance.

Xiaoming

---

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Mon, 24 Sep 2001 09:54:01 +0200

>   In
> draft-mobileip-hmipv6-04.txt in Fig. A.2 MAP sends HI to nAR. This interaction is
> marked 1a which seems to suggest that MAP knows that HO got initiated before
> anybody else. How could this be possible considering the fact that MAP is probably
> the farthest away node in the configuration?
> 
	=> The HI message is triggered by the BU received from the 
	MN. So oAR sends Pr_rtr_adv to the MN, MN sends a BU
	to the MAP which triggers the HI. 
	Of course if every node in the domain is using HMIPv6 then 
	you don't need the HI message at all because the address 
	dupication can be done locally (if you have one MAP). 
	Personally I prefer removing HI completely but there are
	more important issues to be solved in the FMIPv6 draft.

	Cheers, 
	Hesham

> "Hesham Soliman (ERA)" wrote:
> 
> > >     Basic Mode and Extended Mode?
> > >
> >         => No good answer really ! It seemed safer at the time to explicitly
> >         leave on flag per mode.
> >
> > >  (Consequently the "P" and "T")
> >         => You need 2 here because one says that the network is mandatnig
> >         that the user uses RCoA as a source address. So if another
> >         one is used the routers ingress filtering will drop the packets.
> >         Anothe flag is needed to allow the user to use RCoA if they wish (MAY).
> >
> >         => OK, will add that to the TODO list.
> >
> >         Thanks,
> >         Hesham
> 
> Regards,
> 
> --
> Behcet