Subject: Re: [mobile-ip] New BETH Draft

From: James Kempf <[email-masked]>
Date: Wed, 19 Sep 2001 10:52:57 -0700 (PDT)

Hi Rajeev,

>
>it appears that we are in sync. However, I would like to see clear descriptions 
of
>
>- what are the requirements for a BETH MN
>- what are the requirements for a BETH AR
>
>in the draft, especially if it needs to be part of the FMIPv6 draft. As I 
understand,
>BETH is a very specific optimization with underlying assumptions and associated
>requirements. They need to be *clearly* specified, perhaps in an individual 
section.
>If such a thing already exists, please excuse this note.

Agree. I will make sure that they are spelled out in the merged draft.

BTW, what do you think about letting the AR tell the MN whether
it is entering a BETH coverage area? This would allow the MN to
start performing BETH optimization, just as informing it when
it is leaving the coverage area allows it to stop performing
the optimization? If the MN wasn't capable of performing the
optimization, it would simply continue to do FMIPv6 handover.

		jak

---

From: Rajeev Koodli <[email-masked]>
Date: Wed, 19 Sep 2001 11:37:03 -0700

James,

> optimization, it would simply continue to do FMIPv6 handover.

This could be useful. I guess the AR would advertise that it supports BETH, perhaps
through solicited RtAdvs.

Regards,

-Rajeev