Subject: Re: [mobile-ip] Coexistence with other uses for routing header

From: Alper Yegin <[email-masked]>
Date: Wed, 5 Sep 2001 14:50:45 -0700 (PDT)

> Alper Yegin writes:
>  > Mobile node doesn't have to be a "router", it just needs to "forward" the 
packet 
>  > though. It's just like when it forwards the packet to itself when the 
>  > destination of a packet is CoA and the next hop is Home_Address.
>  > 
>  > I can't think of any application that needs this right now, but I think the 
>  > practice was to allow future protocols using routing header work with route 
>  > optimization.
> 
>    We're probably off in the definitional weeds here,

I think so :)

>    but I'd think that something that moves packets
>    toward their destination instead of toward
>    themselves is acting like a router, regardless
>    of what caused them to do so. Practically
>    speaking, I'd sure like some knob -- like the
>    router on/off switch -- which controls whether
>    my node acts as a forwarder regardless of how
>    something is trying to get me to forward.

For example Solaris has a "ip_forwarding" knob. Only when it is turned on, the 
box starts forwarding packets. It doesn't necessarily have to be running any 
"routing protocol" at this point (RIP, etc.). It can do forwarding using minimal 
routing table that contains on-link routes and default route.

alper

---

From: Michael Thomas <[email-masked]>
Date: Thu, 6 Sep 2001 11:06:45 -0700 (PDT)

> routing table that contains on-link routes and default route.

Ah, yes, I didn't mean to imply that there was
anything actively populating its forwarding
tables. Colloquially, "router" means "forwarder"
IMO which may contain be nothing more than static
routes. Routing headers are in essence
self-describing single use routing updates :-)

So what were we talking about?

	Mike