Subject: RE: [mobile-ip] RFC2002bis

From: "Kuntal Chowdhury" <[email-masked]>
Date: Thu, 6 Sep 2001 17:38:51 -0500

Hi all,
3GPP2 cannot use any reference to RFC 2002bis before it reaches RFC status.
Moreover cdma2000 packet data standards i.e. IS-835, IS-835-A refer to RFC
2002. Even the IS-835-B which is scheduled to be released sometime late this
year, will use RFC 2002 reference. All the cdma2000 deployments in the near
future will be based on MIP as defined in RFC 2002. Now, obsoleting RFC 2002
with an incompatible version would basically make cdma2000 networks
incompatible with all other MIP implementations. This seems like a huge
problem for 3G wireless carriers who plan to deploy MIP.

Regards,
Kuntal

-----Original Message-----
From: Patil Basavaraj (NET/Dallas) [mailto:[email-masked]]
Sent: Thursday, September 06, 2001 6:56 AM
To: mobile-ip
Cc: Perkins Charles (IPRG/MtView); Madjid.Nakhjiri
Subject: RE: [mobile-ip] RFC2002bis

rfc2002bis is an I-D and NOT an RFC yet. Outside SDOs can
choose whether they want to reference an I-D, which is essentially
work in progress and has the possibility of change occuring or wait
for it to become a PS with a new RFC number. 
I think you are still on the greens in your understanding of the
status of the 2002bis I-D.

> -----Original Message-----
> From: ext Nakhjiri Madjid-MNAKHJI1 
> 
> There might be a procedure about the bis version that I don't 
> understand.
> Can Charlie or the chairs answer this question?
> 
> Can an outside SDO refer to a bis RFC? i.e. does it have same
> standard status as the non-bis RFC?
> I was under impression that the RFC2002bis has ID status,
> maybe I am way off in the woods???
> 
> Thanks in advance,
> Madjid
> 
> -----Original Message-----
> From: Marcello Lioy [mailto:[email-masked]]
> 
> 
> At 02:00 8/11/2001, you wrote:
> >Hello folks,
> >
> >A new version of RFC2002bis has been prepared.  According
> >to the most recent guidance given by the IESG, a change in
> >the mandated authentication algorithm has been strongly
> >suggested.  Unfortunately, this will have the effect of
> >causing almost all previous implementations of Mobile IP
> >for IPv4 to become incompatible with the new specification.
> >
> >The working group chairs recently asked the working group,
> >by way of the mailing list, whether this incompatible
> >change would be acceptable.  The discussion was quite
> >limited, somewhat to my surprise.  This has been taken
> >as evidence that going with HMAC_MD5 is more-or-less
> >O.K.  Thus, it has been decided to go ahead with the
> >change.  On the other hand, it is conceivable that not
> >all interested parties have been notified of the possible
> >change, or have had time to reply.  If there are dissenters
> >to this change, now would be the time to express that
> >opinion.
> 
> This could be an issue.  TIA/EIA IS-835 (the packet data standard for 
> CDMA2000) is going to be deployed in North America this fall. 
>  It specifies 
> the user of RFC 2002.  There are two major areas of 
> incompatibilty in RFC 
> 2002bis:
> 1) the inclusion of the SPI in the auth calculation
> 2) HMAC_MD5 if that is decided on.
> 
> Both of these things break 2002 - which means that the mobiles and 
> infrastructure that are 835 compliant will be obsoleted when 
> RFC 2002 is 
> obsoleted.
> 
> I think that both of these fixes are good (the SPI was a bug 
> that slipped 
> through in 2002, and HMAC sounds like it is less vulnerable 
> than vanila 
> MD5) but they could cause issues in these planned network deployments.
> -----------------------------------
> Marcello (Wandering through France)
>

---

From: Charlie Perkins <[email-masked]>
Date: Thu, 06 Sep 2001 17:18:47 -0700

Hello,

As far as I can tell, RFC2002bis was completed until this recent
request to merge in MIER, and that is not hard to do.  In fact,
I'm already just about finished with a draft revision containing
MIER, the text of which wouldn't surprise anyone who cared.

If you wanna build RFC2002bis systems, I would say to go ahead
and build them.  There aren't any outstanding issues that would
endanger its progress at this point.

Regards,
Charlie P.

Kuntal Chowdhury wrote:

>
>
> Hi all,
> 3GPP2 cannot use any reference to RFC 2002bis before it reaches RFC
> status. Moreover cdma2000 packet data standards i.e. IS-835, IS-835-A
> refer to RFC 2002. Even the IS-835-B which is scheduled to be released
> sometime late this year, will use RFC 2002 reference. All the cdma2000
> deployments in the near future will be based on MIP as defined in RFC
> 2002. Now, obsoleting RFC 2002 with an incompatible version would
> basically make cdma2000 networks incompatible with all other MIP
> implementations. This seems like a huge problem for 3G wireless
> carriers who plan to deploy MIP.
>
> Regards,
> Kuntal
>