Subject: RE: [mobile-ip] Consensus call - MIPv4 interopration with NATs/VP Ns

From: Phil Roberts <[email-masked]>
Date: Mon, 14 Jan 2002 10:14:34 -0500

Sure.

When we asked during London there was a large constituency in the room that
agreed about the NAT traversal problem.  Not so with the VPN gateway
traversal
and there was some pushback in the private discussion about whether VPN
gateway traversal was needed at all.  If you can get enough folks to post on
the MIP list that they're interested in VPN gateway traversal we can
consider
whether to pursue a draft on it.

Phil

> -----Original Message-----
> From: Iyer, Prakash [mailto:[email-masked]]
> Sent: Monday, January 14, 2002 10:13 AM
> To: [email-masked]'
> Subject: RE: [mobile-ip] Consensus call - MIPv4 interopration with
> NATs/VP Ns
> 
> 
> Was the consensus based on the number of companies. If so, as far as I
> remember there were only
> 2 or 3 companies driving NAT requirements and at least as 
> many (if not more)
> interested in solving 
> the VPN problem. I remember both George and James Kempf 
> raising this issue
> for discussion and a 
> couple of other vendors noting their interest on the 
> [mobileip-nat-vpn]
> mailing list. As I had 
> mentioned earlier there were requests on the IPSRA mailing 
> list as well.
> 
> Maybe the chairs can clarify the basis for this conclusion 
> for the benefit
> of the working group.
> Thanks.
> 
> -Prakash
> 
> -----Original Message-----
> From: Phil Roberts [mailto:[email-masked]]
> Sent: Monday, January 14, 2002 6:42 AM
> To: [email-masked]'
> Subject: RE: [mobile-ip] Consensus call - MIPv4 interopration with
> NATs/VP Ns
> 
> 
> Based on the feedback we'll be making
> draft-levkowetz-vaarala-mobileip-nat-traversal-00.txt
> a working group item and waiting on the interoperation with 
> VPN gateways
> until there is
> a larger constituency of interest in the WG.
> 
> 
> > -----Original Message-----
> > From: Patil Basavaraj (NET/Dallas) 
[mailto:[email-masked]]
> Sent: Friday, January 04, 2002 6:59 PM
> To: 'Mobile IP'
> Subject: [mobile-ip] Consensus call - MIPv4 interopration 
> with NATs/VPNs
> 
> 
> In London a design team was formed to investigate the problem of
> Mobile IPv4 interoperation with NATs and VPNs.  At the time there
> was a clear constituency in the working group that having a solution
> to NAT traversal was important.  It was less clear to the 
> chairs that there was a clear interest in the working group for a
> specification of the operation of Mobile IPv4 across VPN gateways.  To
> that end  we propose that the following draft:
> draft-levkowetz-vaarala-mobileip-nat-traversal-00.txt
> (the output of the design team) be made into a working group item for
> progression on the Standards Track.  Please let us know in the next
> few days if you object to this.
>  
> We would also like to hear feedback from the working group on
> whether there is a perceived need for a solution to Mobile IPv4
> interoperation with VPN gateways.
> 
> WG Chairs
>

---

From: Alexis Olivereau <[email-masked]>
Date: Mon, 14 Jan 2002 17:40:28 +0100

I am interested in that topic, too.

Phil Roberts wrote:
> If you can get enough folks to post on the MIP list that they're 
> interested in VPN gateway traversal we can consider whether to pursue
> a draft on it.

---

From: Joe Lau <[email-masked]>
Date: Mon, 14 Jan 2002 10:20:33 -0800 (PST)

> Phil Roberts wrote:
> > If you can get enough folks to post on the MIP list that
> > they're interested in VPN gateway traversal we can
> > consider whether to pursue a draft on it.
> 
> OK, count me in then [as one who wants VPN gateway traversal].

Count me in as well.

Joe Lau

> -- 
> Regards,
> Uri.
> -=-=-<>-=-=-
> <Disclaimer>

---

From: Uri Blumenthal <[email-masked]>
Date: Mon, 14 Jan 2002 11:03:23 -0500

-- 
Regards,
Uri.
-=-=-<>-=-=-
<Disclaimer>

---

From: "Henrik Levkowetz" <[email-masked]>
Date: Tue, 15 Jan 2002 15:42:37 +0100

I believe that VPN interaction is of interest to mobile IP, but also 
that the problem is not as simple and well understood yet as the NAT
traversal, and would benefit from more work and discussions. In
particular, I'm not convinced that the solution in the adrangi draft
is the best we can come up with. There's a short discussion of different
scenarios in http://www.levkowetz.com/pub/id/nat-vpn-scenarios.html,
but I believe there is more to be said and thought on the subject.. :-)

	Best regards,
		Henrik

> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Phil Roberts
> Sent: Monday, January 14, 2002 4:15 PM