Subject: RE: [mobile-ip] RE: Is RR only enough ?

From: "Rajahalme Jarno (NRC/Helsinki)" <[email-masked]>
Date: Fri, 18 Jan 2002 09:38:32 +0200

Hesham wrote:
> But my point is that, should
> this BU security mechanism be RR only, MITM can 
> hijack a connection and receive the content that was
> intended for the legitimate MN. The will happen, despite
> the presence of e2e security (SSL, TLS, IPsec ...etc) which
> äwas setup based on the relevant identity. 
> Now this is the major difference from today's networks. 
> We agree (I think) that e2e security would stop 
> connection hijacking (by MITM) today, but it will
> not stop it if we rely on RR only for BU authentication /
> authorisation. 
> 

I don't know with whom you think you agree, but I fail to see how e2e
security would stop connection hijacking by MITM today.

It seems that as long as the attacker is anywhere on the CN-HA path,
there is no new vulnerability being introduced by RR based Mobile IP BU
authorization. The benchmark case should be the "MN on it's home link"
(Mobile IP would not be used),  where all the traffic between MN and the
CN would be visible to the same attacker. 

So what is the major difference?

	Jarno

---

From: Pekka Nikander <[email-masked]>
Date: Fri, 18 Jan 2002 13:43:34 +0200

Jarno,

> So what is the major difference?

What comes to the security from the MN's point of view, the
only difference seems to be the so called "future" attacks.
(see e.g. http://www.tml.hut.fi/~pnr/presentations/IETF50-SAAG-AddrOwn-Slides.pdf)
However, there is also the so called "bombing" attack
(see draft-aura-bu-security-something) and another attack,
which might be called "reverse bombing" or bombing on binding
expiry.  In the latter attack, the attacker creates an binding,
orders large amounts of traffic to its CoA, and lets the binding
to expire.  As a result, the large amount of traffic is
redirected to the home network, "bombing" it.

What makes these attacks nasty is that there an attacker
(which must be on path due to RR) can utilize the CN as
an amplifier in a DoS attack.  Furthermore, the future and
bombing effects can be combined, making it possible for an
attacker to visit a target network once, and then at a later
date launch an DDoS attack against it.

However, if we limit the lifetime of those bindings that
created via an RR-only method, we can limit the extend
of the "future" effect to something reasonable.  It seems
like we have to limit the lifetime to a few minutes or so,
and require rerunning the RR protocol on each renewal.

Thus, it seems like we can get _reasonable_ security level
with RR-only methods.  CGA gives more protection, for sure,
and therefore it might be beneficial to adopt it as an optional
feature.  Furthermore, a policy rule saying "if two MNs claim
for the same HoA, and one uses CGA while the other don't,
favour the one using CGA" would cut down most concerns about
an attacker always watering CGA to RR.

--Pekka Nikander