Subject: RE: [mobile-ip] RA Solicitation Response Delay Performance Fatality

From: [email-masked]
Date: Tue, 23 Apr 2002 09:01:13 -0500

Hi Francis,

A mobile node should aware that a layer 2 handover has occurred. For example, in cellular, the MN is given a radio resources information in the target access point to be acquired. Once it acquires the radio link in the target access point, the mobile node can start the layer 3 procedure. I don't know what is the motivation for the mobile node to perform L3 handover quickly, but definitely the mobile node know that L2 handover has been completed (in UMTS the mobile node even send L2 message). 

Thanks.

Rene Purnadi
Phone: +1 972.894.4897
Mobile: +1 972.342.3503
e-mail: [email-masked]

-----Original Message-----
From: ext Francis Dupont [mailto:[email-masked]]
Sent: Tuesday, April 23, 2002 5:00 AM
To: Brett Pentland
Cc: James Kempf; [email-masked]
Subject: Re: [mobile-ip] RA Solicitation Response Delay Performance
Fatality 

   Thanks for your response; I hadn't really pursued that line of thought. In
   any case, the method you describe requires significant infrastructure to
   work.

=> I don't believe this infrastructure is "significant" and (more important)
in many cases it is already there, for instance as soon as you have
common layer two "AAA" features. And don't forget easy cases like PPP.

   I think that in cases where that infrastructure is not in place, if a
   mobile node is aware that a layer two handover has occured then it is
   desirable that it be able to perform a handover at layer three quickly.
   
=> I'd like to know how "a mobile node is aware that a layer two
handover has occured"...

Thanks

[email-masked]

---

From: Francis Dupont <[email-masked]>
Date: Tue, 23 Apr 2002 16:24:41 +0200

A mobile node should aware that a layer 2 handover has
  occurred. For example, in cellular, the MN is given a radio resources
  information in the target access point to be acquired. Once it
  acquires the radio link in the target access point, the mobile node
  can start the layer 3 procedure. I don't know what is the motivation
  for the mobile node to perform L3 handover quickly, but definitely the
  mobile node know that L2 handover has been completed (in UMTS the
  mobile node even send L2 message).
   
=> in your description it is very cler than the target access point
knows the handover occurs. So it can help to make L3 handover faster,
for instance by caching a RA, by triggering a RA by sending itself a RS,
etc. One can imagine many ways, all of them are better than to mess
the neighbor discovery protocol.
About UMTS, if the context type is PPP the peer is the access router,
if it is IPv6 the GGSN is the access router: in all cases a RA will be sent
without a RS and the L3 handover as quick as possible without FMIPv6.

Thanks

---

From: Behcet Sarikaya <[email-masked]>
Date: Tue, 23 Apr 2002 09:58:09 -0500

Hello Francis,
  This is an interesting subject!
I wonder in which context are considering the application of FMIPv6? Is 
it for fast handover inside UMTS domain? Probably it is more interesting 
to consider intertechnology handovers using FMIPv6?

>without a RS and the L3 handover as quick as possible without FMIPv6.
I wonder what Hesham says to this?

>[email-masked]
Regards,

-- 
Behcet

---

From: Rajeev Koodli <[email-masked]>
Date: Tue, 23 Apr 2002 09:59:06 -0700

> without a RS and the L3 handover as quick as possible without FMIPv6.

Some comments on the last sentence..

- quickly receiving an RA is not equivalent to fast handover (in case you
implied it that way).  Anyway, a fast IP handover problem can be
characterized as "how quickly the MN can send _and_ receive IP
packets at its new point of attachment".

- regarding the ability to send packets as soon as possible, quickly
getting an RA helps. In general however, the address acquisition latency
depends on ND including DAD which imposes substantial latency.

- regarding the ability to receive packets as soon as a new link is
available, you need to consider the route-update (BU) latency. FMIPv6
moves BU out of time-sensitive path by having a tunnel from previous
router to the new one. Here, quickly getting an RA can help to the extent
of expediting the transmission of BU. However, packets sent by a CN
before the new IP address is registered at the CN are lost without a
forwarding path from previous router to the new one.

Regards,

-Rajeev

---

From: Greg Daley <[email-masked]>
Date: Wed, 24 Apr 2002 09:09:46 +1000

> the neighbor discovery protocol.

I know of several systems where the L2
Access Point is not an IP device, and therefore
cannot participate in L3 connectivity (even if it
knows about a new association).

The mobile node, on the other hand, may know of a
change in L2, and may use this information to
check that it is not on a new L3 network.

If there is intelligence in the network to assist
with sending RA's, then I'm happy for that effort to
be explored, but it is not a viable method for some
widely deployed technologies.

Greg Daley

---

From: Francis Dupont <[email-masked]>
Date: Wed, 24 Apr 2002 11:35:55 +0200

=> by definition FMIPv6 is intertechnology-capable so this doesn't matter.
   
Thanks

---

From: Francis Dupont <[email-masked]>
Date: Wed, 24 Apr 2002 11:47:41 +0200

implied it that way).

=> we agree, in my message I mean it is the best thing to do when FMIPv6
(aka fast handowver) is not available. So I believe your comment is more
a complement than an objection, isn't it?

   router to the new one.

=> this is BETH, not FMIPv6 fast handover... (no flame war please about
BETH vs FMIPv6 :-).

Thanks

---

From: Francis Dupont <[email-masked]>
Date: Wed, 24 Apr 2002 12:41:30 +0200

=> this is (with possible very high arrival rate) the only issue
in the scheme I propose. But there are already some cases where
the L2 access point has to participate to L3 stuff:
 - AAA (insecure networks are not so popular :-)
 - many xxx handover enhancements (to trigger RA sending is in fact
   the first step of possible enhancements).

   be explored,

=> we agree about this, and perhaps we agree too about the superiority
of this approach over fast RS/RA one.

   but it is not a viable method for some
   widely deployed technologies.
   
=> you have to give concrete examples and don't forget that if current
IEEE 802.11 networks have no deployed good AAA the reason is the lack
of available solutions, and this hole is being filled very quickly.
(for instance if you use LEAP, the radius server can trigger the RA,
in fact if you use address filtering (very common!) the radius server
is used in order to punch holes in filters (messages with the AP for
MAC filters, with the firewall for IP filters, etc). A very easy way
to implement my proposal is to put the radius server on the same link
than the AP and the MN and to send a RS from it).

Regards

---

From: Rajeev Koodli <[email-masked]>
Date: Wed, 24 Apr 2002 09:43:37 -0700

> a complement than an objection, isn't it?

Right, I was not objecting to your statement. Rather, trying to draw
out the differences between this thread and FMIPv6.

> => this is BETH, not FMIPv6 fast handover... (no flame war please about

Both have tunnel from previous AR to new AR :-)

Regards,

-Rajeev

---

From: Behcet Sarikaya <[email-masked]>
Date: Wed, 24 Apr 2002 12:23:11 -0500

Sorry I thought you were discussing FMIPv6 on UMTS, and Francis is 
arguing that it is not applicable because the base protocol (MIPv6) 
handover would always occur first. That's why I suggested that FMIPv6 
could apply to handovers outside UMTS or the like.

Francis Dupont wrote:

> In your previous mail you wrote:
>
Regards,

-- 
Behcet

---

From: Greg Daley <[email-masked]>
Date: Fri, 26 Apr 2002 09:33:41 +1000

Hi Francis,

Some comments are inline.
(also some reformatting done to clarify comment origin).

Francis Dupont wrote:
> => this is (with possible very high arrival rate) 
> => the only issue in the scheme I propose. 
> => But there are already some cases where
> => the L2 access point has to participate to
> => L3 stuff:
> => - AAA (insecure networks are not so popular :-)
> => - many xxx handover enhancements (to trigger RA
> =>   sending is in fact the first step of
> =>   possible enhancements).

[GD]: I agree that many L2 Wireless APs today have IP
[GD]: Function (and that AAA may be somewhat important :)
[GD]: but this does not mean that an AP is necessarily
[GD]: deployed as the L3 router for any of their links.
[GD]: Therefore they cannot send the RA on their own
[GD]: behalf (As L2 devices rather than as router function).

> => we agree about this, and perhaps we agree too
> => about the superiority of this approach over
> => fast RS/RA one.

[GD]: I'm not sure I'd say that yet, my workmates
[GD]: have been using fast RS/RA here...
[GD]: Certainly there is worth in determining 
[GD]: how the network may speed knowledge of handover
[GD]: especially if there is not prior knowledge from
[GD]: the previous access network.
 
> => you have to give concrete examples and don't
> => forget that if currentIEEE 802.11 networks
> => have no deployed good AAA the reason is the 
> => lack of available solutions, and this hole
> => is being filled very quickly.
> =>  (for instance if you use LEAP, the radius
> =>  server can trigger the RA, in fact if you
> =>  use address filtering (very common!) the
> =>  radius server is used in order to punch
> =>  holes in filters (messages with the AP for
> =>  MAC filters, with the firewall for IP
> =>  filters, etc). A very easy way to implement
> =>  my proposal is to put the radius server on
> =>  the same link than the AP and the MN and 
> =>  to send a RS from it).

[GD]: I have to admit that the technologies I was
[GD]: most concerned with were 802.X networks
[GD]: (particularly Ethernet and 802.11).
[GD]: It may take a long time to get LEAP/RADIUS into
[GD]: deployed Ethernet networks...
[GD]: Regarding use of LEAP/RADIUS, I cannot see how
[GD]: the RADIUS responses would apply to any other 
[GD]: host than the AP (i.e. the access router), so even
[GD]: if the appropriate filters are set, the AR still 
[GD]: will wait a random delay (under today's standard)
[GD]: before the response RA is sent (multicast or 
[GD]: to the AP?)

[GD]: I think that a router would still have to respond
[GD]: (possibly selectively) to RS's in an expedited way.
[GD]: Erik's viewpoint that there not be special
[GD]: signalling for fast RS/RA could be coupled with a
[GD]: statement that administrators may configure routers
[GD]: to respond to only certain L3/L2 address pairs
[GD]: quickly (perhaps sent with AH).

[GD]: this situation could obviously be collapsed if
[GD]: the AR is the AP, so that when L2 comes up, an RA
[GD]: would be sent immediately.

[GD]: As an aside, I would never advise people to put
[GD]: an AAA server on an access network, if at all
[GD]: possible.

Greg Daley