Subject: [mobile-ip] Question on RFC3220

From: George Tsirtsis <[email-masked]>
Date: Tue, 30 Apr 2002 11:00:23 -0400

Hi all,

This is probably a stupid question but here it is anyway:
The Registration Request header in MIPv4 have the following flags:

   +-+-+-+-+-+-+-+-+-+-+-+-+
    ...|S|B|D|M|G|r|T|x|    ...
   +-+-+-+-+-+-+-+-+-+-+-+-+

of which:

      r        Sent as zero; ignored on reception.  SHOULD NOT be
               allocated for any other uses.

Can anyone tell me why this SHOULD NOT be allocated in the future?? Is there
any logic behind this or it is just an arbitrary act of fate?

Thanks
George

---

From: Charlie Perkins <[email-masked]>
Date: Tue, 30 Apr 2002 08:32:07 -0700

Hello George,

That's a SHOULD NOT, not a MUST NOT.

The reason for NOT allocating it, would be to avoid damage
to legacy implementations that used the bit for its previous
meaning.

The reason for allocating it, would be to satisfy working
group demand for some other need.

Regards,
Charlie P.