Subject: [mobile-ip] A Question about:draft-ietf-mobileip-aaa-nai-00.txt

From: "Ahmad Muhanna"<[email-masked]>
Date: Fri, 19 Apr 2002 10:55:30 -0500

Hello All;
I would like to address the following two points:

I. Mobile Node and the new HA NAI extension:

In section 4. It reads:
" A mobile node MUST provide this in every registration request sent
   when re-authenticating, or when requesting a specific IP address at
   initial authentication."

	1. Does this mean that whenever the mobile Node include a specific
Static
	Home IP address, Mobile Node MUST provide the AAA NAI extension with
Subtype 1?

	2. Does this mean when the MN change point of attachment due to
Inter-FA handoff
	It MUST include this extension.

If 1 & 2 are true?
Where is the backward compatibility with legacy Mobile Node?

II. Home Agent handling of AAAH Identity Subtype extension:

In section 5. It reads:

"The home agent MUST provide this in every registration reply if using
   the AAA server ."

I would prefer more explicit sentence similar to one used earlier:

"The home agent MUST provide this in every registration reply sent to
  the mobile node destined through the AAA infrastructure."

Thanks for consideration.

Regards;
Ahmad Muhanna

---

From: "Fredrik Johansson" <[email-masked]>
Date: Mon, 22 Apr 2002 17:19:20 +0200

A Question about:draft-ietf-mobileip-aaa-nai-00.txtAhmad,

please see comments inline
/fredrik
  -----Original Message-----
  From: Ahmad Muhanna [mailto:[email-masked]]
  Sent: den 19 april 2002 17:56
  To: [email-masked]
  Cc: [email-masked]'; [email-masked]'
  Subject: A Question about:draft-ietf-mobileip-aaa-nai-00.txt

  Hello All;

  In section 4. It reads:

  [->] yes

          2. Does this mean when the MN change point of attachment due to Inter-FA
handoff
          It MUST include this extension.
  [->] yes

  If 1 & 2 are true?
  Where is the backward compatibility with legacy Mobile Node?
  [->] Isn't it the same as with any extension needed to authenticate through an
AAA infrastructure, e.g. the MN-AAA Authentication extension must be present in
order for the FA/HA to authenticate via AAA?

  In section 5. It reads:

  [->]You mean so don't have to send it every time? I have no problem with that.

  /Fredrik

  Regards;
  Ahmad Muhanna