Subject: RE: [mobile-ip] alt-coa - Comments on Draft 16

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Thu, 4 Apr 2002 11:04:49 +0200

Rajeev,

  > To be more specific,
  > 
  > - oldAR has means to trust CoA-1

=> This *is* where my concerns are. What 
are these means that the AR and MN have to share
trust that is equivalent to the MN - HA trust. 

To elaborate more, In MIPv6 there is no CoA
test between the MN and HA because there is an
underlying assumption that there is strong trust
between the MN and HA which ties the MN's HoA
to more than a device, i.e. if the MN mibehaves
you know the guy and you would sue him!

But this type of trust does not exist between
the MN and the CN, hence the need for CoA test
as well as the HoA test. So for the temp HA/AR
what kind of trust exists and how?

Hesham

---

From: Rajeev Koodli <[email-masked]>
Date: Thu, 04 Apr 2002 11:43:25 -0800

Hi,

I think it is useful to look at the issue more generally
as binding CoA-1 to CoA-2 rather than
viewing AR strictly as a temp HA.

Now, we need to make sure that it is safe to bind
these two together. For that,

CoA-1: AR-1 has been forwarding packets
to/from CoA-1. From an RR standpoint, there
is a "trust" based on routing (specifically on-link
forwarding).

CoA-2: AR-2, which AR-1 trusts, is able to
vouch that redirecting traffic to CoA-2 is safe.

We need to ensure that these things are clearly
spelled out in the specification.

Some comments below in-line.

Regards,

> trust that is equivalent to the MN - HA trust.

Sorry, but by trust I meant that based on being
able to forward packets to/from CoA-1. I elaborated
this in the other previous e-mail.

> you know the guy and you would sue him!

But, you don't have to map an AR to a temp HA and
then look at the protocol. Treat this as a problem of
binding CoA-1 to CoA-2.

> what kind of trust exists and how?

As I mentioned above, the fact that AR-1 has been
forwarding packets to/from CoA-1 is the trust
(that is analogous to trust assumed in RR) that you
use.