Subject: RE: [mobile-ip] A Question about:draft-ietf-mobileip-aaa-nai-00.t xt

From: "Ahmad Muhanna"<[email-masked]>
Date: Fri, 19 Apr 2002 11:15:57 -0500

Hello Again;

One more thing please:

In section 5. It reads:
"
   If the AAAH identity is present, the foreign agent MUST direct an
   authentication request to this home AAA server when authenticating
   the mobile node through the AAA infrastructure by means described in
   [2]
"
I am not sure if the foreign agent has any control over this!!

What about the following text?
"
   If the AAAH identity is present, the foreign agent MUST include 
   this identity when requesting the Mobile Node authentication 
   through the AAA infrastructure as described in [2].
"

Regards; 
Ahmad Muhanna 

-----Original Message-----
From: Muhanna, Ahmad [RICH1:2Q20:EXCH] 
Sent: Friday, April 19, 2002 10:56 AM
To: [email-masked]
Cc: [email-masked]'; [email-masked]'
Subject: [mobile-ip] A Question about:draft-ietf-mobileip-aaa-nai-00.txt

Hello All; 
I would like to address the following two points: 
I. Mobile Node and the new HA NAI extension: 
In section 4. It reads: 
" A mobile node MUST provide this in every registration request sent 
   when re-authenticating, or when requesting a specific IP address at 
   initial authentication." 
        1. Does this mean that whenever the mobile Node include a specific
Static 
        Home IP address, Mobile Node MUST provide the AAA NAI extension with
Subtype 1? 
        2. Does this mean when the MN change point of attachment due to
Inter-FA handoff 
        It MUST include this extension. 
If 1 & 2 are true? 
Where is the backward compatibility with legacy Mobile Node? 
II. Home Agent handling of AAAH Identity Subtype extension: 
In section 5. It reads: 
"The home agent MUST provide this in every registration reply if using 
   the AAA server ." 
I would prefer more explicit sentence similar to one used earlier: 
"The home agent MUST provide this in every registration reply sent to 
  the mobile node destined through the AAA infrastructure." 
Thanks for consideration. 
Regards; 
Ahmad Muhanna

---

From: "Fredrik Johansson" <[email-masked]>
Date: Mon, 22 Apr 2002 08:17:26 +0200

Hi Ahmad,

sounds reasonable

/Fredrik

>From: Ahmad Muhanna [mailto:[email-masked]]
>Sent: den 19 april 2002 18:16
>Subject: RE: [mobile-ip] A Question
about:draft-ietf-mobileip-aaa-nai-00.txt