Subject: RE: [mobile-ip] Last Call: Regional Tunneling input

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Tue, 30 Apr 2002 16:05:34 +0200

Emad, 

  > 	Yes it is not different from the HA registration, but, we are
  > adding additional level(s) for processing registrations. 
  > Therefore, the
  > ultimate timing might be impacted depending on the 
  > scenario. I really
  > wish to see the studies/(bakeoff results if any) for this draft to
  > understand the overall impact to MIP.

=> Just so I understand you, do you mean that it is
like to be worse in terms of performance than standard
MIP?

  > 
  > 	What is the status of the low latency draft? How many vendors
  > have adopted the low latency draft already and have it in their
  > products? Is it required or optional when addition the regional
  > registration scheme? Please don't consider this as a 
  > negative view of
  > the low latency draft, but until these drafts become 
  > adopted and widely
  > implemented, it would be preferable to make new MIP 
  > design/enhancements

=> It's not a negative view but it's certainly inconsistent
with IETF rules. Whether I think that this draft is 
a good one or not, I would strongly suggest that 
we follow one standard process when dealing with
drafts being proposed for standards. 

We had the same argument for the low latency draft
and I'm afraid that requiring vendors to present 
their product plans to IETF to justify whether 
a draft should become an RFC makes no sense at all. 
Does prototyping a solution mean that it will be
in a product? 
What about prototypes by universities are they 
accepatable enough?

  > with the least impact to through traffic. Otherwise, MIP 
  > would be more
  > of non-real time oriented mobility protocol.

=> I hope you're not suggesting that RFC 2002 or 3122
is good for real time.

Hesham

  > 
  > Thx.
  > EQ
  > 	 
  > 
  > > -----Original Message-----
  > > From: [email-masked] [mailto:owner-mobile-
  > > [email-masked]] On Behalf Of Hesham Soliman (ERA)
  > > Sent: Monday, April 29, 2002 5:55 PM
  > > To: [email-masked]'; 'Annika Jonsson';
  > [email-masked]
  > > Subject: RE: [mobile-ip] Last Call: Regional Tunneling input
  > > 
  > > Emad,
  > > 
  > >   > Annika,
  > >   >
  > >   > 	My main concern about this draft:
  > >   >
  > >   > 1) Has there been any studies/scenarios about the impact to
  > >   > in-flight
  > >   > traffic to the MN, while it is performing regional
  > >   > re-registrations?
  > >   >
  > >   > 2) How does the old FA handle the data that is 
  > received while the
  > MN
  > >   > re-registers with a new FA?
  > > 
  > > => Isn't this the same for a HA registration?
  > > Why should we expect this draft to handle all the
  > > handover problems?
  > > The low latency draft handles the problems you
  > > mention, and it includes a section on how to
  > > co-exist with this draft.
  > > 
  > > Hesham
  >

---

From: "Emad Qaddoura" <[email-masked]>
Date: Tue, 30 Apr 2002 18:06:22 +0200

Hi Hesham,

> From: Hesham Soliman (ERA) [mailto:[email-masked]]
> Sent: Tuesday, April 30, 2002 4:06 PM
> To: [email-masked]'; Hesham Soliman (ERA); 'Annika Jonsson';
mobile-
> [email-masked]
[<<<EQ>>>] 
[<<<EQ>>>] Since the regional registration adds more processing, it
would mean longer registration time, due to the hierarchy of
registrations and the different cases that need to be handled.

> drafts being proposed for standards.
[<<<EQ>>>] 
[<<<EQ>>>] I don't disagree. I have been involved with the IETF for many
years.

> What about prototypes by universities are they
[<<<EQ>>>] 
[<<<EQ>>>] Well the question is not requiring vendors to present their
product plans or not. The issue is until such drafts become to the
standard level to where they are adopted, we have to be careful in all
additions to the MIP in terms of not introducing more delays whenever
possible.

> => I hope you're not suggesting that RFC 2002 or 3122
[<<<EQ>>>] 
[<<<EQ>>>] We are on the same lines, No I am not suggesting so.

---

From: "James Kempf" <[email-masked]>
Date: Tue, 30 Apr 2002 08:22:03 -0700

Hesham,

The problem with the low latency draft is that not even universities are
intending to implement it, as far as I can see. So it is not a question
of whether anybody does products or not, but rather whether anybody
wants to implement it at all. I might be wrong, of course, but so far, I
haven't seen any interest.

It is, of course, different with the FMIPv6 draft.

            jak

----- Original Message -----
From: "Hesham Soliman (ERA)" <[email-masked]>
To: <[email-masked]>; "Hesham Soliman (ERA)"
<[email-masked]>; "'Annika Jonsson'"
<[email-masked]>; <[email-masked]>
Sent: Tuesday, April 30, 2002 7:05 AM
Subject: RE: [mobile-ip] Last Call: Regional Tunneling input