Subject: RE: [mobile-ip] Question on RFC3220

From: George Tsirtsis <[email-masked]>
Date: Tue, 30 Apr 2002 11:42:29 -0400

I guess I do not remember what the old meaning was....could you remind me?

Thanks
George

-----Original Message-----
From: Charlie Perkins [mailto:[email-masked]]
Sent: Tuesday, April 30, 2002 4:32 PM
To: George Tsirtsis
Cc: [email-masked]
Subject: Re: [mobile-ip] Question on RFC3220

Hello George,

That's a SHOULD NOT, not a MUST NOT.

The reason for NOT allocating it, would be to avoid damage
to legacy implementations that used the bit for its previous
meaning.

The reason for allocating it, would be to satisfy working
group demand for some other need.

Regards,
Charlie P.

George Tsirtsis wrote:

> Hi all,
>
> This is probably a stupid question but here it is anyway:
> The Registration Request header in MIPv4 have the following flags:
>
>    +-+-+-+-+-+-+-+-+-+-+-+-+
>     ...|S|B|D|M|G|r|T|x|    ...
>    +-+-+-+-+-+-+-+-+-+-+-+-+
>
> of which:
>
>       r        Sent as zero; ignored on reception.  SHOULD NOT be
>                allocated for any other uses.
>
> Can anyone tell me why this SHOULD NOT be allocated in the future?? Is
there
> any logic behind this or it is just an arbitrary act of fate?
>
> Thanks
> George

---

From: George Tsirtsis <[email-masked]>
Date: Tue, 30 Apr 2002 13:46:48 -0400

A good man responded.
Thanks Bob.

George

-----Original Message-----
From: Robert J Marks [mailto:[email-masked]]
Sent: Tuesday, April 30, 2002 6:19 PM
To: 'George Tsirtsis'
Subject: RE: [mobile-ip] Question on RFC3220

V - Van Jacobson compression.

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
|    Registration Lifetime      |R|B|H|F|M|G|V|    reserved     |
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

V        Van Jacobson header compression.  This agent supports use
         of Van Jacobson header compression [10] over the link
         with any registered mobile node.
Bob

> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of 
> George Tsirtsis
> Sent: Tuesday, April 30, 2002 9:42 AM
> To: 'Charlie Perkins'
> Subject: RE: [mobile-ip] Question on RFC3220
> 
>