Subject: [mobile-ip] Move Detection???????

From: "Anjaneyulu" <[email-masked]>
Date: Tue, 25 Jun 2002 16:55:02 +0530

Hi All,
When  MN is performing Move Detection on the basis of Prefix advertised by the router and moves from one foreign network to new foreign network , when he should invalidate the prefixes obtained in a particular foreign network i.e old one???(there are more than one prefix being advertised in a network).

Can u give scenario explaining the move detection?????

Regards,
Anj

---

From: Jari Arkko <[email-masked]>
Date: Tue, 25 Jun 2002 15:38:25 +0300

Anjaneyulu wrote:

> When  MN is performing Move Detection on the basis of Prefix advertised 
> by the router and moves from one foreign network to new foreign 
> network , when he should invalidate the prefixes obtained in a 
> particular foreign network i.e old one???(there are more than one prefix 
> being advertised in a network).

Immediately, if the the MN does not establish forwarding from
a previous care-of address.

The spec doesn't say what lifetime to assume when the MN does
establish such forwarding. However, the BA message received
as a response from the temporary HA has a Lifetime field,
which the HA is expected to fill with a reasonable value.

In any case, forwarding from a previous care-of address has
a limited usefulness period, far smaller than typical prefix
lifetimes.

Jari

---

From: "Anjaneyulu" <[email-masked]>
Date: Tue, 25 Jun 2002 19:02:37 +0530

Hi,
But how to distinguish between the prefixes advertised i.e. whether they are
received in the same foreign network or different????
Case1
======
MN really moved to new FN but there are already some prefixes and default
routers (detected in old FN). In the new FN, the old default routers are
invalid. So how to detect which one to invalidate.

Case 2
=====
MN is in same FN and receives a new prefix and default router. Then all the
other entries belonging to that FN are valid.

---

From: Keiichi SHIMA / 島慶一 <[email-masked]>
Date: Tue, 25 Jun 2002 23:03:48 +0900 (JST)

Hi Anjaneyulu,

From "Anjaneyulu" <[email-masked]>

> other entries belonging to that FN are valid.

One example:

In our IPv6 implementation, we hold the prefix information with the
list of routers which advertises the prefix.  If we have really moved
to another network, the old routers become unreach.  The prefixes
which have no routers reachble become DETACHED (this is our term,
which means that the prefix is no more usable because there is no
routers which advertises the prefix).  The addresses which have a
DETACHED prefix are less preferable than other addresses.

We detect movement if the old CoA becomes DETACHED and there are
another CoA available.

Best Regards,

---
Keiichi SHIMA
IIJ Research Laboratory <[email-masked]>
KAME Project <[email-masked]>