Subject: Issue #43 (was, Re: [mobile-ip] Re: MIPv6 - 17 Review)

From: "Charles E. Perkins" <[email-masked]>
Date: Sat, 22 Jun 2002 16:51:32 -0700

Hello Krishna,

The Binding Refresh Request message is useful for cases
where the Lifetime is 10 times or dozens of times larger
than the expected Refresh interval.  The idea was to avoid
having the availability of nonvolatile storage at the
home agent be a factor when choosing a value for the Lifetime.

Thus I think it is useful, but I really think that we will
have to wait and see to be sure.  Furthermore, if people
think that it is useful for only a small percentage of the
total number of Binding Updates, then we could reorganize
the feature as controlled by an option instead of a field
that is present in all Binding Update messages.  If this is
preferred, I'd like to find out immediately so that we can
fix the specification before the deadline.

Regards,
Charlie P.

> 19. Section 10.2 : The para about :
> 
>    "-  The Refresh field MUST be set to a value less than or equal to"
> 
>    Is Refresh useful at all ? I don't believe it is. It seems to imply that
> it
>    helps in the case of the Home Agent crashing and has only a volatile
> storage
>    for the binding cache.  But if the Home Agent crashed before the Refresh
> 
>    interval is over, the behaviour is identical to the case where the
> Refresh
>    field contains the same value as Lifetime.
> 
>    It will be useful only if the HA crashed after the Refresh interval but
> before
>    the Lifetime interval. Hence it is completely useless in most
> situations.
> 
>    If this can be removed safely, all references need to be removed in the
>    draft and the Format of the BU section (6.1.8) needs to reflect this.

---

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Mon, 24 Jun 2002 14:20:20 +0200

=> So couldn't we set the lifetime to what was meant
to be a refresh time? doesn't this have the same effect?

  > fix the specification before the deadline.

=> I think this would be better. The MH would be 
better aligned without that row anyway.So it 
would be goo to send it when needed.

Hesham