Subject: Re: [mobile-ip] comments on MIPv6 draft-17

From: Keiichi SHIMA / 島慶一 <[email-masked]>
Date: Mon, 03 Jun 2002 15:03:12 +0900 (JST)

Hi Vijay,

I think I understand what you are talking about.  There are four types
of CN.

CN0:  has no special MIP6 processing code.
CN1:  processes HAO only if it is protected (by IPsec).
CN2:  processes HAO only if it is protected (by IPsec)
      and accepts a BU only if it is protected (by IPsec).
CN3:  does RR
      and processes HAO if it is verified
      and accepts a BU if it is protected (by RR).

There is a combination of CN1/CN2 and CN3 also.

If we want to mandate something, we must make sure the following.

for CN0:     nothing.
for CN1:     we never change the HAO processing.
	     For example, we never say 'IPseced HAO is not enough.
	     Lets' obsolete it!' as we have done in the transision to ID16.
for CN2:     same for CN1 and,
	     we never change BCE related processing.
	     For example, we never change the binding update format, 
	     the routing header type 2 format, etc...
for CN3:     same for CN1 and CN2 and,
	     we never change RR processing.

You want to make CN2 functions mandate for all IPv6 node, don't you?

Best Regards,

---
Keiichi SHIMA
IIJ Research Laboratory <[email-masked]>
KAME Project <[email-masked]>

---

From: Vijay Devarapalli <[email-masked]>
Date: Mon, 03 Jun 2002 13:59:56 -0700

> There is a combination of CN1/CN2 and CN3 also.

you are right. for example something like CN2 and CN3.

>              we never change RR processing.

I am bit uncomfortable using the term 'never'.  but I am reasonably 
sure that these wont change. I dont know who can give you that
guarantee.

> You want to make CN2 functions mandate for all IPv6 node, don't you?

yes. but in addition I would also like CN3 mandated. RR can only
improve from now on.

regards
Vijay