Subject: [mobile-ip] MIPv6 Doubts!!!!!

From: "Anjaneyulu" <[email-masked]>
Date: Fri, 14 Jun 2002 15:44:38 +0530

Hi,

Doubt1
=====
When the Mobile Node is in the Home Network, which routers will it select as candidates for default router.
As home agents are also candidated for default routers.
I have a doubt that when the mobility feature is enabled on a host(Mobile Node) , should he only consider entries in the home agents list as the default router or can it also opt from default router list.

Doubt2
=====
Can you give the scenario where more than one prefix is advertised to Mobile Node having single interface???

Regards,
Anj

---

From: Vladislav Yasevich <[email-masked]>
Date: Fri, 14 Jun 2002 09:18:45 -0400

Anjaneyulu wrote:
> I have a doubt that when the mobility feature is enabled on a 
> host(Mobile Node) , should he only consider entries in the home agents 
> list as the default router or can it also opt from default router list.

I would say that that is should consider all routers on the link that are
advertising themselves as default.  But that prompts another question.
Does the mobile flush the default router list every time it moves?

The reason I ask the question is that the default router list is bound by
AdvDefaultLife and will grow while the lifetime on the default routes is
valid.  Once the mobile has moved on, the default routers are no longer
reachable, but might still be tried by the mobile and cause fairly long
delays (when a stale unreachable ND cache entry exists, ND failure
takes about 10 seconds).

> Mobile Node having single interface???

1.  The whole network is multihomed.
2.  A mobile subnet is multihomed

-vlad
+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Vladislav Yasevich	       Tru64 UNIX - IPv6 Project Lead
Hewlett Packard 	       Tel: (603) 884-1079
Nashua, NH 03062	       ZKO3-3/T07

---

From: Vijay Devarapalli <[email-masked]>
Date: Fri, 14 Jun 2002 11:17:58 -0700

> As home agents are also candidated for default routers.

isnt this is a generic issue of choosing a default router when there 
are multiple routers on a link. just pick one. 

there is a new draft
http://www.ietf.org/internet-drafts/draft-ietf-ipv6-router-selection-02.txt
which introduces extensions to Neighbor Discovery to make default
router selection more deterministic.

> list as the default router or can it also opt from default router

when the MN is just staying put in the home network, then the Home 
Agent does not come into the picture. it can pick any router on the 
home link as the default router. 

Vijay