Subject: Re: [mobile-ip] RE: RFC 2462 DAD optimization

From: Charlie Perkins <[email-masked]>
Date: Sat, 01 Jun 2002 20:26:51 -0700

Hello Dave,

Actually, I would be in favor of making link-local to be the
same as "subnet-local".  I don't see the advantage in making
any distinction.  And, I think that the advantage of only having
to do DAD for a single address per subnet is a very good
advantage, one that turns out to be especially handy for
mobile nodes while they are traveling.

In fact, I would say that not having this feature is tantamount
to restricting mobile nodes to a single home address.
Otherwise, it gets to be too much work for the home agent.

Am I missing some good feature that results from making
the distinction?

Regards,
Charlie P.

Dave Thaler wrote:

> As mentioned in email I sent a week or two back, this is
> related to the issue of whether a link-local address has to be
> unique across an entire subnet, not just a link.  Today it's
> defined as a "link-local" not a "subnet-local" address.  This
> means that it is not guaranteed to be unique across a subnet.
>
> Manually configured global addresses don't need to require
> rights to the corresponding link-local address since
> a) it's not necessary as they don't use the link-local address,
> b) it's not sufficient since they need to be unique across the
>    subnet, not just the link.
>
> So unless you're proposing we redefine "link-local" addresses
> as "subnet-local" addresses (which would at least be a
> consistent argument, albeit a change to the architecture),
> then what you suggest does not seem to me to be the right solution.
>
> -Dave

---

From: "Dr. Subrata Goswami" <[email-masked]>
Date: Sat, 1 Jun 2002 20:45:32 -0700

I am just curious about what are  the technical differences between a
link-local address and a subnet-local address.

I agree with Dave that, doing a DAD for "link-local" type of post-fix
address is a unnecessary restriction. 

1. There might be global addresss manually configured with the same
post-fix but  with different pre-fix as the link-local address of a
node. What would HA do if a node like that moves into its territory  ?
2. For 64-bit post-fix it would render  2**64 perfectly good addresses
useless.

Subrata

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of Dave Thaler
Sent: Friday, May 31, 2002 10:59 AM
To: Charles E. Perkins; Richard Draves
Cc: [email-masked]; IPng Working Group
Subject: [mobile-ip] RE: RFC 2462 DAD optimization

-Dave

> -----Original Message-----
> From: Charles E. Perkins [mailto:[email-masked]]
> Sent: Friday, May 31, 2002 10:45 AM
> To: Richard Draves
> Cc: [email-masked]; IPng Working Group
> Subject: Re: RFC 2462 DAD optimization
> 
> 
> Hello Richard,
> 
> Even manually configured global addresses should be required
> to acquire rights to the corresponding link-local address.  Why not?
> 
> Regards,
> Charlie P.
> 
> 
> Richard Draves wrote:
> >
> > I disagree. I think the problem is in the RFC 2462 optimization. The
RFC
> > 2462 optimization also can fail with manually-configured addresses -
> > it's not just a problem with RFC 3041 temporary addresses.
> >
> > I'm curious about the implementation status. I know the Windows
> > implementation does not implement the RFC 2462 optimization - it
> > performs DAD on every address independently. What about other
> > implementations?
> >
> > Rich
> >
> > > -----Original Message-----
> > > From: Charles E. Perkins [mailto:[email-masked]]
> > > Sent: Friday, May 31, 2002 10:03 AM
> > > To: Hesham Soliman (ERA)
> > > Cc: [email-masked] '; 'IPng Working Group '
> > > Subject: Re: [mobile-ip] Issue #23 and Issue #30
> > >
> > >
> > >
> > > Hello Hesham,
> > >
> > > "Hesham Soliman (ERA)" wrote:
> > >
> > > > => RFC 2462 makes an optimisation (not a good
> > > > one IMHO) that if a node does DAD on link-local
> > > > addresses, it 'owns the interface id' for any other
> > > > address with any scope.
> > >
> > > I think this is a good idea.
> > >
> > > > RFC3041 says that a node can generate a new iid
> > > > and does DAD for _that_ address which uses the
> > > > new iid. Since this is typically not a link local
> > > > address, you could get a conflict if the HA
> > > > does not defend all addresses.
> > >
> > > The problem is that RFC 3041 should require any
> > > such node to first acquire rights to the link-local
> > > address.  I hope that is viewed as an omission, and
> > > one which can be quickly repaired.
> > >
> > > Regards,
> > > Charlie P.
> --------------------------------------------------------------------
> IETF IPng Working Group Mailing List
> IPng Home Page:                      http://playground.sun.com/ipng
> FTP archive:                      ftp://playground.sun.com/pub/ipng
> Direct all administrative requests to [email-masked]
> --------------------------------------------------------------------

---

From: Charlie Perkins <[email-masked]>
Date: Sat, 01 Jun 2002 22:41:13 -0700

Hello Subrata,

I reckon I am missing your point, so here is a request for clarification:

> address is a unnecessary restriction.

The choice seems to be to do DAD once for a "link-local" or
"subnet-local" address (even if the node didn't configure one (?!?)),
vs. doing DAD for _every_ configured address.

So, the thing you label a "restriction" seems to bring a large
measure of freedom, if I understand you correctly.

> node. What would HA do if a node like that moves into its territory  ?

The HA would deny that node use of the link.  This is quite unlikely
to ever happen, though.

> 2. For 64-bit post-fix it would render  2**64 perfectly good addresses

I don't understand what you mean here.  Which addresses are useless?

Regards,
Charlie P.

---

From: "Dr. Subrata Goswami" <[email-masked]>
Date: Sun, 2 Jun 2002 01:08:41 -0700

Why is that ?

 
Because you are ignoring the pre-fix (which can be 64 bits).

-----Original Message-----
From: Charlie Perkins [mailto:[email-masked]] 
Sent: Saturday, June 01, 2002 10:41 PM
To: Dr. Subrata Goswami
Cc: [email-masked]; 'IPng Working Group'
Subject: Re: [mobile-ip] RE: RFC 2462 DAD optimization

Hello Subrata,
 
I reckon I am missing your point, so here is a request for
clarification:

 

 

Regards,
Charlie P.