Subject: [mobile-ip] MN source address in MIPv6

From: Luís Miguel Oliveira <[email-masked]>
Date: Tue, 11 Jun 2002 17:42:05 +0100

Hi,

I'm studding mobile IPv6 in transition scenarios (IPv4 /IPv6). When MN way from home network it uses the CoAddr as source address to avoid triangle routing and its home address are sent in one of destination option. These comportment is problematic when we try to use transitions mechanisms (like NAT-PT, TRT) to connect to IPv4 CN.

It is possible to disable IPv6 Binding mechanisms under these situations? 

Anyone was a solution?

Thanks in Advance.

Luís Miguel Oliveira

---

From: Jari Arkko <[email-masked]>
Date: Wed, 19 Jun 2002 18:37:48 +0300

Luis Miguel Oliveira wrote:

> I'm studding mobile IPv6 in transition scenarios (IPv4 /IPv6). When MN 
> way from home network it uses the CoAddr as source address to avoid 
> triangle routing and its home address are sent in one of destination 
> option. These comportment is problematic when we try to use transitions 
> mechanisms (like NAT-PT, TRT) to connect to IPv4 CN.
> 

In the current design you have to handle at least the
first situation below. You may handle the second situation,
if you want to:

1. Route optimization is not used. Then all packets in both
    directions go through the HA. I would assume the translation
    device has to reside between the HA and the CN. In this case
    there's really no difference whatsoever to regular IPv6
    communications, so it should work.

2. Route optimization is used. Then all packets in both
    directions go straight to the CN. Or the translation
    device at least.

    If the translation device for some reason can't handle
    this, it could presumably drop all MH packets, causing
    the mobile node to fail in setting up route optimization
    even if it tried to.

Jari