Subject: [mobile-ip] Issue 20 (extensibility) can be closed

From: Jari Arkko <[email-masked]>
Date: Thu, 27 Jun 2002 21:43:57 +0300

I believe issue 20 -- about the extensibility of the
authorization mechanism to future schemes -- can be
closed with the following observation:

Methods that extend RR with new mobility options can be
accommodated with the inclusion of these mobility options in the
HoTI and CoTI messages.  A receiver that recognizes these options
will return corresponding options. A receiver that does not will
skip the options and behave as for RR. The sender will see this
and can abort the procedure by not sending a Binding Update, if
he so desires.

Methods that extend RR with new message types can be accommodated,
as the peer will reply with the Binding Error (2) message if it
does not recognize the new message.

No new text needed for this.

---

From: "James Kempf" <[email-masked]>
Date: Thu, 27 Jun 2002 15:51:19 -0700

Jari,

I'm curious about whether ABK would fit into this scheme.

Basically, we see ABK as not needing either HoTI or CoTI. The MN exchanges protocol with the CN instructing the CN to load the
id-crypto parameters from the HA. After the parameters are loaded, the MN can send signed BUs to the CN without having to use any
other security signaling.

            jak

---

From: Jari Arkko <[email-masked]>
Date: Fri, 28 Jun 2002 14:01:07 +0300

> other security signaling.

You could add new MH Message Types for the 'instructing' and 'loading'. If the CN does
not support ABK i.e. these new types, it would return a Binding Error.

Jari