Subject: RE: Issue #43 (was, Re: [mobile-ip] Re: MIPv6 - 17 Review)

From: "Hesham Soliman (EAB)" <[email-masked]>
Date: Thu, 27 Jun 2002 20:36:18 +0200

Hi Charlie, 

Since the information was presented and dicussed
and those who had opinions all agreed on removing
this field and making it an option, I think we
should go ahead with that. If we all missed some 
other valid reason for having it, then there is not
much that we can do. OTOH, it seems like there are
good reasons now for not having this field. 

Hesham

  > -----Original Message-----
  > From: Charles E. Perkins [mailto:[email-masked]]
  > Sent: Thursday, June 27, 2002 1:36 AM
  > To: Jari Arkko; Krishna Kumar
  > Cc: [email-masked]
  > Subject: Re: Issue #43 (was, Re: [mobile-ip] Re: MIPv6 - 17 Review)
  > 
  > 
  > Hello folks,
  > 
  > First, I need to clearly state that I am in the role of providing
  > information, not crusading, because I am neutral.
  > 
  > Having said that, I feel that there is a need to present the
  > information about this issue so that a better informed decision
  > can be made.   I forgot who originally proposed this field (it was
  > not me), but it was discussed more than once before, and it does
  > not seem right to expunge it if it's not clearly understood.
  > 
  > It is true, that mixing together lifetime issues due to two
  > different effects (home agent volatility vs. node mobility)
  > may invite problems in the future.  Thus, I do not like the
  > suggestion that we should make the lifetime to be the minimum
  > of the two effects in all cases.
  > 
  > On the other hand, we don't need to have the Refresh field
  > in all Binding Acknowledgements, most probably.  So, I will
  > take it out.  Then the question is whether we should have a
  > option for the information.  That seems to me to be the right
  > solution, given the long history of the field.  The purpose of
  > the information is only advisory; the home agent would keep
  > the binding current for the full lifetime of the Binding
  > anyway, even if a new Binding Update did not arrive within
  > Refresh seconds.
  > 
  > If consensus is to remove the feature entirely even after
  > understanding what it was for, then that is also O.K. with me.
  > I would just expect that it amounts to omitting the feature
  > entirely, not causing it to be commingled with whatever
  > considerations cause selection of a particular Lifetime value.
  > 
  > Regards,
  > Charlie P.
  > 
  > 
  > 
  > 
  > Jari Arkko wrote:
  > > 
  > > Krishna Kumar wrote:
  > > 
  > > > Hi Charlie,
  > > >
  > > > I feel that if the availability of nonvolatile storage 
  > should be a factor
  > > > in determining the lifetime, the following method would 
  > work better :
  > > >
  > > >       If non-volatile storage is available, use a large 
  > value for
  > > >       lifetime  (which is the same as described in the draft, eg
  > > >       something in the range of many hours).
  > > >       Otherwise use smaller values (eg something in the range
  > > >       of many minutes).
  > > >
  > > > Keeping a Refresh value is simulating the above algo by 
  > giving lower
  > > > values for a refresh if there is no non-volatile 
  > storage , and higher
  > > > values (full lifetime) if there is a non-volatile 
  > storage. Why not remove
  > > > the field completely and just use the values based on 
  > type of storage,
  > > > and get the same characteristics ?
  > > 
  > > I agree.
  > > 
  > > > I think that Refresh is not needed for the above 
  > mentioned reason, but
  > > > if the community feels otherwise, I feel an option 
  > might make it more
  > > > cumbersome. In that case it might be better to preserve 
  > this field in the
  > > > BA, instead of making significant changes.
  > > 
  > > I agree here as well.
  > > 
  > > My suggestion is that we remove the field.
  > > 
  > > Jari
  >

---

From: "Charles E. Perkins" <[email-masked]>
Date: Thu, 27 Jun 2002 11:47:31 -0700

Hello Hesham,

I believe your message substantially agrees with the meaning
of my message which you have quoted.  The field has been gone
from draft-18 text now for quite a few hours :-)

Regards,
Charlie P.