Subject: Re: [mobile-ip] Feedback on draft-ietf-mobileip-nat-traversal-04.txt

From: Behcet Sarikaya <[email-masked]>
Date: Thu, 20 Jun 2002 11:43:06 -0500

Henrik,
  I think there was a last call on this draft from IESG but I could find 
the mail so I am writing to the list:
On page 17 you said:
A foreign agent using MIP UDP tunnelling to a home agent because **it**
   is situated behind a NAT may be configured to encourage reverse
   tunnelling, or be neutral about it, depending on the characteristics
   of the NAT. 

the it above, does it refer to HA or FA?
I think it is HA, and not FA.
Therefore my suggestion is to replace the it by HA to make it specific 
and clear.
  Sorry if this mail came to late to change things.

Regards,

Henrik Levkowetz wrote:

--behcet

---

From: "Henrik Levkowetz" <[email-masked]>
Date: Thu, 20 Jun 2002 19:12:31 +0200

Bechet, 

	Thanks, you are right, this should be clarified. 

	'it' in the text you quote actually refers to the FA being
situated behind a NAT.

	The last call period is till July 2nd, so there should be 
no problem incorporating this clarification.

	Best regards,
		Henrik

---

From: Behcet Sarikaya <[email-masked]>
Date: Thu, 20 Jun 2002 13:40:14 -0500

Henrik,
  Oh, really. I think stating that
A foreign agent
   situated behind a NAT
is out of scope
or
is NP-hard problem
or
an immediate version-up is recommended

would be better.

Regards,

---

From: "Henrik Levkowetz" <[email-masked]>
Date: Fri, 21 Jun 2002 00:31:21 +0200

Bechet,

	The draft deals with both MN behind NAT and FA behind
NAT. Regarding FAs, this is from section 4.5:

	"The UDP Tunnel Request Extension MAY be used by a foreign agent when
   it is forwarding a Mobile IP Registration Request to a home agent,
   when the foreign agent is situated behind a NAT or has some other
   compelling reason to require MIP UDP tunnelling.

What I propose to do to clarify the text you originally commented on is
to replace 'it' with 'the FA'.

Maybe I don't quite understand your most recent question below?

	Henrik

---

From: Behcet Sarikaya <[email-masked]>
Date: Thu, 20 Jun 2002 17:46:43 -0500

Henrik,
  As far as I know there has been no interoperability tests on this part 
of the draft. If there is enough evidence that it can be made work, then 
let's keep it.
Regards,