Subject: RE: [mobile-ip] Fast Handover draft: proposed revisions

From: Singh Ajoy-ASINGH1 <[email-masked]>
Date: Fri, 26 Jul 2002 13:04:37 -0500

Hello Alper,
Please find my inline reply.
Regards,
ajoy

-----Original Message-----
From: Alper E. YEGIN [mailto:[email-masked]]
Sent: Thursday, July 25, 2002 7:30 PM
To: Singh Ajoy-ASINGH1; 'Vijay Devarapalli'
Cc: 'James Kempf'; Rajeev Koodli; [email-masked]
Subject: Re: [mobile-ip] Fast Handover draft: proposed revisions

Hello Ajoy,

> Generalizing "anticipated FMIPv4" results to "anticipated FMIP" and
> then applying to "anticipated FMIPv6" without experimenting is not a
> good idea. Protocols are sufficiently different to make considerable
> performance differences.
> 
> Ajoy-> I think claiming something works without proper data and 
> argument is also not a good idea. BTW, do you agree that due to higher
> RTT of cellular link, FMIPv6 will require higher anticipation
> time ? 

Yes of course.

> As you increase anticipation time, the likelihood
> of handover failure will increase. 

This statement by itself also make sense...

Ajoy-> Good 

But, the question is how much difference does it make?
Experimentation can help answer this question, and this is 
why I was asking if your statements were based on 
FMIPv6 experiments...

Also, how much heads up can the mobile terminal or the network
get before the link is broken without any anticipation? 
I presume link down doesn't happen instantly, at least L2 has to 
exchange some messages. Is there a window
in which L3 can exchange packets?

> I do not think this has 
> anything to do with FMIPv6 or FMIPv4. You will observe
> similar behavior in either case. 

But there is more... A fundamental difference between
FMIPv6 and pre-reg FMIPv4 is that with the latter the
registration request has to go all the way to home agent.
This not only effects the latency, but also prevents taking
advantage of L2 triggers on the oFA/oAR to precisely
determine when the routing should change.. And this
should make a difference in the observed performance..

Ajoy-> BTW, in our implementation there were a few hops 
between FA and HA. So, probably this distinction of FMIPv4 
is not relavent in this discussion. I do agree the FMIPv4 problem
will be even worse when FA and HA are located at the two end of the 
Internet.

alper

---

From: "Alper E. YEGIN" <[email-masked]>
Date: Fri, 26 Jul 2002 18:22:03 -0700

Ajoy,

You missed my questions below.. Any data points on these areas?
I'm asking these specific to your cellular links...

alper