Subject: [mobile-ip] MIPv6 rev 18 - Editorial in chapter 8

From: "Hesham Soliman (EAB)" <[email-masked]>
Date: Wed, 3 Jul 2002 17:36:52 +0200

I think there is some ambiguity in chapter
8. It should be clearly stated that this chapter
does not place requirements on All IPv6 nodes. 
The heading of chapter 8.2 says:

'Route Optimization Requirements for All IPv6 Nodes'

I think that people can get confused by this. 
Somewhere in the beginning of chapter 8 it should 
be made clearer that nodes implementing RO are 
a subset of all IPv6 nodes on the Internet. 
Also I think the heading should change to:

'Requirements for IPv6 Nodes that support route optimisation'

Also, I still wonder about the point behind
the MUST in 8.1 for the HAO. We all agreed that
it MUST be supported

Hesham

---

From: Jari Arkko <[email-masked]>
Date: Thu, 04 Jul 2002 09:52:40 +0300

> 'Requirements for IPv6 Nodes that support route optimisation'

Yes. Thanks for noting this. The intention was indeed
to specify the MUSTs for nodes that support RO, and then
leave the decision of which nodes support RO to the node
requirements document that is being worked on in the IPv6
WG.

=> new issue #52

> the MUST in 8.1 for the HAO. We all agreed that

There's two things here. One is whether the current
spec adequately explains how all this works even if RO
is not used. Does it? Secondly, how useful is the
functionality?

=> new issue #53 (hmm... it has been discussed before...)

Jari

---

From: Vijay Devarapalli <[email-masked]>
Date: Mon, 08 Jul 2002 11:14:33 -0700

> => new issue #53 (hmm... it has been discussed before...)

I havent seen the text for this new issue. but this has been
discussed as part of both Issue #31 and Issue #45. and both
issues have been closed.

Vijay