Subject: Re: [mobile-ip] MIPv6 rev 18 - Editorial in chapter 8

From: Vijay Devarapalli <[email-masked]>
Date: Wed, 03 Jul 2002 11:27:27 -0700

Hesham Soliman (EAB) wrote:

> Sorry, unfinished sentence at the end. I
> just discovered that I sent it by accident.
> 
> The last paragraph should read:
> Also, I still wonder about the point behind
> the MUST in 8.1 for the HAO. We all agreed that
> it MUST be supported when a BCE entry, what is 

actually no. we agreed that HAO MUST be processed if the home
address can be verified. verifiability of the home address can be 
achieved by mechanisms other than the a valid BCE entry. for example, 
lets asumme the MN and CN have an IPsec protected data session with
the SA created on MN's home address. in this case the verifiability 
comes from the IPsec SA. another case is, when the CN and MN belong
to the same 'trusted' domain. in this case the HAO can be processed. 
there are other mechanisms like Rajeev's and Charlie's HAO tagging
proposal to verify the HoA.

IMO, HoA verifiability is something I believe we can solve. it
would be wrong to restrict ourselves now by saying HAO MUST NOT be
processed if a vaild BCE does not exist.

> the point of having it supported just in case
> IPsec exists? 
> Is it to use triangular routing? There is nothing

yes. you can have triangular routing if the home address can be
verified.

regards
Vijay

---

From: "Hesham Soliman (EAB)" <[email-masked]>
Date: Wed, 3 Jul 2002 19:15:23 +0200

The last paragraph should read:
Also, I still wonder about the point behind
the MUST in 8.1 for the HAO. We all agreed that
it MUST be supported when a BCE entry, what is 
the point of having it supported just in case
IPsec exists? 
Is it to use triangular routing? There is nothing
in the draft about that. i don't see the benefit, 
but I see confusion for someone reading the spec
and trying to understand what's going on. 

Hesham

PS: The rest of the comments (before this paragrph) 
still apply.

  > I think there is some ambiguity in chapter
  > 8. It should be clearly stated that this chapter
  > does not place requirements on All IPv6 nodes. 
  > The heading of chapter 8.2 says:
  > 
  > 'Route Optimization Requirements for All IPv6 Nodes'
  > 
  > I think that people can get confused by this. 
  > Somewhere in the beginning of chapter 8 it should 
  > be made clearer that nodes implementing RO are 
  > a subset of all IPv6 nodes on the Internet. 
  > Also I think the heading should change to:
  > 
  > 'Requirements for IPv6 Nodes that support route optimisation'
  > 
  > 
  > it MUST be supported
  > Hesham