Subject: RE: [mobile-ip] Fast Handover draft: proposed revisions

From: [email-masked]
Date: Fri, 12 Jul 2002 16:22:37 -0500

Ajoy,

> 
> Basavraj,
> I am not asking to specify L2 trigger in fast handoff draft.
> We just have to state the appropriate L3 behaviors when 
> specific link layer triggers are available. BTW, that is what 

I think we are agreeing on the general approach on how to deal
with triggers. All I am saying is that if link layer X provides
specific triggers to the upper layer, a separate I-D can
document how fast HO will work when these triggers (which would
be identified in that draft) are available. 
So rather than going down the path of identifying all the possible
link layer triggers and the corresponding behavior at L3, the
base FMIPv6 draft should simply document the L3 behavior.

> is done in version V4 of the FMIPv6 draft. 

And my belief is that the current L2 triggers specification in the
version 4 of the draft is of really no help and needs to be moved
to a more appropriate draft that deals with these triggers,.

> regards,
> ajoy 

Cheers,
-Basavaraj

---

From: Behcet Sarikaya <[email-masked]>
Date: Fri, 12 Jul 2002 16:47:17 -0500

Raj,
  I completely agree with you.

Regards,

-- 
Behcet

---

From: "James Kempf" <[email-masked]>
Date: Sat, 13 Jul 2002 05:45:09 -0700

Raj,

I don't think it is quite as simple as just documenting the L3 behavior.

For example, if there is no prehandover notification, it is impossible to do address preconfiguration. Similarly, if there is
prehandover notification on the access router with the appropriate information, it is possible to do tunnel establishment
without any over the air signaling. Both of these are considerably more optimized than what draft 05 seems to allow as a
nonerror case.

I think it should be possible to state what the layer 2 requirements are for particular optimized sequences of layer 3
signaling without going down the path of specifying triggers for specific layer 2s. That is what the layer 2 triggers draft
was attempting to do, but perhaps it has become too specific.

            jak