Subject: RE: [mobile-ip] Fast Handover draft: proposed revisions

From: Singh Ajoy-ASINGH1 <[email-masked]>
Date: Wed, 17 Jul 2002 17:27:42 -0500

Hello Alper,
Please find my inline reply.
regards,
ajoy

-----Original Message-----
From: Alper E. YEGIN [mailto:[email-masked]]
Sent: Tuesday, July 16, 2002 9:29 AM
To: Singh Ajoy-ASINGH1; 'Vijay Devarapalli'
Cc: 'James Kempf'; Rajeev Koodli; [email-masked]
Subject: Re: [mobile-ip] Fast Handover draft: proposed revisions

Hi Ajoy,

> Ajoy-> Target trigger will be suitable for cellular 
> networks.  BTW, even in case of WLAN, you can receive
> L2-TT trigger at nAP. L2TT (Re-association Request) can 
> provide nAP the L2 address of the oldAP as well as L2 
> address of the mobile node. If we implement FA function 

Does re-association also apply to BSS mode, or when
the station moves between two different ESS?

If it is only used when the station moves from one AP
to another in the same ESS, this is not as interesting,
because the mobility is already handled at link-layer
in 802.11b.

Ajoy-> Mostly I have seen Re-association Request is sent 
whenever an MN moves from one AP to other AP in the same ESS. 
This is partly because IAPP handles intra-ESS handoff.
I believe this is an implementation issue and 
can be easily extended, if Mobile/IP provides appropriate hooks. 

> at AP, then this becomes an implementation issue. 
> If not, then you need to define some protocol between 
> AP and AR which can be addressed in separate document. 

http://www.ietf.org/internet-drafts/draft-yegin-l2-triggers-00.txt

...

> Ajoy->IP layer protocol only works for Mobile Initiated trigger. It does
> not work for network initiated trigger. BTW, based upon our 
> implementation, we found anticipated handover does not provide
> good performance on cellular link. Hence, anticipated handover
> is not going to address fast handoff need for various cellular networks. 

Ajoy, was that an FMIPv4 implementation, or FMIPv6 implementation?

Ajoy-> We implemented FMIPv4. But I do not believe FMIPv6 implementation
will provide substantially better performance. More or less the basic 
idea is same. I think the part of the problem is high RTT of 3G wireless 
link (MN to AR). So, adding lots of signaling messages over the high RTT 
link will require sufficiently higher anticipation time. If you keep 
very high anticipation time, handover may not be consistently 
reliable.

---

From: "Alper E. YEGIN" <[email-masked]>
Date: Wed, 17 Jul 2002 19:40:18 -0700

Hi Ajoy,

> This is partly because IAPP handles intra-ESS handoff.

Exactly.... So, IAPP already takes care of the mobility, no need
for higher layer mobility management in that particular case.

> can be easily extended, if Mobile/IP provides appropriate hooks.

I wonder if the spec allows/enables use of re-association messages
in BSS mode.

And than, if client is already sending a re-association message, why not
use ESS and IAPP for this? Why would people need another protocol
that looks like IAPP on the same network..

> very high anticipation time, handover may not be consistently

Generalizing "anticipated FMIPv4" results to "anticipated FMIP" and
then applying to "anticipated FMIPv6" without experimenting is not a
good idea. Protocols are sufficiently different to make considerable
performance differences.

alper