Subject: RE: [mobile-ip] Fast Handover draft: proposed revisions

From: Singh Ajoy-ASINGH1 <[email-masked]>
Date: Wed, 31 Jul 2002 08:59:18 -0500

Alper,
In my previous reply to Rajeev, I explained why
MN is not required to know the L2 address of nAR 
in case of srial link. Why this question again? If you do 
not agree, please comment on my previous 
email.
Regards,
Ajoy 

-----Original Message-----
From: Alper E. YEGIN [mailto:[email-masked]]
Sent: Tuesday, July 30, 2002 6:12 PM
To: James Kempf; Rajeev Koodli
Cc: Singh Ajoy-ASINGH1; 'Vijay Devarapalli';
[email-masked]
Subject: Re: [mobile-ip] Fast Handover draft: proposed revisions

I think we need to include the complete question here:

  1. How does the MN get the L2 address and IP address of the
       new AR ? I see the following possibilities
  a) PrRtAdv provides this
  b) upon establishing a new link, the MN does RS and gets an RA

  How can you avoid PrRtAdv ? Can we assume that L2 trigger
  provides the necessary information ? Which L2 trigger today
  provides such information?

Does MN really get "L2 and IP address of the new AR"?
I see MN is aware of the L2 id of the Base Stations, but note
that this is not same as L2 id of AR(s) behind them.

alper

----- Original Message -----
From: "James Kempf" <[email-masked]>
To: "Alper E. YEGIN" <[email-masked]>; "Rajeev Koodli"
<[email-masked]>
Cc: "Singh Ajoy-ASINGH1" <[email-masked]>; "'Vijay Devarapalli'"
<[email-masked]>; <[email-masked]>
Sent: Tuesday, July 30, 2002 1:58 PM
Subject: Re: [mobile-ip] Fast Handover draft: proposed revisions

> > > Which L2 trigger today
> > > provides such information?
> >
> > I'm not aware of any...
> >
>
> I refer you to "Draft Standard for W-CDMA (Wideband Code Division Multiple
> Access) Air Interface Compatibility Standard for 1.85 to 1.99 GHz PCS
> Applications", ANSI J-STD-015, 1998, Section 11.7 "Handoff Operation",
Section
> 12.2.4.3, "Handoff Messages," Section 12.2.5.3.7, "Handoff Parameter", and
> Section 12.25.3.8, "Handoff Indication". This version is a little old but
> probably not very far off from the current W-CDMA specification.
>
> In Section 11.7, the procedures for mobile controlled and network
controlled
> handover are described. In the mobile controlled case, the mobile sends a
layer
> 2 identifier to the current base station indicating the target base
station to
> which the mobile wants to hand over, and gets back a response indicating
whether
> handover is allowed or denied. In the network controlled case, the current
base
> station sends the same information to the mobile. (Note: "layer 3" in this
> specification actually refers to what from the IP viewpoint would be the
MAC
> layer, or layer 2). The network controlled case is used to manage power
and cell
> load, the mobile controlled case is used when the power level on the
mobile goes
> below the specified handoff point.
>
> In either case, the SolPrRtAdv and PrRtAdv of FMIPv6 duplicate, at the IP
layer,
> what W-CDMA already does at the MAC layer. Also in either case, the layer
2
> information should be sufficient to allow the base station to perform a
layer 3
> handover without any over the air layer 3 signaling, provided the base
station
> has a way to map the target base station id to an IP address, using GAARD
or a
> preconfigured table.
>
> Of course, in the R99 UTRAN, the actual W-CDMA protocol is buried under
the NBAP
> and RNSAP RAN protocols.
>
> I don't have access to an IS-2000 specification at the moment, but I'm
working
> on getting the same information. Other wireless link layers must provide
this
> information in some form, either before handover, as with the cellular
> protocols, or afterwards, as with 802.11. Barring make before break,
without
> some information at layer 2 about where the mobile is going, it is simply
> impossible for the link to get switched, and, without a link, it is not
possible
> to do IP. If the layer 2 protocol supports real make before break (not
soft
> handover), none of the fast handover protocols are necessary, since the
mobile
> can do RS/RA on the forward link while receiving its traffic on the
backward
> one.
>
>             jak
>
> (fyi, Alper, the specification in question is in the DoCoMo library, if
you care
> to check it out.)

---

From: "Alper E. YEGIN" <[email-masked]>
Date: Wed, 31 Jul 2002 12:10:47 -0700

Hi Ajoy,

> in case of srial link. Why this question again?

The reason I cut-and-pasted the same question from an
earlier message was to make sure that we were answering the
same question with James....

> If you do

But now that you asked....
This is becoming more and more like a L2 handover mechanism,
now that the IP stack of MN doesn't even know it changed its
default router... Probably one can make this work, but making
serial link assumptions is also limiting...

alper

---

From: Rajeev Koodli <[email-masked]>
Date: Wed, 31 Jul 2002 12:27:00 -0700

Ajoy,

> in case of srial link. Why this question again? If you do

I also responded to your input. I guess you agree that
an IP protocol has to supply this information in
order for it work on all links ? At the same time,
the protocol has to work if the MN moves without
receiving the PrRtAdv, which should cover your
scenario. So, my suggestion is that the base protocol
defines the messages necessary to work on all links
while it also allows for scenarios such as yours. This
does not mean that you remove the message from
the spec. Do you agree ?

Regards,

-Rajeev