Subject: RE: [mobile-ip] Re: HAO and BE processing will be mandated

From: [email-masked]
Date: Thu, 18 Jul 2002 03:41:18 +0300

Hi Hesham,

>   > > => Exactly, IMHO the support for HAO is tied to
>   > > RO support which is a SHOULD anyway, so the HAO
>   > > should follow that. 
>   > 
>   > Logically, you are inconsistant.  
>   > 
>   > As an example, RO is a should, protecting RO is a MUST.
> 
> => Huh? 
> 
> Protecting it is a must for those who support it! 
> But supporting it is a should.

We're dangerously on the edge of a rathole.

Debates on support / implement / use of various functions is something
to often causes pointless discussions.

The question more is, what do general implementations need to implement.
In my opinion, general often equals robust.  SHOULD does not mean
optional, it means you do it unless you have good reason not to do it.
I think the burden of proof, then, would be the endpoint which does not
implement a certain feature.

I think that since HAO is used for security reasons, it may have a strong
need to be a must than other functionality.  Just my opinion.

John

---

From: Francis Dupont <[email-masked]>
Date: Thu, 18 Jul 2002 04:34:41 +0200

=> I disagree: HAO is only a tunnel optimization and is *not*
used for security reasons.

[email-masked]