Subject: RE: [mobile-ip] Re: HAO and BE processing will be mandated

From: "Bound, Jim" <[email-masked]>
Date: Tue, 30 Jul 2002 14:31:06 -0400

John,

I would prefer all requirements for me to implement are in the specs as a programmer.  I view node reqs doc as a statement of further reqs of the std regarding conformance not implementation.  If we don't want HAO to be MUST make it a SHOULD this should be decided in the MIPv6 spec.k

thanks
/jim

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Wednesday, July 17, 2002 8:14 PM
To: [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; 
[email-masked];
[email-masked]
Subject: RE: [mobile-ip] Re: HAO and BE processing will be mandated

Hi Mike,

Vijay Devarapalli writes:
RO is a SHOULD, it is not a MUST in the current draft. we were 
not talking about route optimization. we were talking about 
processing a HAO. in the current spec HAO MUST be processed but 
not accepted if it cant be verified. verification can be in the 
form of checking for a valid BCE (created securely), IPsec 
protected data session, same trusted domain (where you dont 
expect people to do reflection attacks), the tagging proposal 
from Rajeev and Charlie, smart ingress filtering from Francis 
Dupont, etc...

   Oh, OK. Sorry about that. Still if the code
   isn't in the CN, the MN should still be able
   to operate correctly, right? That still seems
   to me to be a SHOULD rather than a MUST for the
   same reasons in my reply to John.

   I guess the long and short of this is that I'm
   somewhat skeptical of putting general node
   requirements in the MIP draft since it's
   probably not the first place one would be
   looking to figure out if they were an IPv6
   compliant node. If it's really, really vital
   for the health of the net, yadda, yadda, it
   would be better to put it in a general v6 node
   requirements RFC, don't you think?

Just as an FYI, I replied to the earlier mail because I am
trying to sort this out for the node requirements.  I think 
that in MIPv6, it is OK that MIPv6 makes this recommendation (given 
working group consensus, IESG approval, etc.) but the Node 
Requirements
document is the final word on the issue (assuming WG consensus, 
IESG approval, etc.).

John

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: "Bound, Jim" <[email-masked]>
Date: Tue, 30 Jul 2002 14:35:18 -0400

HAO SHOULD be implemented.  MUST is a stretch and I always thought so since draft 1.
The security argument is irrelevant to being a MUST or SHOULD if I deployed MIPv6 I would not use RR or any IPsec there are many ways to secure the mobile nodes and CNs and I agree with Vijays point on this just not the MUST.

That being said anyone who would not want to implement mobile HAO is not in tune with the market at all.  But thats not the IETFs job to keep them in tune.

/jim

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Wednesday, July 17, 2002 8:41 PM
To: [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked];
[email-masked]; [email-masked]
Subject: RE: [mobile-ip] Re: HAO and BE processing will be mandated 

Hi Hesham,

=> Exactly, IMHO the support for HAO is tied to
RO support which is a SHOULD anyway, so the HAO
should follow that. 

Logically, you are inconsistant.  

As an example, RO is a should, protecting RO is a MUST.

=> Huh? 

Protecting it is a must for those who support it! 
But supporting it is a should.

We're dangerously on the edge of a rathole.

Debates on support / implement / use of various functions is something
to often causes pointless discussions.

The question more is, what do general implementations need to 
implement.
In my opinion, general often equals robust.  SHOULD does not mean
optional, it means you do it unless you have good reason not to do it.
I think the burden of proof, then, would be the endpoint 
which does not
implement a certain feature.

I think that since HAO is used for security reasons, it may 
have a strong
need to be a must than other functionality.  Just my opinion.

John