Subject: Re: [mobile-ip] Home and COA cookie generation

From: Samita Chakrabarti <[email-masked]>
Date: Fri, 16 Aug 2002 09:38:39 -0700 (PDT)

> 
> Why would you need to distinguish the cookies like this?
> 
> -vlad

I don't know the reason why it was put in there before. That's why
I was asking the question. 

-Samita

> 
> Samita Chakrabarti wrote:
> > Section 5.2.5 of draft 18, specifies the following algorithm  for
> > home cookie and coa cookie:
> > 
> >   home cookie = First64(MAC_Kcn(home address | nonce))
> >   
> >   care-of cookie = First64(MAC_Kcn(care-of address | nonce))
> >   
> >   
> >   
> >   Previously,  (draft 16) talked about concatanating 0 and 1 for
> >   home cookie and care-of cookie, i.e:
> >   home cookie = MAC_Kcn (home_address | nonce| 0)
> >   coa cookie  = MAC_Kcn (coa_address | nonce | 1)
> >   
> >   Have we decided not use 0 and 1 any more to distinguish the cookies ?
> >   
> >   Thanks,
> >   -Samita
> > 
> > 
> > 
> 
> 
> -- 
> +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
> Vladislav Yasevich	       Tru64 UNIX - IPv6 Project Lead
> Hewlett Packard 	       Tel: (603) 884-1079
> Nashua, NH 03062	       ZKO3-3/T07
> 
>

---

From: Samita Chakrabarti <[email-masked]>
Date: Mon, 19 Aug 2002 12:04:01 -0700 (PDT)

> >   home cookie = First64(MAC_Kcn(home address | nonce)
> The rules have been simplified in draft 18. There does not
> seem to be any advantage in making the cookies truly different
> this way. (A long time ago we debated whether the cookies must
> depend on both addresses, but that was another issue.)
> 
> The inclusion of the 0 or 1 in the input of the MAC has the
> effect of requiring the MN to use specifically the Home Test
> and the Care-of Test messages to retrieve the corresponding
> cookies. If these values are not included, an attacker could
> use the value acquired through a Care-of Test message as a
> home cookie. However, this does not appear to make the life
> of the attacker any easier; if the attacker can send a particular
> MH message then he can most likely send another MH message as
> well. Obviously, the cookies are still dependent on the addresses
> so the attacker can't get a home cookie without being able to
> receive traffic at the home address.
> 
> Tuomas or Mike may comment on this, as the values were included
> in BAKE/2. My proposal is to not include the values unless we
> have an explicit reason to do so.

Thanks for the explanation. I am fine with current proposal.

-Samita