Subject: RE: [mobile-ip] Subject Change: Should PrRtAdv be optional in fmi pv6 ?

From: "Hesham Soliman (EAB)" <[email-masked]>
Date: Thu, 1 Aug 2002 08:19:55 +0200

Catching up with the thread.

> So, my suggestion is that the base protocol
> defines the messages necessary to work on all links
> while it also allows for scenarios such as yours. This
> does not mean that you remove the message from
> the spec. Do you agree ?
>
> AJOY-> I agree with this if you make PrRTAdv as
> an optional message.

This question is for the WG to decide. What do others
think ? Should we make PrRtAdv an optional message ?

=> NO! This is making the handover prediction
in the MN optional, non starter.

Interop implications ?

=> And unacceptable link layer dependencies.

Hesham

>
>
> -----Original Message-----
> From: Rajeev Koodli [mailto:[email-masked]]
> Sent: Wednesday, July 31, 2002 2:27 PM
> To: Singh Ajoy-ASINGH1
> Cc: 'Alper E. YEGIN'; James Kempf; 'Vijay Devarapalli';
> [email-masked]
> Subject: Re: [mobile-ip] Fast Handover draft: proposed revisions
>
> Ajoy,
>
> Singh Ajoy-ASINGH1 wrote:
>
> > Alper,
> > In my previous reply to Rajeev, I explained why
> > MN is not required to know the L2 address of nAR
> > in case of srial link. Why this question again? If you do
> >
>
> I also responded to your input. I guess you agree that
> an IP protocol has to supply this information in
> order for it work on all links ? At the same time,
> the protocol has to work if the MN moves without
> receiving the PrRtAdv, which should cover your
> scenario. So, my suggestion is that the base protocol
> defines the messages necessary to work on all links
> while it also allows for scenarios such as yours. This
> does not mean that you remove the message from
> the spec. Do you agree ?
>
> Regards,
>
> -Rajeev
>
> > not agree, please comment on my previous
> > email.
> > Regards,
> > Ajoy
> >
> > -----Original Message-----
> > From: Alper E. YEGIN [mailto:[email-masked]]
> > Sent: Tuesday, July 30, 2002 6:12 PM
> > To: James Kempf; Rajeev Koodli
> > Cc: Singh Ajoy-ASINGH1; 'Vijay Devarapalli';
> > [email-masked]
> > Subject: Re: [mobile-ip] Fast Handover draft: proposed revisions
> >
> > I think we need to include the complete question here:
> >
> >   1. How does the MN get the L2 address and IP address of the
> >        new AR ? I see the following possibilities
> >   a) PrRtAdv provides this
> >   b) upon establishing a new link, the MN does RS and gets an RA
> >
> >   How can you avoid PrRtAdv ? Can we assume that L2 trigger
> >   provides the necessary information ? Which L2 trigger today
> >   provides such information?
> >
> > Does MN really get "L2 and IP address of the new AR"?
> > I see MN is aware of the L2 id of the Base Stations, but note
> > that this is not same as L2 id of AR(s) behind them.
> >
> > alper
> >
> > ----- Original Message -----
> > From: "James Kempf" <[email-masked]>
> > To: "Alper E. YEGIN" <[email-masked]>; "Rajeev Koodli"
> > <[email-masked]>
> > Cc: "Singh Ajoy-ASINGH1" <[email-masked]>; "'Vijay
Devarapalli'"
> > <[email-masked]>; <[email-masked]>
> > Sent: Tuesday, July 30, 2002 1:58 PM
> > Subject: Re: [mobile-ip] Fast Handover draft: proposed revisions
> >
> > > > > Which L2 trigger today
> > > > > provides such information?
> > > >
> > > > I'm not aware of any...
> > > >
> > >
> > > I refer you to "Draft Standard for W-CDMA (Wideband Code Division
> Multiple
> > > Access) Air Interface Compatibility Standard for 1.85 to 1.99 GHz
PCS
> > > Applications", ANSI J-STD-015, 1998, Section 11.7 "Handoff
Operation",
> > Section
> > > 12.2.4.3, "Handoff Messages," Section 12.2.5.3.7, "Handoff
Parameter",
> and
> > > Section 12.25.3.8, "Handoff Indication". This version is a little
old
> but
> > > probably not very far off from the current W-CDMA specification.
> > >
> > > In Section 11.7, the procedures for mobile controlled and network
> > controlled
> > > handover are described. In the mobile controlled case, the mobile
sends
> a
> > layer
> > > 2 identifier to the current base station indicating the target
base
> > station to
> > > which the mobile wants to hand over, and gets back a response
indicating
> > whether
> > > handover is allowed or denied. In the network controlled case, the
> current
> > base
> > > station sends the same information to the mobile. (Note: "layer 3"
in
> this
> > > specification actually refers to what from the IP viewpoint would
be the
> > MAC
> > > layer, or layer 2). The network controlled case is used to manage
power
> > and cell
> > > load, the mobile controlled case is used when the power level on
the
> > mobile goes
> > > below the specified handoff point.
> > >
> > > In either case, the SolPrRtAdv and PrRtAdv of FMIPv6 duplicate, at
the
> IP
> > layer,
> > > what W-CDMA already does at the MAC layer. Also in either case,
the
> layer
> > 2
> > > information should be sufficient to allow the base station to
perform a
> > layer 3
> > > handover without any over the air layer 3 signaling, provided the
base
> > station
> > > has a way to map the target base station id to an IP address,
using
> GAARD
> > or a
> > > preconfigured table.
> > >
> > > Of course, in the R99 UTRAN, the actual W-CDMA protocol is buried
under
> > the NBAP
> > > and RNSAP RAN protocols.
> > >
> > > I don't have access to an IS-2000 specification at the moment, but
I'm
> > working
> > > on getting the same information. Other wireless link layers must
provide
> > this
> > > information in some form, either before handover, as with the
cellular
> > > protocols, or afterwards, as with 802.11. Barring make before
break,
> > without
> > > some information at layer 2 about where the mobile is going, it is
> simply
> > > impossible for the link to get switched, and, without a link, it
is not
> > possible
> > > to do IP. If the layer 2 protocol supports real make before break
(not
> > soft
> > > handover), none of the fast handover protocols are necessary,
since the
> > mobile
> > > can do RS/RA on the forward link while receiving its traffic on
the
> > backward
> > > one.
> > >
> > >             jak
> > >
> > > (fyi, Alper, the specification in question is in the DoCoMo
library, if
> > you care
> > > to check it out.)

---

From: Singh Ajoy-ASINGH1 <[email-masked]>
Date: Fri, 2 Aug 2002 09:41:31 -0500

Yes, so that we know if majority of link layers already
supply the information needed.

AJOY-> I can see link layer such as CDMA (IS-2000, WCDMA, IS-95A,
IS-95B), TDMA (GSM, GPRS, IS-136) provides serial link connection between
MN and AR. Correct me if I mis-stated? I do not claim to 
be expert in all mentioned link layers? On other handoff
I can see 802.11 provides CSMA/CA type of MAC. Could you 
please list all the link layers where MN will really need 
L2 address as well as IP address of nAR to send any packet
out? 

-----Original Message-----
From: Rajeev Koodli [mailto:[email-masked]]
Sent: Thursday, August 01, 2002 7:17 PM
To: James Kempf
Cc: Erik Nordmark; Singh Ajoy-ASINGH1; 'Alper E. YEGIN'; 'Vijay
Devarapalli'; [email-masked]
Subject: Re: [mobile-ip] Subject Change: Should PrRtAdv be optional in
fmipv6 ?

James Kempf wrote:

> > > If there are link layers where this message isn't useful at all, then it
> > > isn't useful for those link layers. As long as all the MNs and ARs in fact
> > > know that they are operating over such a link layer (which is an
> implementation
> > > issue; my IP stack doesn't know whether it is operating over Ethernet or
> > > 802.11 for instance), then it might be reasonable to state that the message
> is
> > > optional *when running over that link layer*.
> > >
> >
> > Ok. Although, I do not know of *existing* link layers where
> > the functionality is provided by the link layer with the qualifier
> > that serial links need consideration.
> >
>
> See my message sent out yesterday on wCDMA. The message is unnecessary there
> because it duplicates information exchanged at the link layer. I believe IS-2000
> is a similar situation, but I have not checked.
>

I read your message, but did not understand how the MN
gets the L2 address and IP address of the target access router, which
is what it needs to send packets. It seemed like what the MN is
getting is the BSSID of the target base station. Am I missing
something ?

>
> > >
> > > But I think the high-order bit is that such a message might not provide any
> > > utility on particular link layers.
> > >
> >
> > OK. It would be good enlist those link layers that offer the
> > same functionality today or are required to provide in
> > future.
> >
>
>  Do you mean compile a list of such link layers?
>

Yes, so that we know if majority of link layers already
supply the information needed.

-Rajeev

---

From: Singh Ajoy-ASINGH1 <[email-masked]>
Date: Fri, 2 Aug 2002 11:37:50 -0500

I wasn't talking about the UTRAN/GPRS protocols, I was just talking about
the
radio protocol wCDMA.

AJOY-> Ok

If you look at the whole UTRAN/GPRS, it results in a connection-oriented
setup
like a serial link terminating at the GGSN (PDP context). can also set up
using PPP. But the wCDMA radio protocol has nothing in it (as far as I can
tell)
that requires this. Someone having more familiarity with the protocol can
correct me if I am wrong.

AJOY-> Sure, you can can replace UTRAN/GRPS with something else. 
I did say that you were wrong. I just mentioned that 
current WCDMA based network provides serial link between
MN and AR. This is going to remain same unless
the WCDMA MAC is changed drastically.

-----Original Message-----
From: James Kempf [mailto:[email-masked]]
Sent: Friday, August 02, 2002 11:19 AM
To: Singh Ajoy-ASINGH1; 'Rajeev Koodli'
Cc: Erik Nordmark; Singh Ajoy-ASINGH1; 'Alper E. YEGIN'; 'Vijay

Ajoy,

> AJOY-> As far as I know, WCDMA also provides serial link
> between MN and AR. So, I am not sure why it is must
> for MN to know L2 address and IP address of the nAR ?
> Could you clarify?
>

I wasn't talking about the UTRAN/GPRS protocols, I was just talking about
the
radio protocol wCDMA.

If you look at the whole UTRAN/GPRS, it results in a connection-oriented
setup
like a serial link terminating at the GGSN (PDP context). They can also set
up
using PPP. But the wCDMA radio protocol has nothing in it (as far as I can
tell)
that requires this. Someone having more familiarity with the protocol can
correct me if I am wrong.

            jak

---

From: Singh Ajoy-ASINGH1 <[email-masked]>
Date: Fri, 2 Aug 2002 12:30:45 -0500

James,
Sorry,I missed a NOT in "I did  <NOT> say that you were wrong. "
Regards,
ajoy 

-----Original Message-----
From: Singh Ajoy-ASINGH1 
Sent: Friday, August 02, 2002 11:38 AM
To: 'James Kempf'; Singh Ajoy-ASINGH1; 'Rajeev Koodli'
Cc: Erik Nordmark; Singh Ajoy-ASINGH1; 'Alper E. YEGIN'; 'Vijay
Devarapalli'; [email-masked]
Subject: RE: [mobile-ip] Subject Change: Should PrRtAdv be optional in
fmipv6 ?

AJOY-> Ok

-----Original Message-----
From: James Kempf [mailto:[email-masked]]
Sent: Friday, August 02, 2002 11:19 AM
To: Singh Ajoy-ASINGH1; 'Rajeev Koodli'
Cc: Erik Nordmark; Singh Ajoy-ASINGH1; 'Alper E. YEGIN'; 'Vijay

Ajoy,

            jak