Subject: [mobile-ip] Ordering of Mobility Header

From: "Greg O'Shea" <[email-masked]>
Date: Fri, 30 Aug 2002 18:31:38 +0100

Is there a recommended ordering of MH with respect to other header
types?

---

From: Vijay Devarapalli <[email-masked]>
Date: Fri, 30 Aug 2002 10:53:24 -0700

as far as draft 18 is concerned, it is the final header (like ICMP).

if http://www.ietf.org/internet-drafts/draft-ietf-mobileip-piggyback-00.txt
goes through, MH would be the last extension header.

Vijay

Greg O'Shea wrote:

> Is there a recommended ordering of MH with respect to other header types?
>

---

From: Ryuji Wakikawa <[email-masked]>
Date: Sat, 31 Aug 2002 15:27:08 +0900

Hi Vijay.

How about the ordering of Mobility options.
Is there any recommended ordering for options?

regards,
ryuji

-- 
Ryuji Wakikawa <[email-masked]>

---

From: Jari Arkko <[email-masked]>
Date: Sat, 31 Aug 2002 11:23:51 +0300

> Is there any recommended ordering for options?

I don't think we have said anything about the order,
i.e., any order is legal. I don't think we should
recommend anything unless it would also be a mandatory
fixed order.

But a free order seems like the approach
taken in IPv6 protocols in general, so perhaps we
should stick with it here as well.

Jari