Subject: RE: [mobile-ip] Subject Change: Should PrRtAdv be optional in fmi pv6 ?

From: Singh Ajoy-ASINGH1 <[email-masked]>
Date: Fri, 2 Aug 2002 09:23:30 -0500

I read your message, but did not understand how the MN
gets the L2 address and IP address of the target access router, which
is what it needs to send packets. It seemed like what the MN is
getting is the BSSID of the target base station. Am I missing
something ?
AJOY-> As far as I know, WCDMA also provides serial link 
between MN and AR. So, I am not sure why it is must 
for MN to know L2 address and IP address of the nAR ? 
Could you clarify? 

-----Original Message-----
From: Rajeev Koodli [mailto:[email-masked]]
Sent: Thursday, August 01, 2002 7:17 PM
To: James Kempf
Cc: Erik Nordmark; Singh Ajoy-ASINGH1; 'Alper E. YEGIN'; 'Vijay
Devarapalli'; [email-masked]
Subject: Re: [mobile-ip] Subject Change: Should PrRtAdv be optional in
fmipv6 ?

James Kempf wrote:

> > > If there are link layers where this message isn't useful at all, then it
> > > isn't useful for those link layers. As long as all the MNs and ARs in fact
> > > know that they are operating over such a link layer (which is an
> implementation
> > > issue; my IP stack doesn't know whether it is operating over Ethernet or
> > > 802.11 for instance), then it might be reasonable to state that the message
> is
> > > optional *when running over that link layer*.
> > >
> >
> > Ok. Although, I do not know of *existing* link layers where
> > the functionality is provided by the link layer with the qualifier
> > that serial links need consideration.
> >
>
> See my message sent out yesterday on wCDMA. The message is unnecessary there
> because it duplicates information exchanged at the link layer. I believe IS-2000
> is a similar situation, but I have not checked.
>

I read your message, but did not understand how the MN
gets the L2 address and IP address of the target access router, which
is what it needs to send packets. It seemed like what the MN is
getting is the BSSID of the target base station. Am I missing
something ?

>
> > >
> > > But I think the high-order bit is that such a message might not provide any
> > > utility on particular link layers.
> > >
> >
> > OK. It would be good enlist those link layers that offer the
> > same functionality today or are required to provide in
> > future.
> >
>
>  Do you mean compile a list of such link layers?
>

Yes, so that we know if majority of link layers already
supply the information needed.

-Rajeev

>             jak

---

From: "James Kempf" <[email-masked]>
Date: Fri, 2 Aug 2002 09:19:11 -0700

Ajoy,

> for MN to know L2 address and IP address of the nAR ?

I wasn't talking about the UTRAN/GPRS protocols, I was just talking about the
radio protocol wCDMA.

If you look at the whole UTRAN/GPRS, it results in a connection-oriented setup
like a serial link terminating at the GGSN (PDP context). They can also set up
using PPP. But the wCDMA radio protocol has nothing in it (as far as I can tell)
that requires this. Someone having more familiarity with the protocol can
correct me if I am wrong.

            jak