Subject: Re: [mobile-ip] MH type field

From: Samita Chakrabarti <[email-masked]>
Date: Fri, 2 Aug 2002 19:16:53 -0700 (PDT)

Hi Brian,

> >
> > 8 bits looks sufficient now. OTOH I don't think the 8 bit reserved field
> > buys very much either. And there are some protocols in the Internet
> > where 8 bits looked initially sufficient but proved later to be 
insufficient.
> > Mobility is an interesting subject to many folks. Will 256 values cover
> > all the xMIP extensions that we might need in the future? Yeah, you could
> > also say that it's a terrible thought that we'd need so much complexity
> > that 10-15 values wouldn't do...
> >
> > By the way, if you switch statements in the code are in network byte
> > order, you'll save the 3 instructions ;-)
> >
> > My gut feeling is that we should keep the current format, unless
> > someone has strong arguments otherwise.
> 
> My only follow-up would be that we could change a reserved field into
> an "extended type" field in the future.  For example, if type == 255 then
> add "extended type" to it to get the actual type.  It would be harder to go
> the other way.  Noone else seems to have an opinion either way about
> such little issues though...

How do you think the reserved field be useful in future ? Do you
think it could be used for some flags someday ? 

IMHO, I agree with Jari, that we can keep the MH type field 16 bit
for now, as we don't know the extent of future applicability of
MH header, unless we know for sure that saving 8 bit as reserved
will have some applicability in the near future.

-Samita

---

From: Brian Haley <[email-masked]>
Date: Mon, 05 Aug 2002 11:41:29 -0400

> think it could be used for some flags someday ?

Hi Samita,

Flags is an option, I'm sure someone will come up with a need some day,
I just doubt that we'll ever need 65K MH types.

It was simply something I noticed updating to draft 18 that was different
from all the other IPv6 headers (like MH Len).

-Brian

---

From: Jari Arkko <[email-masked]>
Date: Tue, 06 Aug 2002 16:15:57 +0300

It does not seem that there are very strong feelings either
way. Let's just pick one way to do it and stick with it.

But Brian's note about possibility to extend type field later is
true. This removes the main drawback about the 8 bit type
field. The reserved field might also be useful for HOT/COT
messages that do not currently have any Reserved fields.

So, my suggestion is that we should just shorten the field
to 8 bits and leave the rest Reserved. This does not cause
any problems, and while the benefit is questionable it *might*
be useful.

Anyone disagree?

Jari