Subject: [mobile-ip] Preconfigured Kbm between mobile node and correspondent

From: "Charles E. Perkins" <[email-masked]>
Date: Fri, 25 Oct 2002 08:24:20 -0700

Hello folks,

A couple of weeks ago, there was discussion about allowing
a correspondent node and mobile node to use a preconfigured
binding key (Kbm).  The specification does seem to support
this mode of operation, and various issues (e.g., replay)
were discussed with, I think, positive resolution.

The only clarification that I think is needed is that for
preconfigured binding keys, the Nonce Indices option is
truly optional.

I have asked Jari to post the following:

Issue:	How do mobile nodes and correspondent use preconfigured Kbm?

Proposal: Eliminate requirement for Nonce Indices option in this case.

Regards,
Charlie P.

---

From: Michael Thomas <[email-masked]>
Date: Fri, 25 Oct 2002 08:59:29 -0700 (PDT)

As far as I could tell, there was a distinctly
negative reaction to the proposal and an
unanswered question as to why yet another
mechanism is needed. Nor was the replay issue
resolved; handwaving away the problem with a 16
bit counter and no means of recovery if it is
exceeded is not my idea of resolution.

Before we start resolving any problems here, the
chairs need to make a call as to whether this 
should proceed at all.

	    Mike

---

From: Vijay Devarapalli <[email-masked]>
Date: Fri, 25 Oct 2002 12:12:36 -0700

I have argued for this earlier.

lets assume I am roaming with my corporate laptop, with the
Home Agent in my corporate network. I want to transfer a huge
file from my home PC. I have a preconfigured static Kbu with my
home PC. why should I not be able to send a BU to my home PC
and do the file transfer using route optimization? I dont need
return routability to authorize this BU. 

it makes absolutely no sense killing this.

replay protection? I change the key every 64000 binding updates.

Charlie is asking for making the Nonce Indices Option optional.
I agree with him. it should be used only when return routability 
is used for authenticating the BU.

regards
Vijay