Subject: [mobile-ip] Simple MIPv4 Question

From: "Phil Neumiller" <[email-masked]>
Date: Wed, 23 Oct 2002 09:46:09 -0400

Hi,

I am sorry to trouble this busy list with such a simple question, but here goes.  If one wishes
to place a MIPv4 FA somewhere upstream in a large network, i.e. a few routers seperate the
FA and the access routers that MNs attack to, does the FA need to build a source route
to the MN?  In the reverse direction, the MN can clearly use the FA as a default route and
that is fine.  I am concerned about the scenario of:

FA -> Router 1 .... -> Router K -> MN, 

i.e. packets getting from the FA to the MN that may indeed be moving across different
routing chains.

A simple gratuitous ARP does not seem to handle this situation.  What am I missing?

Thanks,

Phil
--
Phillip D. Neumiller ([email-masked])
My PGP key can be imported from the following URL: http://pgpkeys.mit.edu
BTW:  It is undecidable whether an arithmetical formula is true!

---

From: Behcet Sarikaya <[email-masked]>
Date: Wed, 23 Oct 2002 16:30:03 -0500

Hi Phil,
  Chip has a paper on this which appeared in Mobihoc 2000 in which they 
proposed MIPMANET, i.e. they combine Charlie's aodv with MIPv4.
  Maybe worth looking into.

Regards,

-- 
Behcet