Subject: RE: [mobile-ip] Binding Authorization data for Binding Update toHome Agent

From: [email-masked]
Date: Mon, 14 Oct 2002 15:57:13 +0300

gabriel montenegro wrote:
> Charlie Perkins wrote:
> >>Is BAD to home absolutely necessary for base MIPv6?
> > 
> > It is necessary to allow manual configuration of security 
> associations
> > between mobile node and home agent in the same way as is done
> > today in Mobile IPv4, which is manifestly simple and effective.
> 
> Couple issues:
> - yet one more way of doing the same thing (manual SA configuration
> 	between HA and MN).

The method by which the authorization is done between MN and HA would necessarily be a property of the MN-HA security relationship (as well as the key(s)), so there should be no problem in MN choosing the method to use. Also, the method exists already for the MN-CN case, so the only additional burden on the MN is to be able to utilize code it already has if it has been configured to do so.

> - does not provide a way for RR signaling to be encrypted between
> 	HA and MN (which is really important for securing RR)
> 

Non-issue. As per the current specification (draft-ietf-mobileip-mipv6-ha-ipsec-00.txt), the IPsec SAs for the two cases are totally separate, so the MN-HA and MN-CN cases are orthogonal. I.e. the method used for MN-HA BU authorization has nothing to do with RR signaling protection between MN and HA. IPsec would still be used for MN-HA tunnel protection.

I see no reason to block the usage of BAD for MN-HA MH protection. It makes no real difference to MN, and Home Agents should be free to use the method best suited to the implementation.

	Jarno

---

From: [email-masked]
Date: Tue, 15 Oct 2002 10:37:22 +0300

Michael Thomas wrote:
>  > It is as secure as what you have today for MIPv4 if you take
>  > care of the replay protection issue. (I have to say that I do
>  > not know if the replay protection issue has been addressed)
> 
>    Well, that's why I said it isn't obvious to me :)
>    In particular, replay protection requires some for
>    of synchronization. In the current return routeability
>    test, that sychronization happens each test. What
>    would be required for this is some means of saving
>    that synchronized state, what happens if it's lost
>    etc, etc. Indeed, there we would need to consider
>    what would happen if the sequence space was exhausted,
>    etc. 
>    
>    All this really points to is that I don't think this
>    is quite the slight editorial change that is being
>    suggested here. I still agree with Gabriel that this
>    would be better considered separately rather than
>    being included into the base draft.
> 

Maybe the base spec needs the editorial change to not prohibit Binding Authorization Data option in BUs to the Home Agent? Further details on synchronization etc. should be left for other drafts to specify.

	Jarno