Subject: RE: [mobile-ip] Binding Authorization data for Binding Update to Home Agent

From: "Hesham Soliman (EAB)" <[email-masked]>
Date: Tue, 15 Oct 2002 19:03:01 +0200

> > => The problem is that with manual keying you will eventually
  > > (regardless of where the seqno is stored) reuse the same
  > > numbers (see Mike's if statement). With dynamic keying you won't.
  > > So there is minimal replay attack protection when manual
  > > keying is used.
  > 
  > This is the reason that one might wish to re-key after
  > 65,000 Binding Updates (every 7.5 years, if you change
  > care-of addresses once an hour 24 hours a day 7 days a
  > week).  

=> Sure, but you assume that the MN increments the 
seqno by one in each BU. The draft says nothing about
that. It might help to say that in the draft, but 
strictly speaking replay protection is only possible
with dynamic keying. If we can do things 
to help make it better for manual keying that would be 
nice.

Hesham

---

From: "Charles E. Perkins" <[email-masked]>
Date: Tue, 15 Oct 2002 10:12:43 -0700

Hello Hesham,

The choice of whether to use such a system would
depend on the intended use.  Fast-moving or
military systems would probably use dynamic
rekeying just as you suggest.

> that.

Actually, it's not necessary even for maximizing
the use of the sequence number space.  One could
imagine a scheme by which the sequence number is
incremented by a small prime number each time.

>        It might help to say that in the draft, but

The other thing we could do is to have a bigger
sequence number.  This could be done by an
extension, or by swapping the Sequence Number
field with the Lifetime field and stealing a
few of the Reserved bits.    By the time we
get to a few hundred thousand distinct Binding
Updates, we ought to just declare success for
the manual rekeying and insist on dynamic
rekeying for systems that would be put into
fast-moving or permanently deployed mobile nodes.

But, realistically, it would take a very
determined attacker to wait 5 or 10 years,
or even 5 or 10 weeks, to fool a home agent
into accepting an old care-of address!

Regards,
Charlie P.