Subject: [mobile-ip] Intermediate version of Mobile IPv6 base specification

From: "Charles E. Perkins" <[email-masked]>
Date: Tue, 01 Oct 2002 15:41:59 -0700

Hello folks,

A lot of changes have been applied to the base specification
since draft ...-18, along the way of resolving the numerous
Last Call issues.  Now, it is difficult for most people to
carry on discussions about the open issues because the previous
text is so far out of date with the current editors' version.

To repair that problem, especially important as we try to
finish the last issues and get draft ...-19 issued for possible
IESG consideration, a new text file with an intermediate
version has been made available:
    http://people.nokia.net/~charliep/txt/mobilev6/mobilev6.txt

Regards,
Charlie P.

---

From: Jari Arkko <[email-masked]>
Date: Wed, 02 Oct 2002 15:30:05 +0300

>     http://people.nokia.net/~charliep/txt/mobilev6/mobilev6.txt

To give people some understanding what changes this version
includes and does not include, in the following URL I
have listed "19pa1" on the agreed & edited issues:

   http://www.piuha.net/~jarkko/publications/mipv6/MIPv6-Issues.html

For ease of reference, I list below the issues that are known
to be open, don't have text, or have not yet been applied
in this draft revision:

52  Adopted  Yes  -      8.2 editorial problem
53  Open     No   -      HAO keyword (reopening issue #45?)
56  Adopted  No   -      DHAAD responses and bandwidth/own ip optimizations
62  Adopted  No   -      Link-local CoAs and HoAs
69  Open     No   -      Security between the MN and HA
88  Adopted  Yes  -      Need to redefine MIN_DELAY_BETWEEN_RAS?
92  Adopted  No   -      Reflection attack using BUs and BAs
93  Adopted  Yes  -      MH length to include first 8 bytes or not?
94  Open     No   -      Unclear text about "address suitable for RH"
95  Adopted  No   -      Unclear references to RH (type 0 or 2)
98  Open     Yes  -      Concatenate 0/1 before making a cookie?
103 Open     No   -      Cookie lifetime clarifications needed
120 Open     No   -      Unclear issues in MPA
122 Adopted  No   -      More editorial comments from Vesa-Matti Mantyla
124 Adopted? No   -      MPA security resolution isn't in draft 18

The intermediate version is just that, a temporary document and
has inconsistent and raw text at places. So we don't expect
you to review this in depth, but use it as a basis for discussing
issues. Of course, if you see something wrong in the document,
let us know anyway. And if you raised an issue earlier and we
fixed it, take a look that you like the end result.

Jari