Subject: RE: [mobile-ip] question on protecting MN - HA communication

From: "Mohan Parthasarathy" <[email-masked]>
Date: Mon, 14 Oct 2002 17:18:57 -0700

> - 
> hi Mohan
> 
> > Mohan Parthasarathy wrote:
> 
> > In any case, HA should be able to process both forms of tunneled 
> > packets that Vijay showed in his earlier mail. I don't see 
> any harm in
> > documenting both of them and point out the 24 bytes savings in
> > the case of tunnel interface known.
> 
> I prefer specifying just one wire format. IPsec - MIPv6 
> interaction has been a source of confusion for a long time 
> now. we should be simplifying things.
> 
What will the HA do if it receives the format not specified in
the document ?

-mohan

> Vijay

---

From: Vijay Devarapalli <[email-masked]>
Date: Mon, 14 Oct 2002 17:30:46 -0700

> What will the HA do if it receives the format not specified in

drop it!?

I am open to suggestions.

Vijay

---

From: Jari Arkko <[email-masked]>
Date: Sun, 20 Oct 2002 21:13:03 +0300

Vijay Devarapalli wrote:
>>the document

Be liberal in what you accept still applies. But I think we got
it covered already: if there was a HAO then according to base I-D
Section 9.2.2 the source gets to be hoa instead of coa. But  IPsec
tunnel mode reception is going to ignore the outer source field, so
this doesn't change anything.

Jari