Subject: RE: [mobile-ip] FW: Changing RS Reply Timing for Mobile IPv6

From: "Hesham Soliman (EAB)" <[email-masked]>
Date: Tue, 8 Oct 2002 23:51:26 +0200

James,

  > 
  > I think we discussed this when the draft was originally 
  > written. 

=> I must have missed that discussion, I'll
try to find it.

There was some
  > concern on the part of Erik that the router with 
  > MAX_RA_DELAY_TME set to zero
  > would then be open to a DoS attack. In the current design, 
  > the router is only
  > exposed until it runs out of MAX_FAST_RAS. Of course, the 
  > attacker can simply
  > roll over and continue after the RA is multicast, but it 
  > does provide some
  > window of protection.

=> But (I could have missed this too!) I thought 
you were intending to use the same RS as normal
hosts would, so how does a router know if this 
is a legitimate request or a DoS attack? 
I mean, many RSs could arrive at the same time, 
MAX_FAST_RAS are per host right? if so, then
the router would reply to all of them and set 
MAX_FAST_RAS per dst address.

  > 
  > In addition, there is an issue when the network first comes 
  > up (though I would
  > not expect this to be a common problem) that this router 
  > could become
  > overloaded.

=> I didn't get this one.

Hesham

---

From: "James Kempf" <[email-masked]>
Date: Tue, 8 Oct 2002 16:07:15 -0700

> MAX_FAST_RAS per dst address.

MAX_FAST_RAS are per router, not per host. When the router gets MAX_FAST_RAS, it
rolls over to doing multicast. Thus, the attacker can only deny service for as
long as it takes to use up MAX_FAS_RAS. After that, everybody gets the
multicast.

            jak