Subject: RE: [mobile-ip] New HMIPv6 draft

From: "Hesham Soliman (EAB)" <[email-masked]>
Date: Mon, 21 Oct 2002 13:31:02 +0200

Thanks for your comments/questions.

  > During the last few months, I have waited for you to submit 
  > new version of HMIPv6.
  > The announcing of new version may be good news for me and 
  > other mobile-IP researcher.

=> That's good news. Apologies for keeping people waiting
but we had to wait for the basic spec to become stable.

  > 
  > While examining your draft, I have two questions.
  > 
  > 1. About I flag in MAP option 
  >  
  > In your draft, the flag indicates that the MN MAY use its 
  > RCoA as source address of its outgoing packets.
  > I would like to have clear notion about the usage of both I 
  > and P flags.
  > What case this flag 'must' be set in?
  > This flag and the P flag are mutual exclusive? 
  > If so, Cannot the P flag which is not set, take the place 
  > of the I flag?

=> There are 2 different cases addressed by the P and I flags:

case 1: The operator does not see the point in hiding 
the MN's LCoA, but acknowledges that some MNs would need
this feature for location privacy. For this case, the 
I flag is set. Hence, the MN MAY use this feature if 
it wishes to, but the operator does not care.

case 2: The operator wants to hide its internal addresses
regardless of whether the MN needs this feature or not. 
This case was actually requested by some operators. 
In this case, the operator would set the P flag. The
implication is: The MN MUST use RCoA as a src address. 

If the P flag is set, the I flag is irrelevant to the MN.
The MUST in case 2 overrides the MAY in case 1. 

The choice of whether the P or I flags should be 
set is up to the operator's discretion and requirements.

  > 2. Hiding of MN's LCoA vs. Hiding of MN's location?
  > 
  > In page 11 in your draft, you make mention of followings.
  > 
  >    A network operator may prefer to hide the mobile node?s 
  > LCoA from 
  >    nodes outside the MAP domain. To ensure this, a MAP 
  > option can be 
  >    sent with the P flag set. In this case, the mobile node 
  > MUST use its 
  >    RCoA as the source address of its BU (no alternate-CoA option is 
  >    needed) to its HA and correspondent nodes. It MUST also 
  > use its RCoA 
  >    as the source address for its outgoing packets.  
  >     
  >    On the other hand, a mobile node may prefer to hide its 
  > location from 
  >    the correspondent nodes it communicates with and the HA. 
  > To achieve 
  >    this, the mobile node should ensure that it does not 
  > provide both its 
  >    identity and location to any of the correspondent nodes. 
  > Since the 
  >    implied identity of the mobile node is included in every route-
  >    optimised packet (a Home Address), the mobile node 
  > should ensure that 
  >    it does not provide its exact location to the 
  > correspondent nodes and 
  >    HA. Hence, the mobile node should use its RCoA as a 
  > source address 
  >    for all its outgoing packets. This can be done if the I 
  > or P flags 
  >    are set in the MAP option. Otherwise location privacy can not be 
  >    provided in this manner.
  > 
  > I don't catch the difference between the hiding of MN's 
  > LCoA and the hiding of MN's location?.

=> There is no difference in the context of this draft.
I'll clarify this text and send new text to the list.

  > In the concluding part, 
  > the first paragraph says that MN MUST use its RCoA as 
  > the source address of both its BU and all its outgoing packets. 
  > On the other hand, the second paragraph says that 
  > MN SHOULD use its RCoA as only source address of all its 
  > outgoing packets.
  > What criterion makes such discrepancy?

=> The first part is referring to the use of the P
flag (case 2). The second paragrpah refers to case 1.
Perhaps the "should" is confusing. I'll try to come up
with some text to clarify this and send it to the list. 

Thanks, 
Hesham

---

From: "James Kempf" <[email-masked]>
Date: Mon, 21 Oct 2002 10:34:00 -0700

> implication is: The MN MUST use RCoA as a src address.

The distinction seems not very useful, IMHO. The MN can always choose to ignore
the flag, so whether or not the MN actually advertises the LCoA depends on the
host software and configuration. I think a single flag should be sufficient.

            jak