Subject: RE: [mobile-ip] Intermediate version of Mobile IPv6 base specific ation

From: "Hesham Soliman (EAB)" <[email-masked]>
Date: Sat, 12 Oct 2002 19:01:34 +0200

Correction below:

  > I might have missed one of the recent issues, if
  > so please let me know. 
  > 
  > There is a conflict between 
  > Section 5.2.6 of the interim version which says:
  > 
  > "      1.  Binding Update
  > 
  >          The mobile node uses the created binding key Kbu 
  > to authorize
  >          the Binding Update.  The contents of the message 
  > include the
  >          following:
  > 
  >                Src = care-of address
  >                Dst = correspondent
  >                Parameters:
  >                - home address
  >                - MAC (Kbu, (care-of address | correspondent 
  > node address | BU))
  >                - home nonce index
  >                - care-of nonce index
  >                - sequence number           
  > "
  > 
  >  But section 6.1.7 says:
  > 
  > 
  > "         The following options are valid in a Binding Update:
  > 
  >           -  Binding Authorization Data option
  > 
  >           -  Nonce Indices option.
  > 
  >           -  Alternate Care-of Address option
  > "
  > 
  > No mention of the home address in 5.2.6
  > 
  > Finally, chapter 11.7.2 says:
  > 
  > " The mobile node SHOULD create a Binding Update as follows:
  > 
  >     -  The Source Address of the IPv6 header MUST contain 
  > the current
  >        care-of address of the mobile node.
  > 
  >     -  The Destination Address of the IPv6 header MUST contain the
  >        address of the correspondent node.
  > 
  >     -  The Mobility Header is constructed according to rules in
  >        Section 6.1.7, including the authenticator field which is
  >        calculated based on the received home and care-of 
  > keygen tokens.
  > 
  >     -  The Home Address destination option MUST be attached to the
  >        message, unless the Source Address is the home address of the
  >        mobile node. "
  > 
  > what does "attached to the message" mean?
  > Aren't these sections conflicting each other in terms 
  > of what MAC (Kbu, (care-of address | correspondent node 
  > address | BU))
  > should cover? 
  > 
  > It seems to me that we need to either include the HAO
  > in the MH or change the MAC to be:
  > MAC (Kbu, (care-of address | correspondent node address | HAO | BU))

=> We don't actually need to include the home address in the 
MAC. So it might just be an editorial comment and we 
can just remove "home address" from the parameters list
in 5.2.6. 

While we're at it, I would suggest changing the wording 
in 11.7.2 from "attached to the message" to 
"included in the home address option"

Hesham

---

From: Jari Arkko <[email-masked]>
Date: Sun, 13 Oct 2002 11:13:01 +0300

>   >                - MAC (Kbu, (care-of address | correspondent 

...

>   >        calculated based on the received home and care-of 

This is unnecessary (and potentially harmful) repetion. I have
replaced the "based on the received ..." part with "as defined in Section ...".

>   > what does "attached to the message" mean?

This isn't very clear text. Should reword this to "The home address of
the mobile node MUST be added to the packet in a Home Address destination
option, unless the Source Address is the home address."

> can just remove "home address" from the parameters list

5.2.6 is right. (Note the list of parameters is for the BU, not for the
MAC.)

Jari