Subject: RE: [mobile-ip] New Draft on FMIPv6 over 802.11

From: "Hesham Soliman (EAB)" <[email-masked]>
Date: Tue, 8 Oct 2002 18:00:21 +0200

Hi Pete, 

One thing I didn't see when I read the draft 
was how the different handover alternatives
would affect:
1. The network's configuration, specifically if multiple
ARs are on the link. How would tunnel-based handover handle
this?

2. How does the MN discover a default router if 
a handover is done without informing the MN with
Pr_rtr_adv? 

I think the two points are related to each other.
If the MN is not informed about the IP handover
(then later starts receiving RAs on the new link)
it might select any default router on the link.
However, if only one router had already received
HI then the MN cannot simply choose any router. 

If the MN is not informed about the handover and 
is located in the new subnet for some time, it would not 
be able to send packets for this period. 

Comments?

Hesham

---

From: Pete McCann <[email-masked]>
Date: Tue, 8 Oct 2002 14:09:06 -0500

Hi, Hesham,

 > ARs are on the link. How would tunnel-based handover handle

I tried to mention this configuration problem in Section 6 (see the
first two paragraphs).  This is the "link layer mapping" problem, and
you are correct that it gets more complicated if more than one AR is
on the new link.  I could expand on this a bit more.

 > a handover is done without informing the MN with

As the draft says in the 3rd paragraph of Section 6, "through means
currently unspecified."  There is no generally applicable technique
given in the MIPv6 fast handover draft, and it was not my assignment
to invent new protocol.  So I think that's the best I can say for now.

 > HI then the MN cannot simply choose any router. 

Yes, this choice needs to be coordinated with the HI/HACK.

 > be able to send packets for this period. 

Hopefully we could work out a way to detect this error condition and
do a basic MIPv6 registration (and CoA configuration) right away.

-Pete