Subject: RE: [mobile-ip] Preconfigured Kbm between mobile node and corresp ondent

From: "Hesham Soliman (EAB)" <[email-masked]>
Date: Sun, 27 Oct 2002 01:41:52 +0200

> Plus, one has to remember the threat.  If it is a concern
  > that zillions of bad hosts would victimize some care-of
  > address, that is wholly incompatible with the scenario
  > for preconfiguring Kbm between a particular correspondent
  > node and mobile node.

=> That's very much debatable. Pre-configured keys 
are widely used today in public access networks (cellular)
for user authentication. If we put this in the draft 
without the necessary warnings, people might read it
and think that they can reuse the same keys for 
MIPv6. In this case, you don't really know that 
the MN is not the Bad Guy who will use a public
provider's server to bomb Victim(s). So we have
to be careful about the applicability of this scenario.

Hesham

---

From: "Charles E. Perkins" <[email-masked]>
Date: Mon, 28 Oct 2002 09:05:05 -0800

Hello Hesham,

> to be careful about the applicability of this scenario.

I agree that we have to be careful.  I am suggesting that
anyone who goes to the trouble of preconfiguring Kbm will
have some business reason to do so.

If the mobile node is the bad guy, and it's using a
preconfigured Kbm to secure its communications, then
it is directly traceable.  Most bad guys don't like
pointing bright lights at themselves as they are doing
their dirty work, so I don;t believe this is a threat.

I'm not suggesting that we should hold this up as a
preferred mechanism.  Instead, I'm suggesting that we
allow it, with appropriate discussion in the security
considerations, because it is very useful for some
scenarios, and it can be made very secure, and
the specification requires very little in order to
explicitly support it.

Regards,
Charlie P.