Subject: RE: [mobile-ip] Binding Authorization data for Binding Update toHome Agent

From: [email-masked]
Date: Mon, 14 Oct 2002 15:32:26 -0500

>So, I'm trying to sort out exactly what is being
>proposed here. Is what is being proposed is that a
>home agent be allowed to rely *solely* on a return
>routability test?

No. 
What is being proposed is the ability to authenticate to an HA in
a manner similar to what is done in MIPv4 today via a pre-shared key
and the BAD option in the BU thereby bypassing the need for having an
IPsec SA to secure the BU.

> That is, a home agent operating
>as a home agent, not as a CN? If so, then I think
>that there is a considerable amount of difference
>between a CN and a HA which makes this proposition
>pretty dubious. 
>
>Let's start with first principles here: the
>security requirements would always like to have
>strong cryptographic auth/authz. However, we have
>relaxed the requirement for strong auth/authz for
>CN's *because* the existence of a widespread PKI
>which would make it possible is extremely
>unlikely. Thus, requiring strong auth/authz would
>make route optimization essentially a dead
>letter. However when we consider the HA/MN
>requirement for auth/authz we must start from the
>same initial preference: strong crypto. In this
>case however, there is no requirement for a
>widespread and pervasive PKI. Indeed, this is a
>very localized keying necessity, the kind we know
>can be and has been deployed. Thus, I do not think
>there is any reason to make provisions for a
>weaker auth/authz scheme.

I do not believe the BAD scheme makes the BU any weaker. The security
of the BU is as good as the key and the crypto-algo used to compute
the authentication data. So it is in no way any weaker than the IPsec
based SA for securing the BU.

>
>Now, if what is being proposed is some other
>mechanism which requires shared keys of any
>kind in the calculation of the authorization
>data, then I stand by my previous comments.
>
>		  Mike

-Basavaraj

---

From: Michael Thomas <[email-masked]>
Date: Mon, 14 Oct 2002 13:42:53 -0700 (PDT)

> IPsec SA to secure the BU.

   Let me try this again: is what is being proposed is to
   use the binding authorization data which uses a keyed
   hash using a private (to the host) secret key, and
   instead allow it to be directly verified by the other
   party if it is also in possession of the secret?

   If that's what's being proposed, either I'm a real
   dunce and this should have been obvious, or it's going
   to need a bit more explaination than I've seen
   on the list. Nor does it strike me as obvious
   that this is secure, though it's possible I've
   missed that discussion.

	       Mke

---

From: Vijay Devarapalli <[email-masked]>
Date: Mon, 14 Oct 2002 14:17:16 -0700

>    party if it is also in possession of the secret?

what does the word 'instead' mean in the above paragraph? 
if that word is removed, I would have said "Exactly!! this 
is what is being proposed".

Vijay