Subject: RE: [mobile-ip] Question about sending BU to CN

From: [email-masked]
Date: Tue, 1 Oct 2002 11:07:44 -0500

> => The MN doesn't necessarily do RR as a result of movement.
> So this might need to be explpained as a special case
> (BU lifetime expires at the same time that the MN
> moves).
> 
> Hesham

The MN does have to do the COTI/COT test (partial RR) at least 
every time it has a new CoA. I think this is not clear in the 
draft. It needs to be explicitly stated somewhere in section 11.6.2.

Since the HOTI/HoT messages need not be performed unless the lifetime
issabout to expire, there needs to be some text that needs to mention 
that the MN should wait to receive the BAck from the HA before sending
HOTI/HoT (as you say special case).

-Basavaraj

---

From: [email-masked]
Date: Tue, 1 Oct 2002 13:37:56 -0500

> 
> Hesham Soliman (EAB) wrote:
> > => Only if the cookies expired. I believe the draft
> > allows the MN to send a BU without RR before the 
> > cookies expire.
> 
> No.  If the CoA changes, the COTI/COT exchange is required 
> prior to BU,
> so that a new care-of cookie that reflects the new CoA is created.
> Without it, the authentication of the BU will fail becuase the
> care-of cookie will be different at the CN from the one on MN.

This is my understanding as well. The MN can send a BU without RR
if it has NOT moved and the cookies have NOT expired. 
I think that the draft should be explicit about this and some text
to this effect should be in sec 11.6.2

> > => For that special case, yes, but I don't 
> > think the MN needs to perform RR (or COTI
> > only) everytime it moves.
> 
> Full RR is not required, but at least COTI exchange is.

Yes.

> -vlad

-Basavaraj

---

From: "Hesham Soliman (EAB)" <[email-masked]>
Date: Tue, 1 Oct 2002 20:55:33 +0200

> to this effect should be in sec 11.6.2

=> Of course! sorry I was completely wrong about this.

Hesham