Subject: Re: [mobile-ip] MIPv6 Issue 120: Mobile Prefix Advertisements

From: [email-masked]
Date: Sun, 27 Oct 2002 16:57:40 -0800

Jari

I was wondering if a prefix was deleted and nothing else was changed at the home agent/home link then how would your procedure work? Specifically which home address was used in the BU to ack the change? To the one that was deleted? Could we suggest then to use MPS as the only means for acknowledging the MPA?

As MPAs are not secured, wouldn't this "deletion of home prefixes" by an attacker create possibility to a DOS if we allowed any home binding qualify as an acknowledgement? 

Hannu

The home agent SHOULD periodically continue to retransmit an
    unsolicited Advertisement to the mobile node, until it is
    acknowledged by the receipt of one of the following messages
    from the mobile node:

    - A Mobile Prefix Solicitation.

    - A Binding Update for any home address with any of the
      modified prefixes. The modification can be the addition
      of a new prefix, the deletion of an existing prefix, or
      some other change in the information regarding the prefix.

      Note that the Binding Update is considered to be for a
      specific home address either because the home address
      was explicitly given in the message, or because it was
      implied through the use of the Single Address Only (S)
      bit.

---

From: Jari Arkko <[email-masked]>
Date: Mon, 28 Oct 2002 16:35:12 +0200

[email-masked] wrote:

> I was wondering if a prefix was deleted and nothing else was changed at
> the home agent/home link then how would your procedure work? Specifically
> which home address was used in the BU to ack the change? To the one that
> was deleted? Could we suggest then to use MPS as the only means for
 > acknowledging the MPA?
> 
> As MPAs are not secured, wouldn't this "deletion of home prefixes" by
 > an attacker create possibility to a DOS if we allowed any home binding qualify as an acknowledgement?

I think the attack exists whether we use BUs or MPSes as an ack,
IF there is no security (but didn't we finally decided that we
will have it?)

The deleted prefix question is important. When I wrote the proposal
I was thinking that the mobile node will send a de-reg BU for the
prefix that will go away. But what if the MN didn't actually have
a registration for that prefix? We could of course rely on receiving
ANY BU but that doesn't really prove anything, as the mobile node
might be sending them otherwise.

So I agree that we should only use MPS as the ack, and delete the
rest of the text that I proposed!

Jari