Subject: RE: [mobile-ip] New HMIPv6 draft

From: "Hesham Soliman (EAB)" <[email-masked]>
Date: Mon, 21 Oct 2002 19:55:02 +0200

=> The MN can ignore the I flag because it has a choice.
It MUST NOT ignore the P flag, if it does, the operator
can drop its packets. 

The reason for having the 2 flags, is that there is 
an additional (uncompressable in some cases) tunnel involved. 
So there is no need to force this all the time.

  > LCoA depends on the
  > host software and configuration. 

=> The MAP option tells the MN what configuration
it should have for its src address. Just like having
a HA enforces the MN to reverse tunnel. The MN can't 
simply use the HoA address as a source address on the wire
when located in the visited network.

Hesham

PS: If we only have one flag then we are either forcing 
the additional tunnel all the time (if we keep the P
flag) or cannot guarantee that operators will hide 
their addresses (if we keep the I flag).

---

From: "Youn-Hee Han" <[email-masked]>
Date: Wed, 23 Oct 2002 17:16:51 +0900

Hello, Hesham
 
> case 1: The operator does not see the point in hiding 
> the MN's LCoA, but acknowledges that some MNs would need
> this feature for location privacy. For this case, the 
> I flag is set. Hence, the MN MAY use this feature if 
> it wishes to, but the operator does not care.
> 
> case 2: The operator wants to hide its internal addresses
> regardless of whether the MN needs this feature or not. 
> This case was actually requested by some operators. 
> In this case, the operator would set the P flag. The
> implication is: The MN MUST use RCoA as a src address. 
> 
> If the P flag is set, the I flag is irrelevant to the MN.
> The MUST in case 2 overrides the MAY in case 1. 
> 
> The choice of whether the P or I flags should be 
> set is up to the operator's discretion and requirements.
> 

OK, I see. Well then, 
If the operator set the I flag (not P flag), 
can MN use LCoA as the src address of a BU to CNs (and HA)?
In that case, although an MN is aware of 
the HMIPv6 protocol and the existence of a MAP,
it can communicate directly with the CN 
without regard for MAP's packet tunneling function.
That is, the MN can switch off the HMIPv6 function 
and only use MIPv6 protocol stack.
Is it right? If so, should the MN keep up sending 
a local registration to the MAP?

Regards,

Youn-Hee Han
Samsung AIT.

---

From: "Hesham Soliman (EAB)" <[email-masked]>
Date: Wed, 23 Oct 2002 12:58:24 +0200

Forgot to copy the list.

-----Original Message-----
From: Hesham Soliman (EAB) 
Sent: Wednesday, October 23, 2002 12:04 PM
To: 'Youn-Hee Han'
Subject: RE: [mobile-ip] New HMIPv6 draft

  > can MN use LCoA as the src address of a BU to CNs (and HA)?

=> Yes.

  > Is it right? 

=> Correct.

If so, should the MN keep up sending 
  > a local registration to the MAP?

=> It depends on whether it uses Lcoa with
all CNs or not. E.g. it can use RCoA with one
CN and LCoA with another CN. If it does that then
it needs to update the MAP.

Hesham