Subject: RE: [mobile-ip] Binding Authorization data for Binding Update toH ome Agent

From: "Hesham Soliman (EAB)" <[email-masked]>
Date: Mon, 14 Oct 2002 18:06:41 +0200

> Every home agent, by virtue of the fact that it is an Internet node,
  > is also by definition a correspondent node and thus would implement
  > the Binding Authorization Data option. 

=> In the current spec, the HA does not need to implement
any authorisation data. The HA is explicitly distinguished
from the CN by the H bit in the binding update and several
other assumptions that are embedded in the MIPv6 security
design. Anyhow, it is possible that the HA implements this 
feature, but my unanswered question still remains unanswered :(
Why is this needed? Manual config is definitely possible and 
assumed in the spec today with AH/ESP as Gabriel said. 

Other questions that might help this discussion:
- Do we see specific scenarios where this mechanism can 
replace all IPsec SAs between the MN and the HA? 
- Do we need to have some kind of negotiation between 
the MN and the HA to know which method should be used? 
If we don't then we have to mandate both and again I can't
see the reason for it.

Hesham

---

From: Vijay Devarapalli <[email-masked]>
Date: Mon, 14 Oct 2002 10:17:19 -0700

> replace all IPsec SAs between the MN and the HA?

no it cant replace all SAs. but remember that nobody is 
proposing to replace all the SAs either.

> If we don't then we have to mandate both and again I can't

you dont need a negotiation mechanism to implement this.
IPsec policy says protect BU or not. MIPv6 does not accept
unauthenticated BUs. it is easy to plug in Binding 
Authorization Data.

remember HA is a CN first. Binding Authorization Data 
would have already been implemented as part of CN 
functionality.

Vijay

---

From: Michael Thomas <[email-masked]>
Date: Mon, 14 Oct 2002 10:47:29 -0700 (PDT)

So, I'm trying to sort out exactly what is being
proposed here. Is what is being proposed is that a
home agent be allowed to rely *solely* on a return
routability test? That is, a home agent operating
as a home agent, not as a CN? If so, then I think
that there is a considerable amount of difference
between a CN and a HA which makes this proposition
pretty dubious. 

Let's start with first principles here: the
security requirements would always like to have
strong cryptographic auth/authz. However, we have
relaxed the requirement for strong auth/authz for
CN's *because* the existence of a widespread PKI
which would make it possible is extremely
unlikely. Thus, requiring strong auth/authz would
make route optimization essentially a dead
letter. However when we consider the HA/MN
requirement for auth/authz we must start from the
same initial preference: strong crypto. In this
case however, there is no requirement for a
widespread and pervasive PKI. Indeed, this is a
very localized keying necessity, the kind we know
can be and has been deployed. Thus, I do not think
there is any reason to make provisions for a
weaker auth/authz scheme.

Now, if what is being proposed is some other
mechanism which requires shared keys of any
kind in the calculation of the authorization
data, then I stand by my previous comments.

		  Mike

---

From: Vijay Devarapalli <[email-masked]>
Date: Mon, 14 Oct 2002 11:06:25 -0700

Michael Thomas wrote:
> as a home agent, not as a CN? 

absoultely not. sorry for the confusion. 

> data, then I stand by my previous comments.

okay.

Vijay

---

From: Michael Thomas <[email-masked]>
Date: Mon, 14 Oct 2002 11:22:52 -0700 (PDT)

> absoultely not. sorry for the confusion. 

   Good. I was just making sure that I wasn't tilting
   at windmills :)
 
 > > data, then I stand by my previous comments.

   So, this doesn't appear to be in -18. Is there
   a concrete proposal in another draft that I've
   missed?

		Mike

---

From: Vijay Devarapalli <[email-masked]>
Date: Mon, 14 Oct 2002 11:56:26 -0700

>    a concrete proposal in another draft that I've

what is being proposed is to use Binding Authorization
Data option with manual keying for MN - HA BUs. 

considering that manual IPsec keying is currently the 
default mechanism for protecting the MN - HA BUs and 
Binding Authorization Data option is already implemented 
on the HA as part of CN functionality, why is difficult 
to combine the both?

think about it again for a minute.

Vijay

---

From: Michael Thomas <[email-masked]>
Date: Mon, 14 Oct 2002 12:15:53 -0700 (PDT)

> think about it again for a minute.

   I'm thinking about it again, but not much is coming
   out. Is what you are proposing is that we combine
   IPsec manual keying with the return routability test?
   That is, there is no shared key hash or any other
   changes required to the current spec? Is the
   reason to provide replay protection?

   If so, this sort of strikes me as turd
   polishing at best, the camel's nose under the
   tent at worst.

	   Mike

---

From: Vijay Devarapalli <[email-masked]>
Date: Mon, 14 Oct 2002 12:37:52 -0700

>    IPsec manual keying with the return routability test?

NO. there is no return routability here. just the Binding
Authorization Data, which is used in Return Routability.

just reusing it with manual keying.

think about it again :-)

Vijay