Subject: RE: [mobile-ip] Simple MIPv4 Question

From: "Phil Neumiller" <[email-masked]>
Date: Wed, 23 Oct 2002 13:29:12 -0400

Hi Vinod,

I am not sure I understand your suggestion of a pre-configured static tunnel
to each AR from the FA.  How does the FA know which tunnel to use?  I 
am assuming the FA would have to have several of these configured.  The
FA only has a visitor list with a MAC address that tells it nothing about the
correct tunnel - right?  

The globalv4 and globalv6 drafts address this problem for ad hoc networks, 
but it is not addressed for fixed networks, then again, maybe this is just
micro-mobility which is deemed a research topic currently.  It would seem
that the FA should be able to wiretap whatever type of routing that may
be running below it (i.e. MANET of fixed IGP) then it would just be a
matter of route convergence time in the network under the FA.  The MIP
FA advertisements have a TTL of one so they would not be propagated
over any sort of router mesh under the FA, but these static tunnels you
suggest could be used to propagate the FA advertisements out to the
wireless edge it seems, and I suppose the FA could be modified to cache
the proxy ARP interface address of the where solicitations and/or MN
registrations are coming in on from the mobiles.  This assumes though that
the routing protocol constructs a return address as it passes packets up
from the MN to the FA (which is not a given in every routing protocol).

I think I am falling into a ball of confusion here.  Does somebody have
an easy answer for this?  Is HMIP the answer?  Do I really need to
dig up micro-mobility things again to answer this?  Did I miss something
obvious in RFC 3344?

Thanks,

Phil

-----Original Message-----
From: Vinod Kumar Choyi [mailto:[email-masked]]
Sent: Wednesday, October 23, 2002 10:39 AM
To: Phil Neumiller
Subject: Re: [mobile-ip] Simple MIPv4 Question

Hi,
Since you are talking about a MIPv4 FA, I guess that would not be 
possible to put it out there, at least going by the standards you would 
have to put it one hop away from the MN (I hope I am right on this).
The other ways to do it would be to use something like a MAP or RegReg. 
or if you do not want to follow any of the above (including RFC 3220) 
then just have a tunnel (pre-configured- static tunnel) running from FA 
to the AR.
I hope this helps.
regards
vinod
Phil Neumiller wrote:
>Hi,
>
>I am sorry to trouble this busy list with such a simple question, but here goes. If one wishes
>to place a MIPv4 FA somewhere upstream in a large network, i.e. a few routers seperate the
>FA and the access routers that MNs attack to, does the FA need to build a source route
>to the MN? In the reverse direction, the MN can clearly use the FA as a default route and
>that is fine. I am concerned about the scenario of:
>
>FA -> Router 1 .... -> Router K -> MN, 
>
>i.e. packets getting from the FA to the MN that may indeed be moving across different
>routing chains.
>
>A simple gratuitous ARP does not seem to handle this situation. What am I missing?
>
>Thanks,
>
>Phil
>--
>Phillip D. Neumiller ([email-masked])
>My PGP key can be imported from the following URL: http://pgpkeys.mit.edu
>BTW: It is undecidable whether an arithmetical formula is true!
>
--
Phillip D. Neumiller ([email-masked])
My PGP key can be imported from the following URL: http://pgpkeys.mit.edu
BTW:  It is undecidable whether an arithmetical formula is true!

---

From: "Alper E. YEGIN" <[email-masked]>
Date: Wed, 23 Oct 2002 11:58:33 -0700

> an easy answer for this?  Is HMIP the answer?  Do I really need to

Hi Phil,

The easiest solution (from Mobile IP perspective) would be
to create a tunnel between FA and MN, so that they appear to be
on the same link. The rest would be standard Mobile IP.

(you'd have to rely on some out-of-band methods to discover
MN and FA since they are not on the same link until the
tunnel is created, and than create a tunnel).

alper