Subject: [mobile-ip] [ID-Announce] Recommendations for Achieving Seamless IPv6 Handover in IEEE 802.11 Networks.

From: "Paul Tan Hock Lai" <[email-masked]>
Date: Thu, 06 Mar 2003 00:34:00 +0800

Dear contributors,

I have recently submitted an individual draft which entails recommendations on achieving seamless IPv6 handover in 802.11 networks.

** abstract **
To achieve seamless layer 3 handover, mobile nodes must be able to perform movement detection and neighborhood candidate access routers discovery quickly and efficiently.  
    
In this document, we present a conceptual overview on how to extend the IEEE 802.11 Management frames to carry extensible application-specific Information Element, which allow access points to advertise the capabilities information of its associated network/provider and also to improve movement detection. We believe that mobile nodes can thus dynamically discover neighboring candidate access routers or networks more quickly and efficiently, and also to obtain valuable capabilities information so as to select the 'best' target access router to initiate seamless handover.  

You are most welcome to read this draft from the following link:
http://www.ietf.org/internet-drafts/draft-paultan-seamless-ipv6-handoff-802-00.txt

I sincerely look forward to your valuable feedback concerning this draft. All comments and inputs are welcomed and greatly appreciated.

Yours Sincerely,
Paul Tan

" .... success is never guarantee 
  but failure is, if you don't
  even try ... "

---

From: Greg Daley <[email-masked]>
Date: Thu, 06 Mar 2003 11:19:18 +1100

Hi Paul,

Certainly the use of an Information Element or elements
to perform Upper layer signalling is an interesting one,
but there are some concerns which I have.

Section 7.2.3 of 802.11 mentions that IEs which aren't
understood may be ignored by those reading the IEs.
This means that nodes which understand the application
specific IEs will be able to process them and other
devices will skip them (if those devices conform to 802.11).

This is good, though could be made more explicit in your
document's text.

Unfortunately, there is not any Application-Specific-IE
defined in 802.11, and the abovementioned paragraph
says: "Element type codes not explicitly defined in
this standard are reserved, and do not appear in any frames."

This means that the responsibility of allocating an
application-specific-IE rests with IEEE, rather than IETF.
I'm sure that for proof-of-concept this won't be a problem though.

Also, I think that it would be useful to have
an informative reference to Fikouras, K\"onsgen and G\"org
"Accelerating Link-Layer Handoffs Through Link-Layer Information"
When discussing putting the L3 Identifier in the ESSID, for
comparison's sake.

I'll email you later and ask more specific questions, if that is OK?

Greg Daley