Subject: [mobile-ip] Do You FBU?

From: "James Kempf" <[email-masked]>
Date: Thu, 13 Mar 2003 09:57:26 -0800

So I'm sensing a lot of resistance to my proposal to modify the base signaling
for FMIP to better align with existing ND signaling and to make the security
more straightfoward, but most of the comments so far are coming from the spec
editor, who has a natural interest in seeing the number of changes limited, and
old FMIPv6 design team members, who have a natural interest in seeing their
personal investment in "intellectual property" be preserved.

What do other people think? Should we continue with the old MIPv4 idea of having
the AR be an on-link home agent and have the same kind of signaling, or should
we try to separate out the global and local signaling along the lines of the
ideas in draft-kempf-mobileip-arch-00.txt?

I'm happy to go away and shut up for now if people aren't interested in making
such a deep change.

            jak

---

From: Rajeev Koodli <[email-masked]>
Date: Thu, 13 Mar 2003 15:08:43 -0800

James,

> editor, who has a natural interest in seeing the number of changes limited, and

this is inaccurate, as well as unfair characterization.

- I hope you would agree that I, like anyone else interested in this work,
    is entitled to provide comments. If you see that as resistance, that's
    unfortunate. I would like to see it at least as discusssion that solidifies
    our ideas on IP mobility.

- You are throwing a blanket statement that I as an editor would like to
    see the changes minimal. You might be overlooking the fact that I _am_
    proposing changes, just as you might be, all the time. What goes into the
    draft however is based on what the majority of the working group thinks!

- My role as an editor is to sheperd the draft towards a standard based
    on the majority opinion expressed on the working group. I will incorporate
    what the group wants.

> personal investment in "intellectual property" be preserved.

I don't know about any "intellectual property" attributable to design team
members. Nobody has disclosed any statements, as far as I can tell. Is there
something I am not aware of ?

-Rajeev

---

From: Michael Thomas <[email-masked]>
Date: Fri, 21 Mar 2003 11:04:48 -0800 (PST)

> I'm happy to go away and shut up for now if people aren't interested in making

To be contrarian, I guess I don't understand the
value of differentiating between "local" mobility
and "global" mobility. Yes, we all will agree that
speed of light considerations drive you toward the
conclusion that having tunneling agents locally
available for fast handover is clearly a way of
dealing with movement. However, that strikes me as
*mainly* a network engineering issue, not a
protocol or architectural issue. That is, the
mechanisms of providing local tunnel forwarding is
still by and large MIP... with a few added
optimizations. Trying to divine difference could
lead toward unnecessary divergence. Also: for
implementations, it would be really unfortunate if
the outcome was separate development efforts, etc,
because the developers wrongly concluded (or
worse, rightly!) that these were two separate
animals.

So my big question is not whether we need to
partition the problems space, but instead merge
it. Why can't we start with the base MIPv6 draft
as a given (now that it's stable), use its
security mechanism, etc, etc, and *merge* all of
the concepts of FMIP, HMIP, etc, etc, into another
more unified "MIP extensions" draft which is
mainly aimed at things HA-like things can do to
facilitate local handoffs, etc. Also: I think it
might be useful to nuke all of the use-case stuff
in those drafts and move it into either an
informational or BCP kind of RFC leaving only the
concise protocol guts in the standards track
document.

		Mike

---

From: "James Kempf" <[email-masked]>
Date: Fri, 22 Aug 2003 20:38:18 -0700

Michael,

One argument for separating local and global mobility is to provide more
modularity in the design. Though it seems hard to imagine now, it might be
possible that at some point MIP is replaced by something else. It would be good
if the overall IP mobility protocol suite could have enough flexibility to avoid
having to change the local signaling because the global mobility management
changed. There are other, less architectural arguments against your proposal
that I could make, but, since I have made them in the past, I will refrain from
repeating them.

In sum, I don't agree with your proposal.

            jak

---

From: Michael Thomas <[email-masked]>
Date: Sun, 23 Mar 2003 12:20:51 -0800 (PST)

James Kempf writes:
 > modularity in the design. 

   In isolation, modularity buys nothing. Your claim is
   that thinking of this as two separate spaces buys us
   something. I don't see it.

 > Though it seems hard to imagine now, it might be
 > possible that at some point MIP is replaced by something else. 

   Um, so? This is a non-sequitur.

 > It would be good
 > changed. 

   Why? And what prevents anybody from doing that as things
   stand now?

   There is a distinct downside of speciation. There needs
   to be compelling reasons why one would want to do that.
   How designers expect people will deploy things
   is usually not a very good reason as good
   protocols often get used in unexpected ways.

	     Mike