Subject: [mobile-ip] �좷e: Re: Movement Detection (was Re: [mobile-ip] Connectathon최진혁 i_Networking_LAB 삼성종합기술원 전문연구원

From: 최진혁 <[email-masked]>
Date: Wed, 19 Mar 2003 06:13:34 +0900

Hi Greg

> I believe the conclusion which Ed and JinHyeock reached
> earlier was like this. Since we've got to look at the
> situation where L2 triggers aren't available on the MN,
> this may be the required fallback case for beaconing
> systems (Check old router with RS/RA, using beacon as a
> hint).

Even if L2 trigger is available, we may have to do NUD with old AR. 

L2 trigger may give information like 'Old link is down and new is up'. 
Then we can be sure that MN has moved and it's natural to send RS to 
new AR. In this case, No need to send RS to old AR.  

But L2 trigger may give insufficient information like 'Old link 
(signal length) is weakening and a new link (signal length) is 
strengthening'. 

In this case, We can't be sure that MN is actually moving. What is the 
suitable thing MN to do? Should it perform RS/RA with old AR or new AR? 
Or should it just wait till old link go down? 

> I think people are coming to the conclusion
> that reception of an unsolicited RA is insufficient
> to confirm movement, though.

For movement detection, MN can perform the following operations. 
1) receipt of unsolicited RA
2) RS/ RA exchange with old AR
3) RS/ RA exchange with new AR

I agree that 1) alone is not sufficient (at least in the current form 
of RA). I wonder MN should perform all three operations for movement 
detection. I am worried that it would take too much time for seamless 
handoff.

---

From: Greg Daley <[email-masked]>
Date: Wed, 19 Mar 2003 10:14:58 +1100

Hi JinHyeock,

Thanks for your analysis.

If I may add something: you've mentioned
that the current unsolicited RA doesn't
provide enough information to confirm
movement.

I have a thought experiment, which may provide
a solution below.

> Or should it just wait till old link go down? 
I'm pretty sure that movement detection is about
ensuring that you have a valid Care-of-Address,
and not spuriously signalling address changes.

RS/RA can be used to confirm a router's bidirectional
reachability, but people are looking at determining
whether the old router is unavailable. RS/RA may not be
the best mechanism for this check.

> detection. I am worried that it would take too much time for seamless 
RS/RA exchange with a new AR is valid if it tells
you that the MN is not on the old link.

Even an unsolicited RA which can indicate this
(or L2 signals like Paul Lai's) mean that
bidirectional RS/RA checks aren't strictly necessary
(although the test shows bidirectionality, which is
useful knowledge in itself).

If the RA was able to say "I am the primary MIPv6
router on this link", then reception of that RA
would be similar to  what Brett was talking about
with FastRA:

There can not be two primary routers on the link, so
I must have moved.

If the MN receives RAs from a router which is not
indicated as primary for MIPv6, and subsequently
receives RAs from a primary, it may assume that
the primary MIPv6 router's prefixes are valid, since
it will have superior MIPv6 support anyway
(such as FastRA, HMIPv6 options,
Advertisement Intervals, Router Addresses).

If the MN is connected to a router which is a
MIPv6 primary router, and then receives an RA
from a router which doesn't claim to be primary,
It makes sense to check the availability of the
primary router.

In order to defend against spurious RAs close
attention to SEND requirements would have to be
observed, though.

Please tell me if this is a useful idea or not.

Greg D.