Subject: Fw: Movement Detection (was Re: [mobile-ip] Connectathon 2003 issues for MIPv6 draft-20)

From: "James Kempf" <[email-masked]>
Date: Mon, 17 Mar 2003 08:31:32 -0800

> And the frequent RAs don't guarantee that you've moved.
> In somebody adds an additional router on the link
> (or an additional existing router can reach the MN)
> then it doesn't mean that the old router is no longer bidrectionally
> reachable. An RS/RA exchange will indicate whether the old router is
> still bidirectionally reachable.
>

From a deployment standpoint, I think it makes sense to limit links where 50 ms
RAs are multicast to only one router. As Greg and JinHyoeck's paper indicates,
50 ms RAs consumes about 16.6 kbps. The more routers on the link, the more
bandwidth consumed by nonsubscriber traffic. I have hard time seeing wireless
providers and enterprises use the 50 ms RAs, even for free spectrum, though,
perhaps it will be OK for SOHO use.

> Good point.
> I guess it depends on how accurate the movement hints are.

This depends on the link layer. For 802.11, it is pretty accurate, since the MN
is doing the moving, and will only give the hint if the AP has confirmed the
move. However, there is a high probability of ping-pong in 802.11, depending on
the AP deployment configuration. If the two APs between which the MN was
ping-ponging are in different subnets, it could lead to ping-ponged RSs. Of
course, one can ascribe this to a poor deployment but it is hard to get a
deployment right.

For cellular (FWIW), I think the probability of ending up on a different IP
subnet is pretty low too, since the handovers are pretty tightly controlled.

> If a movement hint with high probability corresponds to an actual movement
> there might not be much harm to send a multicast RA in response to an RS,
> because each movement will already incur a few multicast messages
> (MLD join of solicited node MC address(es), DAD, RS to find new routers).
> But if 90% of the movement hints are false (e.g. due to frequent L2 going up
> and down) then it would be a problem to incur additional multicast packets.
> In that case a strategy that first performs a unicast RS/RA exchange with the
> old default router(s) would make more sense.
>

Clarification: I think FastRA does unicast RS to the new router. So it would
require oDAD to really make a difference.

            jak

---

From: Greg Daley <[email-masked]>
Date: Tue, 18 Mar 2003 10:14:56 +1100

Hi James,

> perhaps it will be OK for SOHO use.

Indeed, within a building or organization, we may see this
sort of mechanism if the wireless bandwidth is seen as 'free'.
Also, it scales well for any number of cells per router,
so there may be cost tradeoffs which make it a factor.

I can't think of a generically useful wireless technology
which exceeds the data rates available for WLAN today, but
in situations where the multicast transmissions take up
a very small proportion of the available bandwidth (<0.5%)
the bandwidth load of beacons is unlikely to be a factor
in deployment.

> subnet is pretty low too, since the handovers are pretty tightly controlled.

I think that in most cases, if an MN gets a (reliable) link-up
trigger then it has to send an RS, even if the RA says you're
on the same subnet.

Even in cellular systems, MNs are going to be interested in
checking that their AR/CoA hasn't changed.  It may make more
sense though to use RA caching, or embed L3 information (or
even SP administrative domain change information) in L2
frames, in order to provide full movement detection, or prompt
RS.

If an RS is only needed on change of SP admin domain, then
acting on a trigger which indicates this would be more
appropriate than sending RS on 'link-up' indication.

> require oDAD to really make a difference.

Actually, that's what I was trying to 'hint'.
I'm not sure that it's good practice to send
an RS from the link-local unicast address after
receiving a link-up trigger.
You'd have to treat it as tentative in some fashion,
otherwise the effects of collision (in the rare
case of actually colliding) would be nasty.
Optimistic-DAD on the address should work though.

Greg D.