Subject: [mobile-ip] RE: [mipcharter] comments on draft-kempf-mobileip-arch-00.txt

From: "Hesham Soliman (EAB)" <[email-masked]>
Date: Wed, 5 Mar 2003 18:43:02 +0100

James, 

If I lookup words like "tunnel" or "key" or "exchange"
in Webster's Dictionary I would get useless information
about their applicability to IETF standards. So
please read my comments in this context. More below. 

  > > Mobile IP does not handle routing changes. Routing protocols
  > > do that. MIP handles host movement. So I think that
  > > this description is not accurate.
  > >
  > 
  > My copy of Webster's New Collegiate Dictionary (1979, i.e 
  > preInternet) defines
  > "routing" somewhat circularly:
  > 
  >      routing: to send by a selected route, to divert in a 
  > specified direction
  > 
  > and for a route (in this context):
  > 
  >     route: a traveled way, a line of travel, an established 
  > or selected course
  > of travel or action
  > 
  > To the extent that a home agent diverts packets in a 
  > specified direction toward
  > a mobile node, it is performing routing. To the extent that 
  > a binding update
  > causes that specified direction to change, there is a 
  > routing change.

=> So what I think you're trying to say is that MIP
causes _a_ routing change. _Not_ that "MIP handles _routing_
_changes_". the latter is too generic and confusing. Despite
what Webster says :)

  > > What is "Global routing change"? and what is "local 
  > routing change"?
  > >
  > 
  > Defined in the text, but perhaps we need to call this out 
  > more clearly in the
  > next draft.

=> This text was in the abstract. I think you need to use
terms that are already known to the community in the abstract.

  > > Where is the "routing failure"? Routing does not fail, it
  > > still works and packets are delivered to other nodes.
  > > What happens is that the MN moves. Perhaps you could
  > > say that there is a loss of connectivity, link failure ..etc
  > > but there is no routing failure here.
  > >
  > 
  > My Webster's defines failure as:
  > 
  >     failure: a falling short
  > 
  > To the extent that the packets directed to the MN fall 
  > short of the MN (by
  > virtue of their getting dropped at the old AR) when the MN 
  > moves, there is a
  > failure, until the binding update occurs.

=> Of course, but this failure is due to the fact
that the MN is not present. It is _not_ a failure
in the routing infrastructure. Read: This address
no longer exists!

  > >      "A change in the global routability of packets due 
  > to movement
  > >      betweens subnets"
  > >
  > > "Global routability" ? I don't understand this term.
  > >
  > 
  > Websters on global:
  > 
  >     global: of, related to, or involving the entire world
  > 
  > Routablity is derived from the above, namely the capability 
  > to be sent in a
  > particular direction. Thus global routability implies 
  > capability of directing
  > across the entire world. Considering the Internet's current 
  > span, I think this
  > is accurate.

=> I don't think it is accurate. There is no change in the
global routing system due to an MN's movement. This 
is a major requirement for MIP. I'm not asking for an
abstract explanation of english words; They are simple
enough for me to understand. I'm asking of 
their meaning in the context of Internet routing.

  > >    "The Internet routing architecture uses an IP
  > >    address for two purposes:
  > >
  > >    - To provide a globally unique node identifier for use by the
  > >      transport layer, which is the node identifier, "
  > >
  > > Actually, Internet routing does not use IP addresses for
  > > this purpose. MIP does though for reachability and
  > > transparency to upper layers.
  > >
  > 
  > The TCP (and now SCTP) uses the IP address to identify an 
  > outstanding connection
  > to a node. Perhaps we should have qualified this as "the 
  > Internet architecture"

=> No it wouldn't be accurate either. Please see the extract
from the draft above, it says "node identifier".

  > rather than "routing architecture" because it involves the 
  > Transport Layer which
  > is not directly involved in routing.

=> Transport layers use it to identify a _connection_
not a node.

  > >    "In addition, packets
  > >    from the Mobile Node are typically also reverse 
  > tunneled through the
  > >    Home Agent, if ingress filtering in the access network 
  > is operating."
  > >
  > > Reverse tunnelling is (at least for v6) independent of
  > > the presence of ingress filtering. It will always happen.
  > >
  > 
  > OK. The draft spans v4 and v6.

=> I understand, the comment applies to both.
A host does not know if ingress filtering is present
or not.

  > 
  > >    "In many
  > >    respects, the Foreign Agent looks like an on-link Home 
  > Agent. It
  > >    maintains a binding between the care of address (typically the
  > >    global address of the Foreign Agent itself) and the link layer
  > >    address of the Mobile Node, similar to the binding 
  > cache maintained
  > >    by the Home Agent."
  > >
  > > I don't think this is correct.
  > >
  > 
  > Uh, why?

=> Hmm. Does this look correct to you:
  "It
  maintains a binding between the care of address (typically the
  global address of the Foreign Agent itself) and the link layer
  address of the Mobile Node, similar to the binding 
  cache maintained by the Home Agent."

The HA maintains a binding between a HoA and a CoA not between
an IP address and a MAC address. 
Also the text says that the FA maintains a binding between its 
own address (CoA)which is shared by many MNs and a MN's 
link layer address. If that were the case, the FA would not
be able to forward packets to the MN!

Hesham

---

From: "James Kempf" <[email-masked]>
Date: Wed, 5 Mar 2003 13:41:50 -0800

Hesham,

> their meaning in the context of Internet routing.

I agree that it is not a change in the global routing fabric.

But suppose an MN in California contacts a CN in Singapore. Packets are routed
through the MN's home agent in Japan. Now suppose the MN moves and a BU is sent
causing packets to get routed through Hawaii.

Isn't that a change in the global routing of the MN's packets?

        jak