Subject: RE: Movement Detection (was Re: [mobile-ip] Connectathon 2003 issues for MIPv6 draft-20)

From: "KASSI-LAHLOU Mohammed FTRD/DMI/CAE" <[email-masked]>
Date: Mon, 17 Mar 2003 15:46:05 +0100

Hi,

Moreover to avoid the "ping-pong" problem, the mobile node must be sure
that it has lost the contact with the current router, therefore the
mobile node should not change each time it receives a new RA.

Kassi

-----Message d'origine-----
De : Erik Nordmark [mailto:[email-masked]]
Envoye : lundi 17 mars 2003 14:19
A : [email-masked]
Cc : Erik Nordmark; Ed Remmell; JinHyeock Choi; Jari Arkko; Samita
Chakrabarti; [email-masked]
Objet : Re: Movement Detection (was Re: [mobile-ip] Connectathon 2003
issues for MIPv6 draft-20)

> If the L2 hints that a link may have changed then this is
> a more reliable reason why you would believe an RA from
> a previously unseen router.  This doesn't necessarily
> entail RS/RA exchange with a new router, especially if the
> new network undertakes the MIPv6 RA beaconing behaviour
> (~50ms spacing), or network side L2 systems provide or
> prompt an RA upon MN association.

If you know that the MNs can get a local trigger from L2 that they
might have moved, then there is no need to waste bandwidth by sending
RAs every 50ms. 
The frequent RAs help when there is no such local trigger.

And the frequent RAs don't guarantee that you've moved.
In somebody adds an additional router on the link
(or an additional existing router can reach the MN)
then it doesn't mean that the old router is no longer bidrectionally
reachable. An RS/RA exchange will indicate whether the old router is
still bidirectionally reachable.

> It doesn't handle the issue of RS delay, which is highly
> link-layer dependent.  The delays (also shared by DAD) seem
> to be aimed at reducing multicast packet bombing on links
> where many devices are configuring at once.
> This can happen in MIPv6 if many devices move and transmit
> simultaneously.

It would be good to have some (experimental or simulation) data on this.
In practise how close together would a busload or trainload of operating
MNs get a movement hint (from L2 or from frequent RA beacons) when
they move as a unit from one link to another?
If they would all move within milliseconds I think it would be required
to have some randomization.

> At this stage, our early 802.11b tests with 10 nodes
> simultaneously transmitting multicast packets have shown few
> problems (all packets received in <20 ms, little or no
> packet loss).  This isn't particularly helpful if the number
> of devices moving simultaneously exceed these values.
> So we're focussing on MAC simulation, in order to
> characterize behaviour in this area.

Great that you are looking into this.

> RA rate limiting is relatively straightforward, if
> the MN has an address from which it can send the original
> RS (FastRA).  I'm not sure that we'd want to significantly
> reduce the interval between solicited Multicast RA messages,
> which is the only available response if the RS comes from the
> unspecified address.

Good point.
I guess it depends on how accurate the movement hints are.
If a movement hint with high probability corresponds to an actual
movement
there might not be much harm to send a multicast RA in response to an
RS,
because each movement will already incur a few multicast messages
(MLD join of solicited node MC address(es), DAD, RS to find new
routers).
But if 90% of the movement hints are false (e.g. due to frequent L2
going up
and down) then it would be a problem to incur additional multicast
packets.
In that case a strategy that first performs a unicast RS/RA exchange
with the
old default router(s) would make more sense.

  Erik

---

From: Greg Daley <[email-masked]>
Date: Tue, 18 Mar 2003 13:19:32 +1100

Hi Kassi,

> mobile node should not change each time it receives a new RA.

I'm not sure that the big issue is ping-pong.
There are already methods to handle that
(HMIPv6/FMIPv6 HTT).  The big issue is to ensure
that the RA received actually indicates L3 movement.

If the movement is real, we may have to configure
addresses and perform mobility signalling, even
if this means ping-ponging between networks.

I think people are coming to the conclusion
that reception of an unsolicited RA is insufficient
to confirm movement, though.

Greg.