Subject: [mobile-ip] MPS/MPA in home link

From: Keisuke Sakitani <[email-masked]>
Date: Mon, 10 Mar 2003 21:16:33 +0900

Hi,

I have some questions about Prefix Discovery(MPS/MPA) in home link.

a) If an MN is in home link, can the MN send MPS to the HA?

b) If a) is yes, can the MN send MPS without a HAO like BU?

c) If a) is yes, how should the HA behave when it receives MPS?
(Should the HA send BE when it does not have a BC for the MN?)

We allow DHAAD in home link（Issue 166）.
I am not sure Prefix Discovery(MPS/MPA) should be allowed in home link.

Thanks,
Keisuke Sakitani

---

From: Vijay Devarapalli <[email-masked]>
Date: Mon, 10 Mar 2003 06:05:09 -0800

> I am not sure Prefix Discovery(MPS/MPA) should be allowed in home link.

the MN can discover prefixes advertised on home link by just sending
a router solicitation. why would it do Prefix Discovery?

Vijay

---

From: Keisuke Sakitani <[email-masked]>
Date: Tue, 11 Mar 2003 10:03:45 +0900

>a router solicitation. why would it do Prefix Discovery?

I quite agree. The MN should send RS to discover prefixes on home link.

I'd like to know how a HA should  behave
when it receives MPS form an MN on home link by any chance.

Thanks,
Keisuke Sakitani

---

From: Vijay Devarapalli <[email-masked]>
Date: Mon, 10 Mar 2003 17:38:04 -0800

> when it receives MPS form an MN on home link by any chance.

just drop it. I would consider it a bug in the MN implementation,
if the MN sends a MPS from home link.

Vijay

---

From: Brian Haley <[email-masked]>
Date: Tue, 11 Mar 2003 12:00:18 -0500

> if the MN sends a MPS from home link.

Section 6.7 says a Home Address Option MUST be included (from the MN)
and 10.6.3 says the HA MUST use a Type 2 routing header.  These two imply
that a HA will only respond to an MPS for a MN that it is the HA for,
since in other cases it can't meet these requirements.

So yes, I think the HA should drop the request as well.

-Brian