Subject: [Mobopts] Re: Samitas Review of draft-irtf-mobopts-ro-enhancements-00 (was Re: Review of draft-irtf-mobopts-ro-enhancements-00)

From: Christian Vogt <[email-masked]>
Date: Fri, 17 Jun 2005 07:26:41 +0200

Hi Samita,

yes, you are right.

The HoTI needs to be sent through the *old* MN-HA tunnel when the MN 
chooses to send the HoTI/CoTI right after the BU for home registration.

- Christian

-- 
Christian Vogt, Institute of Telematics, University of Karlsruhe
www.tm.uka.de/~chvogt/pubkey/

Samita Chakrabarti wrote:
> Christian Vogt wrote:
> 
>> Hi Samita,
>>
>> I incorporated your comments into the document.  Responses are inline.
>>
>> Again, thanks a lot for the review.
>>
>> - Christian
>>
>> ++++
>>
> Thanks for the update.
> 
>>
>>> Section 5.3:
>>>
>>> After successful BU to HA, the MN-HA tunnel is created if it is not a
>>> refresh. So, how does the MN send optimistic RO to CN using Hoti msg
>>> while the tunnel is not configured yet ?
>>
>>
> 
> 
> I see your point below on security association. However, I was asking 
> whether this method
> assumes that the optimisitc RO (HOTI) is sent through the old MN-HA 
> tunnel before the new
> tunnel is built  between MN-HA with the new COA?   Since HOTI does not 
> depend on COA,
> it is doable. Otherwise, BU to HA needs to be done first and then 
> re-config the tunnel and then
> HOTI through the new tunnel.
> 
>>
>> The SA at the HA may point to an old CoA at the time the HoTI is
>> received because IPsec processing of the HoTI does not depend on the
>> CoA.  RFC 2401 defines that source addresses of the outer IPv6 headers
>> are not checked.  So the HoTI can pass even when sent from a new CoA.
>>
>> However, the SA must be up-to-date when processing the HoT.  After all,
>> that message must be encapsulated somehow and eventually reach the MN at
>> its new attachment point.
>>
>> See also RFC 3776, section 3.2 (Return Routability Signaling), section
>> 5.2.2 (Return Routability Signaling; yes, the name is the same), and
>> section 6.6 (HoTI from the MN).
>>
> -Samita

_______________________________________________
Mobopts mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mobopts

---

From: Samita Chakrabarti <[email-masked]>
Date: Thu, 16 Jun 2005 11:17:22 -0700

Thanks for the update.

-Samita