Subject: RE: [Mobopts] RESEND: MIPv6 and Location Privacy: Problem Statement

From: "COMBES Jean-Michel RD-MAPS-ISS" <[email-masked]>
Date: Tue, 21 Jun 2005 15:15:20 +0200

Hi Rajeev,

I think you forgot these IDs:
draft-haddad-momipriv-problem-statement-01.txt
draft-haddad-momipriv-threat-model-00.txt

which are, in my point of view, maybe what you are looking for :)

BTW, will there be a MomiPriv session (BOF/BarBOF/...) during the next IETF meeting?

Regards. 
 
JMC.

France Telecom - R&D Division - MAPS/NSS  
Jean-Michel COMBES, Internet/Intranet Security
E-Mail: [email-masked]
Phone: +33 (0)1 45 29 45 94
Fax: +33 (0)1 45 29 65 19
Mobile: +33 (0)6 07 29 30 16

________________________________

	De : [email-masked] [mailto:[email-masked]] De la part de Rajeev Koodli
	Envoyé : mercredi 15 juin 2005 20:26
	À : [email-masked]
	Cc : Gopal Dommety; [email-masked]
	Objet : [Mobopts] RESEND: MIPv6 and Location Privacy: Problem Statement

	Hello folks,
	
	we need to produce a problem statement 
	document (for the MIP6 WG). Just to recap, the problems we 
	are looking into are:
	
	- concerns from disclsoing the Home Address to an on-looker when on a visited network
	- concerns from disclsoing that the MN (user) has roamed to a new network
	   to a correspondent
	
	Following are the relevant IDs that describe the solutions. 
	As a first step, we need a succint problem statement document. 
	We will get to the solutions once the problem statement is defined. 
	
	draft-qiu-mip6-hiding-movement-00.txt
	draft-zhao-mip6-rr-ext.01.txt
	draft-dupont-mip6-privacyext-00.html
	draft-koodli-mip6-location-privacy-solutions-00.txt
	
	In the interest of time, I am proposing that we
	use the existing problem statement document
	draft-koodli-mip6-location-privacy-00.txt.
	All input, especially text, is welcome to improve
	the draft.
	
	Comments?
	
	-Rajeev

_______________________________________________
Mobopts mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mobopts

---

From: Wassim Haddad <[email-masked]>
Date: Tue, 21 Jun 2005 17:32:33 +0300 (EEST)

Hi Jean-Michel,

> BTW, will there be a MomiPriv session (BOF/BarBOF/...) during the next IETF meeting?

=> Yes there will be a BoF.

Regards,

Wassim H.

---

From: "James Kempf" <[email-masked]>
Date: Tue, 21 Jun 2005 09:48:08 -0700

Right, I think we need to at least make sure that the problem statement
drafts draft-haddad and draft-koodli are merged so that issues covered in
both are included in the WG draft.

            jak

----- Original Message ----- 
From: "COMBES Jean-Michel RD-MAPS-ISS" <[email-masked]>
To: "Rajeev Koodli" <[email-masked]>; <[email-masked]>
Cc: "Gopal Dommety" <[email-masked]>; <[email-masked]>;
<[email-masked]>
Sent: Tuesday, June 21, 2005 6:15 AM
Subject: RE: [Mobopts] RESEND: MIPv6 and Location Privacy: Problem Statement

Hi Rajeev,

BTW, will there be a MomiPriv session (BOF/BarBOF/...) during the next IETF
meeting?

Regards.

JMC.

De : [email-masked] [mailto:[email-masked]] De la part
de Rajeev Koodli
Envoyé : mercredi 15 juin 2005 20:26
À : [email-masked]
Cc : Gopal Dommety; [email-masked]
Objet : [Mobopts] RESEND: MIPv6 and Location Privacy: Problem Statement

Hello folks,

- concerns from disclsoing the Home Address to an on-looker when on a
visited network
- concerns from disclsoing that the MN (user) has roamed to a new network
   to a correspondent

Comments?

-Rajeev

---

From: "James Kempf" <[email-masked]>
Date: Tue, 21 Jun 2005 09:53:21 -0700

Is there a mailing list or proposed agenda? Or will the discussion be part
of mobopts?

Also, I believe if I recall correctly that draft-haddad takes a more
comprehensive approach than draft-koodli to the problem. Is the BOF to be
restricted to "what are the problems in the current MIP6 protocol with
location privacy" or is it rather to be more comprehensive? If the latter,
there are some issues that I think are not in either draft that I would like
to see discussed.

            jak

----- Original Message ----- 
From: "Wassim Haddad" <[email-masked]>
To: "COMBES Jean-Michel RD-MAPS-ISS" <[email-masked]>
Cc: "Gopal Dommety" <[email-masked]>; <[email-masked]>;
"Rajeev Koodli" <[email-masked]>; <[email-masked]>;
<[email-masked]>
Sent: Tuesday, June 21, 2005 7:32 AM
Subject: RE: [Mobopts] RESEND: MIPv6 and Location Privacy: Problem Statement

---

From: Wassim Haddad <[email-masked]>
Date: Tue, 21 Jun 2005 20:25:28 +0300 (EEST)

Hi James,

> Is there a mailing list or proposed agenda? Or will the discussion be part

=> The current mailing list is the "momipriv".

> there are some issues that I think are not in either draft that I would like

=> OK. The BoF charter will be posted soon to the momipriv ML.

Regards,

Wassim H.

---

From: Vijay Devarapalli <[email-masked]>
Date: Tue, 21 Jun 2005 11:17:24 -0700

I think not. draft-koodli deals with only two problems that are
very specific to the MIPv6 protocol. hiding the CoA from the CN
and hiding the HoA from the visited network. for this we already
have solutions (4 solution drafts). the solution drafts are
surprisingly very similar. more than one draft talks about
generating a "privacy label" and using that instead of the home
address in the data packets.

momipriv looks at lot more than that just these two problems
and I think merits a BoF and a separate mailing list for the
discussions.

my 2 cents.

Vijay

James Kempf wrote:
> Envoyi : mercredi 15 juin 2005 20:26
> @ : [email-masked]

---

From: "James Kempf" <[email-masked]>
Date: Tue, 21 Jun 2005 11:27:43 -0700

I agree that the solutions for the restricted problem of MIP6 location
privacy are very similar, so I think it should be simple enough to come up
with a merger. But do we really need a BOF in order to do that? The MIP6 WG
could simply modify its charter and put MIP6 location privacy on, then get a
design team of a selected set of authors from the existing drafts to come up
with a solution.

So the question is, what is the purpose of the BOF?

        jak

----- Original Message ----- 
From: "Vijay Devarapalli" <[email-masked]>
To: "James Kempf" <[email-masked]>
Cc: "COMBES Jean-Michel RD-MAPS-ISS" <[email-masked]>;
"Rajeev Koodli" <[email-masked]>; <[email-masked]>; "Gopal Dommety"
<[email-masked]>; <[email-masked]>; <[email-masked]>
Sent: Tuesday, June 21, 2005 11:17 AM
Subject: Re: [Mobopts] RESEND: MIPv6 and Location Privacy: Problem Statement

---

From: Vijay Devarapalli <[email-masked]>
Date: Tue, 21 Jun 2005 11:47:53 -0700

> design team of a selected set of authors from the existing drafts to come up

I agree. or the work could be done in mobopts and standardized
in the MIP6 WG.

> So the question is, what is the purpose of the BOF?

the answer is in

which looks at lot more than just hiding the HoA and CoA. I think
a BoF is needed to figure out what exactly the "privacy problem"
is and what IETF can do to address this.

Vijay

>>>drafts draft-haddad and draft-koodli are merged so that issues covered
> 
> in
> 
>>>From: "COMBES Jean-Michel RD-MAPS-ISS"
> 
> <[email-masked]>
> 
>>>Subject: RE: [Mobopts] RESEND: MIPv6 and Location Privacy: Problem
> 
> Statement
> 
>>>
>>>Hi Rajeev,
>>>
>>>BTW, will there be a MomiPriv session (BOF/BarBOF/...) during the next
> 
> IETF
> 
>>>meeting?
>>>
>>>Regards.
>>>
>>>JMC.
>>>
>>>De : [email-masked] [mailto:[email-masked]] De la
> 
> part
> 
>>>de Rajeev Koodli
>>>- concerns from disclsoing that the MN (user) has roamed to a new
> 
> network
> 
>>>   to a correspondent
>>>

---

From: Rajeev Koodli <[email-masked]>
Date: Tue, 21 Jun 2005 15:32:16 -0700

Hi JMC,

>draft-haddad-momipriv-threat-model-00.txt
Actually, I didn't forget them.

>which are, in my point of view, maybe what you are looking for :)
Let me clarify. The problem scope of what was discussed at the last
IETF MIP6 WG is narrow enough that solutions already exist. The
momipriv IDs deserve broader attention and I believe a BOF could be
a good direction.  To re-iterate the problems (listed in my original 
e-mail),
we are addressing the location privacy problems arising from disclosing
a) HoA to an on-looker from a visited network, and b) disclosing CoA
to an unacquainted CN. We need to produce a problem statement document
outlining this for the MIP6 WG by IETF63 (as per the discussion at IETF62).

The ML is open for discussing broader set of topics around privacy as well.
And, I am sure the momipriv BOF will cover interesting issues.

Hope this helps..

Regards,

-Rajeev