Subject: Re: [Modern] Nationwide Number Portability MODERN Use Case Draft

From: "Richard Hill" <[email-masked]>
Date: Tue, 1 Mar 2016 09:14:58 +0100

Inline.

> -----Original Message-----
> From: Modern [mailto:[email-masked]] On Behalf Of Henning
> Schulzrinne
> Sent: Monday, February 29, 2016 23:14
> To: Richard Shockey; Paul Kyzivat; 'Modern List'
> Subject: Re: [Modern] Nationwide Number Portability MODERN Use Case
> Draft
> 
SNIP
> 
> I'm not sure why you consider the effort "US centric". 

As far as I can tell, all of the discussion on this list has related to
issues that are, at least at present, specific to the US.

>I suspect almost
> all countries will be faced with the IP transition 

Probably, but the timing is different, and the specific ways in which the
transition will occur may also be different.  For example, the transition is
currently taking place in Switzerland but, as far as I know, the issues
raised on this list have not been raised in Switzlerland.

>and, in particular,
> with upgrading the existing number portability system, 

That may or may not be necessary.

>if they have
> one, or creating one. The current number portability (whether or not
> it's geographic) leaves much to be desired, as recent events
> (https://www.fcc.gov/document/fcc-plans-296-million-fine-slamming-
> cramming-and-obstruction-0 makes a good read) illustrate.

Have similar issues arisen elsewhere?

>Thus, maybe you can help point out the
> specific features that would need to be supported to implement a
> version of today's policies, possibly with more formal down-delegation
> to facilitate tracking, and possibly multiple "registrars", as exists
> today in the 800# space. (As you know, today we often don't have a good
> idea of who is actually using a number, given informal "delegation" and
> reselling-that-doesn't-dare-call-itself-that.)

I agree with that. And, as far as I know, that is an issue that occurs
elsewhere around the world.

---

From: "Richard Hill" <[email-masked]>
Date: Tue, 1 Mar 2016 09:16:15 +0100

What Henning says below makes sense to me.

Best,

Richard

From: Henning Schulzrinne [mailto:[email-masked]] 
Sent: Tuesday, March 1, 2016 00:31
To: Richard Hill; 'McGarry, Tom'; 'Modern List'
Subject: Re: [Modern] Nationwide Number Portability MODERN Use Case Draft

My understanding (and the use cases draft may need clarity on that) is that
the two facets are largely independent. In other words, you should be able
to run a TDM network with step switches and allocate numbers via an IP-based
process, even if you may have to use a dial-up modem to get your IP packets.
(As far as I know, the current US-specific number management and porting
process is based, in part, on Internet protocols, just a bit on the dated
side.)

I think suggestions on removing US-specific language are useful. As
discussed in this thread, I do see six broad challenges that apply, in
combinations in many jurisdictions:

(1) IP transition

(2) porting (either newly-introduced or with new capabilities, e.g., between
different modes or geographies), possibly with mechanisms other than
voice-based validation of porting intent

(3) automation for multiple levels of delegation, whether for PBX or some
IOT applications

(4) accountability of both holdership and "meta" data (CNAM)

(5) improved number utilization, with more "just-in-time" processes

(6) more flexibility in the number and structure of registrars/registries
(including, for small countries, outsourcing to third parties rather than
creating technology specific to Liechtenstein)

My sense is that the US is facing more of these challenges than many
countries at this point, but they don't seem US-specific. This is not new -
TV whitespaces and emergency caller location for wireless were initially
largely US problems, too.

Henning

  _____  

From: Modern <[email-masked]> on behalf of Richard Hill
<[email-masked]>
Sent: Thursday, February 25, 2016 9:44 AM
To: 'McGarry, Tom'; 'Modern List'
Subject: Re: [Modern] Nationwide Number Portability MODERN Use Case Draft 

Yes, but such a green field space can, and has been, implemented on the
PSTN, so the use of an all IP solution is  not a requirement.  Whereas your
draft implies that it is, unless I misunderstood something.

Best,

Richard

---

From: "Richard Hill" <[email-masked]>
Date: Tue, 1 Mar 2016 09:20:33 +0100

Inline.

> From: Modern [mailto:[email-masked]] On Behalf Of Richard
> Shockey
> Sent: Tuesday, March 1, 2016 00:33
> To: Henning Schulzrinne; Paul Kyzivat; 'Modern List'

SNIP

> 
>I still have
> problems undertaking work where the actual user community has not
> weighed in on requirements. I’d feel a lot better if there was some
> input from BEREC for instance.
> 
> http://berec.europa.eu/

As I said before, if the intent is to develop something that is not targeted only at the USA, then it would be worth trying to broaden the source of inputs.  Consulting BEREC would indeed make sense, but I would enlarge to include the GSMA and ITU-T Study Group 2.

---

From: "Richard Hill" <[email-masked]>
Date: Tue, 1 Mar 2016 09:24:33 +0100

There is also another scenario, which is actually implemented, and might
become more widespread. The ITU assigns directly to an operator (or
consortium of operators), the operators assigns to its customers, etc.  That
happens for numbers starting with +882 and +883. It seems to be of interest
for IOT because it removes the geographical association in the number.

And it seems to me that, in the IOT scenario, what Henning says below makes
a great deal of sense.

Best,

Richard

From: Henning Schulzrinne [mailto:[email-masked]] 
Sent: Tuesday, March 1, 2016 00:54
To: DOLLY, MARTIN C
Cc: Richard Hill; McGarry, Tom; Modern List
Subject: Re: [Modern] Nationwide Number Portability MODERN Use Case Draft

NRA delegates to registry (LNP, NANPA, etc.); registry delegates to carrier;
carrier loans/assigns/delegates (whatever the legal arrangement is;
substitute your favorite term) to some value-added service provider; VASP
assigns to GM and GM assigns number to car. This is the IOT case.

Or GM  assigns numbers from its "supply" to factory in Kokomo, IN; Delco
plant assigns to PBX extensions.

All of this should happen without having to employ a number manager to log
into a web site, submit a file via ftp or send a fax.

Does that make sense? 

Henning

  _____  

From: DOLLY, MARTIN C <[email-masked]>
Sent: Monday, February 29, 2016 6:38 PM
To: Henning Schulzrinne
Cc: Richard Hill; McGarry, Tom; Modern List
Subject: Re: [Modern] Nationwide Number Portability MODERN Use Case Draft 

Henning

Please expand on (3)

Thank you

Martin C Dolly 

Lead Member of Technical Staff

Core & Government/Regulatory Standards 

AT&T

Cell: 609-903-3360

Email: [email-masked]

On Feb 29, 2016, at 6:30 PM, Henning Schulzrinne
<[email-masked]> wrote:

(1) IP transition

Henning

  _____  

Best,

Richard

_______________________________________________
Modern mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/modern

---

From: Richard Shockey <[email-masked]>
Date: Tue, 01 Mar 2016 10:11:46 -0500

Richard, I will grant one thing Henning mentions.  

A lot of the problems look US centric because the problems have started here first.  I can’t recall if the US was the first country to deploy LNP but it was certainly the largest at the time. I do know the cost factors we encountered in the US scared the daylights out of European NRA's.  Its obviously much easier now.  I could run the NPAC on my iPhone rather efficiently.

IP interconnection for voice in the US is without question much more advanced and further along than anything I’ve looked at in the EU or Asia-Pac. My guess is nearly 40% now and with the VoLTE roll outs it will be about 80% and then the real whining about the PSTN Transition endgame begins. By all accounts Canada is about 24 months behind us but the Cable Operators have begun the process with Bell and the others moving along rather quickly. They are having the same problems with all that lovely ..(cough) Nortel gear.

---

From: "DOLLY, MARTIN C" <[email-masked]>
Date: Tue, 1 Mar 2016 15:50:38 +0000

Henning,

Where I agree we need to automate the process so that numbers flow down the chain easily particularly for IoT, I also believe that the FCC will only directly assign numbers to entities that the FCC can PUNISH.

Regards,

Martin

From: Henning Schulzrinne [mailto:[email-masked]]
Sent: Monday, February 29, 2016 6:54 PM
To: DOLLY, MARTIN C <[email-masked]>
Cc: Richard Hill <[email-masked]>; McGarry, Tom <[email-masked]>; Modern List <[email-masked]>
Subject: Re: [Modern] Nationwide Number Portability MODERN Use Case Draft

NRA delegates to registry (LNP, NANPA, etc.); registry delegates to carrier; carrier loans/assigns/delegates (whatever the legal arrangement is; substitute your favorite term) to some value-added service provider; VASP assigns to GM and GM assigns number to car. This is the IOT case.

Or GM  assigns numbers from its "supply" to factory in Kokomo, IN; Delco plant assigns to PBX extensions.

All of this should happen without having to employ a number manager to log into a web site, submit a file via ftp or send a fax.

Does that make sense?

Henning
________________________________
From: DOLLY, MARTIN C <[email-masked]<mailto:[email-masked]>>
Sent: Monday, February 29, 2016 6:38 PM
To: Henning Schulzrinne
Cc: Richard Hill; McGarry, Tom; Modern List
Subject: Re: [Modern] Nationwide Number Portability MODERN Use Case Draft

Henning

Please expand on (3)

Thank you

Martin C Dolly
Lead Member of Technical Staff
Core & Government/Regulatory Standards
AT&T
Cell: 609-903-3360
Email: [email-masked]<mailto:[email-masked]>

On Feb 29, 2016, at 6:30 PM, Henning Schulzrinne <[email-masked]<mailto:[email-masked]>> wrote:

My understanding (and the use cases draft may need clarity on that) is that the two facets are largely independent. In other words, you should be able to run a TDM network with step switches and allocate numbers via an IP-based process, even if you may have to use a dial-up modem to get your IP packets. (As far as I know, the current US-specific number management and porting process is based, in part, on Internet protocols, just a bit on the dated side.)

I think suggestions on removing US-specific language are useful. As discussed in this thread, I do see six broad challenges that apply, in combinations in many jurisdictions:

(1) IP transition

(2) porting (either newly-introduced or with new capabilities, e.g., between different modes or geographies), possibly with mechanisms other than voice-based validation of porting intent

(3) automation for multiple levels of delegation, whether for PBX or some IOT applications

(6) more flexibility in the number and structure of registrars/registries (including, for small countries, outsourcing to third parties rather than creating technology specific to Liechtenstein)

My sense is that the US is facing more of these challenges than many countries at this point, but they don't seem US-specific. This is not new - TV whitespaces and emergency caller location for wireless were initially largely US problems, too.

Henning
________________________________
From: Modern <[email-masked]<mailto:[email-masked]>> on behalf of Richard Hill <[email-masked]<mailto:[email-masked]>>
Sent: Thursday, February 25, 2016 9:44 AM
To: 'McGarry, Tom'; 'Modern List'
Subject: Re: [Modern] Nationwide Number Portability MODERN Use Case Draft

Yes, but such a green field space can, and has been, implemented on the PSTN, so the use of an all IP solution is  not a requirement.  Whereas your draft implies that it is, unless I misunderstood something.

Best,

Richard

_______________________________________________
Modern mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/modern

---

From: Henning Schulzrinne <[email-masked]>
Date: Tue, 1 Mar 2016 16:23:32 +0000

I'm hoping that any MODERN output simplifies enforcement. A lot of problems with numbering (say, 800#) are where companies explore (or exploit, if you like) the gray areas of the rules. For example, "hoarding" is hard to define precisely and concepts of active usage are becoming harder to define as numbers get used in non-traditional ways such as in IOT applications or where a single communication end point can have any number of identifiers. (The numbered entity may be a pipeline monitor that only sends messages when the pipeline has burst. You'd hope that it remains inactive.)

Defining what would help enforcement in the data structures would be a useful, and I suspect you have operational experience that can be helpful here.

ICANN is going through some of the same problems (see the whois discussion and validation of registrand credentials). The more you can automate validation of data in the database, the easier it is to do enforcement at scale.

Henning

________________________________
From: DOLLY, MARTIN C <[email-masked]>
Sent: Tuesday, March 1, 2016 10:50 AM
To: Henning Schulzrinne
Cc: Richard Hill; McGarry, Tom; Modern List
Subject: RE: [Modern] Nationwide Number Portability MODERN Use Case Draft

Henning,

Regards,

Martin

Does that make sense?

Henning

Henning

Please expand on (3)

Thank you

Martin C Dolly

AT&T

Cell: 609-903-3360

(1) IP transition

Henning

Best,

Richard

---

From: Henning Schulzrinne <[email-masked]>
Date: Tue, 1 Mar 2016 16:59:32 +0000

I think it would be helpful for everybody to tell their friends in various places to invite them to the MODERN party.

---

From: Henning Schulzrinne <[email-masked]>
Date: Tue, 1 Mar 2016 17:26:49 +0000

I think we all agree that urgency and timelines will differ across countries. To some extent, the US *is* special because it has such a large number of carriers. I'm not aware of any other country that has 4000+ certificated carriers, and some of these are bottom-fishers.

Even the extent of the robocall and spoofing problems seems to differ dramatically across countries. 

I do believe that, increasingly, many (smaller/niche) carriers will use out-of-the-box management systems for their voice services rather than home brew, so it helps everyone if vendors don't have to build 100's of slightly different number management protocols. Many carriers are now using open-source components, e.g., for their SIP proxies.

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 1 Mar 2016 13:07:15 -0500

On 2/29/16 6:52 PM, Richard Shockey wrote:
>
> If I had 5 dollars for every time I've heard “phone numbers are stupid”  “We need to use SIP URI’s". I would not be on this list but enjoying the sun at my retirement home on St. Barts or some other charming estate with my own private distillery making craft gin or calvados. I have yet to see a SIP URI on any Pizza Delivery vehicle.

Sure. But how many people discover how to order a pizza by looking at a 
pizza car?

For that matter, what percentage of phone calls involve someone actually 
typing in a phone number?

To the extent that the number is simply something listed in your address 
book, or in a link on a web site, there is no real reason for it to be 
an E.164 number.

The key feature of phone numbers is that there is a broadly 
interoperable infrastructure for communicating between things identified 
by those numbers.

	Thanks,
	Paul

> http://time.com/4170936/facebook-messenger-2016/
>
>
>
>
>>>
>>> Wireless and cable carriers are moving inexhorably towards the IP Multimedia Subsystem (IMS) developed by 3GPP (and enhanced/modified by ETSI, Cable Labs, et al).  The 3GPP IMS specs embrace the idea of both public and private identities.  The ETSI enhancements have been particularly focused on wireline convergence on an IMS signaling and media architecture.
>>>
>>> It seems reasonable that an IMS public user identity might be paul-kyzivat.name and which could be used as a user@host format in a SIP URI either as [email-masked] (where Paul Kyzivat has presumably created his own individual private "carrier" so to speak) or as [email-masked] where the paul-kyzivat.name user name is associated with a hosted SIP service through carrier-name.com.
>>
>> All you need to do is look to the design of sip, which fits much better
>> with email-style URLs than phone numbers, to see that this was a vision
>>from way back. It hasn't happened yet. It may yet happen. But your
>> specific suggestion works a lot better for paul-kyzivat than it does for
>> john-smith. :-) At the end of the day friendly names are also a scarce
>> resource. So *somebody* still needs to ration them in some way. But
>> frankly I would rather it not be my carrier who does it.
>>
>> Why can't I attach any sip URL I "own" (my preference being
>> sip:[email-masked]) to my phone number and have calls to it
>> routed through the carriers to my phone?
>>
>>> I won't try to write much more beyond this other than to say that if the core of the MODERN "problem statement" is individual assignment, then there may be solutions or solution frameworks which are superior to the MODERN solution framework variations so far advanced.
>>>
>>> Make sense?
>>>
>>> Pierce
>>>
>>> From: Modern [mailto:[email-masked]] On Behalf Of Paul Kyzivat
>>> Sent: February 25, 2016 5:01 PM
>>> To: [email-masked]
>>> On 2/25/16 1:01 PM, Gorman, Pierce A [CTO] wrote:
>>>
>>>> Telephone numbers are owned and assigned first and foremost by
>>>> national numbering authorities.
>>>>
>>>> The number authorities delegate number blocks to licensed regulated
>>>> entities which both make individual assignments and further delegate
>>>> block assignments.  (Very much like RIRs not surprisingly.)
>>>
>>> [Disclaimer: I am just a kibitzer here. I have no skin in the game.]
>>>
>>> Certainly what you say is the reality. And I am sure that the licensed and regulated entities do regard these numbers as *theirs*.
>>>
>>> But us end users regard the numbers as *ours*. The fact that we must go, hat in hand, to our carrier and beg for any sort of administration of that number is a *problem*, not a feature. Anything that will give us more control over *our* numbers is a *good* thing!
>>>
>>> I have no illusions that the carriers share this opinion. I do hope that the FCC does.
>>>
>>> Thanks,
>>> Paul
>>>
>>> This e-mail may contain Sprint proprietary information intended for the sole use of the recipient(s). Any use by others is prohibited. If you are not the intended recipient, please contact the sender and delete all copies of the message.
>>>
>>

---

From: Henning Schulzrinne <[email-masked]>
Date: Tue, 1 Mar 2016 19:38:07 +0000

Even though it's rarely used without the aid of an address book, the all-numbers, least-common-denominator property still seems to matter. It might be the only thing you can read on a Chinese poster or a Korean hotel business card. This seems to be one of those cases where 100% coverage is much more valuable than 95% cases-covered. Often, if you need the phone number, you really need it, right now (and well beyond 911 and kin).

In many cases, the phone number has also become a (secondary) customer identifier, so converting to something else means updating the grocery store loyalty card, the bank customer database and similar systems. As long as humans write things less than calligraphy-quality, numbers also seem less likely to get confused (i vs. 1, O vs. 0, j vs. i, m vs. n).

________________________________________
From: Modern <[email-masked]> on behalf of Paul Kyzivat <[email-masked]>
Sent: Tuesday, March 1, 2016 1:07 PM
To: [email-masked]
Subject: Re: [Modern] Nationwide Number Portability MODERN Use Case Draft

        Thanks,
        Paul

---

From: Richard Shockey <[email-masked]>
Date: Tue, 01 Mar 2016 14:57:27 -0500

As much as I hate to give Jon any real ammo for his argument. I don’t think the use cases adequately covered the IoT issue and E.212. As we pointed out the relationship between TSP and consumer is the critical element specifically due to the billing relationship.  The issue w Telematics and further IoT issues does point out that the number management systems might be structured differently for different application sets. But the ultimate validity three part system Registrant Registrar and Registry still holds.

>In many cases, the phone number has also become a (secondary) customer identifier, so converting to something else means updating the grocery store loyalty card, the bank customer database and simil…

RS> Indeed and with NG-NP we can eliminate one more hassle for the consumer. And increase the NANP size ..etc. Of course by the time it could be successfully implemented I’ll probably be raising goats in western part of VA.

---

From: "Richard Hill" <[email-masked]>
Date: Tue, 1 Mar 2016 21:25:25 +0100

ITU responds better to formal written communications. If there is support
for it, I can volunteer to draft a short liaison statement to ITU-T Study
Group 2.

Best,
Richard

> Sent: Tuesday, March 1, 2016 18:00
> To: Richard Hill; 'Richard Shockey'; 'Paul Kyzivat'; 'Modern List'
> I think it would be helpful for everybody to tell their friends in
> various places to invite them to the MODERN party.
> 
> >
> >I still have
> >weighed in on requirements. I'd feel a lot better if there was some
> As I said before, if the intent is to develop something that is not
> targeted only at the USA, then it would be worth trying to broaden the
> source of inputs.  Consulting BEREC would indeed make sense, but I
> would enlarge to include the GSMA and ITU-T Study Group 2.
> 
> 
>

---

From: "Gorman, Pierce A [CTO]" <[email-masked]>
Date: Tue, 1 Mar 2016 21:54:51 +0000

I’m guilty of writing something I myself don’t like to receive- a very long e-mail.  For those with little patience for such things, TLDR won’t hurt my feelings.

“The key feature of phone numbers is that there is a broadly interoperable infrastructure for communicating between things identified by those numbers.” – P. Kyzivat

First, I’ll simply agree, but emphasize the key word is “communicating” and that there is a fairly limited set of applications establishing communication using only a telephone number as an address.

For the most part communication established using a telephone number is voice calls and text messages (occasinally accompanied by small pictures).

3GPP and GSMA specifications envision the possibility of more, but do not encompass (yet) communications such as tweets, social networking IM, commercial website chat, and e-mail to name a few.

In the past I’ve advocated that telephone numbers and (private) ENUM could dramatically help improve communications application reachability.  And really it isn’t ENUM per se that offers such an opportunity so much as NAPTR, SRV, and A/AAAA DNS resource records.  And in that regard, a good old-fashioned domain name will work even better than a telephone number.  And in fact could be used to discover telephone numbers in TEL/SIP URIs.  What I like about NAPTR in particular is the ability to use a domain name to discover multiple addresses and applications of interest for a given domain or host with whom I would like to communicate in one or more ways.

The main MODERN problems we’re going to keep coming back to are security and scarcity.

With regard to security, very few of my children’s generation have their telephone number listed in a phone book and if you suggested they needed to list their number they would most likely be annoyed or appalled (or ask, “what is a phone book?”).  THEY want to control who is able to communicate with them, and one of the prime ways they do that, whether they know it or not, is through obscurity.  Robo-dialers and worse are invading their privacy and destroying their ability to remain anonymous and obscure yet available.

When I read about user agent assignments in MODERN, I immediately think of Public ENUM (which failed and which Richard Shockey reminds us from time time is “dead”).  I think the main problem was fear of SPIT (SPAM over Internet Telephony).

So to me the key problems remaining to be solved in user agent assignments of reachability information are:

1)      auditing and recovery   [the scarcity problem]

2)      securely controlling access to the reachability information   [the security problem]

I will paraphrase the suggestion made by Henning on the call today as, “MODERN should acknowledge aportionment from a limited address space can act as a form of containment for damage from abuse of that space.”

It’s a pretty crude form of containment, but it does somewhat address the problems at #1, but we can do better I think.

As acknowledged by 3GPP IMS technical specifications, single user assignments should include the concept of public addresses (best for applications with SPAM filters), and private addresses for those entities or applications permitted more secure access.

I suggest that public addresses should be nearly infinite with little restriction on their syntax such as are invidual domain names of the .name top-level domain.

Private addresses should be discoverable from the public addresses insofar as the discoverer has one or more key(s) permitting them access to that information.  (This is similar to the idea that bad actors whom wish to use confidence to commit fraud and theft use a telephone number to place a call to someone and then using social engineering and pschological manipulation as a password, retrieve more valuable information such as credit card numbers.)

Discovery could be conducted using something like a NAPTR + OPT RR DNS query using (MODERN?) application-specific logic and where the key(s) in the query were supplied in the OPT RR ala something like “draft-kaplan-dnsext-enum-sip-source-ref-opt-code-00” but without the ENUM reverse decimal dot notation and instead using the public individual domain name.  (Clearly, this isn’t something you could do using your father’s DNS.)

A key to one or more of the private addresses could be something as simple as a 10-digit telephone number but really should be simply a password (and of course potentially very long ugly passwords incorporating prime numbers could be used too depending upon who is asking and what application they’re asking for/from).  One or more subsets of private addresses could be reachable via one or more passwords.

Some of the discoverable private “address” information could be a personal telephone number and a STIR public key certificate and the address of the certificate authority, for example.

Other kinds of discoverable private address information could include URIs for Twitter, Facebook, e-mail, et cetera.

I believe what I’ve described could be part of a MODERN solution framework, but would not necessarily include primary assignment of an individual’s private telephone number (although it wouldn’t prevent it either).  The logic offered today for porting could even be expanded to broker commercial service registration transactions with providers such as CSPs and social networks.

There would necessarily be the usual domain name and password security issues, but domain names are not going away and they don’t suffer from being a finite address space heavily integrated into legacy PSTN databases (yet).

---

From: Henning Schulzrinne <[email-masked]>
Date: Wed, 2 Mar 2016 13:31:29 +0000

A few quick comments:

* You may find my IIT conference presentation relevant:

http://www.cs.columbia.edu/~hgs/papers/2015/2015-iit-identifiers.pdf

* The notion of a universal identifier that then leads to communication identifiers like email addresses and phone numbers has a long history, with attempts like Plaxo and Brewster, as well as the more successful ones like Facebook and LinkedIn. Given the conflicting objectives and human psychology, this is not an easy problem to solve. (For example, apparently, asking your Tinder date for his or her SMS number is considered a significant step in a relationship. The human protocol is a lot more complex than MODERN will ever be...)

* For scarce identifiers, there seem to be essentially two approaches, similar to the spectrum management problem:

(1) administrative (regulatory, etc.): make people file reports, measure utilization, threaten punishment or loss of access, etc.

(2) financial: make it economically inefficient to abuse these resources (spectrum fee proposals, spectrum auctions, BitCoin mining, domain name fees, etc.)

My sense is that the emphasis in the public policy and economics community has moved from (1) to (2), but that the initial "free market" enthusiasm is now being tempered a bit by the operational experiences, including market failures, rent seeking, etc.

One interesting development is the idea of funding public goods such as standards or research through such fees. (I believe ISOC gets a large part of their budget through the .org registry, and in turn funds the IETF.)

I don't know if that fully addresses your note, but I'm certainly straying a bit from the core MODERN mission.

Henning

________________________________
From: Modern <[email-masked]> on behalf of Gorman, Pierce A [CTO] <[email-masked]>
Sent: Tuesday, March 1, 2016 4:54 PM
To: Paul Kyzivat; [email-masked]
Subject: Re: [Modern] Nationwide Number Portability MODERN Use Case Draft

---

From: "Gorman, Pierce A [CTO]" <[email-masked]>
Date: Wed, 2 Mar 2016 15:27:02 +0000

Interesting comments.  Thank you Henning.  I'll check out the presentation.

Buried in my blather around how to use domain names as a starting place for single sign-on management of communications contacts using MODERN protocol tools was the comment that multiple passwords would be used to manage access to sets of private reachability addresses.  i.e., I might permit someone to find me on Tinder, but not permit them to know my telephone number.

If we plan to give individuals the ability to make reachability assignments, the protocol tools should support assignments being fully individualized.

Pierce
From: Henning Schulzrinne [mailto:[email-masked]]
Sent: March 02, 2016 7:31 AM
To: Gorman, Pierce A [CTO] <[email-masked]>; Paul Kyzivat <[email-masked]>; [email-masked]
Subject: Re: [Modern] Nationwide Number Portability MODERN Use Case Draft

A few quick comments:

Henning
________________________________
From: Modern <[email-masked]<mailto:[email-masked]>> on behalf of Gorman, Pierce A [CTO] <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, March 1, 2016 4:54 PM
To: Paul Kyzivat; [email-masked]<mailto:[email-masked]>
Subject: Re: [Modern] Nationwide Number Portability MODERN Use Case Draft

I'm guilty of writing something I myself don't like to receive- a very long e-mail.  For those with little patience for such things, TLDR won't hurt my feelings.

"The key feature of phone numbers is that there is a broadly interoperable infrastructure for communicating between things identified by those numbers." - P. Kyzivat

First, I'll simply agree, but emphasize the key word is "communicating" and that there is a fairly limited set of applications establishing communication using only a telephone number as an address.

In the past I've advocated that telephone numbers and (private) ENUM could dramatically help improve communications application reachability.  And really it isn't ENUM per se that offers such an opportunity so much as NAPTR, SRV, and A/AAAA DNS resource records.  And in that regard, a good old-fashioned domain name will work even better than a telephone number.  And in fact could be used to discover telephone numbers in TEL/SIP URIs.  What I like about NAPTR in particular is the ability to use a domain name to discover multiple addresses and applications of interest for a given domain or host with whom I would like to communicate in one or more ways.

The main MODERN problems we're going to keep coming back to are security and scarcity.

With regard to security, very few of my children's generation have their telephone number listed in a phone book and if you suggested they needed to list their number they would most likely be annoyed or appalled (or ask, "what is a phone book?").  THEY want to control who is able to communicate with them, and one of the prime ways they do that, whether they know it or not, is through obscurity.  Robo-dialers and worse are invading their privacy and destroying their ability to remain anonymous and obscure yet available.

When I read about user agent assignments in MODERN, I immediately think of Public ENUM (which failed and which Richard Shockey reminds us from time time is "dead").  I think the main problem was fear of SPIT (SPAM over Internet Telephony).

I will paraphrase the suggestion made by Henning on the call today as, "MODERN should acknowledge aportionment from a limited address space can act as a form of containment for damage from abuse of that space."

It's a pretty crude form of containment, but it does somewhat address the problems at #1, but we can do better I think.

Discovery could be conducted using something like a NAPTR + OPT RR DNS query using (MODERN?) application-specific logic and where the key(s) in the query were supplied in the OPT RR ala something like "draft-kaplan-dnsext-enum-sip-source-ref-opt-code-00" but without the ENUM reverse decimal dot notation and instead using the public individual domain name.  (Clearly, this isn't something you could do using your father's DNS.)

A key to one or more of the private addresses could be something as simple as a 10-digit telephone number but really should be simply a password (and of course potentially very long ugly passwords incorporating prime numbers could be used too depending upon who is asking and what application they're asking for/from).  One or more subsets of private addresses could be reachable via one or more passwords.

Some of the discoverable private "address" information could be a personal telephone number and a STIR public key certificate and the address of the certificate authority, for example.

I believe what I've described could be part of a MODERN solution framework, but would not necessarily include primary assignment of an individual's private telephone number (although it wouldn't prevent it either).  The logic offered today for porting could even be expanded to broker commercial service registration transactions with providers such as CSPs and social networks.

There would necessarily be the usual domain name and password security issues, but domain names are not going away and they don't suffer from being a finite address space heavily integrated into legacy PSTN databases (yet).

---

From: Henning Schulzrinne <[email-masked]>
Date: Wed, 2 Mar 2016 15:58:35 +0000

Without claiming any first-hand experience, my sense is that handing the person you met in the bar a password to access your phone number may limit your romantic prospects unless the bar happens to be next to an IETF (or RSA conference) meeting.

Access to "whois-like" information should indeed be controllable by users as that could greatly improve CNAM-style services and third-party "this is a good guy/business" validation.

Henning

From: Gorman, Pierce A [CTO] [mailto:[email-masked]]
Sent: Wednesday, March 02, 2016 10:27 AM
To: Henning Schulzrinne <[email-masked]>; Paul Kyzivat <[email-masked]>; [email-masked]
Subject: RE: [Modern] Nationwide Number Portability MODERN Use Case Draft

Pierce

---

From: "Gorman, Pierce A [CTO]" <[email-masked]>
Date: Wed, 2 Mar 2016 16:31:00 +0000

LOL.  Agree.  Probably easier just to give them your telephone number.

And, I suspect a personal telephone number might be a convenient password for folks you really feel you can trust - otherwise maybe they only get the direct-to-voice-mailbox-for-SPAM telephone number (if you chose to use a telephone number as an example password to some set of MODERN reachability info.  I think there is little question individuals will prefer to manage sets and layers of trustworthiness.

From: Henning Schulzrinne [mailto:[email-masked]]
Sent: March 02, 2016 9:59 AM
To: Gorman, Pierce A [CTO] <[email-masked]>; Paul Kyzivat <[email-masked]>; [email-masked]
Subject: RE: [Modern] Nationwide Number Portability MODERN Use Case Draft

Henning

From: Gorman, Pierce A [CTO] [mailto:[email-masked]]
Sent: Wednesday, March 02, 2016 10:27 AM
To: Henning Schulzrinne <[email-masked]<mailto:[email-masked]>>; Paul Kyzivat <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: RE: [Modern] Nationwide Number Portability MODERN Use Case Draft

Pierce