Subject: [Monami6] flow filtering - issue 4

From: Koshiro MITSUYA <[email-masked]>
Date: Wed, 9 Nov 2005 16:30:47 +0900

Hi,

>  4. How to inform these criteria (Attached to the BU & BA messages)
>

I don't like the idea to attache policies to BU&BA messages because  
of scalability.  Image the case that we have many policies.  We  
cannot carry all of them within BU.  And if we need negotiation due  
to duplication of policies, I want to exchange several BU&BA to do that.

At this point, I like the idea of MCoA, to provide a frame work to  
identify a pair of HoA+CoA.

For example, the policies itself, like below, can be exchanged by  
using any transport (HTTP,FTP,SCP whatever suitable).

     <<policy>>
     if both BID=11 and BID=800 available;
         port=80 must be delivered via BID=11
         port=25 must be delivered via BID=800
     default:
         all traffic goes through BID=800

MN or HA then can identify which CoA to be used for a flow.

This kind of idea is much simple and has scalability, I think.

regards,
Koshiro

_______________________________________________
Monami6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/monami6

---

From: "Koojana Kuladinithi" <[email-masked]>
Date: Thu, 10 Nov 2005 11:07:59 +0100

Hi Koshiro,

>to duplication of policies, I want to exchange several BU&BA 

This is right. We need to think abt how to avoid BU/BA fragmentation due
to adding ppolicies.

>         all traffic goes through BID=800

This is correct for special policies that you have mentioned. We can't
adapt this for policies such as address/es, port numbers. 

Koojana

---

From: Koshiro MITSUYA <[email-masked]>
Date: Fri, 11 Nov 2005 03:27:45 +0900

Hi Koojana,

What do you mean by "We can't adapt this for policies such as
address/es, port numbers."?

regards,
Koshiro

---

From: "Koojana Kuladinithi" <[email-masked]>
Date: Mon, 14 Nov 2005 06:39:40 +0100

Hi Koshiro, 

>address/es, port numbers."?

Let me clarify. I understood your suggestion as you wanted to add a
numer like BID to indicate policies. In your e.g, you use port numbers
to identify a protocol. I agree. But, if I want to do set a policiy like
packets coming from address of 3ffe:400xxxx:6/56 to be delivered to BID
11, I have to send the ipv6 address/es to the HA. We can't use a small
number like in our e.g.?

Or

Did I understand your suggestion wrongly? 

Regards,

Koojana 

>> This is right. We need to think abt how to avoid BU/BA fragmentation 
>> due to adding ppolicies.
>>
>> >
>> >[email-masked] https://www1.ietf.org/mailman/listinfo/monami6
>> >
>>
>>
>> [email-masked] https://www1.ietf.org/mailman/listinfo/monami6
>>
>>
>

---

From: Koshiro MITSUYA <[email-masked]>
Date: Mon, 14 Nov 2005 19:10:32 +0900

Hi Koojana,
Thank you for the clarification.

Actually, I want to use BID to indicate the destination of the flow  
matched a policy, because BID identifies a pair of HoA&CoA.  We can  
define a flow by using src/dst address, dst/src port number and so on  
and use the BID as its destination.

So, we also can describe a policy like packets coming from address of  
3ffe:400xxxx:6/56 to be delivered to BID 11 as below.

<<policy>>
     if both BID=11 and BID=800 available;
         port=80 must be delivered via BID=11
         port=25 must be delivered via BID=800
         src=3ffe:400xxxx:6/56 must be delivered via BID=11
         dst=MNP::dead:beef & port=991 must be delivered via BID=800
     default:
         all traffic goes through BID=800

regards,
Koshiro

On 2005/11/14, at 14:39, Koojana Kuladinithi wrote:

>>>>>  4. How to inform these criteria (Attached to the BU & BA
>>>>>
>> messages)
>>
>>>>>
>>>>>
>>>>
>>> This is correct for special policies that you have
>>>
>> mentioned. We can't
>>