Subject: [MEXT] Use of destination option in Binding Revocation Indication

From: <[email-masked]>
Date: Mon, 15 Sep 2008 09:35:15 +0200

draft-ietf-mext-binding-revocation
(draft-muhanna-mext-binding-revocation)
specifies the BRI packet to contain a destination option with the home
address option.  Can this be true?

Assuming the mobile node is currently attached to an IPv6 foreign
network, the home agent, when emitting the BRI packet, will send the
packet using its own address, v6HA, as source address, and must send
the packet to the care-of address of the mobile node, v6CoA, the
topologically correct address of the mobile node.  Because
the v6CoA is not the ultimate destination of the packet, the packet
must be routed to the ultimate destination, and MIPv6 uses the
Type 2 Routing Header, so the packet can be routed from the v6CoA
to the v6HoA.  Also, the packet is to be ESP protected using the SA
established with v6HoA and v6HA, so of course the v6HoA must appear in 
the packet.  Thus, the BRI packet has the following layout

    IPv6 Header (src = v6HA, dst = v6CoA)
    Type 2 Routing Header (v6HoA)
    ESP Header (using SA between v6HoA and v6HA)
    BRI Message

The response packet, the BRA packet, will be sent from the v6CoA to
v6HA,
so the packet will be routed correctly, but to inform the home agent 
of the true source address, a destination option is added.  Thus, the
BRA packet has the following layout

    IPv6 Header (src = v6CoA, dst = v6HA)
    Destination Option (Home Address option = v6HoA)
    ESP Header (using SA between v6HoA and v6HA)
    BRA Message

Thus

 * Why the is the BRA packet not specified as having an extension
header?
 * Why does the BRI packet use Destination Option, when all other
   messages to my knowledge uses the Type 2 Routing Header in
   packets destined _to_ the mobile node?

Christian
_______________________________________________
MEXT mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mext

---

From: "Ahmad Muhanna" <[email-masked]>
Date: Wed, 17 Sep 2008 15:04:15 -0500

Hi Christian,

Sorry for the delay. 
I agree. That is an oversight and we will update the draft accordingly.
As you correctly pointed out, BRI and BRA packets should follow those of
the BU/BA.

Regards,
Ahmad

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of [email-masked]
> Sent: Monday, September 15, 2008 2:35 AM
> To: [email-masked]
> Subject: [MEXT] Use of destination option in Binding 
> Revocation Indication
> 
> specifies the BRI packet to contain a destination option with 
> the home address option.  Can this be true?
> 
> Assuming the mobile node is currently attached to an IPv6 
> foreign network, the home agent, when emitting the BRI 
> packet, will send the packet using its own address, v6HA, as 
> source address, and must send the packet to the care-of 
> address of the mobile node, v6CoA, the topologically correct 
> address of the mobile node.  Because the v6CoA is not the 
> ultimate destination of the packet, the packet must be routed 
> to the ultimate destination, and MIPv6 uses the Type 2 
> Routing Header, so the packet can be routed from the v6CoA to 
> the v6HoA.  Also, the packet is to be ESP protected using the 
> SA established with v6HoA and v6HA, so of course the v6HoA 
> must appear in the packet.  Thus, the BRI packet has the 
> following layout
> 
> The response packet, the BRA packet, will be sent from the 
> v6CoA to v6HA, so the packet will be routed correctly, but to 
> inform the home agent of the true source address, a 
> destination option is added.  Thus, the BRA packet has the 
> following layout
> 
>  * Why the is the BRA packet not specified as having an 
> extension header?