Subject: [Mpls-interop] On Req.41

From: "Annamaria Fulignoli" <[email-masked]>
Date: Tue, 31 Mar 2009 17:36:21 +0200

Hi Ben, 
I notice that  the requirement  41  "It MUST be possible to operate and
configure the MPLS-TP data plane without any IP forwarding capability in
the MPLS-TP data plane. "
in  last  version  i.e
http://tools.ietf.org/html/draft-ietf-mpls-tp-requirements-05  has been
moved under Control Plane requirement section. 
I think it should be moved again under the Data Plane requirements
section as it was until ver. 4 of the draft.
Thank you and regards
Annamaria

---

From: "Malis, Andrew G. (Andy)" <[email-masked]>
Date: Tue, 31 Mar 2009 13:24:28 -0400

Annamaria,

That's a control plane requirement - this really says that an IP-based
control plane must be able to operate out-of-band, since it can't make
any IP forwarding assumptions on the data plane.

Cheers,

Andy

From: [email-masked]
[mailto:[email-masked]] On Behalf Of Annamaria Fulignoli
Sent: Tuesday, March 31, 2009 11:36 AM
To: Ben Niven-Jenkins
Cc: [email-masked]
Subject: [Mpls-interop] On Req.41

Hi Ben, 

in  last  version  i.e
http://tools.ietf.org/html/draft-ietf-mpls-tp-requirements-05
<http://tools.ietf.org/html/draft-ietf-mpls-tp-requirements-05>   has
been moved under Control Plane requirement section.

---

From: "Annamaria Fulignoli" <[email-masked]>
Date: Tue, 31 Mar 2009 20:57:52 +0200

Hi Andy,
I can agree on this . 
 
However we have lost ( or at least  I can't  find it )  the equivalent requirement on Data Plane; so I think that we should add in the Data Plane requirements section the following requirement too: 
" OAM , protection and forwarding of data packets MUST be able to operate without IP forwarding support."  as reported in the framework draft .
 
Cheers,
Annamaria

________________________________

From: Malis, Andrew G. (Andy) [mailto:[email-masked]] 
Sent: martedì 31 marzo 2009 19.24
To: Annamaria Fulignoli; Ben Niven-Jenkins
Cc: [email-masked]
Subject: RE: [Mpls-interop] On Req.41

Annamaria,

That's a control plane requirement - this really says that an IP-based control plane must be able to operate out-of-band, since it can't make any IP forwarding assumptions on the data plane.

Cheers,

Andy

From: [email-masked] [mailto:[email-masked]] On Behalf Of Annamaria Fulignoli
Sent: Tuesday, March 31, 2009 11:36 AM
To: Ben Niven-Jenkins
Cc: [email-masked]
Subject: [Mpls-interop] On Req.41

Hi Ben, 
I notice that  the requirement  41  "It MUST be possible to operate and configure the MPLS-TP data plane without any IP forwarding capability in the MPLS-TP data plane. "

in  last  version  i.e http://tools.ietf.org/html/draft-ietf-mpls-tp-requirements-05 <http://tools.ietf.org/html/draft-ietf-mpls-tp-requirements-05>   has been moved under Control Plane requirement section. 

I think it should be moved again under the Data Plane requirements section as it was until ver. 4 of the draft. 
Thank you and regards 
Annamaria

---

From: Ben Niven-Jenkins <[email-masked]>
Date: Tue, 31 Mar 2009 21:35:22 +0100

My view.

Operation & configuration belong to control plane. We have requirement for
that.

Operation & configuration also belong to management plane. That sits in
Eric's NM requirements draft.

OAM belongs to Martin's OAM requirements draft.

I would argue protection triggers are likely to be either control plane
driven (we have that covered), management plane driven (Eric's draft) or OAM
driven (Martin's) draft.

Forwarding plane is irrelevant, the forwarding plane is MPLS-TP.

So, Annamaria, I agree you have raised a valid requirement but the only part
of it that belongs in the general requirements draft is already covered IMO.

Ben

On 31/03/2009 19:57, "Annamaria Fulignoli"
<[email-masked]> wrote:

> Hi Andy,
> I can agree on this .
>  
> However we have lost ( or at least  I can't  find it )  the equivalent
> requirement on Data Plane; so I think that we should add in the Data Plane
> requirements section the following requirement too:
> " OAM , protection and forwarding of data packets MUST be able to operate
> without IP forwarding support."  as reported in the framework draft .
>  
> Cheers,
> Annamaria
>  
> 
> 
> That's a control plane requirement - this really says that an IP-based control
> plane must be able to operate out-of-band, since it can't make any IP
> forwarding assumptions on the data plane.
> 
>  
> 
> Cheers,
> 
> Andy
> 
>  
> 
> configure the MPLS-TP data plane without any IP forwarding capability in the
> MPLS-TP data plane. "
> 
> in  last  version  i.e
> <http://tools.ietf.org/html/draft-ietf-mpls-tp-requirements-05>   has been

---

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 31 Mar 2009 23:26:50 +0100

Hi,

> driven (we have that covered), management plane driven (Eric's draft)
> or OAM driven (Martin's) draft.

Or, locally, data plane driven.

Please see draft-sprecher-mpls-tp-survive-fwk-01.txt for more details on 
protection triggers.

Adrian